Jump to content
spidometrs

[CONTRIBUTION] Ultimate SEO URLs v2.1 - by Chemo

Recommended Posts

I have to hand it to ya Jack, another very nice contrib!

Works nice no install issues, took less than 5 minutes and the malicious url trick does not work as it gets redrected to the correct url so I dont think it will cause any SE issues.

Thanks again for the awesom contrib!

Edited by sitefire

Share this post


Link to post
Share on other sites

Jack I have a quick question.

Will using the Enable use Header Tags as name? option add much more over head and DB queries?

No, not much, if any at all. The code determines which to load in, which is insignificant, and the code is the same after that. Just be sure all of your Header Tags titles are setup since there's no checking done. None is done with the regular names either but there's no choice on those as is there is in Header Tags.

Share this post


Link to post
Share on other sites

Hello to all!!

 

Urls on my site are like..

 

/shum12/care-c-36.html?osCsid=bad4a4339f15081bbef5932c6d9efb1c

 

but i want to change this to

 

/shum12/care?osCsid=bad4a4339f15081bbef5932c6d9efb1c

 

or

 

/shum12/care.html?osCsid=bad4a4339f15081bbef5932c6d9efb1c

 

i.e dnt want to display 'c','p' and their numeric id

 

thanks !!

Share this post


Link to post
Share on other sites

Hi to all!!

 

My site URL shows in "address bar" of browser and on the "status bar" while mouseover on any link is differnt.

 

 

My site shows URL on a page ..

 

in address bar:-/catalog/body-care-c-24.html?osCsid=19606f7b2c84dad6a394a120c2832cc1

in status bar-/catlog/product_info.php?cPath=30&product_id=12&osCsid=19606f7b2c84dad6a394a120c2832cc1

 

why both URL are different and how is resolve??

 

Thanks

Share this post


Link to post
Share on other sites

Hi to all!!

 

My site URL shows in "address bar" of browser and on the "status bar" while mouseover on any link is differnt.

 

 

My site shows URL on a page ..

 

in address bar:-/catalog/body-care-c-24.html?osCsid=19606f7b2c84dad6a394a120c2832cc1

in status bar-/catlog/product_info.php?cPath=30&product_id=12&osCsid=19606f7b2c84dad6a394a120c2832cc1

 

why both URL are different and how is resolve??

 

Thanks

 

The address bar shows the link that you came in from (or were redirected to).

 

The mouseover is showing you the link produced and therefore where you will go when you click it.

 

Sounds to me like you have some hardcoded links in your site that are not using tep_href_link() and when you are coming in on an old osC url you are being redirected to the seo url.

Share this post


Link to post
Share on other sites

i.e dnt want to display 'c','p' and their numeric id

That isn't possible with this addon, though it is planned, but one of the other url rewiters may have that option.

Share this post


Link to post
Share on other sites

OK, it looks like the SSL isn't working because of content I have added to /catalog/includes/column_right.php

 

If I remove the content, SSL works correctly.

 

I never had this problem before. What can I do to resolve this?

 

 

Nevermind, it was because I had unsecure content. Disregard.

Edited by jacobsag

Share this post


Link to post
Share on other sites

Hello,

 

I have just installed Ultimate SEO 2-2.2d-5 to the osCommerce Online Merchant v2.2 RC2a.

Everything seems work fine, also In the administrator panel i have the "SEO Urls" options in the "Configuration" menu, but there are problems when listing on my website articles and categories I get 404.

 

Here is the web and click on the left menu some categories. For example these is the link for the "Test" category but it don't work.

 

Also I have instaled Oscomerce in the root directory and set the .htacess file in the root directory and the right version of them.

 

Thank you for the help.

 

 

EDIT: Please ignore my message. I made a mistake and name wrong my .htaccess file. Now it works fine everything!!

Edited by blindek

Share this post


Link to post
Share on other sites

Read the instructions regarding testing the installation. If you still can't figure it out, paste your .htaccess file here.

Share this post


Link to post
Share on other sites

Hello robert,

I need help with this one,

I have just installed ULTIMATE_Seo_Urls_5_r141_stable On v2.2RC2

 

After I upload the modify files I try to go to my site and i get

 

Fatal error: Cannot instantiate non-existent class: arrayiterator in xxx/catalog/includes/application_top.php on line 50

 

my application_top.php line 50 is :

 

$base = new ArrayIterator( array( 'SCRIPT_NAME', 'PHP_SELF', 'REQUEST_URI', 'ORIG_PATH_INFO', 'HTTP_X_ORIGINAL_URL', 'HTTP_X_REWRITE_URL' ) );

 

 

my Server

 

Operating System: Linux Hosting Type: Shared Hosting

PHP Version: PHP 4.x

Thank you

Share this post


Link to post
Share on other sites

Hello robert,

I need help with this one,

I have just installed ULTIMATE_Seo_Urls_5_r141_stable On v2.2RC2

 

After I upload the modify files I try to go to my site and i get

 

Fatal error: Cannot instantiate non-existent class: arrayiterator in xxx/catalog/includes/application_top.php on line 50

 

my application_top.php line 50 is :

 

$base = new ArrayIterator( array( 'SCRIPT_NAME', 'PHP_SELF', 'REQUEST_URI', 'ORIG_PATH_INFO', 'HTTP_X_ORIGINAL_URL', 'HTTP_X_REWRITE_URL' ) );

 

 

my Server

 

Operating System: Linux Hosting Type: Shared Hosting

PHP Version: PHP 4.x

Thank you

 

Hi No 1 you are in the wrong support thread.

 

Ultimate Seo Urls 5

 

No 2 Ultimate Seo Urls 5 requires php 5.2+

Share this post


Link to post
Share on other sites

Thanks for the contribution! Great work Chemo!

 

I have a quick question, my site displays products that are out of stock. The product status is set to '0', i.e. the product is out of stock. So when you look at the <title>, it is just my store name, not the manufacturer, category, product name.

 

I am looking through the module, but I am not too sure where to look. Can someone give me a hint as to where to look?

 

Thanks!

Share this post


Link to post
Share on other sites

Thanks for the contribution! Great work Chemo!

 

I have a quick question, my site displays products that are out of stock. The product status is set to '0', i.e. the product is out of stock. So when you look at the <title>, it is just my store name, not the manufacturer, category, product name.

 

I am looking through the module, but I am not too sure where to look. Can someone give me a hint as to where to look?

 

Thanks!

 

Ultimate Seo Urls has no effect on the <title></title> at all. It purely produces urls.

Share this post


Link to post
Share on other sites

Hi great contrib. The Update works fantastic. I do need one thing. I am using Alphabetical Search and I am trying to isolate the searches to a category. I almost have it down. Ultimate Seo is kinda standing in my way. would it be possible to have seo move ?Alpha=A or any ?Alpha=Z to the end after .html

Share this post


Link to post
Share on other sites

great contribution so far...there is one issue (on my site at least)...when i turn the SEO urls off and i click on any product it gives me an error on FF that

 

The page isn't redirecting properly

 

 

Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

 

any ideas why?

thanks

Share this post


Link to post
Share on other sites

Hi great contrib. The Update works fantastic. I do need one thing. I am using Alphabetical Search and I am trying to isolate the searches to a category. I almost have it down. Ultimate Seo is kinda standing in my way. would it be possible to have seo move ?Alpha=A or any ?Alpha=Z to the end after .html

Ultimate SEO applies the rewrites above any search code in the shop so it won't affect it, unless you doing something that deliberately searches the url, which you shouldn't.

Share this post


Link to post
Share on other sites

great contribution so far...there is one issue (on my site at least)...when i turn the SEO urls off and i click on any product it gives me an error on FF that

 

any ideas why?

You have to turn off all of the cacheing options to turn it off, not just the main option.

Share this post


Link to post
Share on other sites

Just managed to install this one without any problems, thanks for a great contribution :)

 

The only problem I've got is the new way Urls are shown.

I used this mod around a year ago and was very happy with it, but it seems it's been updated somewhat.

My Urls are now showing as;

 

http://www.domainname.co.uk/category-c-23.html

 

Or if I click on a specific product it's;

 

http://www.domainname.co.uk/category-p-28.html

 

(Where it says category it shows up as the correct category)

 

If I remember right it always used to be like;

 

http://www.domainname.co.uk/category-product.html

 

Is there anyway to get back to this?

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

Hi, I'm working on an osC shop that is using this contribution.

 

I have one problem that look simple.

 

I do changes on the pages (index.php and product_info.php) and they don't show up online, only if I turn off the contribution.

 

I tried to do a clean cache on the admin panel but it also didn't work out.

 

Need help! :)

 

Thank you!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×