Jump to content
spidometrs

[CONTRIBUTION] Ultimate SEO URLs v2.1 - by Chemo

Recommended Posts

I did one more thing. From the code I write the manual sql script to put it to database manually. So the rows were imported, BUT when I refresh the page, it automatically delete all the rows with the "SEO" match...belows is the sql code...

Adding that code manually won't work since it has not been updated with the releases. As soon as Ultimate SEO checks it, it will see it doesn't match and replace it. Perhaps your server doesn't meet the requirements for this contribution so the database entries can't be inserted in the first place? Or, there is, apparently, something in your code preventing this from working, but I can't think of anything else to offer.

Share this post


Link to post
Share on other sites

Adding that code manually won't work since it has not been updated with the releases. As soon as Ultimate SEO checks it, it will see it doesn't match and replace it. Perhaps your server doesn't meet the requirements for this contribution so the database entries can't be inserted in the first place? Or, there is, apparently, something in your code preventing this from working, but I can't think of anything else to offer.

 

I understand :(

 

Can you please write me what are that requirements for the contribution?

Share this post


Link to post
Share on other sites

I understand :(

 

Can you please write me what are that requirements for the contribution?

They are listed in the install file.

Share this post


Link to post
Share on other sites

Can someone please help.. I cannot resolve this issue..

?osCsid
is still being inserted into my URL's and causing product not found issues..

This only happens on the first click on the site then everything works fine.. I went thru the configure.php and .htaccess rewrite and everything seems to be correct..

 

Configure.php

define('HTTP_SERVER', 'http://www.carstickersdecals.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'https://oggjay.globat.com/stickers/'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'www.carstickersdecals.com');

define('HTTPS_COOKIE_DOMAIN', 'https://oggjay.globat.com/stickers/');

define('HTTP_COOKIE_PATH', '/');

define('HTTPS_COOKIE_PATH', '');

define('DIR_WS_HTTP_CATALOG', '/');

define('DIR_WS_HTTPS_CATALOG', '');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', '/hermes/bosweb/web170/b1702/glo.oggjay/carstickersdecals/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

// define our database connection

define('DB_SERVER', '*****'); // eg, localhost - should not be empty for productive servers

define('DB_SERVER_USERNAME', '****');

define('DB_SERVER_PASSWORD', '********');

define('DB_DATABASE', 'csd');

define('USE_PCONNECT', 'false'); // use persistent connections?

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

 

.htaccess file

ErrorDocument 404 /pageerrors.php

 

Options +FollowSymLinks

RewriteEngine On

RewriteBase /

 

RewriteRule ^(.*)-sticker-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-stickers-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-m-([0-9]+).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pi-([0-9]+).html$ popup_image.php?pID=$2&%{QUERY_STRING}

RewriteRule ^(.*)-t-([0-9]+).html$ articles.php?tPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-a-([0-9]+).html$ article_info.php?articles_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-au-(.*).html$ articles.php?authors_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pr-([0-9]+).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pri-([0-9]+).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-i-([0-9]+).html$ information.php?info_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-links-(.*).html$ links.php?lPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pm-([0-9]+).html$ info_pages.php?pages_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-by-(.*).html$ all-products.php?fl=$2&%{QUERY_STRING}

Edited by Oggster

Share this post


Link to post
Share on other sites

Can someone please help.. I cannot resolve this issue.. is still being inserted into my URL's and causing product not found issues..

This only happens on the first click on the site then everything works fine.

That is normal.

Share this post


Link to post
Share on other sites

Ok,

 

Since it's still not working, maybe I also need to update my Header Tags SEO to latest? I now have version 3.0.7 installed.

 

Thanks.

 

Since I already have 1.57 of Articles Manager installed - could it help to install latest Header Tags SEO in order to get the seo url work for articles?

 

:huh:

Share this post


Link to post
Share on other sites

That is normal.

 

So its normal for every customer to come to your site and click on a product and get a product not found page...

I don't think so.. Talk about loosing customers..

Edited by Oggster

Share this post


Link to post
Share on other sites

Since I already have 1.57 of Articles Manager installed - could it help to install latest Header Tags SEO in order to get the seo url work for articles?

Yes.

Share this post


Link to post
Share on other sites

So its normal for every customer to come to your site and click on a product and get a product not found page...

I don't think so.. Talk about loosing customers..

You said the session id was being added to the url when first going to the site. My answer is correct.

Share this post


Link to post
Share on other sites

You said the session id was being added to the url when first going to the site. My answer is correct.

 

I understand that it is supposed to be added after the URL... But not in the middle...

 

.com/bear-scene-sticker-201?osCsid.html

 

And Causing Page errors.. I've tried everything I can think of to fix it..

This is why I came here asking people with maybe a little more knowledge of what might be going on..

It seems that know one has any idea why this is happening.. Or is up to the challenge..

 

I will keep trying to figure it out..

Edited by Oggster

Share this post


Link to post
Share on other sites

I understand that it is supposed to be added after the URL... But not in the middle...

 

 

 

And Causing Page errors.. I've tried everything I can think of to fix it..

This is why I came here asking people with maybe a little more knowledge of what might be going on..

It seems that know one has any idea why this is happening.. Or is up to the challenge..

 

I will keep trying to figure it out..

Hi

 

If your using php5 i would suggest going with this contribution http://addons.oscommerce.com/info/6768

 

there is also an upgrade instructions from version you are using now

 

Steve

Share this post


Link to post
Share on other sites

Hi

 

If your using php5 i would suggest going with this contribution http://addons.oscommerce.com/info/6768

 

there is also an upgrade instructions from version you are using now

 

Steve

 

Thank you Steve... Thats what I get for not using the newest versions... Can't believe it took almost a week for someone to tell me that...

Thanks Again...

Jay

Share this post


Link to post
Share on other sites

If your using php5 i would suggest going with this contribution http://addons.oscommerce.com/info/6768

Not necessary. This contribution works perfectly well with php5.

Share this post


Link to post
Share on other sites

Not necessary. This contribution works perfectly well with php5.

 

We will just have to agree to disagree on this point Jack.

 

There are many reasons why not to stick with this old code and its hundreds of hacks. For a while it seemed a reasonable idea to attempt to keep this old code going "by fixing the broken bits" which I did by supporting here with 2.1d original updated but it was and is still a mess .. for this reason I took the time to write for the community a totally fresh version a far more flexible structure, modern code base and no known bugs at time of posting.

 

The latest version will be out soon offering for the first time true multi language support and a lot more.

 

Ultimately we will have to let the users decide which they wish to use.

Share this post


Link to post
Share on other sites

We will just have to agree to disagree on this point Jack.

 

There are many reasons why not to stick with this old code and its hundreds of hacks. For a while it seemed a reasonable idea to attempt to keep this old code going "by fixing the broken bits" which I did by supporting here with 2.1d original updated but it was and is still a mess .. for this reason I took the time to write for the community a totally fresh version a far more flexible structure, modern code base and no known bugs at time of posting.

 

The latest version will be out soon offering for the first time true multi language support and a lot more.

 

Ultimately we will have to let the users decide which they wish to use.

It truly makes no difference to me which contribution anyone uses, unless they are paying me for my opinion. This contribution works great and is completely compatible with all other SEO contributions, which yours isn't (or hasn't been). Until this one doesn't perform well, it is the one I recommend. This isn't my contribution and support thread but if it were, I would request others with similar contributions not to troll it trying to convert users. That is generally considered to be bad form and serves no purpose here. I don't care, or have any say, if you want to push your version over this one. But I would ask, for the sake of keeping this suport thread for what it is meant, that you post your comparisons elsewhere.

Share this post


Link to post
Share on other sites

This contribution works great and is completely compatible with all other SEO contributions, which yours isn't (or hasn't been).

 

Totally incorrect, USU5 uses tep_href_link() like all other link based contributions so is and always was compatible with anything correctly written, in fact in rewrite mode the uris are exactly the same. There are contributions out there which incorrectly use PHP_SELF to return a base filename which will often fail with a path based uri, the answer .. correct their coding or use the rewrite method. Others like sitemap seo fail because they do not utilize the standard tep_href_link() but have series 2 seo urls hardcoded in so nothing but series 2 CAN work. And I don't believe series 2 works great in fact it is getting worse ( spaces in the uri text indeed! apart from anything else it is syntactically incorrect as Unix operating systems don't allow spaces )

 

I would request others with similar contributions not to troll it trying to convert users.

 

You are missing the point here, it's not about you, me or other contributors it is about the users of ultimate seo urls in whatever guise. I have been active in helping users in this particular support topic for a long time and still am so please don't dare to call me a TROLL! the original contributor has been banned for years, my posts are neither contraversial, inflammatory, irrelevant nor off topic so your troll comment is totally uncalled for. You are quite correct this is NOT your contribution.

 

I had the option of USU5 being a "version" uploaded to the existing long list .. why didn't I? because that would have just added to the carnage that is series 2 which is one of the key annoyances for so many users. Also USU5 is a total and complete rewrite and bears no resemblance to this old croc.

 

Nevertheless USU5 using the rewrite method can produce exactly the same uris as series 2 so is an advancement of series 2 and not just a "similar contribution". If a user could not accurately recreate their existing urls then it would indeed be a "different contribution".

 

If I see a post here where I think the user would be better off using USU5, will I mention it to them? absolutely!

Share this post


Link to post
Share on other sites

Totally incorrect, USU5 uses tep_href_link() like all other link based contributions so is and always was compatible with anything correctly written

That could be. I didn't state it as fact. I just know about all of the problems I see posted about it. If you say it is compatible, that's good enough for me.

 

You are missing the point here, it's not about you, me or other contributors it is about the users of ultimate seo urls in whatever guise. I have been active in helping users in this particular support topic for a long time and still am so please don't dare to call me a TROLL! the original contributor has been banned for years, my posts are neither contraversial, inflammatory, irrelevant nor off topic so your troll comment is totally uncalled for. You are quite correct this is NOT your contribution.

No, I'm not missing the point. This is a support thread for Ultimate SEO V 2. If it has a problem, then that can be addressed by anyone, of course. It is when the responses are not about support for this contribution that, in my opinion, are going aganist the intention of this thread. It would be similar to me going into all of the support threads for meta tags contributions and telling everyone they are making a mistake using anything other than Header Tags SEO. Whether that statement is true or not, it would have no place in those threads.

 

I had the option of USU5 being a "version" uploaded to the existing long list .. why didn't I? because that would have just added to the carnage that is series 2 which is one of the key annoyances for so many users. Also USU5 is a total and complete rewrite and bears no resemblance to this old croc.

That's why I decided to start a sub-version and fix the various problems with it. My version is completely stable and works well, other than obvious things that were overlooked, as in any contribution. The point that your contribtuon is a completely different contribution supports the fact that this isn't the support thread for it.

 

If I see a post here where I think the user would be better off using USU5, will I mention it to them? absolutely!

And that is, in my opinion, the definition of trolling. I don't mean that as an attack against you or your contribution. It is just a label I'm using for lack of another. The point is that posts like that just don't belong in a support thread for a different contribution. If someone started posting in the support thread for SEO 5 that the users would be better off using Ultimate SEO, it would be the same thing. You, or someone would respond to it, say it isn't so, maybe a long discussion would follow as to why it is or isn't, and in the end all that was accomplished was causing a lot of extra posts in a support thread that shouldn't be there. Perhaps a new thread labeled "Why use SEO 5 instead of Ultimate SEO" would get your point across and not dilute this thread. Opinions as to the pros and cons could be given by anyone that cares and a link to could be added to your signature. That is the normal procedure for handling such a situation and has always worked well.

Share this post


Link to post
Share on other sites

Ok Jack

 

We'd better leave it here as support this is not.

 

You are modifying Chemos original code .. I have rewritten ultimate seo urls .. as far as I am concerned neither of us are the initial contributor and are both supporting the seo urls concept in one way or other.

 

As long as the users get a decent seo urls contribution for free I doubt they'll be complaining.

Share this post


Link to post
Share on other sites

Hi,

How to remove ?osCsid=e5100e0944a9814152c397ceb7b0ebdb after html?

Thank you

 

This is not an seo urls issue it is "potentially" a configuration issue.

 

The osCsid should and must be present when you first visit the site (unless you are forcing cookie use). The osCsid should disappear from the links after the first click .. if it does not disappear then you have issues with your catalog/includes/configure.php file.

Share this post


Link to post
Share on other sites

Ok Jack

 

We'd better leave it here as support this is not.

 

You are modifying Chemos original code .. I have rewritten ultimate seo urls .. as far as I am concerned neither of us are the initial contributor and are both supporting the seo urls concept in one way or other.

 

As long as the users get a decent seo urls contribution for free I doubt they'll be complaining.

I completely agree.

Share this post


Link to post
Share on other sites

I believe i have setup the addon correctly.

 

However

when i click a category i get this sort of url

http://shireen.com.au/-c-58.html

 

and when i click a product i get this sort of url

http://shireen.com.au/brass-earrings-lime-green-p-398.html

 

which looks fine only that the product page doesn't appear i just get an error saying the page doesn't exist..

 

can someone help me out here...

Share this post


Link to post
Share on other sites

I believe i have setup the addon correctly.

 

However

when i click a category i get this sort of url

http://shireen.com.au/-c-58.html

 

and when i click a product i get this sort of url

http://shireen.com.au/brass-earrings-lime-green-p-398.html

 

which looks fine only that the product page doesn't appear i just get an error saying the page doesn't exist..

 

can someone help me out here...

 

This is the usual user error which has been covered umpteen times.

 

1) Are you on a *nix server?

2) Is mod_rewrite compiled in Apache?

3) Does AllowOverride have sufficient permissions for .htaccess RewriteRules?

4) Is RewriteBase set correctly ?

www.mysite.com = RewriteBase /

www.mysite.com/catalog/ = RewriteBase /catalog/

www.mysite.com/catalog/shop/ = RewriteBase /catalog/shop/

5) In some setups you need to comment out Options +FollowSymLinks

Like ..

#Options +FollowSymLinks

Share this post


Link to post
Share on other sites

This is the usual user error which has been covered umpteen times.

 

I am sure it has been covered so many times...but i dont have the time or ability to sort through 225 pages of posts to find the answer to my question. Maybe there somoeone should add and FAQ section to the install with trouble shooting

 

www.mysite.com = RewriteBase /

 

That was my problem...

 

now the pages appear however for the category pages i still get URLs like

 

http://shireen.com.au/-c-61_64.html

 

which of course is not ideal.

 

Ilan

Share this post


Link to post
Share on other sites

I am sure it has been covered so many times...but i dont have the time or ability to sort through 225 pages of posts to find the answer to my question. Maybe there somoeone should add and FAQ section to the install with trouble shooting

 

Maybe you should take the few minutes/hour it takes to read what has already been written for you. Perhaps you should also appreciate the 100s of hours spent developing these things so you can have them free!

 

More to the point you may have read the contribution instructions??

 

That was my problem...

 

I think you meant .. "thank you very much for taking the time to help me, that did indeed sort out my problem"

 

Spot the help vampire

Edited by FWR Media

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×