Jump to content
spidometrs

[CONTRIBUTION] Ultimate SEO URLs v2.1 - by Chemo

Recommended Posts

Hi

 

I have installed the contribution but I seem to have two problems:

 

If I modify the .htaccess file I get a ‘500 Internal Server Error’

 

Also when my site is working(without the .htaccess modification), I get a “webpage cannot be found 404 error when I click on a product sub-category

 

I Guess I’ve done something wrong?

Share this post


Link to post
Share on other sites
Hi

 

I have installed the contribution but I seem to have two problems:

 

If I modify the .htaccess file I get a ‘500 Internal Server Error’

 

Also when my site is working(without the .htaccess modification), I get a “webpage cannot be found 404 error when I click on a product sub-category

 

I Guess I’ve done something wrong?

Go to the bottom of this page, enter Internal Server in the search string and click Search Topic.

 

Jack

Share this post


Link to post
Share on other sites

Hello Jack,

 

I am trying to install USU 5 and when I run installer.php I get the following error:

 

"You cannot install this script as the function filter_var() does not exist in your PHP set up"

 

I have php 5 running. Can you please help? Thanks.

Share this post


Link to post
Share on other sites
Hello Jack,

 

I am trying to install USU 5 and when I run installer.php I get the following error:

 

"You cannot install this script as the function filter_var() does not exist in your PHP set up"

 

I have php 5 running. Can you please help? Thanks.

You need to ask in the support thread for that contribution. This one is for Ultimate SEO URLs V2.

 

Jack

Share this post


Link to post
Share on other sites

i guess you probably need a pre-installer.php to install install.php, and if that does not work then you probably need another pre-pre-installer.php to install pre-installer.php, until you get through it.

 

seriously, chemo's U SEO URLs was famoursly created for idiots with less than 10 minutes at hand. looking for an "installer" is looking for trouble and show how lazy one may be. I have seen a site using an installer to install an addon and manage to wipe out all the original records in the configuration table.

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites
Hey guys!

 

How do I remove "p-44", "c-22" etc. at the end of the URLs?

 

Hi!

 

With this contribution only you can not remove the "p-44", "c-22" etc. at the end of the URLs, you need another one contribution and some more actions to do (search previous pages and you will find the directions that you need)!

 

However please be very carefull with it, since from my experience I managed to remove the "p-44", "c-22" etc. at the end of the URLs in my website www.ellinas.org BUT then I had page not found errors when my visitors used another language than english! In my web site I offer 6 different languages and this was really a big mess!!!

Share this post


Link to post
Share on other sites

If I enable seo URL

Fatal error: Call to undefined function mb_convert_case() in /home/userp/public_html/mydomain.com/clean/includes/classes/seo.class.php on line 1819

 

I am on a VPS, PHP Version 5.2.8

Share this post


Link to post
Share on other sites
If I enable seo URL

Fatal error: Call to undefined function mb_convert_case() in /home/userp/public_html/mydomain.com/clean/includes/classes/seo.class.php on line 1819

 

I am on a VPS, PHP Version 5.2.8

 

I solvled my problem by replace seo.class.php from this version Ultimate SEO URLs - 2.1d.

All the rest followed Ultimate SEO URLs v2.8. Is this OK?

It seems all right now.

Share this post


Link to post
Share on other sites
Hi!

 

With this contribution only you can not remove the "p-44", "c-22" etc. at the end of the URLs, you need another one contribution and some more actions to do (search previous pages and you will find the directions that you need)!

 

However please be very carefull with it, since from my experience I managed to remove the "p-44", "c-22" etc. at the end of the URLs in my website www.ellinas.org BUT then I had page not found errors when my visitors used another language than english! In my web site I offer 6 different languages and this was really a big mess!!!

 

Thank you!

Share this post


Link to post
Share on other sites

I have the newest v2.8 installed, awesome btw, but I do have an issue...

 

My Site --> http://www.customwheelsexpress.com

 

I have quotes in my category and product names. As far as I can tell the script strips out any quotes (probably to make it not interfere with anything else). I have tried using the html markup for a quote (") in the product name but it also seem to strip out the '&' symbol and just leaves 'quot'. In either case is there a way for me to make the " either appear as a quote or change it to a word such as 'inch'?

 

Thanks,

Blaine

Share this post


Link to post
Share on other sites

hi

 

I'd like to ask whether it's possible to make my store urls, for example :

domain/category1/subcategory1/product-name.html

 

I am using Ultimate SEO URL, but the url displayed :

domain/manufacture-product-name-p-12.html

 

Is there any contributions that can make my store URLS like i mentioned above ?

 

thanks

Share this post


Link to post
Share on other sites

hi

i install it and work great

thanks

 

i have a problem

i installed before ajax buy now on my shop

for install that must change the html_output.php

return $link;

to

 

// AJAX Addto shopping_cart - Begin
$link_ajax = '';
if( tep_not_null($parameters) && preg_match("/buy_now/i", $parameters) && $page != 'ajax_shopping_cart.php'){
  $link_ajax = '" onclick="doBuyNowGet(\'' . tep_href_link( 'ajax_shopping_cart.php', $parameters, $connection, $add_session_id, $search_engine_safe) . '\'); return false;';
}

return $link . $link_ajax;
// AJAX Addto shopping_cart - End

 

 

after install seo url , i change it like this :

////
////
// Ultimate SEO URLs v2.1
// The HTML href link wrapper function
if (SEO_ENABLED == 'true') { //run chemo's code
 function tep_href_link($page = '', $parameters = '', $connection = 'NONSSL', $add_session_id = true, $search_engine_safe = true) {
	global $seo_urls;
			if ( !is_object($seo_urls) ){
					if ( !class_exists('SEO_URL') ){
							include_once(DIR_WS_CLASSES . 'seo.class.php');
					}
					global $languages_id;
					$seo_urls = new SEO_URL($languages_id);
			}
	return preg_replace('/&/','&',$seo_urls->href_link($page, $parameters, $connection, $add_session_id));
 }
} else { //run original code
// The HTML href link wrapper function
 function tep_href_link($page = '', $parameters = '', $connection = 'NONSSL', $add_session_id = true, $search_engine_safe = true) {
global $request_type, $session_started, $SID;

if (!tep_not_null($page)) {
  die('<br><br><font color="#ff0000"><b>Error!</b></font><br><br><b>Unable to determine the page link!<br><br>');
}
 }
if ($connection == 'NONSSL') {
  $link = HTTP_SERVER . DIR_WS_HTTP_CATALOG;
} elseif ($connection == 'SSL') {
  if (ENABLE_SSL == true) {
	$link = HTTPS_SERVER . DIR_WS_HTTPS_CATALOG;
  } else {
	$link = HTTP_SERVER . DIR_WS_HTTP_CATALOG;
  }
} else {
  die('<br><br><font color="#ff0000"><b>Error!</b></font><br><br><b>Unable to determine connection method on a link!<br><br>Known methods: NONSSL SSL</b><br><br>');
}

if (tep_not_null($parameters)) {
  $link .= $page . '?' . tep_output_string($parameters);
  $separator = '&';
} else {
  $link .= $page;
  $separator = '?';
}

while ( (substr($link, -1) == '&') || (substr($link, -1) == '?') ) $link = substr($link, 0, -1);

// Add the session ID when moving from different HTTP and HTTPS servers, or when SID is defined
if ( ($add_session_id == true) && ($session_started == true) && (SESSION_FORCE_COOKIE_USE == 'False') ) {
  if (tep_not_null($SID)) {
	$_sid = $SID;
  } elseif ( ( ($request_type == 'NONSSL') && ($connection == 'SSL') && (ENABLE_SSL == true) ) || ( ($request_type == 'SSL') && ($connection == 'NONSSL') ) ) {
	if (HTTP_COOKIE_DOMAIN != HTTPS_COOKIE_DOMAIN) {
	  $_sid = tep_session_name() . '=' . tep_session_id();
	}
  }
}

if ( (SEARCH_ENGINE_FRIENDLY_URLS == 'true') && ($search_engine_safe == true) ) {
  while (strstr($link, '&&')) $link = str_replace('&&', '&', $link);

  $link = str_replace('?', '/', $link);
  $link = str_replace('&', '/', $link);
  $link = str_replace('=', '/', $link);

  $separator = '?';
}

if (isset($_sid)) {
  $link .= $separator . $_sid;
}

// AJAX Addto shopping_cart - Begin
$link_ajax = '';
if( tep_not_null($parameters) && preg_match("/buy_now/i", $parameters) && $page != 'ajax_shopping_cart.php'){
  $link_ajax = '" onclick="doBuyNowGet(\'' . tep_href_link( 'ajax_shopping_cart.php', $parameters, $connection, $add_session_id, $search_engine_safe) . '\'); return false;';
}

return $link . $link_ajax;
// AJAX Addto shopping_cart - End
}

 

now both of them work correctly on productinfo page but in index page behaviour of ajax disabled and work like when i don't install that

can give me a solution ?

Share this post


Link to post
Share on other sites

When ultimate SEO URL is enabled my product url's look like this:

 

http://www.website.com/catalog/puma-future-p-1306.html

 

and they dont link to anything, the only page that loads is the home page.

 

When ultimate SECO URL is disabled my product url's look like this

 

http://www.website.com/catalog/product_inf...roducts_id=1306

 

and site works just fine.

 

Did i do something wrong in the installation?

 

-Wala

Share this post


Link to post
Share on other sites

My be i should add some details, i am using the newest version of SEO v2.8. This is a first time install. When I enable SEO in the admin all my products link to "page not found"

 

I have read this forum up and down, and everyone keeps mentioning the .htaccess file. So i have included it below.

 

Server info:

 

Server OS: Linux 2.4.21-53.ELsmp Database: MySQL 5.0.67.d7-ourdelta-log

Server Date: 08/18/2009 23:09:57 Datebase Date: 08/18/2009 22:09:57

Server Up Time: 22:09:57 up 349 days, 19:59, 0 users, load average: 5.57, 5.47, 5.21

HTTP Server: Apache

PHP Version: 5.2.5 (Zend: 2.2.0)

 

Any help would be greatly appreciated.

# $Id: .htaccess 1739 2007-12-20 00:52:16Z hpdl $
#
# This is used with Apache WebServers
#
# For this to work, you must include the parameter 'Options' to
# the AllowOverride configuration
#
# Example:
#
# <Directory "/usr/local/apache/htdocs">
#   AllowOverride Options
# </Directory>
#
# 'All' with also work. (This configuration is in the
# apache/conf/httpd.conf file)

# The following makes adjustments to the SSL protocol for Internet
# Explorer browsers

#<IfModule mod_setenvif.c>
#  <IfDefine SSL>
#    SetEnvIf User-Agent ".*MSIE.*" \
#             nokeepalive ssl-unclean-shutdown \
#             downgrade-1.0 force-response-1.0
#  </IfDefine>
#</IfModule>

# If Search Engine Friendly URLs do not work, try enabling the
# following Apache configuration parameter

# AcceptPathInfo On

# Fix certain PHP values
# (commented out by default to prevent errors occuring on certain
# servers)

# php_value session.use_trans_sid 0
# php_value register_globals 1

# Ultimate SEO URLs BEGIN
Options +FollowSymLinks
RewriteEngine On
RewriteBase /

RewriteCond %{QUERY_STRING} ^options\=(.*)$
RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2%1
RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING}
RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-au-(.*).html$ articles.php?authors_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING}
# BOF: "Extra pages-info box w/ admin" support added by faaliyet
RewriteRule ^(.*)-pm-([0-9]+).html$ info_pages.php?pages_id=$2&%{QUERY_STRING}
# EOF: "Extra pages-info box w/ admin" support added by faaliyet
RewriteRule ^(.*)-links-(.*).html$ links.php?lPath=$2&%{QUERY_STRING}
# Added polls and newsdesk
#RewriteRule ^(.*)-po-([0-9]+).html$ pollbooth.php?pollid=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-n-(.*).html$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-nc-(.*).html$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-nri-(.*).html$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-nra-(.*).html$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING}
# BOF: Faqdesk support added by faaliyet
 RewriteRule ^(.*)-f-(.*).html$ faqdesk_info.php?faqdesk_id=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-fc-(.*).html$ faqdesk_index.php?faqPath=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-fri-(.*).html$ faqdesk_reviews_info.php?faqdesk_id=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-fra-(.*).html$ faqdesk_reviews_article.php?faqdesk_id=$2&%{QUERY_STRING}
# EOF: Faqdesk support added by faaliyet
# Ultimate SEO URLs END

# Block Bad Bots
RewriteCond %{HTTP_USER_AGENT} ^BlackWidow [OR]
RewriteCond %{HTTP_USER_AGENT} ^Bot\ mailto:craftbot@yahoo.com [OR]
RewriteCond %{HTTP_USER_AGENT} ^ChinaClaw [OR]
RewriteCond %{HTTP_USER_AGENT} ^Custo [OR]
RewriteCond %{HTTP_USER_AGENT} ^DISCo [OR]
RewriteCond %{HTTP_USER_AGENT} ^Download\ Demon [OR]
RewriteCond %{HTTP_USER_AGENT} ^eCatch [OR]
RewriteCond %{HTTP_USER_AGENT} ^EirGrabber [OR]
RewriteCond %{HTTP_USER_AGENT} ^EmailSiphon [OR]
RewriteCond %{HTTP_USER_AGENT} ^EmailWolf [OR]
RewriteCond %{HTTP_USER_AGENT} ^Express\ WebPictures [OR]
RewriteCond %{HTTP_USER_AGENT} ^ExtractorPro [OR]
RewriteCond %{HTTP_USER_AGENT} ^EyeNetIE [OR]
RewriteCond %{HTTP_USER_AGENT} ^FlashGet [OR]
RewriteCond %{HTTP_USER_AGENT} ^GetRight [OR]
RewriteCond %{HTTP_USER_AGENT} ^GetWeb! [OR]
RewriteCond %{HTTP_USER_AGENT} ^Go!Zilla [OR]
RewriteCond %{HTTP_USER_AGENT} ^Go-Ahead-Got-It [OR]
RewriteCond %{HTTP_USER_AGENT} ^GrabNet [OR]
RewriteCond %{HTTP_USER_AGENT} ^Grafula [OR]
RewriteCond %{HTTP_USER_AGENT} ^HMView [OR]
RewriteCond %{HTTP_USER_AGENT} HTTrack [NC,OR]
RewriteCond %{HTTP_USER_AGENT} ^Image\ Stripper [OR]
RewriteCond %{HTTP_USER_AGENT} ^Image\ Sucker [OR]
RewriteCond %{HTTP_USER_AGENT} Indy\ Library [NC,OR]
RewriteCond %{HTTP_USER_AGENT} ^InterGET [OR]
RewriteCond %{HTTP_USER_AGENT} ^Internet\ Ninja [OR]
RewriteCond %{HTTP_USER_AGENT} ^JetCar [OR]
RewriteCond %{HTTP_USER_AGENT} ^JOC\ Web\ Spider [OR]
RewriteCond %{HTTP_USER_AGENT} ^larbin [OR]
RewriteCond %{HTTP_USER_AGENT} ^LeechFTP [OR]
RewriteCond %{HTTP_USER_AGENT} ^Mass\ Downloader [OR]
RewriteCond %{HTTP_USER_AGENT} ^MIDown\ tool [OR]
RewriteCond %{HTTP_USER_AGENT} ^Mister\ PiX [OR]
RewriteCond %{HTTP_USER_AGENT} ^Navroad [OR]
RewriteCond %{HTTP_USER_AGENT} ^NearSite [OR]
RewriteCond %{HTTP_USER_AGENT} ^NetAnts [OR]
RewriteCond %{HTTP_USER_AGENT} ^NetSpider [OR]
RewriteCond %{HTTP_USER_AGENT} ^Net\ Vampire [OR]
RewriteCond %{HTTP_USER_AGENT} ^NetZIP [OR]
RewriteCond %{HTTP_USER_AGENT} ^Octopus [OR]
RewriteCond %{HTTP_USER_AGENT} ^Offline\ Explorer [OR]
RewriteCond %{HTTP_USER_AGENT} ^Offline\ Navigator [OR]
RewriteCond %{HTTP_USER_AGENT} ^PageGrabber [OR]
RewriteCond %{HTTP_USER_AGENT} ^Papa\ Foto [OR]
RewriteCond %{HTTP_USER_AGENT} ^pavuk [OR]
RewriteCond %{HTTP_USER_AGENT} ^pcBrowser [OR]
RewriteCond %{HTTP_USER_AGENT} ^RealDownload [OR]
RewriteCond %{HTTP_USER_AGENT} ^ReGet [OR]
RewriteCond %{HTTP_USER_AGENT} ^SiteSnagger [OR]
RewriteCond %{HTTP_USER_AGENT} ^SmartDownload [OR]
RewriteCond %{HTTP_USER_AGENT} ^SuperBot [OR]
RewriteCond %{HTTP_USER_AGENT} ^SuperHTTP [OR]
RewriteCond %{HTTP_USER_AGENT} ^Surfbot [OR]
RewriteCond %{HTTP_USER_AGENT} ^tAkeOut [OR]
RewriteCond %{HTTP_USER_AGENT} ^Teleport\ Pro [OR]
RewriteCond %{HTTP_USER_AGENT} ^VoidEYE [OR]
RewriteCond %{HTTP_USER_AGENT} ^Web\ Image\ Collector [OR]
RewriteCond %{HTTP_USER_AGENT} ^Web\ Sucker [OR]
RewriteCond %{HTTP_USER_AGENT} ^WebAuto [OR]
RewriteCond %{HTTP_USER_AGENT} ^WebCopier [OR]
RewriteCond %{HTTP_USER_AGENT} ^WebFetch [OR]
RewriteCond %{HTTP_USER_AGENT} ^WebGo\ IS [OR]
RewriteCond %{HTTP_USER_AGENT} ^WebLeacher [OR]
RewriteCond %{HTTP_USER_AGENT} ^WebReaper [OR]
RewriteCond %{HTTP_USER_AGENT} ^WebSauger [OR]
RewriteCond %{HTTP_USER_AGENT} ^Website\ eXtractor [OR]
RewriteCond %{HTTP_USER_AGENT} ^Website\ Quester [OR]
RewriteCond %{HTTP_USER_AGENT} ^WebStripper [OR]
RewriteCond %{HTTP_USER_AGENT} ^WebWhacker [OR]
RewriteCond %{HTTP_USER_AGENT} ^WebZIP [OR]
RewriteCond %{HTTP_USER_AGENT} ^Wget [OR]
RewriteCond %{HTTP_USER_AGENT} ^Widow [OR]
RewriteCond %{HTTP_USER_AGENT} ^WWWOFFLE [OR]
RewriteCond %{HTTP_USER_AGENT} ^Xaldon\ WebSpider [OR]
RewriteCond %{HTTP_USER_AGENT} ^Zeus
RewriteRule .* - [F]

Share this post


Link to post
Share on other sites
When ultimate SEO URL is enabled my product url's look like this:

 

http://www.website.com/catalog/puma-future-p-1306.html

 

and they dont link to anything, the only page that loads is the home page.

 

When ultimate SECO URL is disabled my product url's look like this

 

http://www.website.com/catalog/product_inf...roducts_id=1306

 

and site works just fine.

 

Did i do something wrong in the installation?

 

-Wala

Check the path in the .htaccess file.

 

Jack

Share this post


Link to post
Share on other sites
got it working! thanks to the contributor! I have a small new problem though. If a product is added to the cart prior to clicking the product page, the customer is automatically redirected to the new product page. This is a minor issue but could be annoying for future customers.. Any ideas?

 

I'm having the same problem with all my pages returning 404 but I can see them. How did you get that fixed? Can you post the changes here? Thank you!

Share this post


Link to post
Share on other sites

For those having problems with the pages showing, that is almost always due to the .htaccess file being setup incorrectly. But without the .htaccess file and the domain name, what you are basically saying is, "It's broke," which doesn't give anyone enoguh information to help you with.

 

Jack

Share this post


Link to post
Share on other sites

I've upgrading my store to rc2a. I use multi vendor shipping and it has a shipping estimator. I've gotten every thing to work except the shipping estimator. I posted over in the MVS forum and was told "the Ultimate SEO URLs addon interferes with passing GET variables. You'll need to modify it to pass the pID to the estimator page."

 

Anyone know what this means or how to fix it?

 

TIA

Share this post


Link to post
Share on other sites
For those having problems with the pages showing, that is almost always due to the .htaccess file being setup incorrectly. But without the .htaccess file and the domain name, what you are basically saying is, "It's broke," which doesn't give anyone enoguh information to help you with.

 

Jack

 

Hey Jack, I added the code in my .htaccess file in the post directly after the original, i followed the instruction that you provided and it still does not work. What information do you need to help with this problem?

Share this post


Link to post
Share on other sites
Hey Jack, I added the code in my .htaccess file in the post directly after the original, i followed the instruction that you provided and it still does not work. What information do you need to help with this problem?

You state your shop is locate in a directory named catalog - http://www.website.com/catalog - but your .htaccess file shows it is in the root - RewriteBase /. The instructions tell you to enter the directory the shop is located in. It even provides an example using catalog. You may want to take another look at that.

 

Jack

Share this post


Link to post
Share on other sites
You state your shop is locate in a directory named catalog - http://www.website.com/catalog - but your .htaccess file shows it is in the root - RewriteBase /. The instructions tell you to enter the directory the shop is located in. It even provides an example using catalog. You may want to take another look at that.

 

Jack

 

 

Wow that was stupid, thanks for your help Jack.

Share this post


Link to post
Share on other sites
I have the newest v2.8 installed, awesome btw, but I do have an issue...

 

My Site --> http://www.customwheelsexpress.com

 

I have quotes in my category and product names. As far as I can tell the script strips out any quotes (probably to make it not interfere with anything else). I have tried using the html markup for a quote (") in the product name but it also seem to strip out the '&' symbol and just leaves 'quot'. In either case is there a way for me to make the " either appear as a quote or change it to a word such as 'inch'?

 

Thanks,

Blaine

 

Bump

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×