Jump to content
spidometrs

[CONTRIBUTION] Ultimate SEO URLs v2.1 - by Chemo

Recommended Posts

Does anyone know why my urls look like this:

 

http://www.supplementedge.com/whey-gold-fr...292?osCsid.html

 

I get a 404 because of the osCsid. anyone have any ideas?

 

Could someone please help with this problem. I have the same problem and I don't know what's wrong.

 

When a fresh customer first arrives and the sid is present, if the first link a customer clicks on is products "details" link the resulting url is this:

 

http://www.mysite.com/save-decal-p-220?osCsid.html

instead of

http://www.mysite.com/save-decal-p-220.html

 

clicking on it results in an error 404 page not found.

 

It doesn't happen once the sid is gone.My .htaccess file is exactly what was provided with Ultimate Seo

 

Also I have noticed that if a customer is not logiged in and adds a product to the cart and proceeds to checkout, they are asked to login, but after they do they are redirected back to index.php instead of continuing through the check out process.

 

Thank You

 

Larry

Share this post


Link to post
Share on other sites
Could someone please help with this problem. I have the same problem and I don't know what's wrong.

 

When a fresh customer first arrives and the sid is present, if the first link a customer clicks on is products "details" link the resulting url is this:

 

http://www.mysite.com/save-decal-p-220?osCsid.html

instead of

http://www.mysite.com/save-decal-p-220.html

 

clicking on it results in an error 404 page not found.

 

It doesn't happen once the sid is gone.My .htaccess file is exactly what was provided with Ultimate Seo

 

Also I have noticed that if a customer is not logiged in and adds a product to the cart and proceeds to checkout, they are asked to login, but after they do they are redirected back to index.php instead of continuing through the check out process.

 

Thank You

 

Larry

 

Larry, do you have the 'page cache' contribution installed? I have disabled that contribution and now everything works fine. But I really want to get page cache working with SEO urls because it really increased the speed of my site.

I would also like to say that I only started getting this problem when I restored one of my database backups.

 

Does anyone else have any incite with using SEO urls and page cache contributions together?

Edited by p0ng

Share this post


Link to post
Share on other sites
i have installed Ultimate_SEO_URLSv21d_UPDATED-23-NOV-2008 and work if i select the products from menu categories

if i select an product from new products box or specials box and push add to cart the shopping cart show 0. if i go back the product appear in the shopping cart.

same like are reset the cash (cookies)

 

what can i do?

 

Thanks

 

first add some products on shopping cart , after i'm going and click to an product from specials box or new products box

my url become: localhost/Osc/catalog2/speed-cruise-control-p-18.html?whatsnew=Speed-2:-Cruise-Control&osCsid=cb7451a50e81db1d46fdf0ac025eabc8

if i delete the last of url ?whatsnew=Speed-2:-Cruise-Control&osCsid=cb7451a50e81db1d46fdf0ac025eabc8 and click refresh on browser the shopping cart show 0 products

 

please.... any ideea

 

Thanks

Edited by danut82

Share this post


Link to post
Share on other sites
Larry, do you have the 'page cache' contribution installed? I have disabled that contribution and now everything works fine. But I really want to get page cache working with SEO urls because it really increased the speed of my site.

I would also like to say that I only started getting this problem when I restored one of my database backups.

 

Does anyone else have any incite with using SEO urls and page cache contributions together?

 

Thanks for the reply. i don't have a page cache contribution, but I do have a "Cache" option in the admin panel. And I also have several cache options under Configuratin / Seo Urls:

 

Enable SEO cache to save queries? true

Enable product cache? true

Enable categories cache? true

Enable manufacturers cache? true

Enable articles cache? true

Enable topics cache? true

Enable information cache? true

Enable link directory cache? true

 

These are all the default settings

 

Larry

Share this post


Link to post
Share on other sites
I have installed 2.1d ORIGINAL updated

on a Zeus server and i get 404 errors

I have installed this on Apache servers before without any problems

Now I am installing it on a Zeus Web Server I get 404 errors

 

If this is still an issue, I spent yesterday battling with a Zeus server trying to install a working OSC site ...

The following is what I was able to get things working with

(with thanks to http://www.realisingdesigns.com/weblog/ind...us-web-server/)

 

RULE_0_START:

map path into SCRATCH:DOCROOT from /
set SCRATCH:ORIG_URL = %{URL}
set SCRATCH:REQUEST_URI = %{URL}

#Check for Querystring and add to Scratch
match SCRATCH:ORIG_URL into $ with ^/(.*)\?(.*)$
if matched then
  set SCRATCH:QUERY_STRING = $2
endif

# Check for category pages
match URL into $ with \/c([^/]*)/index\.html$
if matched then
  set URL = /index.php?cPath=$1
  goto RULE_QUERY_APPEND_START
endif

# Check for article_info.html pages
match URL into $ with \/a([0-9]+_?[0-9]*)/(.*)/article_info\.html$
if matched then
  set URL = /article_info.php?articles_id=$1
  goto RULE_QUERY_APPEND_START
endif

# Check for product_info.html pages
match URL into $ with \/p([0-9]+_?[0-9]*)/(.*)/product_info\.html$
if matched then
  set URL = /product_info.php?products_id=$1
  goto RULE_QUERY_APPEND_START
endif

# Check for product_reviews.html pages
match URL into $ with \/p([0-9]+_?[0-9]*)/(.*)/product_reviews\.html$
if matched then
  set URL = /product_reviews.php?products_id=$1
  goto RULE_QUERY_APPEND_START
endif

# Check for information.html pages
match URL into $ with \/i([0-9]+_?[0-9]*)/(.*)/information\.html$
if matched then
  set URL = /information.php?info_id=$1
  goto RULE_QUERY_APPEND_START
endif

#Test output - Uncomment this to debug
#set BODY=MATCHED ROOT "%{SCRATCH:DOCROOT}" FOLDER "%{SCRATCH:SUBFOLDER}" AND URI "%{SCRATCH:REQUEST_URI}" AND QUERY STRING "%{SCRATCH:QUERY_STRING}"

# if we made it here then its no rewrite
goto END
RULE_0_END:

#-------------------------------------------------------------

RULE_QUERY_APPEND_START:

match SCRATCH:ORIG_URL into $ with \?(.*)$
if matched then
#  set URL = %{URL}
  set URL . &%{SCRATCH:QUERY_STRING}
endif

RULE_QUERY_APPEND_END:

Share this post


Link to post
Share on other sites
I just installed v2.7 on my oscommerce MS2.2. everything seems fine but i have a serious problem in the checkout process.

 

i'm using PayPay IPN for my site, however my site seems cannot capture the order number, it always shows 0. And the order has not been created evenif my customer has checkout successfully.

 

If I turn off the SEO URLs form admin, everything work fine!

 

I'm thinking if the problem is caused in the "catalog\includes\functions\html_output.php"? Is that a way to exclude the checkout pages from processing by the SEO URL codes?

 

Thank guys!

 

Anyone has the same problem!?

 

Thanks!

George

Share this post


Link to post
Share on other sites
Anyone has the same problem!?

 

Thanks!

George

 

Yes I've seen this before and it was related to the W3C and &/&

 

The example I remember was express where $params['RETURNURL'] used tep_href_link() this returned url had to be doctored to remove the & .. like ..

$params['RETURNURL'] = str_replace('&', '&', tep_href_link('ext/modules/payment/paypal/express.php', 'osC_Action=retrieve', 'SSL', true, false));

Share this post


Link to post
Share on other sites
The original seo urls quite wrongly used a delete where LIKE seo statement.

 

This in turn means that the installation of seo urls deletes any entries with the words seo in them (e.g. seo header tags)

 

Jack put up a version of ultimate seo urls with this problem fixed. perhaps you should change to that version.

 

Any future uploads I put of 2.1d original updated I put up will include this change.

 

 

FWR Media,

 

please make downloadable this modification because i think that is the answer of all my problems

if i disable from admin seo url all it's ok and shoppig cart are working

 

Thank you for all

Share this post


Link to post
Share on other sites

I have installed SEO URLs and after a long hard battle with the server declarations finally got it to work. Well, almost. I have one last hurdle I am trying to solve. If anyone can help me with this I would really appreciate it.

 

It seems that whenever I click on any of the categories, the url rewrite works just fine for about a second and then the loaded page gets redirected back to the index.php. This happens if I click on any of the categories or the test product I uploaded. I took a look at the server error logs and there were a bunch of missing image files that were being called by the stylesheet. Since I am using a template I figured these files were not included because they were not necesary. So, I created a few 1px x 1px images with the corresponding missing names in the images folder in the hopes that the "missing" error was causing some kind or 404 or 301 re-direct to happen. This didn't work. Now I am stuck. There are no more errors in the logfile and I don't know where to turn next. Here is the link so you can see what I'm talking about. Any help or ideas would be much appreciated. The DNS is not pointed to this site yet as I want to get it up and running first.

 

http://67.192.61.51/catalog

 

Thanks in advance.

 

-C

 

p.s. I have Ultimate SEO URLs 2.7 by faaliyet updated on the March, 23rd 2009

Share this post


Link to post
Share on other sites
first add some products on shopping cart , after i'm going and click to an product from specials box or new products box

my url become: localhost/Osc/catalog2/speed-cruise-control-p-18.html?whatsnew=Speed-2:-Cruise-Control&osCsid=cb7451a50e81db1d46fdf0ac025eabc8

if i delete the last of url ?whatsnew=Speed-2:-Cruise-Control&osCsid=cb7451a50e81db1d46fdf0ac025eabc8 and click refresh on browser the shopping cart show 0 products

 

please.... any ideea

 

Thanks

 

 

maybe my problem is in .htaccess file

please help me to create an RewriteRule for Wishlist contribution because now are stop working - work just if first i add something in shopping cart

(and the modifications in seo.class.php)

 

have anyone this problem

 

thanks in advance

Edited by danut82

Share this post


Link to post
Share on other sites

Lots of many unanswered questions on this add-on, so I don't want to add to them really, so this is more an observation than a question.

 

I have a mirror osCommerce site as a back-up to my live site just in case the worse happens - until this morning they were absolutely 100% identical, but just pointed to different databases (the mirror DB was an install of a back-up of the live site). On that mirror site today I successfully installed cDynamic_Meta_Tags v1.5.1, Ultimate Seo Urls v2.7 (23 Mar 2009) and google_base_auto_feeder_1_2_1. So, with my mirror site working perfectly, I decided to apply the add-ons to the live site.

 

cDynamic works fine, but Ultimate Seo just won't run properly - I still get the loooooong osC codes after the Ultimate Seo generated URL, and the "Sort order:" drop down is completely ignored. I currently have the Ultimate Seo add-on disabled on the live site, which is a shame (but the sort order now works!)... I am totally puzzled as to why on earth one runs and one doesn't.

 

I literally copied every single file that works perfectly well on the mirror site to the live site, but just altered the .htaccess to point to a different directory.

 

Jonathan

Share this post


Link to post
Share on other sites

A few days ago I asked for help on Ultimate SEO v 2.7. I was told about the .htaccess file (which I had already done), and I was asked if the store is under root or /catalog/.

 

I responded, thanked people for their time, and gave a little additional info, which I thought might help.

 

So far, I have received no answers. The comments about being a help vampire are much understood, but if one does not know how to fix an apparent error in a contrib, what happens next?

 

Not trying to make anyone angry, just trying to figure out a problem.

Share this post


Link to post
Share on other sites
A few days ago I asked for help on Ultimate SEO v 2.7. I was told about the .htaccess file (which I had already done), and I was asked if the store is under root or /catalog/.

 

I responded, thanked people for their time, and gave a little additional info, which I thought might help.

 

So far, I have received no answers. The comments about being a help vampire are much understood, but if one does not know how to fix an apparent error in a contrib, what happens next?

 

Not trying to make anyone angry, just trying to figure out a problem.

 

Hello Cindy,

 

You have probably not received any replies because this is the support thread for the Ultimate SEO URLs v2.1 release

The latest release is 2.1d - Chemo's ORIGINAL updated - by Jack_mcs - 23 Nov 2008

http://addons.oscommerce.com/info/2823

Share this post


Link to post
Share on other sites
Hello Cindy,

 

You have probably not received any replies because this is the support thread for the Ultimate SEO URLs v2.1 release

The latest release is 2.1d - Chemo's ORIGINAL updated - by Jack_mcs - 23 Nov 2008

http://addons.oscommerce.com/info/2823

It's a fair point, larry, but there doesn't seem be a separate support thread.

 

Cindy, what was the problem with you .htaccess file?

 

Any road up. A little update on the post I made yesterday. It seems Ultimate SEO was working, but I needed the additional SID killer add-on which can be found at http://www.oscommerce.com/community/contributions,952, to get rid of all the id numbers.

 

Just a point of interest though. I renamed my mirror site folder, which originally worked without the SID killer add-on and had none of the long numbers after the html page, so that it was the main site visitors went to. However, rather oddly as soon as I did that, all the pesky long numbers appeared again. So it seems that for one area of my site, it didn't add the SID numbers, but on another area of the site it did - for no apparent reason!

 

Soz for rambling, but it may one day be of interest to somebody!

 

Jonathan

Share this post


Link to post
Share on other sites
A few days ago I asked for help on Ultimate SEO v 2.7. I was told about the .htaccess file (which I had already done), and I was asked if the store is under root or /catalog/.

 

I responded, thanked people for their time, and gave a little additional info, which I thought might help.

 

So far, I have received no answers. The comments about being a help vampire are much understood, but if one does not know how to fix an apparent error in a contrib, what happens next?

 

Not trying to make anyone angry, just trying to figure out a problem.

It looks to me that you are installing under wamp or xampp on your pc.

You use http://localhost/catalog/index.html to access your web site on the pc, the htaccess looks ok from that point of view.

Why not install the version that jack did? We know that works.

 

The help vampire was not referring to you, it was just a link in Robert's signature.

Edited by Coopco

The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
It looks to me that you are installing under wamp or xampp on your pc.

You use http://localhost/catalog/index.html to access your web site on the pc, the htaccess looks ok from that point of view.

Why not install the version that jack did? We know that works.

 

The help vampire was not referring to you, it was just a link in Robert's signature.

 

 

 

can you add support for Wish list contribution to jack version?

 

Thanks

Edited by danut82

Share this post


Link to post
Share on other sites

Thank you, everyone, for your answers. I could not find a separate support forum for Ultimate SEO v2.7.

 

It takes me HOURS to add contribs and get the bugs out. I really wish I could find some reference to a list of contribs that are known to work with each other. I have 6 OSC books, and they all recommend different contribs, and many of them note that they are best done on a clean install. How can you do more than one installation on a clean install?

 

I have OSC ms2.2 installed on a local Linux server (Ubuntu 8.10), with the latest versions of MySQL and Apache and PHP. (Ubuntu does a very decent job of keeping the updates current.)

As a for instance, I installed STS, but later found that others recommend BTS. Once you have the template system installed, you have to do most other mods by hand. If the instructions do not match what I have, because I have already installed another contrib, then I search carefully, compare code, and do a lot of fiddling. I am sure most of us do the same thing.

 

Is there a list of contribs that are known to work together? Is there some chance that these are available to use as a bundle, they are already combined and tested?

 

Much as I don´t want to, I guess I will delete everything and start over. Sorry for being grumpy, but I am under a deadline, and feeling the pressure.

 

Again, thans to everyone for their help. I will use Jack´s contrib for the SEO.

Share this post


Link to post
Share on other sites

There isn't a list that I know of as a lot of it is up to the ability of the coder putting the site together. I do know Bill (STS Creator) has a link in his signature to a contributions download area where people have created bundles with STS and other contrib's.

 

WinMerge is very handy for file comparison ;)

 

 

Thank you, everyone, for your answers. I could not find a separate support forum for Ultimate SEO v2.7.

 

It takes me HOURS to add contribs and get the bugs out. I really wish I could find some reference to a list of contribs that are known to work with each other. I have 6 OSC books, and they all recommend different contribs, and many of them note that they are best done on a clean install. How can you do more than one installation on a clean install?

 

I have OSC ms2.2 installed on a local Linux server (Ubuntu 8.10), with the latest versions of MySQL and Apache and PHP. (Ubuntu does a very decent job of keeping the updates current.)

As a for instance, I installed STS, but later found that others recommend BTS. Once you have the template system installed, you have to do most other mods by hand. If the instructions do not match what I have, because I have already installed another contrib, then I search carefully, compare code, and do a lot of fiddling. I am sure most of us do the same thing.

 

Is there a list of contribs that are known to work together? Is there some chance that these are available to use as a bundle, they are already combined and tested?

 

Much as I don´t want to, I guess I will delete everything and start over. Sorry for being grumpy, but I am under a deadline, and feeling the pressure.

 

Again, thans to everyone for their help. I will use Jack´s contrib for the SEO.


~Tracy
 

Share this post


Link to post
Share on other sites

He was banned from posting in the osC forums - happened before my time here so I don't know the details.

 

Sorry for my ignorance but does anyone know what it means that Chemo is in the "Banned" group?

~Tracy
 

Share this post


Link to post
Share on other sites
He was banned from posting in the osC forums - happened before my time here so I don't know the details.

 

 

 

hi,

 

Tracy i see in your description that you use seo urls with all products contribution

when you select an product from column left - what's new box are adding to shopping cart?

because at my version remane 0

i uninstalled "All Products" contribution and work

have you any ideea where is the mistake

 

apreciate any answer

 

thanks

Dani

Share this post


Link to post
Share on other sites
There isn't a list that I know of as a lot of it is up to the ability of the coder putting the site together. I do know Bill (STS Creator) has a link in his signature to a contributions download area where people have created bundles with STS and other contrib's.

 

WinMerge is very handy for file comparison ;)

 

I found OSC Max v2.0 RC 4, which has about 46 of the contribs already loaded and working together. It looks like this has everything I want in it.

 

Now, to find a hosting company that offers OSC Max instead of just OSC...

Share this post


Link to post
Share on other sites

You should be able to install it yourself with filezilla and access to your database (usually via phpMyAdmin)

 

I found OSC Max v2.0 RC 4, which has about 46 of the contribs already loaded and working together. It looks like this has everything I want in it.

 

Now, to find a hosting company that offers OSC Max instead of just OSC...


~Tracy
 

Share this post


Link to post
Share on other sites

Hmmm- I don't have my "What's New" box set to add products to the cart.

 

Are you wanting it to add the product or no?

 

Are you making any changes to your includes/boxes/whats_new.php when you install "All Products" ?

 

hi,

 

Tracy i see in your description that you use seo urls with all products contribution

when you select an product from column left - what's new box are adding to shopping cart?

because at my version remane 0

i uninstalled "All Products" contribution and work

have you any ideea where is the mistake

 

apreciate any answer

 

thanks

Dani


~Tracy
 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×