Jump to content
spidometrs

[CONTRIBUTION] Ultimate SEO URLs v2.1 - by Chemo

Recommended Posts

I have installed this Contribution, and works great.

Thank you very much for your effort.

 

Now i have the site local, on my laptop, but have problems with links, after Ultimate SEO URL v2.1

 

Online works fine.

Offline, when try to acces a link www.mydomain.com/aaaaa.html , dosen't exist.

Actually, this link is generate by this contribution, but works only online.

 

Any ideas how to work offline?

 

I have installed the sql file, all files, everything looks ok.

The main page it is ok, but any link, dosen't work.

 

Thank you,

Edmond

 

SEO URLs requires the ability to use RewriteRules.

 

apache on your local server has to be set up with mod_rewrite and the allow_overide settings must be sufficient.

Share this post


Link to post
Share on other sites

I've uploaded a new version . It has the following changes.

 

- Changed code to prevent the mass deletion of any group in the database that ends in SEO. This is breaking other contribution.

 

- Added code from an earlier version so that it works with Links Manager

 

Jack

Share this post


Link to post
Share on other sites
Slave products? are you talking about products with attributes?

 

seo urls works, just make sure you install 2.1d original updated which currently has no known issues.

 

ex.

products_id = 30 for master product,

 

several related products with master_id = 30,

 

The program will list all the related products when I click the master product 30.

 

But when I changed the product id from '30' to '30abc' and the master id for those related products to '30abc' in my database table, those related products don't get displayed. I have a feeling somewhere in the program insist the product id and master id to be numerical. Just don't know the program well to figure out where.

Share this post


Link to post
Share on other sites
ex.

products_id = 30 for master product,

 

several related products with master_id = 30,

 

The program will list all the related products when I click the master product 30.

 

But when I changed the product id from '30' to '30abc' and the master id for those related products to '30abc' in my database table, those related products don't get displayed. I have a feeling somewhere in the program insist the product id and master id to be numerical. Just don't know the program well to figure out where.

 

Yes for security the product id must indeed be numerical .. unless it is a uprid where it is numerical plus curly brackets.

 

Otherwise messing with this would create potential security issues unless skillfully handled.

 

Either way it is outside of the realms of support for this contribution.

Share this post


Link to post
Share on other sites
Uninstall it and install 2.1d ORIGINAL updated by FWR Media 7 Nov 2008

 

Will this contribution allow me to rewrite urls in folder-method style ?


Manpower moves wrenches, horsepower moves cars, and the power of the mind moves the world !

Share this post


Link to post
Share on other sites

I got installed: Ultimate SEO Urls v2.1dORIGINAL @osCMS2.2

 

And it's working very nice but I still got the kinda ugly '?cPath=21&osCsid=6c6cbb8c3d3af9847023d7f305553f3f' connected to my URL. Also my test product named 'Never Gonna Give You Up' (yes after the Rick Asthley song) only shows like never-gonna-give-p-29.html dropping off 2 words which might been important for spiders.

 

How can I drop the ?cPath part from the URL and maybe extend the length of the product name in the URL.

 

Thanks in advanced.

Share this post


Link to post
Share on other sites
I got installed: Ultimate SEO Urls v2.1dORIGINAL @osCMS2.2

 

And it's working very nice but I still got the kinda ugly '?cPath=21&osCsid=6c6cbb8c3d3af9847023d7f305553f3f' connected to my URL. Also my test product named 'Never Gonna Give You Up' (yes after the Rick Asthley song) only shows like never-gonna-give-p-29.html dropping off 2 words which might been important for spiders.

 

How can I drop the ?cPath part from the URL and maybe extend the length of the product name in the URL.

 

Thanks in advanced.

 

Firstly there should not be a cPath on the seo url so something is odd in your shop.

 

Secondly the osCsid will not be on the url after the first click if your configuration settings are correct.

 

Thirdly: SEO URLs is droppoing the two lettered word as that is the way it is set up as standard .. have a look at the seo url settings in admin and change the setting.

Share this post


Link to post
Share on other sites

Hey Guys,

 

Sounds like a great contribution. I just wanted to make sure it is going to be worth the headache of installing it on my store. On a 1-10 scale how effective is this? Can anyone tell me how much they think this has increased their organic rankings?

 

Thanks!

Share this post


Link to post
Share on other sites

What does "$2&%" mean in this .htaccess line?

 

RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}

Share this post


Link to post
Share on other sites

If we turn off the SEO URL through admin config by setting it false for 'Enable SEO RULs?' then the it will go back to product_info.php?products_id=.... right? (theorectically speaking since I did turn it off but it doesn't seems to have any effect)

 

If this doesn't turn it off, what do I need to do?

Share this post


Link to post
Share on other sites
If we turn off the SEO URL through admin config by setting it false for 'Enable SEO RULs?' then the it will go back to product_info.php?products_id=.... right? (theorectically speaking since I did turn it off but it doesn't seems to have any effect)

 

If this doesn't turn it off, what do I need to do?

Edited by bbyyaa

Share this post


Link to post
Share on other sites

Hi all

I would like to install this contribution. But by my first test my Onlineshop started with 500 InternalError. I have delete the .htaccess and after that the shop start but not absolut correct. OK, the .htaccess should do something, but for a test I deleted this file. My shop is installed on the root and I didn't find a mistake in the .htaccess.

 

I ask my self, will this contrib not work together with HeaderTags_SEO_V_3.0.4_1_2 ??

 

To your information. I have the oscommerce v2.2 RC2a. As I understood this contrib should be working together with the version from oscommerce or not?

 

Thanks a lot for your anwer

Lexus3

Share this post


Link to post
Share on other sites
Hi all

I would like to install this contribution. But by my first test my Onlineshop started with 500 InternalError. I have delete the .htaccess and after that the shop start but not absolut correct. OK, the .htaccess should do something, but for a test I deleted this file. My shop is installed on the root and I didn't find a mistake in the .htaccess.

 

I ask my self, will this contrib not work together with HeaderTags_SEO_V_3.0.4_1_2 ??

 

To your information. I have the oscommerce v2.2 RC2a. As I understood this contrib should be working together with the version from oscommerce or not?

 

Thanks a lot for your anwer

Lexus3

 

It works fine with RC2a but you have to follow the instructions and your server has to have the normal settings available.

 

Read this thread it has been covered 100 times.

Share this post


Link to post
Share on other sites
I found out that this problem depends on the setting of "persistent connections" in configure.php

 

If I set USE_PCONNECT to false in both includes/configure.php and admin/includes/configure.php everything just works fine :-)

 

KEYWORDS: orders_id, Order ID, bug fix

 

Just quoting this for everyone to know, you cannot use persistent connections with this mod or it does not return the orders_id properly to link as the foreign key in the following tables.

 

orders_products

orders_products_attributes

orders_products_download

orders_status_history

orders_total

Share this post


Link to post
Share on other sites

That happened to my this morning and it has been working fine for months now.

My server told me that the htaccess file doesn't comply with apache 2, it does with apache 1.3 !

 

I'm now on a search for that answer but thought you might want to know what I was told, hope that helps?

 

tim

 

 

 

Hi all

I would like to install this contribution. But by my first test my Onlineshop started with 500 InternalError. I have delete the .htaccess and after that the shop start but not absolut correct. OK, the .htaccess should do something, but for a test I deleted this file. My shop is installed on the root and I didn't find a mistake in the .htaccess.

 

I ask my self, will this contrib not work together with HeaderTags_SEO_V_3.0.4_1_2 ??

 

To your information. I have the oscommerce v2.2 RC2a. As I understood this contrib should be working together with the version from oscommerce or not?

 

Thanks a lot for your anwer

Lexus3

Share this post


Link to post
Share on other sites

I installed Ultimate SEO URL v2.1d ORIGINAL dated 23/11/2008 and i have a problem when adding items to the cart. Items are added fine and shown in the cart when added through the product info screen but when items are added through the product listing page the cart clears of all items in it. I have noticed that everytime i add items from the product listing page the session id is renewed.

 

I am using xampp and oscommerce rc2.2a.

 

Any help would be appreciated.

Share this post


Link to post
Share on other sites
I installed Ultimate SEO URL v2.1d ORIGINAL dated 23/11/2008 and i have a problem when adding items to the cart. Items are added fine and shown in the cart when added through the product info screen but when items are added through the product listing page the cart clears of all items in it. I have noticed that everytime i add items from the product listing page the session id is renewed.

 

I am using xampp and oscommerce rc2.2a.

 

Any help would be appreciated.

 

 

Not an issue with seo urls .. you must have a code problem.

Share this post


Link to post
Share on other sites
Not an issue with seo urls .. you must have a code problem.

 

The only reason why i posted here was because if i remove Ultimate SEO URL then it all works fine but if i install Ulatimate SEO URL then the problem occurs. Was hoping someone could give me some insight on this and help solve the problem.

Share this post


Link to post
Share on other sites
The only reason why i posted here was because if i remove Ultimate SEO URL then it all works fine but if i install Ulatimate SEO URL then the problem occurs. Was hoping someone could give me some insight on this and help solve the problem.

 

I had the same problem with an old store of mine. Here was the fix for me:

 

Ultimate SEO works great, but it also adds & to redirects which can mess up some cart functions. I bet if you disable your cookies completely your site will work. That would not be a good idea though, so here is how to get SEO to work correctly with your cart:

 

 

Find (catalog/includes/classes/seo.class.php)..

 

------------ CODE SAMPLE ----------

case ($this->attributes['USE_SEO_REDIRECT'] == 'true'):

header("HTTP/1.0 301 Moved Permanently");

header("Location: $url"); // redirect...bye bye

-----------------------------------

 

and adjust to ..

 

------------ CODE SAMPLE ----------

case ($this->attributes['USE_SEO_REDIRECT'] == 'true'):

$url = str_replace('&', '&', $url);

header("HTTP/1.0 301 Moved Permanently");

header("Location: $url"); // redirect...bye bye

-----------------------------------

 

 

 

For good measure find (catalog/includes/functions/general.php) ..

 

------------ CODE SAMPLE ----------

header('Location: ' . $url);

-----------------------------------

 

Add directly above ..

 

------------ CODE SAMPLE ----------

$url = str_replace('&', '&', $url);

-----------------------------------

Share this post


Link to post
Share on other sites

Modifications to Ultimate SEO URLS

 

Hello,

 

I've been doing some very heavy modifications to our stores lately and have learned a tremendous amount about osCommerce. I have about 30 contributions I've created for us but I don't know if I'd be helping or hurting by sharing it with others because of how customized some of them are. Some of the more simple mods I've made are to Ultimate SEO URLs to prevent duplicate content and they work very well on our server and store. Would I be stepping on someones toes if I uploaded a contribution to Ultimate SEO URLs? A few of the mods I made rely on FWRs URL validation, but some of them just simply modify .htaccess and parts of the tep_href_link function in html_output.

Share this post


Link to post
Share on other sites
For good measure find (catalog/includes/functions/general.php) ..

 

------------ CODE SAMPLE ----------

header('Location: ' . $url);

-----------------------------------

 

Add directly above ..

 

------------ CODE SAMPLE ----------

$url = str_replace('&', '&', $url);

-----------------------------------

 

Thanks for this Kalyn. This last piece of code fixed everything.

Share this post


Link to post
Share on other sites
Thanks for this Kalyn. This last piece of code fixed everything.

 

 

I posted that fix ages ago in this thread, I had assumed that this had been done.

Share this post


Link to post
Share on other sites
Modifications to Ultimate SEO URLS

 

Hello,

 

I've been doing some very heavy modifications to our stores lately and have learned a tremendous amount about osCommerce. I have about 30 contributions I've created for us but I don't know if I'd be helping or hurting by sharing it with others because of how customized some of them are. Some of the more simple mods I've made are to Ultimate SEO URLs to prevent duplicate content and they work very well on our server and store. Would I be stepping on someones toes if I uploaded a contribution to Ultimate SEO URLs? A few of the mods I made rely on FWRs URL validation, but some of them just simply modify .htaccess and parts of the tep_href_link function in html_output.

 

The contrib system is there for people to post contibutions. The only issues occur when .. like seo urls .. the original concept is overloaded with bad addons and partial changes.

 

If you feel it is valuable then why not start a new contrib as a USU fork?

Share this post


Link to post
Share on other sites

Hello,

 

Great contrib but I have a little problem:

When Force Cookie use is set to True, direction show the correct way:

http: //localhost/tienda_base/microsoft-intellimouse-explorer-p-26.html

but I can't add the item to the cart (it leaves me to the cookies' page)

 

But when Force Cookie use is set to False (which is the option I want not to lose sells), direction shows the following way

http://localhost/tienda_base/microsoft-int...u6gokvmmu51lmq0

and it that case I can add the item to cart.

 

Could anybody give me a idea please?

 

Sébastien

 

Note: the shop is not located in the root

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×