Jump to content
spidometrs

[CONTRIBUTION] Ultimate SEO URLs v2.1 - by Chemo

Recommended Posts

The closest I have to that is this:

 

Ok then ..

 

Find ..

		function check_redirect(){
			$this->need_redirect = false; 
			$this->path_info = is_numeric(strpos(ltrim(getenv('PATH_INFO'), '/') , '/')) ? ltrim(getenv('PATH_INFO'), '/') : NULL;

 

Replace with ..

 

		function check_redirect(){
			$this->need_redirect = false; 
			// BOF: FWR - Some servers show the folders in getenv('PATH_INFO') like /catalog/shop/
			$getEnvPathInfo = getenv('PATH_INFO');
			if( false !== strpos($getEnvPathInfo, DIR_WS_HTTP_CATALOG) ){
			  $rawpath = str_replace(DIR_WS_HTTP_CATALOG, '', $getEnvPathInfo);
			} else {
			  $rawpath = $getEnvPathInfo;
			}  
			$this->path_info = is_numeric(strpos(ltrim($rawpath, '/') , '/'))
			? ltrim($rawpath, '/') : NULL;
			// EOF: FWR - Some servers show the folders in getenv('PATH_INFO') like /catalog/shop/

Share this post


Link to post
Share on other sites
Ok then ..

 

Find ..

 

 

I have tried this and everything is the same. The drop down boxes are still redirecting to the index.php page. Any other thoughts?

 

Thanks again.

Share this post


Link to post
Share on other sites
I have tried this and everything is the same. The drop down boxes are still redirecting to the index.php page. Any other thoughts?

 

Thanks again.

 

Well that is deffo the problem which must mean my code is faulty .. are you online for quick responses for a bit?

Share this post


Link to post
Share on other sites
Well that is deffo the problem which must mean my code is faulty .. are you online for quick responses for a bit?

 

 

Sorry for the late response... If you're around tomorrow maybe we can try again. Thanks again for all of your help.

Share this post


Link to post
Share on other sites

I have installed the Rapid SSL in my website: www.officeconsumables.com.au

 

Now besides the homepage, there are almost all pages has https, even the info page.

 

What I want is just for the payment sections use the SSL, like my account.

 

I changed the code in admin/include/configure.php

 

I try to reset the SEO URLs cache by Reset SEO URLs Cache under SEO URLs admin. got this after change: Last Modified: 11/03/2008

 

but after I reseting, Nothing changed.

 

Did I make the right action for SEO URLs?

 

 

Anybody has a clue?

 

Thanks!

 

Dan

Share this post


Link to post
Share on other sites
Aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaah!!!!!

 

For the LAST time, ultimate seo urls provides URLS!!! it does not alter the way forms work in basic html.

 

No need to have a stroke, if you go back and read the message trail, that is what I have been trying to get you to confirm for almost a month.

 

 

thanks.

Share this post


Link to post
Share on other sites
I have installed the Rapid SSL in my website: www.officeconsumables.com.au

 

Now besides the homepage, there are almost all pages has https, even the info page.

 

What I want is just for the payment sections use the SSL, like my account.

 

I changed the code in admin/include/configure.php

 

I try to reset the SEO URLs cache by Reset SEO URLs Cache under SEO URLs admin. got this after change: Last Modified: 11/03/2008

 

but after I reseting, Nothing changed.

 

Did I make the right action for SEO URLs?

 

 

Anybody has a clue?

 

Thanks!

 

Dan

 

Admin files have nothing to do with the catalog config and this is a config issue not an seo urls issue.

 

Check catalog /includes/configure.php which should be like (if the shop is in root)..

 

  define('HTTP_SERVER', 'http://www.mysite.com');
 define('HTTPS_SERVER', 'https://www.mysite.com');
 define('ENABLE_SSL', true);
 define('HTTP_COOKIE_DOMAIN', 'www.mysite.com');
 define('HTTPS_COOKIE_DOMAIN', 'www.mysite.com');
 define('HTTP_COOKIE_PATH', '/');
 define('HTTPS_COOKIE_PATH', '/');
 define('DIR_WS_HTTP_CATALOG', '/');
 define('DIR_WS_HTTPS_CATALOG', '/');

Share this post


Link to post
Share on other sites
Well that is deffo the problem which must mean my code is faulty .. are you online for quick responses for a bit?

 

 

I'll be around for a bit today. Should I remove the last bit of code that you recommended I try?

 

Thanks again.

Share this post


Link to post
Share on other sites

Hello all

 

I've installed seo urls v2.6 today and am having a problem in that all of the special characters (like the £ - GB pound sterling symbol) are showing up as ?? (double question mark) across the whole site. I've tried to set the 'output w3c valid urls' to false and reset the cache but it doesn't solve the problem. I've also tried to enter some special character conversions such as £=>£ and £=>£ but it hasn't worked and I can't seem to find any support threads on special character conversions. If anyone can help or point me in the right direction it would be much appreciated.

 

Thanks,

 

Mike

Share this post


Link to post
Share on other sites
Hello all

 

I've installed seo urls v2.6 today and am having a problem in that all of the special characters (like the £ - GB pound sterling symbol) are showing up as ?? (double question mark) across the whole site. I've tried to set the 'output w3c valid urls' to false and reset the cache but it doesn't solve the problem. I've also tried to enter some special character conversions such as £=>£ and £=>£ but it hasn't worked and I can't seem to find any support threads on special character conversions. If anyone can help or point me in the right direction it would be much appreciated.

 

Thanks,

 

Mike

 

That didn't solve the problem because seo urls isn't causing it. seo urls writes urls it doesn't change price formatting. Usually this type of thing happens when there is a conflict of UTF8 and iso-8859-1 (which oscommerce uses).

Share this post


Link to post
Share on other sites
That didn't solve the problem because seo urls isn't causing it. seo urls writes urls it doesn't change price formatting. Usually this type of thing happens when there is a conflict of UTF8 and iso-8859-1 (which oscommerce uses).

 

Thanks Robert - you're right of course, I've found the problem now with your pointer - it was when I was copying the database to set up a testing version of the shop, the settings I used to export or import it with phpmyadmin were wrong and the characters were question marks in the tables themselves :blush:

Share this post


Link to post
Share on other sites
Well that is deffo the problem which must mean my code is faulty .. are you online for quick responses for a bit?

 

 

Any further thoughts or suggestions on what should be done to correct this? Thanks again.

Share this post


Link to post
Share on other sites
hello

 

i install this aplicattions in my store but i got the next

 

http://www.wearandgifts.com

 

some one can help me please, the support says it is a error in htacess file

 

thanks

 

Read this thread the answers are all here.

Share this post


Link to post
Share on other sites
i allready try edit the htacess puting

 

RewriteBase /catalog/

and

RewriteBase /

 

etc

 

and it still not work

 

Ok

 

Is your shop in /catalog or root?

 

Is it a Windoze server?

 

If not .. do you have mod_rewrite enabled?

 

If so are there sufficient permissions to allow rewrite rules in .htaccess?

Edited by FWR Media

Share this post


Link to post
Share on other sites

my shop is in catalog/

 

the server is linux

and the mod_rewrite is enabled

 

i need this: "Options +FollowSymLinks" in htacess file to seo url work, my server dont suportt

Share this post


Link to post
Share on other sites
my shop is in catalog/

 

the server is linux

and the mod_rewrite is enabled

 

i need this: "Options +FollowSymLinks" in htacess file to seo url work, my server dont suportt

 

Ahh then you can't use it .. if they wont enable it (it is very standard) find a new supplier.

Share this post


Link to post
Share on other sites

Hi,

 

I get this error, when I work on hebrew language it works great but when I switch to English then I get this error..

 

Warning: Cannot modify header information - headers already sent by (output started at /home/shakedtr/public_html/index.php:39) in /home/shakedtr/public_html/includes/classes/seo.class.php on line 1057

 

Warning: Cannot modify header information - headers already sent by (output started at /home/shakedtr/public_html/index.php:39) in /home/shakedtr/public_html/includes/classes/seo.class.php on line 1058

 

 

I would like please first to reset the database and let SEO to generate fresh links..

 

Do you think it can work?

 

I installed FWR seo.

 

Could someone help me please to solve this problem ?

 

Please help?

 

Thanks

 

Nathali


Best Regards,

Nathali

Share this post


Link to post
Share on other sites
Hi,

 

I get this error, when I work on hebrew language it works great but when I switch to English then I get this error..

 

Warning: Cannot modify header information - headers already sent by (output started at /home/shakedtr/public_html/index.php:39) in /home/shakedtr/public_html/includes/classes/seo.class.php on line 1057

 

Warning: Cannot modify header information - headers already sent by (output started at /home/shakedtr/public_html/index.php:39) in /home/shakedtr/public_html/includes/classes/seo.class.php on line 1058

 

 

I would like please first to reset the database and let SEO to generate fresh links..

 

Do you think it can work?

 

I installed FWR seo.

 

Could someone help me please to solve this problem ?

 

Please help?

 

Thanks

 

Nathali

 

Headers sent is a well documented issue the solution available by searching the forums. it tends to mean that you have some unwanted whitespace at the bottom of your file below the closing ?>, or indeed at the top.

Edited by FWR Media

Share this post


Link to post
Share on other sites
Headers sent is a well documented issue the solution available by searching the forums. it tends to mean that you have some unwanted whitespace at the bottom of your file below the closing ?>, or indeed at the top.

 

 

Thanks a lot Robert for your kind reply!

 

But when it can be?


Best Regards,

Nathali

Share this post


Link to post
Share on other sites
Thanks a lot Robert for your kind reply!

 

But when it can be?

Sins you dont have the problem with hebrew language it is most likely in the english language file. Check the files you have edit or replaced after it worked last time.

Share this post


Link to post
Share on other sites
Sins you dont have the problem with hebrew language it is most likely in the english language file. Check the files you have edit or replaced after it worked last time.

 

 

Thanks a lot Arild Evensen !

 

Best Regards,

 

Nathali


Best Regards,

Nathali

Share this post


Link to post
Share on other sites
Sorry for the slow reply have been "internetless" for 12 days.

 

Which versions have you tried? how many products does the shop in question have?

 

I'm sorry for the lateness of my reply. I just now noticed your reply.

 

 

I am using Ultimate SEO URLs v2.6. I have also tried 2.4, 2.1 and 2.1d ORIGINAL updated

 

I start to have problems with the products cache at about 60,000 products. The store in questions has 113,000 products.

 

Our stores are on a dual xeon dedicated server with 4 GB of RAM. I am currently using my-huge.cnf. Adding the product cache to begin with manually does not really work. It stops the incredible slowness when the products caching is enabled, but the caching does nothing, so disabling the product caching on store above 60k+ or so products is what I have been doing for now.

Edited by rs2k

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×