Jump to content
spidometrs

[CONTRIBUTION] Ultimate SEO URLs v2.1 - by Chemo

Recommended Posts

Hi I have installed the 2.1d SEO ultimate and can't understand why the 301 redirect doesn't work fine

 

catalog/index.php?cPath=1_49

 

redirects to

 

catalog/index.php?catalog=index.php

 

I know this has something to do with base_url but what ?

 

Thanks

 

Please read this thread before posting. You only had to look back one page.

Share this post


Link to post
Share on other sites
I have loaded the recent version onto the server. When I placed the htaccess file in the catalog folder the site would go down with an internal server error. I spoke to the providers who said that "Options +FollowSymLinks" is not supported. What function does this provide ? Also is their an alternative ?

 

DanR

 

Hey Dan, which host are you with? I was having a similar problem after moving to a new server (didn't know at the time it didn't support Options +FollowSymLinks) but tonight I just got it working, so I may be able to help?

Share this post


Link to post
Share on other sites
Which version are you using?

not trying to be a pest but i installed this contr back in april and it seemed to work fine but since I have been adding product pages i get these errors. and now am getting this from googlebot ( Details - URLs not followed

When we tested a sample of the URLs from your Sitemap, we found that some URLs were not accessible to Googlebot because they contained too many redirects. Please change the URLs in your Sitemap that redirect and replace them with the destination URL (the redirect target). All valid URLs will still be submitted.

HTTP Error:URL:Problem detected on: 301 (Moved permanently)http://www.floatmarine.com/waterproof-...llite-ready-stereo-with-playe-p-60.html on Oct 2, 2008

Share this post


Link to post
Share on other sites

Hi All

 

Wonder if someone can help me out here.

 

 

 

Have installed ultimate SEO every thing working fine osCommerce 2.2-MS2 My problem is that when I click on the text link for a product I get this:

 

http://www.discountsuperstore-uk.com/-p-.html

 

and this takes me to a page Product not found!

 

 

When I click on the image for the same product i get this:

 

http://www.discountsuperstore-uk.com/samsu...lip-p-7813.html

 

and this takes me to the product page

 

This problem only affect the home page and any subsequent Categories pages Maybe if someone wants to check it out http://www.discountsuperstore-uk.com Any help would be much appreciated

 

Thanks in advance

 

Liam

Share this post


Link to post
Share on other sites
HTTP Error:URL:Problem detected on: 301 (Moved permanently)http://www.floatmarine.com/waterproof-...llite-ready-stereo-with-playe-p-60.html on Oct 2, 2008

I found that product in your shop and it seems that it contains special character (r in circle - registered). That can confuse redirect if not properly encoded. I think you should specify special replacement character for this char (and maybe other specials too).

 

But now redirect seems to work on your site. If my browser does not have problems with it then google shouldn't have either.

Share this post


Link to post
Share on other sites

Hi, I posted this question earlier and haven't been able to fix this yet. Any input please? Here's my site: www.partylanes.co.uk

 

Thanks in advance,

Kat

 

I installed this contribution a couple of weeks ago and it seems to work perfectly.

 

However I now have all my categories and products in the non www. form, e.g. homepage - http://www.mysite.com, product - http://mysite.com/product. Google indexing is gone pear-shaped so I need to 301 all non www. urls to www. format. But if I add mod_rewrites to .htaccess it creates a redirection loop! I am guessing it is something to do with contribution's redirects conflict? I am not technical enough to see where this conflict is - can anyone shed some light?

 

Many thanks,

Kat

Share this post


Link to post
Share on other sites
Yes.. solved the both problems...

 

and for you will solve too...

 

go to your includes/classes/seo.class.php file and on line 624 put a coma ","

 

save and its done....

 

Line 624 says = 'pages_id' => '-pm-'

 

Where would you put a comma?

Share this post


Link to post
Share on other sites
Hey Dan, which host are you with? I was having a similar problem after moving to a new server (didn't know at the time it didn't support Options +FollowSymLinks) but tonight I just got it working, so I may be able to help?

 

The option is maybe already activ on the new server, did you try to comment the line with a "#" ? (was fine for me)

Share this post


Link to post
Share on other sites

I need to upgrade from ver 2.1.

Can anyone give me some advice on how to go about it. I don't see upgrade instructions in each of the packages from 2.1 to 2.6.

 

I'd appreciate it.

 

Thanks

 

Phil

Share this post


Link to post
Share on other sites
Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING, expecting ')' in /home//public_html/includes/classes/seo.class.php on line 626

Warning: Unknown: Your script possibly relies on a session side-effect which existed until PHP 4.2.3. Please be advised that the session extension does not consider global variables as a source of data, unless register_globals is enabled. You can disable this functionality and this warning by setting session.bug_compat_42 or session.bug_compat_warn to off, respectively. in Unknown on line 0

Edited by DjiXas

Share this post


Link to post
Share on other sites
I need to upgrade from ver 2.1.

Can anyone give me some advice on how to go about it. I don't see upgrade instructions in each of the packages from 2.1 to 2.6.

 

I'd appreciate it.

 

Thanks

 

Phil

Don't go beyond Ultimate SEO URLS v21d_UPDATED by FWR.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING, expecting ')' in /home//public_html/includes/classes/seo.class.php on line 626

Warning: Unknown: Your script possibly relies on a session side-effect which existed until PHP 4.2.3. Please be advised that the session extension does not consider global variables as a source of data, unless register_globals is enabled. You can disable this functionality and this warning by setting session.bug_compat_42 or session.bug_compat_warn to off, respectively. in Unknown on line 0

You have an error.

 

You do not give any information that may help.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING, expecting ')' in /home//public_html/includes/classes/seo.class.php on line 626

Warning: Unknown: Your script possibly relies on a session side-effect which existed until PHP 4.2.3. Please be advised that the session extension does not consider global variables as a source of data, unless register_globals is enabled. You can disable this functionality and this warning by setting session.bug_compat_42 or session.bug_compat_warn to off, respectively. in Unknown on line 0

 

OK, my hosting admin fixed that for me. But now my urls are:

 

whatever-p-69.html?osCsid=0ac0159ae01def16937e8b6b35b5e500

 

How do I remove session id?

 

Nvm, removed :)

Edited by Jan Zonjee

Share this post


Link to post
Share on other sites

I don't know what I did wrong, I installed v2.1d. When I call the link, nothing shows up on the screen , totally blank!! what could be wrong here? I have osc 2.2ms2 hosted on godaddy, no other package

 

http://www.rosybabyproduct.com/

 

help please!!

Edited by rabbit0860

slingcarrier dot com

Share this post


Link to post
Share on other sites

Probably your htaccess file, but just guessing. Sent you a PM with some other info.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

Hi,

 

I have problems after i have installed this mod.

 

I started with a fresh install of oscommerce 2.2 rc2 in the root of my html directory. got it working ok. followed the instructions and uploaded the files required, then changed the php code as instructed. ran the query on the database. added the lines to .htaccess file.

 

Now when i go to www.dbwsolutions.co.uk, I get HTTP 500 internal server error? When I go into the admin panel it works, but there is no SEO option on my configuration?

 

I've been told by my host that mod_rewrite is enabled and is being used on other sites on the server, so that should be ok...

 

any other ideas?

 

Cheers,

 

Paul.

Share this post


Link to post
Share on other sites

Hi,

 

I'm getting 500 internal server errors too .. but only for my products. The admin is fine, log-in, cart and all other pages.. its just when i click on a product I get the 500 error...

 

I also had the problem with the missing comma in the seo-class.php file which I sorted... and now its so close to working i can almost taste it!!

 

The .htaccess seems to be fine .. I changed "directory" to catalog... I've read almost this entire thread and I can't figure out why its just my products that can't be found ..

 

Any pointers in the right direction would be greatly appreciated..

 

Thanks alot.

 

Steve

Share this post


Link to post
Share on other sites
Hi,

 

I'm getting 500 internal server errors too .. but only for my products. The admin is fine, log-in, cart and all other pages.. its just when i click on a product I get the 500 error...

 

I also had the problem with the missing comma in the seo-class.php file which I sorted... and now its so close to working i can almost taste it!!

 

The .htaccess seems to be fine .. I changed "directory" to catalog... I've read almost this entire thread and I can't figure out why its just my products that can't be found ..

 

Any pointers in the right direction would be greatly appreciated..

 

Thanks alot.

 

Steve

 

Also i've noticed that in the SEO URLS section in admin, if I set Enble SEO URLS? to false my products can be found again,

 

So for some reason when its set to true my server can't find the products ...

 

Anyone had that happen before?

 

Thanks

Share this post


Link to post
Share on other sites
Also i've noticed that in the SEO URLS section in admin, if I set Enble SEO URLS? to false my products can be found again,

 

So for some reason when its set to true my server can't find the products ...

 

Anyone had that happen before?

 

Thanks

If you have catalog, it should be /catalog/

If the store is in the root directory, it should be /


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
If you have catalog, it should be /catalog/

If the store is in the root directory, it should be /

 

Thanks Coopco..

 

Yes the .htaccess is in catalog and I changed /directory/ to /catalog/ ...

 

I've been reading this entire thread and theres one or two similar problems, but I haven't come across a fix yet ...

Share this post


Link to post
Share on other sites
Thanks Coopco..

 

Yes the .htaccess is in catalog and I changed /directory/ to /catalog/ ...

 

I've been reading this entire thread and theres one or two similar problems, but I haven't come across a fix yet ...

There has been an update posted today, seo.class.php typo/bug fix

 

There was a typo in the last package Ultimate SEO URLs v2.6 (FullPackage)

 

includes/classes/seo.class.php

 

Line 624

'pages_id' => '-pm-'

 

Has a missing , should be

'pages_id' => '-pm-',

 

 

but the version that you should have installed is

 

2.1d ORIGINAL updated by FWR Media 23 Feb 2008


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
There has been an update posted today, seo.class.php typo/bug fix

 

There was a typo in the last package Ultimate SEO URLs v2.6 (FullPackage)

 

includes/classes/seo.class.php

 

Line 624

'pages_id' => '-pm-'

 

Has a missing , should be

'pages_id' => '-pm-',

 

 

but the version that you should have installed is

 

2.1d ORIGINAL updated by FWR Media 23 Feb 2008

 

Hi again,

 

No i've installed the v2.6 ... and yeah I found out there was a missing comma myself ...

 

Now everything seems to be working perfect except when I click on a catagory or product the server can't find it. Internal 500 server error. If I set Enable SEO URLs to false in admin, then the server can find them again ...

 

I can't work out whats gone wrong .. I have STS installed but I don't think its that ...

 

I don't think its the .htaccess .. although it might be but i don't see how .....

Edited by steve_spaces

Share this post


Link to post
Share on other sites
Hi again,

 

No i've installed the v2.6 ... and yeah I found out there was a missing comma myself ...

 

Now everything seems to be working perfect except when I click on a catagory or product the server can't find it. Internal 500 server error. If I set Enable SEO URLs to false in admin, then the server can find them again ...

 

I can't work out whats gone wrong .. I have STS installed but I don't think its that ...

 

I don't think its the .htaccess .. although it might be but i don't see how .....

Maybe try Reset SEO URLs Cache to true and see what happens.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×