Jump to content
spidometrs

[CONTRIBUTION] Ultimate SEO URLs v2.1 - by Chemo

Recommended Posts

Please help me figure out what I'm doing wrong...

 

I'm getting the general Internal Server Error. RC2, STS, and Header Tags SEO have been freshly installed and I'm stuck on Step #7 of USU (Test the installation). Site is www.tamogila.com, right now I have everything commented out in the .htaccess file so I at least I can get to admin. This is the code I've been trying to use in the .htaccess file, commenting different things in and out with the same result.

 

#

# $Id: .htaccess 1739 2007-12-20 00:52:16Z hpdl $
#
# This is used with Apache WebServers
#
# For this to work, you must include the parameter 'Options' to
# the AllowOverride configuration
#
# Example:

<Directory "/usr/local/apache/htdocs">
AllowOverride Options
</Directory>

# 'All' with also work. (This configuration is in the
# apache/conf/httpd.conf file)

# The following makes adjustments to the SSL protocol for Internet
# Explorer browsers

<IfModule mod_setenvif.c>
<IfDefine SSL>
SetEnvIf User-Agent ".*MSIE.*" \
nokeepalive ssl-unclean-shutdown \
downgrade-1.0 force-response-1.0
</IfDefine>
</IfModule>

# If Search Engine Friendly URLs do not work, try enabling the
# following Apache configuration parameter

AcceptPathInfo On

# Fix certain PHP values
# (commented out by default to prevent errors occuring on certain
# servers)

# php_value session.use_trans_sid 0
# php_value register_globals 1

# SEF BEGIN
# Change ReWrite base according to where your store is located
# / is domain.com and /catalog is domain.com/catalog


Options +FollowSymLinks
RewriteEngine On
RewriteBase /

RewriteCond %{QUERY_STRING} ^options\=(.*)$
RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2%1
RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-m-([0-9]+).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pi-([0-9]+).html$ popup_image.php?pID=$2&%{QUERY_STRING}
RewriteRule ^(.*)-t-([0-9]+).html$ articles.php?tPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-a-([0-9]+).html$ article_info.php?articles_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pr-([0-9]+).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pri-([0-9]+).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-i-([0-9]+).html$ information.php?info_id=$2&%{QUERY_STRING}

 

Some stuff from my Server Info:

 

HTTP Server: Apache/1.3.34 (Unix) mod_throttle/3.1.2 PHP/4.4.4 with Suhosin-Patch FrontPage/5.0.2.2623 mod_ssl/2.8.25 OpenSSL/0.9.7d-p1

 

PHP Version: 4.4.4 (Zend: 1.3.0)

 

Loaded Modules: mod_throttle, mod_php4, mod_frontpage, mod_ssl, mod_setenvif, mod_so, mod_unique_id, mod_usertrack, mod_headers, mod_expires, mod_cern_meta, mod_proxy, mod_digest, mod_auth_db, mod_auth_anon, mod_auth, mod_access, mod_rewrite, mod_alias, mod_userdir, mod_speling, mod_actions, mod_imap, mod_asis, mod_cgi, mod_dir, mod_autoindex, mod_include, mod_info, mod_status, mod_negotiation, mod_mime, mod_mime_magic, mod_log_config, mod_define, mod_env, mod_vhost_alias, http_core

 

Can anyone point me in the right direction? :blink:

Edited by tamogila

Share this post


Link to post
Share on other sites

On the same note, can someone who has successfully implemented this contribution and the redirects from old to new URLs are working fine provide me with two things:

 

1. An example of your actual .htaccess file (I prefer an example where it is in the /catalog/ directory)

2. What is in their root directory - doe sthere something need to be or should not be in the root directory?

 

Thanks,

Abhay

Share this post


Link to post
Share on other sites

Try putting the # sign back in front of everything above the Options +FollowSymLinks

 

Your RewriteBase looks correct. Make sure the htaccess file is uploaded to the root directory. With the FTP programs I use, I have to save the file as htaccess.txt and then once it's uploaded rename the file to .htaccess

 

 

 

Please help me figure out what I'm doing wrong...

 

I'm getting the general Internal Server Error. RC2, STS, and Header Tags SEO have been freshly installed and I'm stuck on Step #7 of USU (Test the installation). Site is www.tamogila.com, right now I have everything commented out in the .htaccess file so I at least I can get to admin. This is the code I've been trying to use in the .htaccess file, commenting different things in and out with the same result.

 

#

# $Id: .htaccess 1739 2007-12-20 00:52:16Z hpdl $
#
# This is used with Apache WebServers
#
# For this to work, you must include the parameter 'Options' to
# the AllowOverride configuration
#
# Example:

<Directory "/usr/local/apache/htdocs">
AllowOverride Options
</Directory>

# 'All' with also work. (This configuration is in the
# apache/conf/httpd.conf file)

# The following makes adjustments to the SSL protocol for Internet
# Explorer browsers

<IfModule mod_setenvif.c>
<IfDefine SSL>
SetEnvIf User-Agent ".*MSIE.*" \
nokeepalive ssl-unclean-shutdown \
downgrade-1.0 force-response-1.0
</IfDefine>
</IfModule>

# If Search Engine Friendly URLs do not work, try enabling the
# following Apache configuration parameter

AcceptPathInfo On

# Fix certain PHP values
# (commented out by default to prevent errors occuring on certain
# servers)

# php_value session.use_trans_sid 0
# php_value register_globals 1

# SEF BEGIN
# Change ReWrite base according to where your store is located
# / is domain.com and /catalog is domain.com/catalog


Options +FollowSymLinks
RewriteEngine On
RewriteBase /

RewriteCond %{QUERY_STRING} ^options\=(.*)$
RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2%1
RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-m-([0-9]+).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pi-([0-9]+).html$ popup_image.php?pID=$2&%{QUERY_STRING}
RewriteRule ^(.*)-t-([0-9]+).html$ articles.php?tPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-a-([0-9]+).html$ article_info.php?articles_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pr-([0-9]+).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pri-([0-9]+).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-i-([0-9]+).html$ information.php?info_id=$2&%{QUERY_STRING}

 

Some stuff from my Server Info:

 

HTTP Server: Apache/1.3.34 (Unix) mod_throttle/3.1.2 PHP/4.4.4 with Suhosin-Patch FrontPage/5.0.2.2623 mod_ssl/2.8.25 OpenSSL/0.9.7d-p1

 

PHP Version: 4.4.4 (Zend: 1.3.0)

 

Loaded Modules: mod_throttle, mod_php4, mod_frontpage, mod_ssl, mod_setenvif, mod_so, mod_unique_id, mod_usertrack, mod_headers, mod_expires, mod_cern_meta, mod_proxy, mod_digest, mod_auth_db, mod_auth_anon, mod_auth, mod_access, mod_rewrite, mod_alias, mod_userdir, mod_speling, mod_actions, mod_imap, mod_asis, mod_cgi, mod_dir, mod_autoindex, mod_include, mod_info, mod_status, mod_negotiation, mod_mime, mod_mime_magic, mod_log_config, mod_define, mod_env, mod_vhost_alias, http_core

 

Can anyone point me in the right direction? :blink:


~Tracy
 

Share this post


Link to post
Share on other sites

I have this working in two environments - one where the store is the root directory, so the RewriteBase only has / after it. In this case the .htaccess file is in the root directory.

 

Then, I have a testing server setup where I make changes and install new things and get them running before going live. In this case the store is in a different folder, so the RewriteBase has /FooBar/ after it, and the .htaccess file is in the FooBar folder (not in the root directory).

 

My .htacess file for my FooBar folder is:

# $Id: .htaccess,v 1.3 2003/06/12 10:53:20 hpdl Exp $
#
# This is used with Apache WebServers
#
# For this to work, you must include the parameter 'Options' to
# the AllowOverride configuration
#
# Example:
#
# <Directory "/usr/local/apache/htdocs">
#   AllowOverride Options
# </Directory>
#
# 'All' with also work. (This configuration is in the
# apache/conf/httpd.conf file)

# The following makes adjustments to the SSL protocol for Internet
# Explorer browsers

<IfModule mod_setenvif.c>
 <IfDefine SSL>
SetEnvIf User-Agent ".*MSIE.*" \
		 nokeepalive ssl-unclean-shutdown \
		 downgrade-1.0 force-response-1.0
 </IfDefine>
</IfModule>

# If Search Engine Friendly URLs do not work, try enabling the
# following Apache configuration parameter
#
# AcceptPathInfo On

# Fix certain PHP values
# (commented out by default to prevent errors occuring on certain
# servers)
#
#<IfModule mod_php4.c>
# php_value session.use_trans_sid 0
# php_value register_globals 1
#</IfModule>

Options +FollowSymLinks
RewriteEngine On 
RewriteBase /FooBar/

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-m-([0-9]+).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pi-([0-9]+).html$ popup_image.php?pID=$2&%{QUERY_STRING}
RewriteRule ^(.*)-t-([0-9]+).html$ articles.php?tPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-a-([0-9]+).html$ article_info.php?articles_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pr-([0-9]+).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pri-([0-9]+).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-i-([0-9]+).html$ information.php?info_id=$2&%{QUERY_STRING}
ErrorDocument 404 /404.php

 

My .htacess file for my root directory on the live site is:

# $Id: .htaccess,v 1.3 2003/06/12 10:53:20 hpdl Exp $
#
# This is used with Apache WebServers
#
# For this to work, you must include the parameter 'Options' to
# the AllowOverride configuration
#
# Example:
#
# <Directory "/usr/local/apache/htdocs">
#   AllowOverride Options
# </Directory>
#
# 'All' with also work. (This configuration is in the
# apache/conf/httpd.conf file)

# The following makes adjustments to the SSL protocol for Internet
# Explorer browsers

<IfModule mod_setenvif.c>
 <IfDefine SSL>
SetEnvIf User-Agent ".*MSIE.*" \
		 nokeepalive ssl-unclean-shutdown \
		 downgrade-1.0 force-response-1.0
 </IfDefine>
</IfModule>

# If Search Engine Friendly URLs do not work, try enabling the
# following Apache configuration parameter
#
# AcceptPathInfo On

# Fix certain PHP values
# (commented out by default to prevent errors occuring on certain
# servers)
#
#<IfModule mod_php4.c>
#  php_value session.use_trans_sid 0
#  php_value register_globals 1
#</IfModule>

Options +FollowSymLinks
RewriteEngine On 
RewriteBase /

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-m-([0-9]+).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pi-([0-9]+).html$ popup_image.php?pID=$2&%{QUERY_STRING}
RewriteRule ^(.*)-t-([0-9]+).html$ articles.php?tPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-a-([0-9]+).html$ article_info.php?articles_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pr-([0-9]+).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pri-([0-9]+).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-i-([0-9]+).html$ information.php?info_id=$2&%{QUERY_STRING}

ErrorDocument 404 /404.php

 

On the same note, can someone who has successfully implemented this contribution and the redirects from old to new URLs are working fine provide me with two things:

 

1. An example of your actual .htaccess file (I prefer an example where it is in the /catalog/ directory)

2. What is in their root directory - doe sthere something need to be or should not be in the root directory?

 

Thanks,

Abhay


~Tracy
 

Share this post


Link to post
Share on other sites

After all the experiments, I am concluding that my problem has bothing to do with .htaccess

.htacces translates the new URLs to the old URLs - and that part is working fine.

 

Its got something to do that when a direct link for index.pho?cPath=xx is used, it is translated to index.php?catalog=index.php and I have no clue where that is coming from. I read the code in index.php if it has some translation to this but I could not locate any.

 

Thanks,

Abhay

Share this post


Link to post
Share on other sites
After all the experiments, I am concluding that my problem has bothing to do with .htaccess

.htacces translates the new URLs to the old URLs - and that part is working fine.

 

Its got something to do that when a direct link for index.pho?cPath=xx is used, it is translated to index.php?catalog=index.php and I have no clue where that is coming from. I read the code in index.php if it has some translation to this but I could not locate any.

 

Thanks,

Abhay

 

SEO URLs is a very simple beast (due to Chemos great coding) You need to get three things right for it to work ..

 

1) Be on a Linux server with mod_rewrite enabled and sufficient settings for rewrite rules to work. (Get rewritebase correct))

 

2) Apply the minor code changes correctly

 

3) Upload the files and it will self install

 

You Abhay have issues outside of this and looking briefly at the files in root you also have a php.ini which can also have settings that could affect this.

Share this post


Link to post
Share on other sites

I think that somewhere in root (probably php.ini) you have a rule that states (in laymans terms)

 

If the request is for oscommerce then ..

 

Redirect index.php?catalog=index.php

Edited by FWR Media

Share this post


Link to post
Share on other sites
SEO URLs is a very simple beast (due to Chemos great coding) You need to get three things right for it to work ..

 

1) Be on a Linux server with mod_rewrite enabled and sufficient settings for rewrite rules to work. (Get rewritebase correct))

 

2) Apply the minor code changes correctly

 

3) Upload the files and it will self install

 

You Abhay have issues outside of this and looking briefly at the files in root you also have a php.ini which can also have settings that could affect this.

 

I have every confidence that Chemos's code is spot on, and it is something on my end.

 

1) From my post above, it looks to the untrained eye that I'm on a Linux server with mod_rewrite enabled, and I've tried many different combinations of the .htaccess file, including what TracyS posted above (is the .htaccess code what you mean by "Get rewritebase correct"?).

 

2) Pretty sure I did this right.

 

3) reset_seo_cache.php and seo.class.php are the only files, correct?

 

That leaves sufficient settings for rewrite rules to work...Is there any way to troubleshoot this without asking my hosting company? I've been bugging them non stop over SSL and other stuff for the last week, and don't want to go there if it's something I'm doing wrong. I just want to make sure the rewrite rule settings are absolutely the problem before I call them again.

 

Edit...Also, with all the mods listed as running on my host's server, is it normal for them to have those mods unaccessable to the user? It just seems like if they went through the trouble of putting them on there, they wouldn't restrict the use.

Edited by tamogila

Share this post


Link to post
Share on other sites
I have every confidence that Chemos's code is spot on, and it is something on my end.

 

1) From my post above, it looks to the untrained eye that I'm on a Linux server with mod_rewrite enabled, and I've tried many different combinations of the .htaccess file, including what TracyS posted above (is the .htaccess code what you mean by "Get rewritebase correct"?).

 

2) Pretty sure I did this right.

 

3) reset_seo_cache.php and seo.class.php are the only files, correct?

 

That leaves sufficient settings for rewrite rules to work...Is there any way to troubleshoot this without asking my hosting company? I've been bugging them non stop over SSL and other stuff for the last week, and don't want to go there if it's something I'm doing wrong. I just want to make sure the rewrite rule settings are absolutely the problem before I call them again.

 

Edit...Also, with all the mods listed as running on my host's server, is it normal for them to have those mods unaccessable to the user? It just seems like if they went through the trouble of putting them on there, they wouldn't restrict the use.

 

You haven't stated your problem and/or relevant error messages.

Share this post


Link to post
Share on other sites
You haven't stated your problem and/or relevant error messages.

 

Sorry, I posted higher up on this page.

 

Please help me figure out what I'm doing wrong...

 

I'm getting the general Internal Server Error. RC2, STS, and Header Tags SEO have been freshly installed and I'm stuck on Step #7 of USU (Test the installation). Site is www.tamogila.com, right now I have everything commented out in the .htaccess file so I at least I can get to admin. This is the code I've been trying to use in the .htaccess file, commenting different things in and out with the same result.

 

#

# $Id: .htaccess 1739 2007-12-20 00:52:16Z hpdl $
#
# This is used with Apache WebServers
#
# For this to work, you must include the parameter 'Options' to
# the AllowOverride configuration
#
# Example:

<Directory "/usr/local/apache/htdocs">
AllowOverride Options
</Directory>

# 'All' with also work. (This configuration is in the
# apache/conf/httpd.conf file)

# The following makes adjustments to the SSL protocol for Internet
# Explorer browsers

<IfModule mod_setenvif.c>
<IfDefine SSL>
SetEnvIf User-Agent ".*MSIE.*" \
nokeepalive ssl-unclean-shutdown \
downgrade-1.0 force-response-1.0
</IfDefine>
</IfModule>

# If Search Engine Friendly URLs do not work, try enabling the
# following Apache configuration parameter

AcceptPathInfo On

# Fix certain PHP values
# (commented out by default to prevent errors occuring on certain
# servers)

# php_value session.use_trans_sid 0
# php_value register_globals 1

# SEF BEGIN
# Change ReWrite base according to where your store is located
# / is domain.com and /catalog is domain.com/catalog


Options +FollowSymLinks
RewriteEngine On
RewriteBase /

RewriteCond %{QUERY_STRING} ^options\=(.*)$
RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2%1
RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-m-([0-9]+).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pi-([0-9]+).html$ popup_image.php?pID=$2&%{QUERY_STRING}
RewriteRule ^(.*)-t-([0-9]+).html$ articles.php?tPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-a-([0-9]+).html$ article_info.php?articles_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pr-([0-9]+).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pri-([0-9]+).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-i-([0-9]+).html$ information.php?info_id=$2&%{QUERY_STRING}

 

Some stuff from my Server Info:

 

HTTP Server: Apache/1.3.34 (Unix) mod_throttle/3.1.2 PHP/4.4.4 with Suhosin-Patch FrontPage/5.0.2.2623 mod_ssl/2.8.25 OpenSSL/0.9.7d-p1

 

PHP Version: 4.4.4 (Zend: 1.3.0)

 

Loaded Modules: mod_throttle, mod_php4, mod_frontpage, mod_ssl, mod_setenvif, mod_so, mod_unique_id, mod_usertrack, mod_headers, mod_expires, mod_cern_meta, mod_proxy, mod_digest, mod_auth_db, mod_auth_anon, mod_auth, mod_access, mod_rewrite, mod_alias, mod_userdir, mod_speling, mod_actions, mod_imap, mod_asis, mod_cgi, mod_dir, mod_autoindex, mod_include, mod_info, mod_status, mod_negotiation, mod_mime, mod_mime_magic, mod_log_config, mod_define, mod_env, mod_vhost_alias, http_core

 

Can anyone point me in the right direction? :blink:

Edited by tamogila

Share this post


Link to post
Share on other sites
I think that somewhere in root (probably php.ini) you have a rule that states (in laymans terms)

 

If the request is for oscommerce then ..

 

Redirect index.php?catalog=index.php

 

yeah but if that is the case, then this should happen even without installing the Seo Ultimate URL contribution. It only happened after I installed the contribution.

here is my php.ini - I have the same php.ini in my root directory as well as /catalog/directory - is taht aproblem?

register_globals = on
allow_url_fopen = off

expose_php = Off
max_input_time = 60
variables_order = "EGPCS"
extension_dir = ./
upload_tmp_dir = /tmp
precision = 12
SMTP = relay-hosting.secureserver.net
url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=,fieldset="

[Zend]
zend_extension=/usr/local/zo/ZendExtensionManager.so
zend_extension=/usr/local/zo/4_3/ZendOptimizer.so

Share this post


Link to post
Share on other sites
I think that somewhere in root (probably php.ini) you have a rule that states (in laymans terms)

 

If the request is for oscommerce then ..

 

Redirect index.php?catalog=index.php

 

It may be related too - Aren't we able to turn the contribution off and on from the admin panel? When I turn it off, then the same behaviour happens - I get redirected to index.php?catalog=index.php

So, its somewhere in my code - where should I look at?

Share this post


Link to post
Share on other sites

I would look at the files that you modify to install this contribution and make sure that they were modified correctly. I believe includes/application_top.php gets modified - that would be my first thought on where to start.

 

It may be related too - Aren't we able to turn the contribution off and on from the admin panel? When I turn it off, then the same behaviour happens - I get redirected to index.php?catalog=index.php

So, its somewhere in my code - where should I look at?


~Tracy
 

Share this post


Link to post
Share on other sites

My Internal Server Error has been resolved. It was the permissions my hosting company has set that wouldn't allow the .htaccess file to do it's job. With a quick e-mail they changed the permissions and USU is now working like a charm.

Share this post


Link to post
Share on other sites

Hi All

 

I have a problem with this contribution. I can no longer see my website. server information below

 

CGI: Active

Platform Type Debian

MySQL Version 5.0.45

Perl Version 5.8.8

PHP Version 4.4.7

 

I installed this on a clean version of os commerce and have followed the instruction down to a tee backing up each file that was changed. But als no longer able to view website. I also removed the contribution completly and still can't see website.

 

I have also even deleted the intire website files from the server and deleted the database and started from scratch again and still can't see the website

 

Have checked my website logs and this is the re-peating error that comes up:

 

PHP Fatal error: Cannot redeclare tep_href_link() (previously declared in /hermes/web07/b2592/pow.*********/htdocs/includes/functions/html_output.php:14) in /hermes/web07/b2592/pow.*********/htdocs/includes/functions/html_output.php on line 117

 

if anyone could help I would be very apprecaited..

 

Regards

 

Liam

Edited by sligoman

Share this post


Link to post
Share on other sites

is there a way to put the cpath before the .html instead of the end of the product URL when using this function "Add cPath to product URLs?"

 

also does this do any damage to the ranking on google because it's not an html

Share this post


Link to post
Share on other sites

Hi Guys,

 

I've installed chemo's 2.1e ultimate seo version. It works pretty well but when I try to login to start the checkout process it redirects me to the index.php and it does not allow me to login nor buy products. The shopping cart it fills well but no way to go through buying the products.

 

I don't know wether the problem is because the NONSSL url and the SSL url are slightly diferent. I mean:

 

For the NONSSL urls I have: http://www.mydomain.com/...

 

For the SSL urls, the hosting redirects my domain to https://hostingsdomain.com/mydomain/....

 

Is there someone with the same problem, or knows how to solve it? I have been looking around in the forum and I can not get through a solution.

 

Thank you very much for your help.

 

Gemma

Share this post


Link to post
Share on other sites
Jack,

I was having the same problem and tried your solution. It works (removes the osCsid#) but when you try to add something to the shopping cart, you get this madate to set the cookie level to Medium. The instructions are very clear, but even after changing the setting to Medium, you continue be blocked by this warning. you are never taken to the cart even after setting the level to Medium.

Did you ever figure this out?

Carol Ann

 

Hello Carol and Jack,

it'd be a great help if either of you (or someone else) can post how you got to resolving this problem after setting "Force Cookie Use = True" in admin under Session.

 

Thank you

Share this post


Link to post
Share on other sites
Hello Carol and Jack,

it'd be a great help if either of you (or someone else) can post how you got to resolving this problem after setting "Force Cookie Use = True" in admin under Session.

 

Thank you

 

I don't understand the question. If you force cookies then users MUST have cookies enabled to use the site.

Share this post


Link to post
Share on other sites
Hi Guys,

 

I've installed chemo's 2.1e ultimate seo version. It works pretty well but when I try to login to start the checkout process it redirects me to the index.php and it does not allow me to login nor buy products. The shopping cart it fills well but no way to go through buying the products.

 

I don't know wether the problem is because the NONSSL url and the SSL url are slightly diferent. I mean:

 

For the NONSSL urls I have: http://www.mydomain.com/...

 

For the SSL urls, the hosting redirects my domain to https://hostingsdomain.com/mydomain/....

 

Is there someone with the same problem, or knows how to solve it? I have been looking around in the forum and I can not get through a solution.

 

Thank you very much for your help.

 

Gemma

 

USU doesn't touch the checkout or login pages, the problem lies somewhere else.

 

You also need to be more descriptive than "when I try to login to start the checkout process"

Edited by FWR Media

Share this post


Link to post
Share on other sites
I don't understand the question. If you force cookies then users MUST have cookies enabled to use the site.

 

Hello Robert,

that's exactly the problem: as Carol also explained in her posting, even with cookies enabled in Firefox, one is NOT able to buy, log in or otherwise access any of the customer pages - you're never taken to the cart or appropriate log-in pages but get thrown to the cookies_usage page. Apparently, "Jackandersen" had a solution . Unfortunately, he PM'ed his solution directly to Carol as one can infer from his posting direckty after the quoted posting from Carol. Any ideas!

 

Jon

Share this post


Link to post
Share on other sites
Hello Robert,

that's exactly the problem: as Carol also explained in her posting, even with cookies enabled in Firefox, one is NOT able to buy, log in or otherwise access any of the customer pages - you're never taken to the cart or appropriate log-in pages but get thrown to the cookies_usage page. Apparently, "Jackandersen" had a solution . Unfortunately, he PM'ed his solution directly to Carol as one can infer from his posting direckty after the quoted posting from Carol. Any ideas!

 

Jon

 

This is nothing to do with USU it sounds like you have not set configure.php correctly.

 

Example: -

 

Very important: Assumes the certificate is issued to www.mysite.com NOT JUST mysite.com

Very important: Assumes your store is in root NOT in a folder

Very important: Assumes you have a full SSL certificate not shared

 

  define('HTTP_SERVER', 'http://www.mysite.com'); // eg, http://localhost - should not be empty for productive servers
 define('HTTPS_SERVER', 'https://www.mysite.com'); // eg, https://localhost - should not be empty for productive servers
 define('ENABLE_SSL', true); // secure webserver for checkout procedure?
 define('HTTP_COOKIE_DOMAIN', 'www.mysite.com');
 define('HTTPS_COOKIE_DOMAIN', 'www.mysite.com');
 define('HTTP_COOKIE_PATH', '/');
 define('HTTPS_COOKIE_PATH', '/');
 define('DIR_WS_HTTP_CATALOG', '/');
 define('DIR_WS_HTTPS_CATALOG', '/');

Edited by FWR Media

Share this post


Link to post
Share on other sites

Hello Robert,

 

I will be more explicit. As Jon said, USU works fine but no way to go to customer pages, to login or to buy products. You can have a look at my site:

 

www.bambinnos.com/test

 

And here is my configure.php, so you can have an idea.

 

define('HTTP_SERVER', 'http://www.bambinnos.com'); // eg, [url="http://localhost"]http://localhost[/url] - should not be empty for productive servers
 define('HTTPS_SERVER', 'https://espacioseguro.com'); // eg, [url="https://localhost"]https://localhost[/url] - should not be empty for productive servers
 define('ENABLE_SSL', true); // secure webserver for checkout procedure?
 define('HTTP_COOKIE_DOMAIN', 'bambinnos.com');
 define('HTTPS_COOKIE_DOMAIN', 'espacioseguro.com');
 define('HTTP_COOKIE_PATH', '/test/');
 define('HTTPS_COOKIE_PATH', '/bambinnos/test/');
 define('DIR_WS_HTTP_CATALOG', '/test/');
 define('DIR_WS_HTTPS_CATALOG', '/bambinnos/test/');

 

 

For what you said I guess the problem may be in having a shared SSL certificate. (espacioseguro.com is owned by the hosting service). Could you please get me out of that doubt? By the way, if I turn off USU from admin, site works perfectly well and have no problems.

 

The .htaccess is set to /test/

 

Thank you very much,

 

Gemma

 

This is nothing to do with USU it sounds like you have not set configure.php correctly.

 

Example: -

 

Very important: Assumes the certificate is issued to www.mysite.com NOT JUST mysite.com

Very important: Assumes your store is in root NOT in a folder

Very important: Assumes you have a full SSL certificate not shared

 

  define('HTTP_SERVER', 'http://www.mysite.com'); // eg, http://localhost - should not be empty for productive servers
 define('HTTPS_SERVER', 'https://www.mysite.com'); // eg, https://localhost - should not be empty for productive servers
 define('ENABLE_SSL', true); // secure webserver for checkout procedure?
 define('HTTP_COOKIE_DOMAIN', 'www.mysite.com');
 define('HTTPS_COOKIE_DOMAIN', 'www.mysite.com');
 define('HTTP_COOKIE_PATH', '/');
 define('HTTPS_COOKIE_PATH', '/');
 define('DIR_WS_HTTP_CATALOG', '/');
 define('DIR_WS_HTTPS_CATALOG', '/');

Edited by Gemmeta

Share this post


Link to post
Share on other sites

HI,

Coming back to get the support from teh pros on this forum -

I had implemented this contribution and everything worked fine.

However, if I typed my old URLs in the browser or had a flash piece that had old style dynamic URL as a link, that would take me to weird pages. For category pages, it would take me to: index.php?catalog=index.php

and for product pages, it would take me to: product_info.php?catalog=product_info.php

 

I am not sure if there is something in my code or if there is something in my settings. My phpinfo file is at:

http://www.india1imports.com/phpinfo.php

 

For now, I have turned the contribution off and unloaded it, but if someone could help me figure this out, it would be great. I am willing to even pay for someone to help me figure this out, since I am not able to get my dynamic URLs into googles indexed sites even after submitting the sitemap to them multiple times. None of my product pages are in search indexes and it is killing my business.

 

Any experts want to make a little fast money?

 

Thanks,

Abhay

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×