Jump to content
spidometrs

[CONTRIBUTION] Ultimate SEO URLs v2.1 - by Chemo

Recommended Posts

trådløs-deluxe-ver-24g-som-bullet-kamera-med-2-adaptere-p-40.html like that it shows up in googlebot

should be

tr?dl?se-deluxe-ver-24g-som-bullet-kamera-med-2-adaptere-p-40.html

 

Bj?rn

Share this post


Link to post
Share on other sites

You can replace this line in seo_class.php:

 

return htmlspecialchars(utf8_encode($link));

with:

return $link;

 

in fact, that's how I have my store running since I didn't like other things it was doing.

Edited by stevel

Share this post


Link to post
Share on other sites

it was only after installing this mod i noticed that there are an extra 4characters in the url when i click coupon redeem in the payment checkout page (CCGV)

 

this what comes up:

 

catalog/checkout_payment.php?

payment_error=ot_gv&error=You+did+not+enter+a+redeem+code.

=================================================

 

 

this is what should come up:

 

catalog/checkout_payment.php?payment_error=ot_gv&error=You+did+not+enter+a+redeem+code.

=================================================

 

can anyone please tell me how to get rid of (or what generates) the following code in the url:

 

amp;

 

many thanks


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
it was only after installing this mod i noticed that there are an extra 4characters in the url when i click coupon redeem in the payment checkout page (CCGV)

 

this what comes up:

 

catalog/checkout_payment.php?

payment_error=ot_gv&error=You+did+not+enter+a+redeem+code.

=================================================

this is what should come up:

 

catalog/checkout_payment.php?payment_error=ot_gv&error=You+did+not+enter+a+redeem+code.

=================================================

 

can anyone please tell me how to get rid of (or what generates) the following code in the url:

 

amp;

 

many thanks

ok, thanks to Rhea/Vger, i have this:

 

 

if (tep_not_null($parameters)) {

$link .= $page . '?' . tep_output_string($parameters);

$separator = '&';

} else {

$link .= $page;

$separator = '?';

}

 

now that this code is gone and replaced, in the HTML OUTPUT page, can anyone please tell me what to do to stop getting this:

 

amp;

 

in my url?

 

thanks


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

hello

 

i've installed this contribution and it works fine but there is still this "osCsid " in url.

I've checked my cokies settings and they look ok,

i'm trying to find out what is wrong and i cannot find the solution

 

if someone could give me an advice

thanks in advance

Share this post


Link to post
Share on other sites

This contribution has nothing to do with osCsid in URLs. The session ID will be in the URL for links on the first page, but should go away for other pages if the customer's browser accepts cookies. Spiders should not be getting sessions if you have Prevent Spider Sessions set to true in Admin and are using a current spiders.txt.

Share this post


Link to post
Share on other sites
This contribution has nothing to do with osCsid in URLs.  The session ID will be in the URL for links on the first page, but should go away for other pages if the customer's browser accepts cookies.  Spiders should not be getting sessions if you have Prevent Spider Sessions set to true in Admin and are using a current spiders.txt.

 

so how to get rid of this osCsid from the url? it looks like this now :

http://www.samplesite.com/sampleprodukt.ht...fc64d04771b8e5c

should be :http://www.samplesite.com/sampleprodukt.html

It is seen all the time, not only on the first page.

someone said that it's maybe because of the cokies setings but i've checked it and everything is ok.

Share this post


Link to post
Share on other sites

It would seem that your cookie settings are NOT ok. But this is a matter for some other thread, not the SEO support thread. Post in the General Support section of the forum and include the first 20 lines of your configure.php.

Share this post


Link to post
Share on other sites
You can replace this line in seo_class.php:

 

return htmlspecialchars(utf8_encode($link));

with:

return $link;

 

in fact, that's how I have my store running since I didn't like other things it was doing.

Steve,

 

thanks a milion-zillion for helping me (again), i am grateful :-)

 

i got your instructions at the same time as someone else who has this issue, he suggested replacing the same line but with this code:

 

return str_replace('"','"',str_replace('>','&gt',str_replace('<','<',utf8_encode($link))));

 

being a copy and paste person with hardly any knowledge of php, can you kindly advise on what is the best one to have... your one or this one

 

(just for future reference) what is benefit of having this one over yours, as both seem to do the job?

 

i have used your simple code, thanks again

 

i have added your


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

Well, I don't know which is "best". The other one you got does part of what the original would have done, except that the characters it replaces should never occur in a link. Mine doesn't do any of the substitutions, so characters such as & are left as-is in the URL and international characters are not replaced with their proper "escaped" equivalents. You would not see any other difference I think.

 

I'm uncertain why the original drops the & in the leasting &, but that's a mystery for another day.

Share this post


Link to post
Share on other sites
Well, I don't know which is "best".  The other one you got does part of what the original would have done, except that the characters it replaces should never occur in a link.  Mine doesn't do any of the substitutions, so characters such as & are left as-is in the URL and international characters are not replaced with their proper "escaped" equivalents.  You would not see any other difference I think.

 

I'm uncertain why the original drops the & in the leasting &, but that's a mystery for another day.

ok

 

i am with it now.. i think i understand about this a little bit better now

 

i am using your simple code

 

thanks


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

hi there after instaling this contribution i am receiving page can not be displayed when cliking on catagories from the menu and any product page not displayed can anyone help me on this i have followed the instruction givan to a tee but am unsure of 1 instruction given and that was this

 

STEP #6 - Edit .htaccess file (in your catalog directory)

If your store is located in a DIRECTORY add this to the /*directory*/.htaccess file:

 

NOTE: you will have to edit the "directory" to match your directory name!

 

Options +FollowSymLinks

RewriteEngine On

RewriteBase /directory/

 

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING}

RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING}

 

If your store is located in the root add this to the /.htaccess file:

 

Options +FollowSymLinks

RewriteEngine On

RewriteBase /

 

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING}

RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING}

 

 

 

I added the first set of code to the very end of my .htaccess file not sure if this is correct or not but can not find any other possable fault unless is with the menu i am using not sure this does look like a good contribution and am very happy that i can turn this off untill i fix this problem any one have any ideas

 

thank you in advance

Share this post


Link to post
Share on other sites
hi there after instaling this contribution i am receiving page can not be displayed

 

 

In your .htaccess file you will find

 

/directory/

 

 

change this to where your directory is located for your catalog on your server

 

 

mine i changed to

 

/catalog/

 

and worked fine

 

Hope this helps

 

jon

Share this post


Link to post
Share on other sites
In your .htaccess file you will find

 

/directory/

change this to where your directory is located for your catalog on your server

mine i changed to

 

/catalog/

 

and worked fine

 

Hope this helps

 

jon

 

thank you for your reply

 

 

have already changed the direct to catalog any other ideas

 

kind regards

 

maltonge

Share this post


Link to post
Share on other sites

I've installed this contrib (thanks BTW) but ofcourse now any old links are getting a page-not-found error

 

I know there is a line of code you can put in the .htacess that will redirect any broken links back to the main page but I can't find it anywhere, anyone know offhand?

Share this post


Link to post
Share on other sites

In Admin, SEO URLs, set Enable Automatic Redirects to true. This will redirect old URLs to new.

 

Mal, what is the actual folder where your store is installed? The RewriteBase line needs to reflect that.

Share this post


Link to post
Share on other sites

Hello Bobby,

 

Thanks very much for the Ultimate SEO URLs contribution. It's exactly what I need for my store.

 

I cleared my store off the server (backed up first) and installed a clean milestone 2.2 OSC store. I empited the database of all products, customers, etc. No other contributions are installed. The path to the store is /store/catalog/ . I've installed the files and added the code as directed in the install.htm file. I've logged into the admin section and cleared the cache. I called up the store, but I still see the osCsidblahblahblah. I checked a spider simulator and it too logged the sid.

 

It's true that it's way past my bedtime, but I don't believe I've made mistakes.

 

Can you please let me know (when you have time) what the best guess is as to what I've done wrong?

 

Thanks very much,

TS

Share this post


Link to post
Share on other sites
Hello Bobby,

 

Thanks very much for the Ultimate SEO URLs contribution. It's exactly what I need for my store.

 

I cleared my store off the server (backed up first) and installed a clean milestone 2.2 OSC store. I empited the database of all products, customers, etc. No other contributions are installed. The path to the store is /store/catalog/ .  I've installed the files and added the code as directed in the install.htm file. I've logged into the admin section and cleared the cache. I called up the store, but I still see the osCsidblahblahblah. I checked a spider simulator and it too logged the sid.

 

It's true that it's way past my bedtime, but I don't believe I've made mistakes.

 

Can you please let me know (when you have time) what the best guess is as to what I've done wrong?

 

Thanks very much,

TS

 

Ultimate SEO URLs contribution does not remove the sids , it just gives you the category/product name in the url.

 

The sids can be removed several ways...

 

1. Set force cokies to true in the admin

 

or

 

2. Set disable spider session to true (You will still see the sids, but the search engine spiders will not) , also update your spiders.txt file to the latest version.

 

or

 

3. Install a sid killer contrib

 

or

 

4. i remeber seeing a mod for ultimate url in regards to sids...have a look around you might find it....

Share this post


Link to post
Share on other sites

Hi

 

I just played around with the admin login mod and gave up installing it. i am sure i replaced my back up files and everything seems to work, except when i am on the main admin page and click onfiguration and then SEO URL's, this is what i see above the SEO URL options

 

Warning: call_user_func(tep_reset_cache_data_seo_urls): First argument is expected to be a valid callback in /home/osa786/public_html/catalog/admin/includes/functions/general.php on line 1195

 

all of the SEO links work etc, but why the error?

 

i did replace the original admin/functions/general.php

 

can some please help?

 

thanks

Edited by chooch

Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

Hi,

 

If wonder if you could help me? I have installed SEO URLs on my site, www.allforyoulingerie.com. However, i seem to be having a problem.

 

I am running on a shared host with other similar websites. If I load my page for the first time it generates the correct URL on the menu on the left.

 

i.e. www.allforyoulingerie.com/catalogue/wigs-c-28.html

 

If I click on that the pages refreshes and doesnt seem to do anything. However, all the URL's have redirected to another domain!!

 

What was www.allforyoulingerie.com/catalogue/wigs-c-28.html is now

 

www.naughtyniknaks.com/catalogue/index.php?cPath=28

 

Naughtniknaks.com is not my domain!! Any idea why this is happening and how i can stop it?

Share this post


Link to post
Share on other sites

Interesting combination of domains...

 

Go into Admin, Configuration, Sessions. Set Use Cache to false. Either that, or change the cache folder to be one local to your site and not /tmp.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×