Jump to content
Latest News: (loading..)
Chemo

[CONTRIBUTION] Google XML Sitemap Feed - by Chemo

Recommended Posts

im haveing a slight problem where this contrib is creating files called

 

googlesitemapsitemapindex.xml

 

instead of

 

sitemapindex.xml

 

any ideas ?

Share this post


Link to post
Share on other sites

THE COMMUNITY SHOULD NOW GO INTO OFFICIAL MOURNING :'( , AS THE "POWERS THAT BE" HAVE FINALLY MANAGED TO KILL OFF ONE OF THE BEST AND MOST KNOWLEDGABLE CONTRIBUTORS TO THIS FORUM.

Not to mention the outstanding support, documentation & endless hours of work he obviously puts in.

This is punishing the rest of the community who have benefitted greatly from Bobby's contributions and expertise. Not to mention the number of new users osCommerce have probably made because of such members, great contributions and support.

Seems a bit of a loss all round including a big loss to osCommerce.

 

Come on moderators, will we be getting an explanation as to why most of the BIG contributions will no longer be supported. Or will you be lifting his contributions aswell? <_<

 

Excellent work Bobby, if you set up elsewhere let us know.

 

Julian


A little knowledge is dangerous, I SHOULD KNOW.

If Life Begins At 40, What ends????

Share this post


Link to post
Share on other sites
im haveing a slight problem where this contrib is creating files called

 

googlesitemapsitemapindex.xml

 

instead of

 

sitemapindex.xml

 

any ideas ?

 

Dasonix, read back through the forum posts as this problem has been discussed and solved.

 

H2H

Matt

Share this post


Link to post
Share on other sites

I hope this is temporarily and a mistake. I am using already some months chemo 's contribution and they work verry good and the support is perfekt.

 

This is not good for this forum.

 

About my problem with the script index.php it is solved; There was to mutch security on my files changed teh ensim setting and now it is working fine.

 

Thanks

 

Hans

Share this post


Link to post
Share on other sites

The loss of Chemo is big... but I am sure he will be found. Was this forum's IM being used by him before he was banned? If so, maybe there was 'inappropriate' dialog while in there (it is monitored). Or was it that he pushed Google services here (not really).

 

As of yet, the Open-Source community lacks any real 'standardization' when it comes to programmer qualifications and support. So, losing someone like this is a setback for many... Come on, we have ALL seen bad advice and 'contributions' thrown around as science. Then again we have also seen greatness.

 

Well, at any rate, I am setting up gForge at http://palaia.us/ and http://qwest.net/ and welcome him to continue there. I also plan on releasing an abstraction layer version of osC. Hopefully, all will be forgiven and we can move on.


· willross

··········

Share this post


Link to post
Share on other sites

Following on from my post above where my cron e:mail was a failure. I have updated my version of SEO URLs to the latest 2.1. Hoping that this met with the latest version of the Google XML Sitemap feed

This however has now created a different problem where i get the following error when i enter the googlesitemap/index.php after my address.

 

Fatal error: Call to undefined function: tep_get_parent_categories() in /home/julianp/public_html/includes/seo_cache.php on line 175

Has anybody had this error or know what could be wrong?

the other addresses work for the cats/prods and index.xml

 

Thanks

 

Julian

 

I see mesa had the same problem, but would removing this line be detrimental to anything else?


A little knowledge is dangerous, I SHOULD KNOW.

If Life Begins At 40, What ends????

Share this post


Link to post
Share on other sites
My /googlesitemap/index.php is empty  :'(

 

Installed version 1 saturday and it worked. Saw the dateerror on google and therefore installed version 1.3 today. When entering /googlesitemap/index.php  on my site I see nothing at all. Theres no err.msg's and the html rendered reads:

 

 

I have exactly the same problem... You probably used Firefox. If i use firefox it's just an empty site, if i use internet explorer i get an error.


HIM - Dark Light - Out on 26/09/05

Share this post


Link to post
Share on other sites
I have exactly the same problem... You probably used Firefox. If i use firefox it's just an empty site, if i use internet explorer i get an error.

 

Alas not. I use Maxthon, but have ofcourse tried it out in IE also. As mentioned it shows nothing, and when viewing the html I see the rendered emty file as:

 

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=Content-Type content="text/html; charset=windows-1252"></HEAD>
<BODY></BODY></HTML>

Share this post


Link to post
Share on other sites

I have the following error

Can they help me?

 

Warning: fopen(datos/home/microfie/public_html/sitemapproducts.xml): failed to open stream: No such file or directory in /datos/home/microfie/public_html/googlesitemap/sitemap.class.php on line 291

ERROR: Google Product Sitemap Generation FAILED!

 

 

Warning: fopen(datos/home/microfie/public_html/sitemapcategories.xml): failed to open stream: No such file or directory in /datos/home/microfie/public_html/googlesitemap/sitemap.class.php on line 291

ERROR: Google Category Sitemap Generation FAILED!

 

 

Warning: fopen(datos/home/microfie/public_html/sitemapindex.xml): failed to open stream: No such file or directory in /datos/home/microfie/public_html/googlesitemap/sitemap.class.php on line 291

ERROR: Google Sitemap Index Generation FAILED!

 

Array

(

[QUERY] => Array

(

[PRODUCTS] => Array

(

[sTATUS] => success

[NUM_ROWS] => 1436

)

 

[CATEOGRY] => Array

(

[sTATUS] => success

[NUM_ROWS] => 129

)

 

)

 

[sAVE_FILE_XML] => Array

(

[0] => Array

(

[file] => datos/home/microfie/public_html/sitemapproducts.xml

[status] => failure

[file_exists] => false

)

 

[1] => Array

(

[file] => datos/home/microfie/public_html/sitemapcategories.xml

[status] => failure

[file_exists] => false

)

 

[2] => Array

(

[file] => datos/home/microfie/public_html/sitemapindex.xml

[status] => failure

[file_exists] => false

)

 

)

 

)

 

Thanks and sorry for my English evil

Share this post


Link to post
Share on other sites
Warning: fopen(datos/home/microfie/public_html/sitemapproducts.xml): failed to open stream: No such file or directory in /datos/home/microfie/public_html/googlesitemap/sitemap.class.php on line 291

ERROR: Google Product Sitemap Generation FAILED!

 

 

Warning: fopen(datos/home/microfie/public_html/sitemapcategories.xml): failed to open stream: No such file or directory in /datos/home/microfie/public_html/googlesitemap/sitemap.class.php on line 291

ERROR: Google Category Sitemap Generation FAILED!

 

 

Warning: fopen(datos/home/microfie/public_html/sitemapindex.xml): failed to open stream: No such file or directory in /datos/home/microfie/public_html/googlesitemap/sitemap.class.php on line 291

ERROR: Google Sitemap Index Generation FAILED!

that looks like you have either put the files in the wrong directory or you haven't set the permissions for read/write.


A little knowledge is dangerous, I SHOULD KNOW.

If Life Begins At 40, What ends????

Share this post


Link to post
Share on other sites

Elkanario,

 

I would agree with julianpuje.

 

Did you follow this step in the directions?

Upload the dummy files (the XML files) to your catalog directory. So, when you are done you should be able to call the files in your browser like this:

If the store is in the document root:

 

* domain.com/sitemapproducts.xml

* domain.com/sitemapcategories.xml

* domain.com/sitemapindex.xml

 

Else if the store is in a directory:

 

* domain.com/directory/sitemapproducts.xml

* domain.com/directory/sitemapcategories.xml

* domain.com/directory/sitemapindex.xml

 

Once you have the dummy XML files uploaded you will need to make them wrtieable by the web server. The easiest way to do this is to start your favorite FTP client, right click the files, and change the permissions on each one. The correct settings will vary based on your server setup but generally speaking a setting of 777 or read, write, execute will work every time.

 

Paul

Share this post


Link to post
Share on other sites

W :angry: I cannot believe that they can just ban someone when they have contributed so greatly to the OSCommerce cause. Unbelievable.

 

:blush: I have a 'stupid' problem with this contribution... I am certain of it..

 

Please forgive my stupidity as I really just follow the contribs and know very little about how it all works. I am getting this error when I try to run googlesitemap/index.php on my site. Does anyone know what would be causing this?

 

Warning: mysql_connect(): Access denied for user: 'root@localhost' (Using password: NO) in /hsphere/local/home/happydan/myhappydance.com/includes/functions/database.php on line 19

Unable to connect to database server!

 

Please, if you can, send a solution. Thanks.

 

Carol@myhappydance.com

Share this post


Link to post
Share on other sites
Alas not. I use Maxthon, but have ofcourse tried it out in IE also.  As mentioned it shows nothing, and when viewing the html I see the rendered emty file as:

 

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=Content-Type content="text/html; charset=windows-1252"></HEAD>
<BODY></BODY></HTML>

 

I i view the source it looks like this:

<html><body></body></html>

 

totally empty...


HIM - Dark Light - Out on 26/09/05

Share this post


Link to post
Share on other sites

ERROR: Google Product Sitemap Generation FAILED!

 

ERROR: Google Category Sitemap Generation FAILED!

 

Generated Google Sitemap Index Successfully

 

 

Any one a solution for this strange problem ?

 

 

 

Thanks,

 

Hans

Share this post


Link to post
Share on other sites

Help! I'm stuck! As Chemo isnt around to pester for help, im hoping someone else will sort me out!

 

I have installed all as instructed, but when i go to catalog/googlesitemap/index.php I just get a blank page - no error message, just nothing. This happened to me with the old days on ultimate seo url's, all i had to do was comment out the cache('GLOBAL') line, then everything worked (to a point). I've tried doing that, still blank......?!

 

Any ideas?


Please note - if I have suggested a contrib above, it doesnt mean it will work! Most of the contribs are not ones I've used, but may be useful for your particular problem....

Have you tried a refined search? Chances are your problem has already been dealt with elsewhere on the forums.....

if (stumped == true) {

return(square_one($start_over)

} else {

$random_query = tep_fetch_answer($forum_query)

}

Share this post


Link to post
Share on other sites

check your server application/error logs and see what is generated. you can also turn on sql logging in the admin/configuration/logging to see what is going on


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites

Chemo

 

Here is a quick fix for SEF Lite users. It also adds the option to track your indexed links. Open the file 'sitemap.class.php' and...

 

Find this on line 402:

$location = $this->hrefLink(FILENAME_PRODUCT_INFO, 'products_id=' . $result['pID'], 'NONSSL', false);

and replace it with:

$location = $this->hrefLink('product' . $result['pID'] . FILENAME_PRODUCT_INFO, 'source=google', 'NONSSL', false);


Then find this on line 447:

$location = $this->hrefLink(FILENAME_DEFAULT, 'cPath=' . $this->GetFullcPath($result['cID']), 'NONSSL', false);

and replace it with:

$location = $this->hrefLink('category' . $this->GetFullcPath($result['cID']) . FILENAME_DEFAULT, 'source=google', 'NONSSL', false);

The 'source=google' is the optional tracking variable. I added it because this is an experimental program from Google and I want to keep tabs on it. You can change it to your liking or not. I hope this helps SEF users out there!


· willross

··········

Share this post


Link to post
Share on other sites
ERROR: Google Product Sitemap Generation FAILED!

 

ERROR: Google Category Sitemap Generation FAILED!

 

Generated Google Sitemap Index Successfully

Any one a solution for this strange problem ?

Thanks,

 

Hans

 

 

Hi Hans,

 

I have got the same problem. It something to do with a contribution i have installed somewhere. I tried the Google XML Sitemap contribution on a fresh install and it worked fine. Are you using BTS??

 

Regards,

 

Fish

Share this post


Link to post
Share on other sites
Hi Hans,

 

I have got the same problem. It something to do with a contribution i have installed somewhere. I tried the Google XML Sitemap contribution on a fresh install and it worked fine. Are you using BTS??

 

Regards,

 

Fish

 

 

Hi again Hans,

 

I've fixed the problem I was having. My store is still under development and I only had 1 category and 1 product. I added another category with 1 more product and now the contribution works a treat. This had me stumped all day.

 

Hope it helps you too.

 

Regards,

 

Fish

Share this post


Link to post
Share on other sites

I have this error....

 

Fatal error: Call to undefined function: tep_get_parent_categories() in /home/downdogs/public_html/includes/seo_cache.php on line 166

Share this post


Link to post
Share on other sites

Ok, here's one. My cron just sent me a message.

This is all it sent. Read between the lines. :D

---------------------------------

No input file specified.

 

 

.

 

----------------------------------

 

The cron is "/usr/bin/php /home/sitename/store/googlesitemap/index.php"

 

Odd? I don't know. I'm tired.

 

Paul

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×