Jump to content
Chemo

[CONTRIBUTION] Google XML Sitemap Feed - by Chemo

Recommended Posts

Google is referenced in urlset because when this addon was originally written, that was the way to do it. The other search engines will accept the maps as long as the reference to the index is made in the robots file. The urlset change will be in the next release.

Share this post


Link to post
Share on other sites

There isn't any code in place to do that so you would have to edit it. For example, in the sitemap,class.php file, find

		$sql = "SELECT products_id as pID, products_date_added as date_added, products_last_modified as last_mod, products_ordered 
			    FROM products 
				WHERE products_status='1'" . $quotes . "
				ORDER BY products_ordered DESC";

and change it to

		$sql = "SELECT products_id as pID, products_date_added as date_added, products_last_modified as last_mod, products_ordered 
			    FROM products 
				WHERE products_status='1'" . $quotes . "
                and products_id NOT IN (1,2,3)
				ORDER BY products_ordered DESC";

where the 1,2,3 are the product ID's (as many as you want). I haven't tested the above but I think it will do what you want. There is a similar function for categories where such a change can be made.

Share this post


Link to post
Share on other sites

I know this is a VERY old thread, but it worked on my site for many years .. and now it won't ?  It actually worked perfectly for many years from cron.. then a couple years ago the cron started failing (due to register_variables issue), but it would run just fine from the browser window.. so I just kept doing it manually.  Now, it also fails from the browser with a 127.0.0.1 call . which I think means it can't find the actual IP address where it used to be .. which is most likely because of the latest series of security changes made by all ISPs and everyone else too.

I haven't found anything in this thread and I don't see any mentions in the original addon series.. but, of course. all of that is years old now ..

Is anyone still 'listening here'?  Is there a way around the problem?  Is there a replacement feeder that works that I need to change to?  The store is still running under MS2.2 .. yes.. a terribly OLD version of OSC, but I just haven't taken the time to upgrade and the store still works .. for the time being.

Sorry for asking here, but I don't 'stay on top' of this store as well as I should since there is a relatively small number of products in a small store.  But I would like to get the google feeder working again.

TIA,

Steve

Share this post


Link to post
Share on other sites
Posted (edited)

@Steve80Yes, the addon is still supported. The last update was about 8 months ago. It should work in your shop, though I haven't tried the latest version in an MS2 shop. There isn't reason for the one you have installed to stop working unless something on the server changed.

I just realized this is the old support thread. The new support thread is here. And the addon is located here.

Edited by Jack_mcs

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×