Jump to content
Sign in to follow this  
echodsm

"invalid serial number" using geotrust/skip jack

Recommended Posts

hey guys i am new to this

 

i am using the contributed geotrust/skipjack payment module

 

when a transaction is attempted a message is returned saying invalid serial number

 

the serial number i input in the edit section is correct though

 

any ideas ? ? help would be very useful as i said i am new to this thank you

Edited by echodsm

Share this post


Link to post
Share on other sites
hey guys i am new to this

 

i am using the contributed geotrust/skipjack payment module

 

when a transaction is attempted a message is returned saying invalid serial number

 

the serial number i input in the edit section is correct though

 

any ideas ? ? help would be very useful as i said i am new to this thank you

 

I had the same problem; here you go:

 

ASSUMPTION: You registered your payment gateway directly with Skipjack (not an affiliate) and you're using the CURRENT version of the geotrust/skipjack module (currently geotrust_081905_1)

 

The default processing link will not work and must be replaced. I spoke directly with Skipjack and got this link: https://www.skipjackic.com/scripts/EvolvCC.dll?Authorize

 

This needs to replace the link found in this line of the geotrust.php payment module (includes/modules/payment/geotrust.php):

 

Go to line containing (line 32):

$this->form_action_url = 'https://developer.skipjackic.com/scripts/EvolvCC.dll?Authorize';

 

Assuming this has/had been done, and you still have the error, it could be one of two things:

 

1.) You're not using the actual HTML serial number provided. (There are usually two numbers; HTML Serial Number, and Login Serial Number. Use the first)

OR

2.) You purchased the Skipjack payment processor through a reseller and you're not using the proper link provided by that reseller. I've stumbled across several forum posts that show the link for various resellers. Do a search.

 

Hopefully this answers your question. If you're anything like me, you'll get passed that problem only to run into a new one. After processing with Skipjack, you're *supposed* to be redirected to the checkout_process.php page (as setup in your response files on skipjack) but are instead redirected to the login page. If that DOESN'T happen to you, PLEASE let me know, cause I'm STUCK! LOL!

 

Thanks,

 

-D

Edited by desoto0311

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×