Jump to content
deep-silver

### POINTS AND REWARDS MODULE V1.00 ###

Recommended Posts

Still, the points is being deducted twice on the checkout_confirmation page. Even I did as engbok did in post 1873. Yes this has been asked a few times, but engbok is only suggestion I can find. I just finished going through all 96 pages.

 

I know the instructins for points/rewards refers at some point, regarding CCGV. I do not have that mod installed, I have coupon discount. I did not see any conflict with that mod. I even removed it through admin, but still, that did not solve the issue.

 

Maybe the solution is so simple, but I cannot seem to find it.

 

Any help is appreciated. Thanks.

Share this post


Link to post
Share on other sites
Still, the points is being deducted twice on the checkout_confirmation page. Even I did as engbok did in post 1873. Yes this has been asked a few times, but engbok is only suggestion I can find. I just finished going through all 96 pages.

 

I know the instructins for points/rewards refers at some point, regarding CCGV. I do not have that mod installed, I have coupon discount. I did not see any conflict with that mod. I even removed it through admin, but still, that did not solve the issue.

 

Maybe the solution is so simple, but I cannot seem to find it.

 

Any help is appreciated. Thanks.

 

Did you install Deep Silvers latest release?

Share this post


Link to post
Share on other sites

I have installed the latest release, I done it this morning.

 

However there is no evidence of the modifcation in the order total it just doesn't display even when you tick the box to say you wish to use the points.

 

So basically it just doesn't display in the order total or on PayPal, so there are no reduction?

 

Is this the same problem people have been having or is it something I have done wrong.

 

There is no sign of the module in the order total section of the admin panel, Is there a file missing?

Share this post


Link to post
Share on other sites

Help,

 

I have moved my site to a new server with Mysql 5 PHP 5.2 and apache 2.2

every thing is working fine also the point and reward system, however in admin at customer points pending the value of the points is 0 (zero) so if i confirm the points the customer gets a mail that his point are been confirmed and the message says 500 points with a value of 0 (zero)

 

In the frontend at articles the points and the value is correct and the points which have been confirm to the customer have the right value in money at there account. So the only problem is that for some reason in in customer points pending is something wrong or no longer working correct. I think this has to do with the new server specification. Can somebody please help me where to look or what is no longer compatible with the new server specification?

 

Thank you for the help

Marcel

Share this post


Link to post
Share on other sites

Hi again.

 

I am still having the same problems and I really need to sort them to open up my store with points and rewards.

 

Basically, it is the same as before, that there are no points being deducted from the order total on the checkout confirmation page and therefore the price is not being reduced nor the points deducted.

 

I noticed the following from a page back...

 

points.jpg

 

Notice the image shows the rewards module in the order totals module in the admin control. This does not appear here on my store, what could I have done wrong, is it a database thing? I believe this may be the cause, am I right and does anyone know the fix for this?

 

Thanks...

Share this post


Link to post
Share on other sites
Did you install Deep Silvers latest release?

 

 

That I did. The update dated Jan 8, 2009.

Edited by blr044

Share this post


Link to post
Share on other sites
That I did. The update dated Jan 8, 2009.

 

 

In my own experience, I have found nothing but trouble with anyone elses release of this module.

 

Therefore, I advise you to install V2.1rc2a by deep-silver - 4 Oct 2008.

 

It works - at least it does for me - and I wish it does for you too :-)

 

Regards

Edited by ssnb

Share this post


Link to post
Share on other sites
Hi again.

 

I am still having the same problems and I really need to sort them to open up my store with points and rewards.

...../

 

This does not appear here on my store, what could I have done wrong, is it a database thing? I believe this may be the cause, am I right and does anyone know the fix for this?

 

Thanks...

 

Dude, if you don't see this, I suggest you go back thru your installation and re-install this version

V2.1rc2a deep-silver 4 Oct 2008

Share this post


Link to post
Share on other sites
In my own experience, I have found nothing but trouble with anyone elses release of this module.

 

Therefore, I advise you to install V2.1rc2a by deep-silver - 4 Oct 2008.

 

It works - at least it does for me - and I wish it does for you too :-)

 

Regards

 

 

OK, I will work on this during the next few days.. I have all of my fingers crossed! Thanks.

Share this post


Link to post
Share on other sites
OK, I will work on this during the next few days.. I have all of my fingers crossed! Thanks.

 

 

I had a chance to install P/R dated 4 Oct 2008 by deep-silver. But still am getting the same results. Where the points is being deducted twice. The setting in order total module for P/R is between sut-total and total.

 

After first test run, since it was still incorrect, I put store back as before the install. Did it the second time. Did not change.

 

Everything else works in admin and the store except the total is incorrect.

 

Thanks.

Edited by blr044

Share this post


Link to post
Share on other sites

Review pbm + Paypal

 

Hi guys !

Thanks for this GREAT contribution !!!! So wonderfull, so great, so everything ! Thanks a lot !!!!

 

I have 2 pbms.

 

1) is there a way for customers who write review on the site, can let only one review by product. Because each review cost me money !!! lol

So, only one review by product by customer.

 

2) i have paypal module and paypal_standard module . But they both doesn't work with Points and Rewards.

What's happen is that the reduction is correct and customer can pay on papal the good order total, but after paiment, the reward point are not deducted from the customer account and customer doesn't have any reward for the order his just pass.

 

Please.... someone for help me....

 

Thanks again for the great contrib !

Share this post


Link to post
Share on other sites

Hi can someone tell me how to run the report or view the report once you enable it in the configuration. Where does it save the report? Cant see a link in the reports tab in the catalogue? Basically i want to see the report for the redeemed points.

 

Ta in advance

 

Regards,

 

 

****ACTUALLY GUYS JUST FOUND IT***

If your wondering this too anyone its under the customers tab then pending points, there is a drop down and select redeemed.

 

:) simples.

Edited by bodymaxs

Share this post


Link to post
Share on other sites

hiya,

 

i have been using this contrib for a whle with no probs....i was doing some testing on my site and this error msg came up on the checkout_payment.php at the top. it has also started not deleting points that have been redeemed and also not adding points for new orders on....???

 

the only thing that i have done recently to my site is that i have removed the right side colum but thats it....

 

any ideas?

 

1054 - Unknown column 'coupon_status' in 'where clause'

select count(*) as total from coupons where coupon_status = '1'

[TEP STOP]

Share this post


Link to post
Share on other sites
I had a chance to install P/R dated 4 Oct 2008 by deep-silver. But still am getting the same results. Where the points is being deducted twice. The setting in order total module for P/R is between sut-total and total.

 

After first test run, since it was still incorrect, I put store back as before the install. Did it the second time. Did not change.

 

Everything else works in admin and the store except the total is incorrect.

 

Thanks.

 

 

Am wondering if anyone had a chance to read post #1914 I posted back a bit. Still have not solved or found an post to as where i can correct my problem?

 

Thanks.

Share this post


Link to post
Share on other sites
Am wondering if anyone had a chance to read post #1914 I posted back a bit. Still have not solved or found an post to as where i can correct my problem?

 

Thanks.

 

 

Hi

 

Did you try deleting the P&R table in your database and re-installing? (backup entire DB first)

 

If it's duplicating the deduction, there must be an error somewhere!

 

What other contributions do you have installed - perhaps there was a conflict in one of the files when merging the code?

Sorry I don't have the answer for you!

Share this post


Link to post
Share on other sites
1) is there a way for customers who write review on the site, can let only one review by product. Because each review cost me money !!! lol

So, only one review by product by customer.

 

2) i have paypal module and paypal_standard module . But they both doesn't work with Points and Rewards.

What's happen is that the reduction is correct and customer can pay on papal the good order total, but after paiment, the reward point are not deducted from the customer account and customer doesn't have any reward for the order his just pass.

 

I don't have answers, only theories:

 

1) Not as standard with this contribution. You would have to modify it considerably to do this.

 

2) There is a fix for this. You need to find the Paypal IPN

http://addons.oscommerce.com/info/3220 look for mod: DEEP SILVER ACCESSORY 27 Jun 2005

 

You would be advised to search this forum to see if it has been updated. BACKUP your store first before install.....

 

To search this forum: copy and paste the following into google:

 

site:forums.oscommerce.com points & rewards module v1.00 "paypal ipn"

Share this post


Link to post
Share on other sites

Thanks for the answer ...

But i know about paypal IPN solution, but i can't change my paypal module cause i need both... Cause each module works with a different currencies and different fees.... so i have to keep my paypal module.

 

That's The Problem !!!! lol

 

i need a solution for paypal standard module and paypal module.

I could try to cut , paste and modify the original code of paypal IPN solution... but i don't know enought about php to do that ....

 

I need help for that !

Please .... someone for help ...

 

Thanks again for your answer !

Share this post


Link to post
Share on other sites
Hi

 

Did you try deleting the P&R table in your database and re-installing? (backup entire DB first)

 

If it's duplicating the deduction, there must be an error somewhere!

 

What other contributions do you have installed - perhaps there was a conflict in one of the files when merging the code?

Sorry I don't have the answer for you!

 

Am sorry, but do not what is wrong. I installed coupon discount before adding P/R. All test, before P/R, proved to have issues. I did remove all signs of {/R from DB and removed P/R. Then Installed P/R of the latest deep-silver.

 

Not one clue. If my store wasn't so heaely modified, I would do a clean install. That might the only solution, because I have racked my brain for a few weeks now.

Share this post


Link to post
Share on other sites

hiya,

 

i have been using this contrib for a whle with no probs....i was doing some testing on my site and this error msg came up on the checkout_payment.php at the top. it has also started not deleting points that have been redeemed and also not adding points for new orders on....???

 

the only thing that i have done recently to my site is that i have removed the right side colum but thats it....

 

any ideas?

 

 

CODE

1054 - Unknown column 'coupon_status' in 'where clause'select count(*) as total from coupons where coupon_status = '1'[TEP STOP]

Share this post


Link to post
Share on other sites

Hi

 

I am using this excellent contribution with order editor, which is used to edit the orders in the admin of the site. Everything works perfectly and when I go to the admin order editor (edit_orders.php) the points are shown as correctly deducted. However, when I update the order status on edit_orders.php or just press 'update' the points are still shown in the order summary block but the total reverts back to the original amount, as though no points have been deducted.

 

Please, please can someone help me with this as I have been struggling with it for days now and just cant seem to figure out what the problem is.

 

Many thanks.

Share this post


Link to post
Share on other sites
hiya,

 

i have been using this contrib for a whle with no probs....i was doing some testing on my site and this error msg came up on the checkout_payment.php at the top. it has also started not deleting points that have been redeemed and also not adding points for new orders on....???

 

the only thing that i have done recently to my site is that i have removed the right side colum but thats it....

 

any ideas?

 

 

CODE

1054 - Unknown column 'coupon_status' in 'where clause'select count(*) as total from coupons where coupon_status = '1'[TEP STOP]

 

Tracey

 

Have you used phpmyadmin to see if the field does exist in the table coupons?

 

G


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites
Hi

 

I am using this excellent contribution with order editor, which is used to edit the orders in the admin of the site. Everything works perfectly and when I go to the admin order editor (edit_orders.php) the points are shown as correctly deducted. However, when I update the order status on edit_orders.php or just press 'update' the points are still shown in the order summary block but the total reverts back to the original amount, as though no points have been deducted.

 

Please, please can someone help me with this as I have been struggling with it for days now and just cant seem to figure out what the problem is.

 

Many thanks.

 

Mark

 

Check you have followed the installtion instructions exactly especially those steps updating edit_orders.php

 

G


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

I just completed the install of this contribution and it all seems to work except for one small thing.

 

When a customer has enough points to pay for the entire order it works fine. But for some reason when you try to use the points to partially pay for an order and you get the message that you will also need to choose a payment method, the points are not applied.

 

You click the checkbox, and then click a form of payment. Then when you got to the order comfirmation page it still has the same full total whether you click to use the points or not. Also when you go to complete the order and pay, the total amount is still the full amount.

 

I'm wondering if this problem has been seen before and if so, how do I solve this?

 

Thanks again and any help is appreciated.

Share this post


Link to post
Share on other sites

i seem to have the contribution installed correctly although i am too having the issue with PayPal, the total is correct so all the points are calculating. the only problem i am having is that the points are not removed from the customer account after it is been used and the new points have not been added. now i can manually change the points in ADMIN but this can be a big job. when using bank deposit the points system is perfect. it is only having issues with PayPal standard.

 

Any help or ideas would be great.

 

i did try the code previously listed in the thread although i got errors when trying to add the points to the PayPal_standard.php files.

 

i don't really need to have the points show in PayPal but i do need them to calculate on my site.

 

Thanking you again.


Thanks in advance!

 

Ben

Share this post


Link to post
Share on other sites
Tracey

 

Have you used phpmyadmin to see if the field does exist in the table coupons?

 

G

 

 

i would if i knew how to :blush: the only thing that im confused about is that it wasnt happing befoer....so im not exactly sure why its just started happening

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×