Jump to content
deep-silver

### POINTS AND REWARDS MODULE V1.00 ###

Recommended Posts

Did reinstall Points/Reward after many months with v2..1rc2a.

 

Am having two issues. Doing a test purchase w/o P/R all figures is correct with correct sub-total. But clicking the redeem points box, the figures is coorect but the sub-total is incorrect. Doing th math, points is being deducted twice:

 

Sub-total $128.35

Points: - $ 14.00

S/H: $ 16.69 13% over 99.00

Tax: $ 8.34 6.5%

----------------------------------

Sub-Total: $125.38 Should be $ 139.38

 

Second issue after points has been approved or added, customer does not receive notification of points, even though in admin, it states customer has received notice.

 

I am going to disable this till I can get an answer!!!

Share this post


Link to post
Share on other sites

Hi i am a newbie on the forum.

well, I install points and rewards 1.5 for a CD Store

 

but I dont understand how it works

 

and i need give credit if someone buy something but we are out of stock.

I give them store credit then they can use the credit to pay for other items in the store.

 

Can someone help me with these please?

 

thanks

Vic.

Edited by considered

Share this post


Link to post
Share on other sites
Open: catalog/includes/modules/payment/paypal_ipn.php

 

STEP ONE: Find this.... (start at aprox. line no.77)

 

global $cartID, $cart_PayPal_IPN_ID, $customer_id, $languages_id, $order, $order_total_modules;

 

.. and REPLACE it with this...

 

#### Points/Rewards Module v1.20 balance customer points BOF ####

// global $cartID, $cart_PayPal_IPN_ID, $customer_id, $languages_id, $order, $order_total_modules;

global $cartID, $cart_PayPal_IPN_ID, $customer_id, $languages_id, $order, $customer_shopping_points, $customer_shopping_points, $customer_shopping_points_spending, $order_total_modules;

#### Points/Rewards Module v1.10 balance customer points EOF ####*/

 

------------------------------------------------------------------------------------------

 

 

STEP TWO Find this.... (start at aprox. line no.178)

 

tep_db_perform(TABLE_ORDERS_TOTAL, $sql_data_array);

}

 

.. and add this after...

 

#### Points/Rewards Module v1.20 balance customer points BOF ####

// customer shoppping points account balanced

if (USE_REDEEM_SYSTEM == 'true' && $customer_shopping_points_spending) {

$points_toset = $customer_shopping_points - $customer_shopping_points_spending;

tep_set_shopping_points($points_toset,$customer_id);

if ($customer_shopping_points_spending && DISPLAY_POINTS_REDEEMED == 'true') {

tep_add_redeemed_points($customer_id, $insert_id,$customer_shopping_points_spending);

}

}

// customer pending points added

$points_toadd = get_points_toadd($order);

$rules_discounted = get_award_discounted($order);

if ((USE_POINTS_SYSTEM == 'true') && ($order->info['total'] > 0) && (USE_POINTS_FOR_SPECIALS == 'true' || $rules_discounted == true)) {

tep_add_pending_points($ordernum, $customer_id, $insert_id,$points_toadd);

}

#### Points/Rewards Module v1.20 balance customer points EOF ####*/

 

------------------------------------------------------------------------------------------

 

STEP THREE Find this.... (start at aprox. line no.557)

 

// unregister session variables used during checkout

tep_session_unregister('sendto');

tep_session_unregister('billto');

tep_session_unregister('shipping');

tep_session_unregister('payment');

tep_session_unregister('comments');

 

... and add after.....

 

tep_session_unregister('customer_shopping_points');// Points/Rewards Module v1.20

tep_session_unregister('customer_shopping_points_spending');// Points/Rewards Module v1.20

 

Let us know if that works for you

Has anyone gotten thisto work with PayPal_IPN 2.3.4.6 (http://addons.oscommerce.com/info/2679)? I have done the above, but it is still showing the full price when the customer goes to PayPal.

 

Thanks!!

Edited by jrthor2

Share this post


Link to post
Share on other sites

Still am seeing no sugguestions on what I may be missing or need to get points and rewards working correctly in post 1878!

 

Did anyone else out there whom is using this mod, ever had an issue like this?

Edited by blr044

Share this post


Link to post
Share on other sites

hi,

 

i just installed the add on to my store. The redemption system is enable in the configuration. My customer have 1000 points in her account but she can't redempt item when she trying to check out. The payment method only show cash on delivery and credit card. I am wondering which step i do wrong during the installation. <_<

 

Any one can help? :blink:

Share this post


Link to post
Share on other sites

Hi all,

 

My the other question, is it possible to make this...

 

example,

 

In the product catelogue, there are 100 of products are available only thru purchase. thru those purchase can accumulate points. then define 10 more proudcts which are not available for purchase but can let member to redeem.

 

How to do this? or any contribution got this?

Share this post


Link to post
Share on other sites
Has anyone gotten thisto work with PayPal_IPN 2.3.4.6 (http://addons.oscommerce.com/info/2679)? I have done the above, but it is still showing the full price when the customer goes to PayPal.

 

Thanks!!

Is this forum monitored anymore? I don't see any replies to the most recent posts. I hope this addon is still supported. It doesn't seem to work with PayPal IPN v 2.3.4.6. has anyone gotten this to work with the PayPal IPN?

 

Thanks

Share this post


Link to post
Share on other sites

I've followed the install instructions but claerly have done something wrong. My customers points are not being awarded or showing at all. If I go and manually adjust points, they are not subtracted from when customers are using them during checkout.

 

I'm thinking it's a database issue but not sure what I should check.

 

Any help would be appreciated.

 

Thanks.


Nancy

Share this post


Link to post
Share on other sites

Has anyone gotten an answer to their questions on this forum for this contribution?? Is this contribution not supported anymore? I'd like to have this working with PayPal, since it is such a popular payment type

 

Thanks!

Share this post


Link to post
Share on other sites

hey. I am having this problem with this add-on on my website

 

 

1. I can't install it on admin/modules/points redeemption

2. I do not see the following part on my configuration

==> Still in the OSC admin, under "Configuration" you should see Points/RewardsV2.1rc2a

Click on the link and make change to suite your site.

 

Please help me out!

Share this post


Link to post
Share on other sites

This is a great addition. Never notice before, but before a customer sees the point value for the products, do they actually need to log in or create a account before the points is visible?

 

I did look at code, to me it seems thats how it was created.

 

Thanks.

Share this post


Link to post
Share on other sites
Has anyone gotten thisto work with PayPal_IPN 2.3.4.6 (http://addons.oscommerce.com/info/2679)? I have done the above, but it is still showing the full price when the customer goes to PayPal.

 

Thanks!!

 

I too am curious if anyone found a fix for this problem. My Points are not showing in PayPal. Thanks!

Share this post


Link to post
Share on other sites
Hi All

 

Doe anyone have an idea of how to exclude a payment module from Points and Rewards? i.e when a customer chooses payment option A then they are not elligible for Points and cannot redeem points against that order.

 

Thanks

Ashley

 

 

Hay everyone,

 

I would also like to know if it is possible to exclude a certain payment module?

 

Regards

Sol

Share this post


Link to post
Share on other sites

I installed this contrib, an think it's great.

 

Everything seems to be fine. It shows in customers account, it shows on the product page and during check out it asks if the customer would like to use their points, however when it comes to actually going through the cart, the points dollar value is not being subtracted from the end total.

 

what do I have to do to fix this minor glitch :P

 

Thanx

 

kindest regards,

Nancy

Share this post


Link to post
Share on other sites

I fixed the problem, and thought I would post how, just incase anyone else is daft like me.

 

As it turns out in the moduals (order total ) section of the admin, I had two items showing their order of display at the same setting, both "points redemption and subtotal" were set to show 4th in line of the checkout. One was over riding the other. I set all the items in there to the proper show order, 1, 2, 3, 4 ,5, and now the points dollar value is properly being subtracted from the subtotal of the order.

 

I hope this little tidbit is useful to someone else.

 

KR

Nancy :D

 

 

 

I installed this contrib, an think it's great.

 

Everything seems to be fine. It shows in customers account, it shows on the product page and during check out it asks if the customer would like to use their points, however when it comes to actually going through the cart, the points dollar value is not being subtracted from the end total.

 

what do I have to do to fix this minor glitch :P

 

Thanx

 

kindest regards,

Nancy

Share this post


Link to post
Share on other sites

I posted this in post 1878 awhile back. Am i the only using points/rewards that is having this issue?

 

 

Am having two issues. Doing a test purchase w/o P/R all figures is correct with correct sub-total. But clicking the redeem points box, the figures is coorect but the sub-total is incorrect. Doing th math, points is being deducted twice:

 

Sub-total $128.35

Points: - $ 14.00

S/H: $ 16.69 13% over 99.00

Tax: $ 8.34 6.5%

----------------------------------

Sub-Total: $125.38 Should be $ 139.38

 

I have worked with the settings, but nothing changes the total. Below is showing my order total settings.

 

points.jpg

Edited by blr044

Share this post


Link to post
Share on other sites
I posted this in post 1878 awhile back. Am i the only using points/rewards that is having this issue?

 

 

Am having two issues. Doing a test purchase w/o P/R all figures is correct with correct sub-total. But clicking the redeem points box, the figures is coorect but the sub-total is incorrect. Doing th math, points is being deducted twice:

 

Sub-total $128.35

Points: - $ 14.00

S/H: $ 16.69 13% over 99.00

Tax: $ 8.34 6.5%

----------------------------------

Sub-Total: $125.38 Should be $ 139.38

 

I have worked with the settings, but nothing changes the total. Below is showing my order total settings.

 

points.jpg

 

 

 

You'll have to do a search as I believe this has been mentioned before:

Share this post


Link to post
Share on other sites

hi there,

after i instass rewards module v1.4 this thing has occured on shop website

Fatal error: Cannot redeclare class infoBox in /var/www/catalog/includes/classes/boxes.php on line 98

 

and in that file almost every class has the same error.. it is strange cause admin panel works fine... with rewards module and without any error.

it is important that only that error is visible, and i cannot see shop website.. file boxex php is standart installation file.. if anyone can give me some clue or need some extra code pls give me a shout.

Share this post


Link to post
Share on other sites

I really need help with this. I have installed the add-on and can not seem to get the points to redeem with the point total is less then the actual order total (Total $15.00 - $5.00 points = $10.00 balance). it keeps asking to select a form of payment even when one is selected (using test credit card and/or Cash on delivery) Using points when the total is less then the amount of points works fine.

 

Can someone please help I really want to get this working so I can update my site. And I have triple check my instal and can not seem to find an answer in the forum.

Share this post


Link to post
Share on other sites
I too am curious if anyone found a fix for this problem. My Points are not showing in PayPal. Thanks!

 

 

This forum (and this contribution) is a very popular one - it's quite an old one!

 

The author (Deep Silver) does seem to come back every once in a while to check what's going on - though I understand he is a new father which is keeping him busy offline!! He recently uploaded the latest version which basically, ironed out most of the bugs - at least it works for me.

 

It's frustrating when there is no-one to help! I think the best we can do is use the search facility because there are over 90 pages - the chance are, your question may have been answered elsewhere!

 

However because the forum search tool is poor, I suggest using google like this:

 

site:forums.oscommerce.com "search topic"

 

Good luck

Edited by ssnb

Share this post


Link to post
Share on other sites
You'll have to do a search as I believe this has been mentioned before:

Have read through this twice. I see there is around a half dozen post regarding this issue. But did not see a solution for ithis. I again have uninstalled points/rewards and reinstalled the latest mod with all fixes.

 

And still gettin same results with the order total.

 

My site is located here.

Edited by blr044

Share this post


Link to post
Share on other sites
This is a great addition. Never notice before, but before a customer sees the point value for the products, do they actually need to log in or create a account before the points is visible?

 

I did look at code, to me it seems thats how it was created.

 

Thanks.

 

 

The answer to this as far as I am aware is yes, the customer needs to create an account and you can credit them with points just for joining up, in admin > Config > Points&rewards > new signup customers

 

Does that answer your question?

 

Further to my point about using google to search this topic, I found a better way to do it - try this in the google search field:

 

http://forums.oscommerce.com/index.php?showtopic=152746 "search topic"

Share this post


Link to post
Share on other sites
hey. I am having this problem with this add-on on my website

 

 

1. I can't install it on admin/modules/points redeemption

2. I do not see the following part on my configuration

==> Still in the OSC admin, under "Configuration" you should see Points/RewardsV2.1rc2a

Click on the link and make change to suite your site.

 

Please help me out!

 

 

It's not under admin modules, you should see it in Config > points/rewards V2.00 - if not, then you will need to go over your installation again.

Share this post


Link to post
Share on other sites
The answer to this as far as I am aware is yes, the customer needs to create an account and you can credit them with points just for joining up, in admin > Config > Points&rewards > new signup customers

 

Does that answer your question?

 

Further to my point about using google to search this topic, I found a better way to do it - try this in the google search field:

 

http://forums.oscommerce.com/index.php?showtopic=152746 "search topic"

Did find out that customers do not need to log to see point value at product_info.php.

 

Am sorry if I stated my question wrong.

 

But please refer to post 1896. I am again reading through this thread in hopes of finding a solution. At present, I am at page 35.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×