Jump to content
deep-silver

### POINTS AND REWARDS MODULE V1.00 ###

Recommended Posts

im also recieving this error when someone tries to sign up.....

 

Fatal error: Call to undefined function: tep_href_link() in /clientdata/n5200-2-dynamic/s/i/silkycreations.com.au/www/create_account_success.php on line 16

 

but if they refresh the index page they are logged in? points being allocated etc just not that in between page... i just noticed that when the other half tried to make an account

Share this post


Link to post
Share on other sites

My welcome points are not being credited to Points status when the user creates an account. Everything else seems fine.

 

BTW: The file catalog\create_account_success.php in the modified files archive appears to be the definition file not the public one.

Share this post


Link to post
Share on other sites

Hey Deep,

 

The fix that you have described asks for the languages file to be changed which wouldn't work. The correct file that should be changed is:

 

catalog/includes/modules/order_total/ot_redemptions.php

 

But I'm sure everyone would have worked that out on their own :)

 

Cheers!

 

Mike

 

Bug found.

In a very rare case where full amount is covered by point and shipping tax and regular items tax are separated

the order total is not rounded correctly and you will be returned to payment page asking you to choose payment method.

to fix it

open catalog/includes/languages/english/modules/order_total/ot_redemptions.php

find this at line no.37

$order->info['total'] = $order->info['total'] - tep_calc_shopping_pvalue($customer_shopping_points_spending);

and replace with this.

$order->info['total'] = number_format($order->info['total'] - tep_calc_shopping_pvalue($customer_shopping_points_spending), 4);

in a normal cases you won't see any different.

Share this post


Link to post
Share on other sites
My welcome points are not being credited to Points status when the user creates an account. Everything else seems fine.

 

BTW: The file catalog\create_account_success.php in the modified files archive appears to be the definition file not the public one.

 

OK, I did a clean install and solved my problem.

Share this post


Link to post
Share on other sites
My welcome points are not being credited to Points status when the user creates an account. Everything else seems fine.

 

BTW: The file catalog\create_account_success.php in the modified files archive appears to be the definition file not the public one.

 

this is the screen that appears after they complete their signin before going onto all the points screens

Share this post


Link to post
Share on other sites

Hi Everyone!

 

Just a need quick answer for this question.

 

I have a minimally modified OSC site and I need to use SPPC, X-Sell and ###POINTS AND REWARDS MODULE V1.00### contribs.

Now my questions is. based on your experiences what's the recommended sequence in installing these 3 modules to minimize errors and incompatibility.

Also if there are other contribs needed to make them compatible, please provide.

 

Thanks a lot!

Share this post


Link to post
Share on other sites
im also recieving this error when someone tries to sign up.....

 

Fatal error: Call to undefined function: tep_href_link() in /clientdata/n5200-2-dynamic/s/i/silkycreations.com.au/www/create_account_success.php on line 16

 

but if they refresh the index page they are logged in? points being allocated etc just not that in between page... i just noticed that when the other half tried to make an account

Have you fixed the problem?

BTW i think you missed CATALOG STEP = 14.


Remember - - - "STRESSED" spelled backwards "DESSERTS"

Share this post


Link to post
Share on other sites

Hi Deep

 

Any idea where I may be going wrong here? I get these funny totals redeeming points

1 x GIGABYTE GA-X48-DQ6 R4,049.00

Sub-Total: R4,049.00

delivery : R60.00

Points Redeemed: -R40.49

Total: R4.00

 

Checkout normal without points

 

1 x GIGABYTE GA-X48-DQ6 R4,049.00

Sub-Total: R4,049.00

delivery: R60.00

Total: R4,109.00

Share this post


Link to post
Share on other sites

Thank you for a wonderful contribution.

 

By the way, I want occasionally to hear it.

OsCommerce rc2a is being used in a Japanese environment now.

The currency is Japanese yen.

 

In that case, the following symptoms occur by checkout_confirmation.php if this contribution is used.

 

Example

Subtotal:11,000 Yen

Points Redeemed: -1,000 Yen

Total 10 Yen

 

When the point system is invalidated, it becomes Total 10,000 Yen.

 

The symptom

$order->info['total'] = number_format($order->info['total'] - tep_calc_shopping_pvalue($customer_shopping_points_spending), 4);

To change

$order->info['total'] = $order->info['total'] - tep_calc_shopping_pvalue($customer_shopping_points_spending);

 

It has been improved by changing.

This is a content of the other day's bugfix.

 

I'm sorry English ..unskilled...

Share this post


Link to post
Share on other sites
Thank you for a wonderful contribution.

 

By the way, I want occasionally to hear it.

OsCommerce rc2a is being used in a Japanese environment now.

The currency is Japanese yen.

 

In that case, the following symptoms occur by checkout_confirmation.php if this contribution is used.

 

Example

Subtotal:11,000 Yen

Points Redeemed: -1,000 Yen

Total 10 Yen

 

When the point system is invalidated, it becomes Total 10,000 Yen.

 

The symptom

$order->info['total'] = number_format($order->info['total'] - tep_calc_shopping_pvalue($customer_shopping_points_spending), 4);

To change

$order->info['total'] = $order->info['total'] - tep_calc_shopping_pvalue($customer_shopping_points_spending);

 

It has been improved by changing.

This is a content of the other day's bugfix.

 

I'm sorry English ..unskilled...

 

Thanks so much for this, it solved my problem. :)

Share this post


Link to post
Share on other sites

We wish to express our gratitude for POINTS AND REWARDS MODULE V2.1rc2a that is the latest version opened to the public this time.

It made to operate osCommerce rc2a with Japanese Localize, UTF-8, PHP5, MySQL5, and Register Globals OFF now and it changed it.

 

I think that I patronize not MS3 but MS2 for a long time.

 

Thank you for such a contribution that outs to lunch corresponding to rc2a.

Share this post


Link to post
Share on other sites

Great Rewards module!!! just one question.

 

Is there a way to prevent specific products or categories from receiving points? i noticed the admin page lets u activate products or categories but not allow everything except certain items. I have the gift card module and i don't want my customers to receive points for the gift card and points for the purchase, basically double the points.

 

Thanks for the help

 

Anthony,

Share this post


Link to post
Share on other sites
It look like Reward point system will be implemented into the osCommerce MS3.

found it on osCommerce roadmap list

http://www.oscommerce.com/community/roadmap,10

 

 

That's great news Deep - but don't get too excited. There is a lot of talk about OSC being dead! There has been little or no development for a long time and the core coders have hardly even been on the site, some as little as once in the last year.... it seems other e commerce carts are taking over (magento?).....

http://forums.oscommerce.com/index.php?sho...0025&st=320

Edited by ssnb

Share this post


Link to post
Share on other sites
That's great news Deep - but don't get too excited. There is a lot of talk about OSC being dead! There has been little or no development for a long time and the core coders have hardly even been on the site, some as little as once in the last year.... it seems other e commerce carts are taking over (magento?).....

http://forums.oscommerce.com/index.php?sho...0025&st=320

magento??????

osCommerce has been on the market since early 2000, that's 8 years ago.

still used by lots of people world wide.

if magento(or any other un solid) will be around at 2016, then we'll talk!

Edited by deep-silver

Remember - - - "STRESSED" spelled backwards "DESSERTS"

Share this post


Link to post
Share on other sites

I am doing a complete virgin install using osCommerce-2.2rc2a and the install dated 10/8: ##POINTS AND REWARDS MODULE V2.1rc2a_1.

 

I took your advice and uploaded the installer to the admin directory, got thru the initial screen then got the following error:

 

Warning: Cannot modify header information - headers already sent by (output started at /home/xxx/public_html/members/admin/installer.php:31) in /home/xxx/public_html/members/admin/installer.php on line 242

 

The line looks ok in install.php but I'm no expert:

}

 

$_POST['install'] = "";

header("location:?success");

}

 

Something simple no doubt but can't get past this.

 

Thanks

Share this post


Link to post
Share on other sites
I am doing a complete virgin install using osCommerce-2.2rc2a and the install dated 10/8: ##POINTS AND REWARDS MODULE V2.1rc2a_1.

 

I took your advice and uploaded the installer to the admin directory, got thru the initial screen then got the following error:

 

Warning: Cannot modify header information - headers already sent by (output started at /home/xxx/public_html/members/admin/installer.php:31) in /home/xxx/public_html/members/admin/installer.php on line 242

 

The line looks ok in install.php but I'm no expert:

}

 

$_POST['install'] = "";

header("location:?success");

}

 

Something simple no doubt but can't get past this.

 

Thanks

 

Have not tried the installer myself. But if you are doing a clean install from scratch, then you can just overwrite your files with the ones in package. New files and modified files in the package need to be applied. Run the SQL and you are all done.

Share this post


Link to post
Share on other sites
Have not tried the installer myself. But if you are doing a clean install from scratch, then you can just overwrite your files with the ones in package. New files and modified files in the package need to be applied. Run the SQL and you are all done.

 

Thanks for the quick response. Same error.

Share this post


Link to post
Share on other sites
Thanks for the quick response. Same error.

 

Hi John

 

I was suggesting doing the install without installer.php. The error you got was related to installer.php, you should not get that error again if you are not using installer.php

Share this post


Link to post
Share on other sites
Hi John

 

I was suggesting doing the install without installer.php. The error you got was related to installer.php, you should not get that error again if you are not using installer.php

 

That did it! Thanks again for your quick response.

Share this post


Link to post
Share on other sites

First, THANKS for the CONTRIBUTION !!! IT'S GREAT !!

 

 

I installed the last update ( 08 AGO) Everything is working great, but, I can't make the EXPIRATION PERIOD appear in the FAQ ... does anybody knows what can be the problem !?

 

And, when someone make a buy in the store, the point is the queue appears 3x, just like someone did 3 buys in a row !!

 

any ideas !?

 

Thanks

Share this post


Link to post
Share on other sites

When a customer tries to pay with PayPal and uses reward points for part of the payment PayPal will not accept the request. See the error response below. PayPal does not accept a negative value.

24 July 2008: "Apparently PayPal changed their server behavior so the negative value is no longer accepted."

 

Is there any fix for this problem?

 

In function: before_process()

Response from PayPal:

 

[security] = N/A

[RequesterCredentials]

[0]

[Credentials]

[0]

[username] = N/A

[Password] = N/A

[subject] = N/A

 

[DoExpressCheckoutPaymentResponse]

[0]

[Timestamp] = 2008-10-13T13:24:07Z

[Ack] = FailureWithWarning

[CorrelationID] = b89618454d14a

[Errors]

[0]

[shortMessage] = Invalid Data

[LongMessage] = Handling total is invalid.

[ErrorCode] = 10428

[severityCode] = Error

 

[1]

[shortMessage] = Transaction refused because of an invalid argument. See additional error messages for details.

[LongMessage] = The totals of the cart item amounts do not match order amounts.

[ErrorCode] = 10413

[severityCode] = Warning

Share this post


Link to post
Share on other sites

When you set Use MIME HTML When sending emails to true in the Admin configuration, the welcome points are not being credited to the user's account. Unable to test on the demo store because the configuration settings there have been changed.

Share this post


Link to post
Share on other sites
When you set Use MIME HTML When sending emails to true in the Admin configuration, the welcome points are not being credited to the user's account. Unable to test on the demo store because the configuration settings there have been changed.

 

Ashley I had the same problem since I am assuming you are using the uHTML contribution? - In the create_account.php there is code which you edited to insert the call to update the points, but if you notice that code was already edited by uHTML to say if it is HTML use the code above. I literally copied the code which calls the update of the function and duplicated it in the other section of the IF statement.

 

Hope this helps.

 

Mike

Share this post


Link to post
Share on other sites
Ashley I had the same problem since I am assuming you are using the uHTML contribution? - In the create_account.php there is code which you edited to insert the call to update the points, but if you notice that code was already edited by uHTML to say if it is HTML use the code above. I literally copied the code which calls the update of the function and duplicated it in the other section of the IF statement.

 

Hope this helps.

 

Mike

 

Hi Mike

 

Thanks for pointing me in the right direction. How would I rearrange this ???

 

// build the message content

/--- Beginning of addition: Ultimate HTML Emails ---//

if (EMAIL_USE_HTML == 'true') {

require(DIR_WS_MODULES . 'UHtmlEmails/'. ULTIMATE_HTML_EMAIL_LAYOUT .'/create_account.php');

$email_text = $html_email;

}else{

//--- End of addition: Ultimate HTML Emails ---//

$name = $firstname . ' ' . $lastname;

 

if (ACCOUNT_GENDER == 'true') {

if ($gender == 'm') {

$email_text = sprintf(EMAIL_GREET_MR, $lastname);

} else {

$email_text = sprintf(EMAIL_GREET_MS, $lastname);

}

} else {

$email_text = sprintf(EMAIL_GREET_NONE, $firstname);

}

 

// Points/Rewards system V2.1rc2a BOF

if ((USE_POINTS_SYSTEM == 'true') && (NEW_SIGNUP_POINT_AMOUNT > 0)) {

tep_add_welcome_points($customer_id);

 

$points_account = '<a href="' . tep_href_link(FILENAME_MY_POINTS, '', 'SSL') . '"><b><u>' . EMAIL_POINTS_ACCOUNT . '</u></b></a>.';

$points_faq = '<a href="' . tep_href_link(FILENAME_MY_POINTS_HELP, '', 'NONSSL') . '"><b><u>' . EMAIL_POINTS_FAQ . '</u></b></a>.';

$text_points = sprintf(EMAIL_WELCOME_POINTS , $points_account, number_format(NEW_SIGNUP_POINT_AMOUNT,POINTS_DECIMAL_PLACES), $currencies->format(tep_calc_shopping_pvalue(NEW_SIGNUP_POINT_AMOUNT)), $points_faq) ."\n\n";

 

$email_text .= EMAIL_WELCOME . EMAIL_TEXT . $text_points . EMAIL_CONTACT . EMAIL_WARNING;

} else {

$email_text .= EMAIL_WELCOME . EMAIL_TEXT .EMAIL_CONTACT . EMAIL_WARNING;

}

// Points/Rewards system V2.1rc2a EOF

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×