Jump to content
deep-silver

### POINTS AND REWARDS MODULE V1.00 ###

Recommended Posts

hey everyone :)

 

my client purchased the creloaded version of the points and rewards system, however..upon trying to create account..you are faced with this...

 

1054 - Unknown column 'customers_shopping_points' in 'field list'

 

UPDATE customers SET customers_shopping_points = customers_shopping_points + '100', customers_points_expires = DATE_ADD(NOW(),INTERVAL '10' MONTH) WHERE customers_id = '1511'

 

TEP_DB_ERRORR

 

any help would be great...

 

thanks muchly

T

Share this post


Link to post
Share on other sites
hey everyone :)

 

my client purchased the creloaded version of the points and rewards system, however..upon trying to create account..you are faced with this...

 

 

 

any help would be great...

 

thanks muchly

T

 

 

hi tec sounds like the ALTER TABLE CUSTOMERS sql statement did not run correctly and create those two columns needed to run the MOD :) Hope that helps.


-------------------------------------------------

Best Regards,

 

ggbig (maestro)

Share this post


Link to post
Share on other sites

w o w Is that THE Deep Silver? Phew - you been away a long time brother! We need you here!!!

 

Welcome back

Share this post


Link to post
Share on other sites

For info:

 

I have uploaded a new instruction file - and I'm working on a uploading a new installation package.

 

I would appreciate some help RE comparison of a WORKING COPIES of the following files

 

includes/functions/redemptions.php

includes/modules/order_total/ot_redemptions.php

checkout_confirmation.php

checkout_payment.php

 

Please get in touch if you can help

Thanks

Sol

Share this post


Link to post
Share on other sites
w o w Is that THE Deep Silver? Phew - you been away a long time brother! We need you here!!!

 

Welcome back

Yup that's me why? i'm always here, was and busy with all other things + my new baby born and my wife drive me crazy and so on....

No one need me here.

most of the PM i get are in refer to the same things, people just don't spend time searching the this forum topic and instead PM me for nothing.

members in this forum topic are great help to everyone so really nobody need me(well... maybe my wife :rolleyes: ).

God Bless the world (and most of the people in it)


Remember - - - "STRESSED" spelled backwards "DESSERTS"

Share this post


Link to post
Share on other sites
Yup that's me why? i'm always here, was and busy with all other things + my new baby born and my wife drive me crazy and so on....

No one need me here.

most of the PM i get are in refer to the same things, people just don't spend time searching the this forum topic and instead PM me for nothing.

members in this forum topic are great help to everyone so really nobody need me(well... maybe my wife :rolleyes: ).

God Bless the world (and most of the people in it)

 

 

First of all, congrats on the new babe, I myself know all about that.... less time for this stuff when the real world calls...

 

Secondly, actually I think you are wrong that nobody needs you.... There are several people with outstanding issues regarding the functionality of this contribution.

 

I myself am currently working on putting together a re-release of this contribution, but to do that, I need some help. There have been so many modifications to your original code that the whole package is a nightmare to navigate and install.

 

Specifically, the fixes by Phocea and Texmaxx (back on pages 55- 60) need to be incorporated into a new release - which is what I am doing.

 

However, I have hit a wall with some of that code and I really need to see someone else's working copies of the following files

 

includes/functions/redemptions.php

includes/modules/order_total/ot_redemptions.php

checkout_confirmation.php

checkout_payment.php

 

These are the ones that have been most heavily modified and currently do not work.

 

So, Deep Silver, if you want to help out a fellow father?

 

It must be a proud moment for you, you gave birth to a great contribution (not just your new babe)

 

Let's make this contribution great again, rather than the VERY messy version it is now (have you seen the amount of add ons to your orginal contribution!)

 

 

 

I have PM'd you too, so feel free to reply through their or here.

 

I await your response.

Cheers

Sol

Edited by ssnb

Share this post


Link to post
Share on other sites
I myself am currently working on putting together a re-release of this contribution, but to do that, I need some help. There have been so many modifications to your original code that the whole package is a nightmare to navigate and install.

ncludes/functions/redemptions.php

includes/modules/order_total/ot_redemptions.php

checkout_confirmation.php

checkout_payment.php

 

These are the ones that have been most heavily modified and currently do not work.

Let's make this contribution great again, rather than the VERY messy version it is now (have you seen the amount of add ons to your orginal contribution!)

Do you really think that i should go over someone else code to fix or clean it?.

when i say im here, thats not include any update to the code by someone else, who ever post something should take full responsabality for it.

do u think that i ever download any update to my code?.

this system is working 100%. not only that but i have made more then 20 custom made points system to store owners via this forum. and ALL of them are happy with what they got.

but this is not why im here to say, the point is that i went over and made a demo store for people to test before installing on their live stores .... and the result......

people abused the demo site so i took it off, then they abused my live store. :wacko:

so now my store staff need to deal with fake order almost every day.

There is a new version V3.00 that give all that asked for on this forum + new php5,Mysql5, register_global and so on....

but im not ready to release it yet. cuse i don't have the time to follow it up as well as can you imagine what will happen to my live store!!!!

If you are happy cleaning up someone else mass, good luck! sorry but i don't see myself doing it.

Edited by deep-silver

Remember - - - "STRESSED" spelled backwards "DESSERTS"

Share this post


Link to post
Share on other sites

BTW the post u reffered to

the idea taken from CCGV but there is a big security issue with that, its clear the payment method and therefore all the checks against it. u do that and i will be able to shop at ur store free :D

Edited by deep-silver

Remember - - - "STRESSED" spelled backwards "DESSERTS"

Share this post


Link to post
Share on other sites

OK, well, you are obviously and rightly upset at such abuse, but quite honestly, is that fair for everyone else?

 

I would have thought you were keen to see your project grow. Your code has been modified to reflect other peoples needs (such as the need to incorporate other discount codes and the need to include a more stable paypal set up) that you didn't include in the original.

 

I would have thought that you would welcome "development" so that your baby can evolve, if it were me, I would be proud to see it move on.... but instead, you seem unhappy about it.

 

Keen to see V3 when you have time.

 

Please see my PM.

Cheers

Sol

Share this post


Link to post
Share on other sites

hey everyone, how are we all doing?

 

i was able to get rid of the table error i was having earlier (client purchased this mod for creloaded)

 

problem is, i cant get the points redeem box to show up on the checkout_payment page

 

any thoughts? has anyone used the purchased version for cre?

Share this post


Link to post
Share on other sites
hey everyone, how are we all doing?

 

i was able to get rid of the table error i was having earlier (client purchased this mod for creloaded)

 

problem is, i cant get the points redeem box to show up on the checkout_payment page

 

any thoughts? has anyone used the purchased version for cre?

Your client purchased this mod for creloaded and you ask us for support????????

you are posting at the wrong forum! you should seek support from whom you paid to.


Remember - - - "STRESSED" spelled backwards "DESSERTS"

Share this post


Link to post
Share on other sites

Hi All

 

I installed V2.0d from the contribution list dated 18 July 2006 and used the instructions from ssnb dated 8 Sept 2008. Problem I have is that when a customer places a order his pending points don't show as pending in admin. I can add the points manually to the account, but then the pending points are still there on the client side.

 

I am not sure which fixes I need to apply from the forum posts. Or maybe a setting I missed ?

 

Anybody have this before ?

Share this post


Link to post
Share on other sites
Hi All

 

I installed V2.0d from the contribution list dated 18 July 2006 and used the instructions from ssnb dated 8 Sept 2008. Problem I have is that when a customer places a order his pending points don't show as pending in admin. I can add the points manually to the account, but then the pending points are still there on the client side.

 

I am not sure which fixes I need to apply from the forum posts. Or maybe a setting I missed ?

 

Anybody have this before ?

 

 

Hi Hotclutch,

 

I hope you found my instructions useful?

 

I had the very same issue until Installed the Paypal IPN module. There are some notes about this in my instructions, however, it was challenging! What payment module are you using? I have only tested P&R with paypal and bank transfer (both now credit the correct points to the customer)

 

I am currently working on resolving a couple of minor issues that I am having and when I have done that, I will re-upload a new package to make life easier for all.... hopefully in the next week or two.

 

Regards

Sol

Share this post


Link to post
Share on other sites

Hi Sol

 

Your instructions were certainly very useful. The instruction is lengthy, but very easy to follow and actually went without a hitch. Thanks for that.

 

My site is not live as yet. I am testing with the COD option of default Oscommerce. I am in South Africa, we don't have PayPal here :D . I will be implementing a credit card gateway solution in the next few days. At the moment I have a problem with my email not being setup (waiting for a domain transfer) so I hope that's the cause of my problem. From reading the posts in the forum most people seem to have a problem with the redemption of points on checkout. Mine works perfectly, at least with COD. I just cannot convert pending points to qualified points at the moment.

Share this post


Link to post
Share on other sites
Hi Sol

 

Your instructions were certainly very useful. The instruction is lengthy, but very easy to follow and actually went without a hitch. Thanks for that.

 

My site is not live as yet. I am testing with the COD option of default Oscommerce. I am in South Africa, we don't have PayPal here :D . I will be implementing a credit card gateway solution in the next few days. At the moment I have a problem with my email not being setup (waiting for a domain transfer) so I hope that's the cause of my problem. From reading the posts in the forum most people seem to have a problem with the redemption of points on checkout. Mine works perfectly, at least with COD. I just cannot convert pending points to qualified points at the moment.

 

 

Thanks for the feedback.

 

What do you mean by "we don't have paypal here" - it's a web based payment system. I guess you mean people in SA aren't keen on it?

 

yes, I am aware of the redemption issue - I suffer from it myself! lol But I am working on it and aiming to pst a new, updated contrib soon as.

Share this post


Link to post
Share on other sites

I need a bit of help... :blush:

 

I've installed V2.0d together w/ Add French Files contrib. and just about everything is working. Except on the checkout_confirmation page. The points deduction is not shown or calculated. I've followed the new install instructions (from ssnb, I must say very easy to follow) including changes for users with discount modules installed. The only thing I haven't done is the Paypal IPN upgrade.

 

Any insight on this would be greatly appreciated!

 

I've read through the posts, and maybe I've missed something but I'm starting to see doubles :blink:

 

Thanks!

David

Share this post


Link to post
Share on other sites
I need a bit of help... :blush:

 

I've installed V2.0d together w/ Add French Files contrib. and just about everything is working. Except on the checkout_confirmation page. The points deduction is not shown or calculated. I've followed the new install instructions (from ssnb, I must say very easy to follow) including changes for users with discount modules installed. The only thing I haven't done is the Paypal IPN upgrade.

 

Any insight on this would be greatly appreciated!

 

I've read through the posts, and maybe I've missed something but I'm starting to see doubles :blink:

 

Thanks!

David

 

 

Hi David

 

I'm sorry to say that this is exactly the problem I am having. I am working on this and will post the resolution as soon as I have it.

 

AS far as I can tell, this is the only glitch that needs to be resolved now before I post the updated package.

 

I am working with a couple of programmers to find the issue - but feel free to post here if you find it before I do!!

 

Cheers

Sol

Share this post


Link to post
Share on other sites

In installing points and reward module V2.00, there is pieceof code which might break (send html email).

 

In the instructions - catalog step # 6:

 

Find this: $email_text .= EMAIL_WELCOME . EMAIL_TEXT . EMAIL_CONTACT . EMAIL_WARNING;

 

 

but when html emails was installed, that piece of code change to this: $Vartextmail = EMAILWELCOME . EMAILTEXT . EMAILCONTACT . EMAILWARNING;

 

Is there a work around to solving this without breaking the send html email mod?

 

Thanks.

 

blr044

Share this post


Link to post
Share on other sites
In installing points and reward module V2.00, there is pieceof code which might break (send html email).

 

In the instructions - catalog step # 6:

 

Find this: $email_text .= EMAIL_WELCOME . EMAIL_TEXT . EMAIL_CONTACT . EMAIL_WARNING;

 

 

but when html emails was installed, that piece of code change to this: $Vartextmail = EMAILWELCOME . EMAILTEXT . EMAILCONTACT . EMAILWARNING;

 

Is there a work around to solving this without breaking the send html email mod?

 

Thanks.

 

blr044

 

Hi...

 

Try Step 6 with this and see. Backup first!

 

CATALOG STEP = 6. open catalog/create_account.php

 

This will add Welcome Points (and send email) defined by admin if enabled.

 

Find this.... (aprox. line no.245)

 

$email_text .= EMAIL_WELCOME . EMAIL_TEXT . EMAIL_CONTACT . EMAIL_WARNING;

 

 

... and REPLACE with.....

 

// Points/Rewards system V2.00 BOF

if (NEW_SIGNUP_POINT_AMOUNT > 0) {

tep_add_welcome_points($customer_id);

 

$points_account .= '<a href="' . tep_href_link(FILENAME_MY_POINTS, '', 'SSL') . '"><b><u>' . EMAIL_POINTS_ACCOUNT . '</u></b></a>.';

$points_faq .= '<a href="' . tep_href_link(FILENAME_MY_POINTS_HELP, '', 'NONSSL') . '"><b><u>' . EMAIL_POINTS_FAQ . '</u></b></a>.';

$text_points = sprintf(EMAIL_WELCOME_POINTS , $points_account, number_format(NEW_SIGNUP_POINT_AMOUNT,POINTS_DECIMAL_PLACES), $currencies->format(tep_calc_shopping_pvalue(NEW_SIGNUP_POINT_AMOUNT)),$points_faq) ."\n\n";

}

 

// $email_text .= EMAIL_WELCOME . EMAIL_TEXT .EMAIL_CONTACT . EMAIL_WARNING;

$Vartextmail .= EMAIL_WELCOME . EMAIL_TEXT . $text_points .EMAIL_CONTACT . EMAIL_WARNING;

 

// Points/Rewards system V2.00 EOF

Share this post


Link to post
Share on other sites

Do the two Phocea fixes mentioned in the instructions and forum actually work? I apply them and system still asks for a payment method even though points cover the order total.

 

If you checkout with enough points to pay for your order, and select COD you still get confirmation success. So this is not a big deal, just want to know if the fixes worked for anybody.

Share this post


Link to post
Share on other sites

Sorry Hotclutch, referring to post #1650, that did not help. Some steps taken. Removed points/reward - send html email then works. Then reversed it. Removed html email and reinstalled points/reward - all is fine. It has to do with the two mod. Will try to express the best I can.

 

Before adding HTML emails - catalog/create_account.php:

// build the message content
     $name = $firstname . ' ' . $lastname;

     if (ACCOUNT_GENDER == 'true') {
        if ($gender == 'm') {
          $email_text = sprintf(EMAIL_GREET_MR, $lastname);
        } else {
          $email_text = sprintf(EMAIL_GREET_MS, $lastname);
        }
     } else {
       $email_text = sprintf(EMAIL_GREET_NONE, $firstname);
     }

     $email_text .= EMAIL_WELCOME . EMAIL_TEXT . EMAIL_CONTACT . EMAIL_WARNING;

 

That piece of code was replaced with this:

// BEGIN SEND HTML MAIL//

$name = $firstname . " " . $lastname;
$Varlogo = ' '.VARLOGO.' ' ;

$Vartable1 = ' '.VARTABLE1.' '  ;
$Vartable2 = ' '.VARTABLE2.' '  ;
$Vartextmail = EMAILWELCOME . EMAILTEXT . EMAILCONTACT . EMAILWARNING;
$Vartrcolor = ' '. TRCOLOR . '  ' ;
$Varmailfooter = '  ' . EMAIL_TEXT_FOOTER . ' <br><br> '  ;

if (ACCOUNT_GENDER == 'true') {
      if ($HTTP_POST_VARS['gender'] == 'm') {
        $Vargendertext = EMAILGREET_MR;
      } else {
        $Vargendertext = EMAILGREET_MS;
      }
   } else {
     $Vargendertext = EMAILGREET_NONE;
   }


require(DIR_WS_MODULES . 'email/html_create_account.php');
$email_text = $html_email_text ;

if (EMAIL_USE_HTML == 'true') {

$email_text;

} 

else

{

if (ACCOUNT_GENDER == 'true') {
      if ($HTTP_POST_VARS['gender'] == 'm') {
        $email_text = EMAILGREET_MR;
      } else {
        $email_text = EMAILGREET_MS;
      }
   } else {
     $email_text = EMAILGREET_NONE;
   }

$email_text .=  EMAILWELCOME . "\n\n" . EMAILTEXT ."\n\n" . EMAILCONTACT . 
               EMAIL_TEXT_FOOTER . "\n\n\n" .
               EMAIL_SEPARATOR . "\n" .
               EMAILWARNING . "\n\n" ;
$email_text .=  HTTP_SERVER . DIR_WS_CATALOG . "\n" . 
               EMAIL_TEXT_FOOTERR . "\n" ; 

 }


//END SEND HTML EMAIL//

 

Now with P/R mod catalog/create_account.php ask to find this:

     $email_text .= EMAIL_WELCOME . EMAIL_TEXT . EMAIL_CONTACT . EMAIL_WARNING;

 

AND REPLACE WITH THIS:

// Points/Rewards system V2.00 BOF
if (NEW_SIGNUP_POINT_AMOUNT > 0) {
tep_add_welcome_points($customer_id);

$points_account .= '<a href="' . tep_href_link(FILENAME_MY_POINTS, '', 'SSL') . '"><b><u>' . EMAIL_POINTS_ACCOUNT . '</u></b></a>.';
$points_faq .= '<a href="' . tep_href_link(FILENAME_MY_POINTS_HELP, '', 'NONSSL') . '"><b><u>' . EMAIL_POINTS_FAQ . '</u></b></a>.';
$text_points = sprintf(EMAIL_WELCOME_POINTS , $points_account, number_format(NEW_SIGNUP_POINT_AMOUNT,POINTS_DECIMAL_PLACES), $currencies->format(tep_calc_shopping_pvalue(NEW_SIGNUP_POINT_AMOUNT)),$points_faq) ."\n\n";
}

// $email_text .= EMAIL_WELCOME . EMAIL_TEXT .EMAIL_CONTACT . EMAIL_WARNING;
$Vartextmail .= EMAIL_WELCOME . EMAIL_TEXT . $text_points .EMAIL_CONTACT . EMAIL_WARNING;
// Points?Rewards system V2.00 EOF

 

So am not sure if I am to post here or to send html email forum!

Share this post


Link to post
Share on other sites

Hi

 

Sorry blr044, I am a bit lost here. I would post in the support thread for the html email contrib because you now have to integrate the Points and Rewards Welcome points into your HTML format.

Share this post


Link to post
Share on other sites

Could possibly be another problem. Uninstalled points/reward. Store gets a html email of order, but customer does not get a email. So need to go to!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×