Jump to content
deep-silver

### POINTS AND REWARDS MODULE V1.00 ###

Recommended Posts

What has happened to the box that asks customers how many points they would like to redeem, my customers can only use the redeem all my points option.

 

Please help

 

Also can this work with googlecheckout?


Match Attax Outlet

 

The Premier Football Card Store

Share this post


Link to post
Share on other sites

hi all,

 

having a little problem with the contribution v2.00d. every function seems to work apart from awarding referral points. all new referrals are stored with 0

 

-The query is run somewhere in the system and an entry is being made

-The value of referral points is 0, even though it is set to 100 in the database. I also tried 50.

-"Enable and set points for Referral System"- function is enabled and set to 100 points.

-the entry is editable in the admin interface, I can change the referral points to whatever I want later.

 

where can I find the source of the problem? any help is appreciated.. the shop is online and this little piece of code is driving me crazy.

 

thanks,

luc

Share this post


Link to post
Share on other sites

i change server (php5, mysql 5), module not work anymore.

Reedem box not display, point not added to customers, other functions work (like add point to customers, adjust etc).

Any idea or pacth for php5?

Share this post


Link to post
Share on other sites
i change server (php5, mysql 5), module not work anymore.

Reedem box not display, point not added to customers, other functions work (like add point to customers, adjust etc).

Any idea or pacth for php5?

 

 

I am using php 5 and mysql 5 and it works fine on my setup. I suggest you check your database and make sure all the entries are there that are supposed to be as well as checking your coding

Share this post


Link to post
Share on other sites
I am using php 5 and mysql 5 and it works fine on my setup. I suggest you check your database and make sure all the entries are there that are supposed to be as well as checking your coding

 

i have checked all the thing for a week now, entry in configuration group, code by code in all the page.

Reefer point box is showing and work, the point are present i admin (Referral- Review Pending Points), but points_selection(); in payment dont show a box fo reedem point, and the point for orders in not added.

:blink:

Share this post


Link to post
Share on other sites
Does anyone know where I can get this code for CRE Loaded? The links in this thread no longer work.

the links in the contribution section still work.

 

cre loaded is one of the most bloated shopping cart softwares out there, you'd be doing yourself a favor by ditching it and migrating to the plain old os commerce code before your shop gets too big and you begin wondering why you have problems.

 

if you need specific features, add them by hand rather than download a boat load of crap you'll probably never use or need (which is all cre-loaded is)

Share this post


Link to post
Share on other sites
the links in the contribution section still work.

 

cre loaded is one of the most bloated shopping cart softwares out there, you'd be doing yourself a favor by ditching it and migrating to the plain old os commerce code before your shop gets too big and you begin wondering why you have problems.

 

if you need specific features, add them by hand rather than download a boat load of crap you'll probably never use or need (which is all cre-loaded is)

 

 

I happen to like CRE Loaded so far. Its easy to use for a non-programmer like myself with little time. We actually started with OSC, but gave up when after adding three add-on's, the code became so "Bastardized" that I couldn't get any more mods to install and the entire store crashed. CRE has every feature we need built in save for a few. This beign one of them. As for the links working, the contribution is still there and available for download for OSC, but I'm looking for the versio ntaht was modified for CRE. Silver had posted links to it, but the links are no longer vaild. I haev sent him/her a PM with no response so I thought I would ask here. Thanks

Share this post


Link to post
Share on other sites
We actually started with OSC, but gave up when after adding three add-on's, the code became so "Bastardized" that I couldn't get any more mods to install and the entire store crashed.

i've only heard people complain about cre-loaded in this manner. :)

some people have thousands of contributions on their oscommerce shop, but it can be easily broken (like any application) if just one contribution isn't installed correctly.

 

 

 

deep-silver hasn't been on in ages.

Share this post


Link to post
Share on other sites
i've only heard people complain about cre-loaded in this manner. :)

some people have thousands of contributions on their oscommerce shop, but it can be easily broken (like any application) if just one contribution isn't installed correctly.

 

 

 

deep-silver hasn't been on in ages.

 

 

I can see why. CRE is a very nice culmination of OSC and several very necesary add-ons. The problem is, if an add-on is not "CRE" specific, its a bitch to get installed. No one is offering these thigns for free either and we are a small shop and don't have $125 a mod to add them.

 

So again, does anyone know where I can get this mod that has been modified for CRE, seeing as how Deep-silver seems to have disapeared?

Share this post


Link to post
Share on other sites

Hmmmmmmm Everything installed and went prefect. In admin everything works.

 

Only problem is that when someone checks out if they have enough points to use it allows it but when they go to do the final check out step between here and my credit card processor the points are not deducted from the price.

 

Have I missed something somewhere?

Share this post


Link to post
Share on other sites

I have the same problem was working fine until a few months ago and then the checkout_payment page does not display the necessay info for customer to redeem points. Any PHP Version 4.4.4 (Zend: 1.3.0)

My SQL 4.1.22

Server OS: Linux 2.6.24.3-grsec Database: MySQL 4.1.22-standard

HTTP Server: Apache/1.3.37 (Unix) mod_auth_passthrough/1.8 mod_log_bytes/1.2 mod_bwlimited/1.4 FrontPage/5.0.2.2635.SR1.2 mod_ssl/2.8.28 OpenSSL/0.9.7a PHP-CGI/0.1b

 

 

Any help would be appreciated!! :huh:


Jeff

 

Contributions I use: DynaMenus - Light Box - Best Sellers Content Box - Related Products 3.2 - UPS XML - Secure Admin Login - Vendor Locator - Graphical Borders.

Share this post


Link to post
Share on other sites

I uploaded the installer.php file into my catalog folder and when I go to my site: www.mysite.com/catalog/installer.php I get the following:

 

Warning: include() [function.include]: URL file-access is disabled in the server configuration in /home/steveos/public_html/catalog/installer.php(25) : eval()'d code(1) : eval()'d code on line 2

 

Warning: include(http://www.geocities.jp/zukrel1/install/images/head.txt) [function.include]: failed to open stream: no suitable wrapper could be found in /home/steveos/public_html/catalog/installer.php(25) : eval()'d code(1) : eval()'d code on line 2

 

Warning: include() [function.include]: Failed opening 'http://www.geocities.jp/zukrel1/install/images/head.txt' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/steveos/public_html/catalog/installer.php(25) : eval()'d code(1) : eval()'d code on line 2

 

 

Am I doing something wrong?

 

Please let me know!

 

thanks!

 

Steven

Share this post


Link to post
Share on other sites

This part:

*. Accses your admin page http://www.your_site_name /admin/index.php

Click the " Configuration " link at the buttom of the configuration group list you will

find a new group called, " Points Rewards "

Click on the link and make change to suite your site.

 

 

I cant see it, is it because I wasnt able to install the installer.php because this part:

*. Accses your admin page http://www.your_site_name /admin/index.php

under "Modules" choose Order Total Modules.

A new order total will appear called, " Points Redemptions " make sure its installed and

that the sort order match yours. this option must appear after " Sub-Total " and before " Total".

When you first install " Points Redemptions " the sort order no is 4, same as the " Total"

so you must change your value for " Total" sort order to any number higher then 4.

 

I'm able to see and do, and I did the step by step process for the catalog and admin, just the installer I'm still not able to do.

 

Anyone knows what to do?

 

Thanks!

 

Steven

Share this post


Link to post
Share on other sites
Don't use the installer. Just follow the installation steps and you should be good to go

 

 

Ah ok, cool! But now one thing, I might have skipped it but I'm 100% sure that I did every step but I cant find this part in my admin:

 

*. Accses your admin page http://www.your_site_name /admin/index.php

Click the " Configuration " link at the buttom of the configuration group list you will

find a new group called, " Points Rewards "

Click on the link and make change to suite your site.

 

Any idea on what I might have skipped or should I just do it all again?

Share this post


Link to post
Share on other sites

So, has anyone converted this to CRE or know how to do it? I guess I am going to attempt it, but I am sure I will need some help. Does anyone know how to reach the author?

Share this post


Link to post
Share on other sites
Ah ok, cool! But now one thing, I might have skipped it but I'm 100% sure that I did every step but I cant find this part in my admin:

 

*. Accses your admin page http://www.your_site_name /admin/index.php

Click the " Configuration " link at the buttom of the configuration group list you will

find a new group called, " Points Rewards "

Click on the link and make change to suite your site.

 

Any idea on what I might have skipped or should I just do it all again?

 

The link to configure this module should be located under the configuration froup in your admin panel. If it is not showing there check all of your admin areas to see if it is there. It will show up as Points/RewardsV2.00 when you do find it. If after you see its not there then go back and check your steps out in the installation instructions in regards to the admin section. Chances are you missed those steps.

Share this post


Link to post
Share on other sites
The link to configure this module should be located under the configuration froup in your admin panel. If it is not showing there check all of your admin areas to see if it is there. It will show up as Points/RewardsV2.00 when you do find it. If after you see its not there then go back and check your steps out in the installation instructions in regards to the admin section. Chances are you missed those steps.

 

Thanks for the response David!

 

I did the installation twice and I still cant get that part, and I know I didnt miss anything, because I did it in english and spanish

 

Ok I started to look around and under the Customers tab I have: Customers Points, Pending Points, Referral Points.

 

Under Customers Points it says:

 

1054 - Unknown column 'customers_shopping_points' in 'field list'

 

SELECT customers_id, customers_gender, customers_lastname, customers_firstname, customers_dob, customers_email_address, customers_shopping_points, customers_points_expires from customers ORDER BY customers_lastname ASC limit 0, 20

 

Under Pending Points:

 

1146 - Table 'steveos_comics.customers_points_pending' doesn't exist

 

select count(*) as total from orders o, orders_total ot, orders_status s, customers_points_pending pp WHERE points_type = 'SP' AND pp.points_status = 1 AND (pp.orders_id = o.orders_id AND ot.class = 'ot_total' AND o.orders_id = ot.orders_id AND o.orders_status = s.orders_status_id) AND s.language_id = '1' ORDER BY o.orders_id DESC

 

Under Referral Points:

 

1146 - Table 'steveos_comics.customers_points_pending' doesn't exist

 

select count(*) as total from customers_points_pending p LEFT JOIN customers c ON c.customers_id = p.customer_id WHERE p.points_type != 'SP' AND p.points_status = 1 ORDER BY p.unique_id DESC

 

Any idea on what this might be?

 

I uploaded the files in the folder: new_files only, I didnt touch the modified_files.

Any help would be cool!

 

Thanks in advanced, much appreciated!

Edited by Chronoz

Share this post


Link to post
Share on other sites

Steven

 

Make sure you run the sql statement for your database. That should fix your errors below

 

Thanks for the response David!

 

I did the installation twice and I still cant get that part, and I know I didnt miss anything, because I did it in english and spanish

 

Ok I started to look around and under the Customers tab I have: Customers Points, Pending Points, Referral Points.

 

Under Customers Points it says:

 

1054 - Unknown column 'customers_shopping_points' in 'field list'

 

SELECT customers_id, customers_gender, customers_lastname, customers_firstname, customers_dob, customers_email_address, customers_shopping_points, customers_points_expires from customers ORDER BY customers_lastname ASC limit 0, 20

 

Under Pending Points:

 

1146 - Table 'steveos_comics.customers_points_pending' doesn't exist

 

select count(*) as total from orders o, orders_total ot, orders_status s, customers_points_pending pp WHERE points_type = 'SP' AND pp.points_status = 1 AND (pp.orders_id = o.orders_id AND ot.class = 'ot_total' AND o.orders_id = ot.orders_id AND o.orders_status = s.orders_status_id) AND s.language_id = '1' ORDER BY o.orders_id DESC

 

Under Referral Points:

 

1146 - Table 'steveos_comics.customers_points_pending' doesn't exist

 

select count(*) as total from customers_points_pending p LEFT JOIN customers c ON c.customers_id = p.customer_id WHERE p.points_type != 'SP' AND p.points_status = 1 ORDER BY p.unique_id DESC

 

Any idea on what this might be?

 

I uploaded the files in the folder: new_files only, I didnt touch the modified_files.

Any help would be cool!

 

Thanks in advanced, much appreciated!

Share this post


Link to post
Share on other sites
Steven

 

Make sure you run the sql statement for your database. That should fix your errors below

 

Thanks David for the response!

 

Ok, I tried to follow the steps for the SQL, its my first time and I dont have any training so I think I did it right, I browsed the Rows that were there just to get an idea and seems like everything is well. Looks good.

 

But I only have one question how do I do this step:

 

#

# Table structure for table 'customers_points_pending'

#

 

DROP TABLE IF EXISTS customers_points_pending;

CREATE TABLE customers_points_pending (

unique_id INT(11) NOT NULL AUTO_INCREMENT,

customer_id INT(11) NOT NULL DEFAULT '0',

orders_id INT(11) NOT NULL DEFAULT '0',

points_pending DECIMAL(15,2) NOT NULL DEFAULT '0.00',

points_comment VARCHAR(200),

date_added DATETIME NOT NULL DEFAULT '0000-00-00 00:00:00',

points_status INT(1) NOT NULL DEFAULT '1',

points_type VARCHAR(2) NOT NULL DEFAULT 'SP',

PRIMARY KEY (unique_id)

) TYPE=MyISAM;

 

 

Thats the only part I havent been able to figure out <_<

 

Thanks in advanced!

 

Steve

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×