Jump to content
deep-silver

### POINTS AND REWARDS MODULE V1.00 ###

Recommended Posts

hi all,

i have the same problem of points being redeemed but no money being cut from the total order..

i tried to change the lines as written above but it doesn't change...

any other idea? all the rest of the contrib is working fine.

 

thanks

ciao

Share this post


Link to post
Share on other sites
hi all,

i have the same problem of points being redeemed but no money being cut from the total order..

i tried to change the lines as written above but it doesn't change...

any other idea? all the rest of the contrib is working fine.

 

thanks

ciao

 

 

nevermind... sometimes it's like i can't read! :blush:

Share this post


Link to post
Share on other sites

Ok. this time is for real!

everything is ok apart for the fact it doesn't send confirmation mails anymore! the order shows on the admin panel but no mail is sent to the customer or shop

and i found out the entire shop doesn't send mails anymore.. could it be related?

 

i found something similar around page 22 of this thread but it relates to those systems having gift & voucher contrib installed.. which i don't have..

 

any help?

thanks

Edited by marcods

Share this post


Link to post
Share on other sites

It's Ok. it was a coincidence, the mail server was down.

 

has anyone used this contrib to give away prizes?

 

i thought about putting some prizes in a new category so that you can "buy" them using your points..

but you would need them to be in a hidden category so that they don't result in your shop as regular products.. is that possible?

 

ciao

Share this post


Link to post
Share on other sites

I have found one bug.

 

When custommer buy one quantity of 1 item the points are put in the customer table

But

I the same customer buy more than 1 of the same item the points are not working.

 

Does somebody have a solution ?

Share this post


Link to post
Share on other sites
I have found one bug.

 

When custommer buy one quantity of 1 item the points are put in the customer table

But

I the same customer buy more than 1 of the same item the points are not working.

 

Does somebody have a solution ?

 

If the error is at the paypal site,

Go to Admin->Payment Modules->PayPal (Credit Card / Debit)

Ensure that you set the options in this module under... "Transaction Type" you MUST select Aggregate else it will not show the correct total at paypal.

Share this post


Link to post
Share on other sites

I have been trying for 3 days to get this redemption when a customer has more point than then the purchase price problem fixed. I have tried all of the previous fixes 3 or 4 times, even starting from the beginning twice.

 

One way I tried takes me to Paypal System (the only pay system I am using) with a zero amount. The other way simply takes me to the Paypal login page with no amount or evidence of any transaction.

 

I do not have CCGV loaded.

 

The previous fixes have come in different post mixed in with code for the CCGV addon, may it would help if I had all the fixes all together, without the CCGV parts.

 

Can anyone help? This addon is exactly what I need in order to accomplish a few of my goals I have for my shopping cart. That's why I am still trying to figure this addon out. :huh:

Share this post


Link to post
Share on other sites
I've got a fix. I've inserted code which hides the payment selection table if the box is checked, unhiding it when you uncheck.

It does this dynamically, only when there's enough points to pay for the whole order and I'm very proud of it!

If anyone wants info on this let me know. Although I won't have chance to do anything until tuesday.

 

I would like to see that code

Share this post


Link to post
Share on other sites
YES YES YES I fixed the problem... the solution was the same as I described above....

For all having trouble with register_globals=off; use this code:

 

in catalog\includes\modules\order_total\ot_redemptions.php search for:

 

// if customer is using points to pay
  if ($customer_shopping_points_spending > 0){

	$order->info['total'] = $order->info['total'] - (tep_calc_shopping_pvalue($customer_shopping_points_spending));

	$this->output[] = array('title' =>''. MODULE_ORDER_TOTAL_REDEMPTIONS_TEXT . ':',
							'text' => '<font color="FF0000">-'.$currencies->format(tep_calc_shopping_pvalue($customer_shopping_points_spending), true, $order->info['currency'], $order->info['currency_value'].'</font>'),
							'value' => tep_calc_shopping_pvalue($customer_shopping_points_spending));

  }

and replace with:

// if customer is using points to pay
  if ($_POST['customer_shopping_points_spending'] > 0){

	$order->info['total'] = $order->info['total'] - (tep_calc_shopping_pvalue($_POST['customer_shopping_points_spending']));

	$this->output[] = array('title' =>''. MODULE_ORDER_TOTAL_REDEMPTIONS_TEXT . ':',
							'text' => '<font color="FF0000">-'.$currencies->format(tep_calc_shopping_pvalue($_POST['customer_shopping_points_spending']), true, $order->info['currency'], $order->info['currency_value'].'</font>'),
							'value' => tep_calc_shopping_pvalue($_POST['customer_shopping_points_spending']));

  }

 

Thanks all for help!

 

hi after doing the above and creating a php.ini file to turb global on, the amount that is shown next to the check box and you click it, then go to the next page, the amount -$x is shown finally!

 

Sub-Total: $12.99

Per Item (Best Way): $3.50

CA TAX 7.75%: $1.01

Points Redeemed: -$15.99

Total: $1.50

 

 

but now there is another problem

 

i checked my account as user and look at the Shopping Points Balance : Shopping Points Balance : 320 points. Valued at : $15.99

 

it still shows the total amount of points even though i just redemmed the points with an order places

 

also, after i go to check my account logged in as user, and check the last order placed which i used redeem points, the info shows

 

Sub-Total: $12.99

Per Item (Best Way): $3.50

CA TAX 7.75%: $1.01

Total: $17.50

 

 

 

the Points Redeemed: -$15.99 is not displaying and is also not being registered in the users account that he redeemed these points , and also the points are not being subtracted in the real order

 

any thoughts?

Share this post


Link to post
Share on other sites
hi after doing the above and creating a php.ini file to turb global on, the amount that is shown next to the check box and you click it, then go to the next page, the amount -$x is shown finally!

 

Sub-Total: $12.99

Per Item (Best Way): $3.50

CA TAX 7.75%: $1.01

Points Redeemed: -$15.99

Total: $1.50

but now there is another problem

 

i checked my account as user and look at the Shopping Points Balance : Shopping Points Balance : 320 points. Valued at : $15.99

 

it still shows the total amount of points even though i just redemmed the points with an order places

 

also, after i go to check my account logged in as user, and check the last order placed which i used redeem points, the info shows

 

Sub-Total: $12.99

Per Item (Best Way): $3.50

CA TAX 7.75%: $1.01

Total: $17.50

the Points Redeemed: -$15.99 is not displaying and is also not being registered in the users account that he redeemed these points , and also the points are not being subtracted in the real order

 

any thoughts?

 

 

i forgot to mentin it works with the paypal but it is not working as described above with Money Order option selected or Bank Wire Transfer option selected

Share this post


Link to post
Share on other sites

Hello,

 

Installing the Awards system for the first time, but on product_info.php page I get an error. I added the below, but I get most a blank page??

 

Thanks JR

 

<?php

 

}

// Points/Rewards system V2.00 BOF

if ((USE_POINTS_SYSTEM == 'true') && (DISPLAY_POINTS_INFO == 'true')) { // check that the points system is enabled

if ($new_price = tep_get_products_special_price($product_info['products_id'])) {

$products_price_points = tep_display_points($new_price, tep_get_tax_rate($product_info['products_tax_class_id'])) . '</span>';

} else {

$products_price_points = tep_display_points($product_info['products_price'], tep_get_tax_rate($product_info['products_tax_class_id']));

}

$products_points = tep_calc_products_price_points($products_price_points);

$products_points_value = tep_calc_price_pvalue($products_points);

if (USE_POINTS_FOR_SPECIALS == 'true' || $new_price == false){

echo '<p>' . sprintf(TEXT_PRODUCT_POINTS , number_format($products_points,POINTS_DECIMAL_PLACES), $currencies->format($products_points_value)) . '</p>';

} else {

echo '<p>' . TEXT_PRODUCT_NO_POINTS . '</p>';

}

}

// Points/Rewards system V2.00 EOF

 

?>

 

<p><?php echo stripslashes($product_info['products_description']); ?></p>

Share this post


Link to post
Share on other sites

Hello,

 

I need to exclude ONE item from getting any points when bought ?

 

I am trying some of the options in the configuration, but it beats me.....somehow the item gets points.

 

Can anyone explain a way ?

 

dca

Share this post


Link to post
Share on other sites
I have been trying for 3 days to get this redemption when a customer has more point than then the purchase price problem fixed. I have tried all of the previous fixes 3 or 4 times, even starting from the beginning twice.

 

One way I tried takes me to Paypal System (the only pay system I am using) with a zero amount. The other way simply takes me to the Paypal login page with no amount or evidence of any transaction.

 

I do not have CCGV loaded.

 

The previous fixes have come in different post mixed in with code for the CCGV addon, may it would help if I had all the fixes all together, without the CCGV parts.

 

Can anyone help? This addon is exactly what I need in order to accomplish a few of my goals I have for my shopping cart. That's why I am still trying to figure this addon out. :huh:

 

I finally figured it out. The way I solved this problem, after redoing the fixes, I found that I had to enable the "Cash On Delivery" payment option on the "Payment Modules". Once I did this the customer, with points enough to download a product with paying, was redirected to the download page without going through a payment processor, and the points were deducted.

Share this post


Link to post
Share on other sites

I apologize if this has been asked before, i could not find this answer here.

 

I installed v2. on a brand new site. I am hoping to just use it just for redemptions (to give customers credit) but not to give them points for purchases. When I deactivated the points system in the config the redeem points did not show up in the payment_confirmation page. I had to activate the enable points system to true to get the redeem box to show up. Is it set up this way or is there a way to just use redemptions?

 

Here are my config settings just in case.

 

screenshot.jpg

 

 

 

Thanks so much,

Nikki

 

Thanks to the contributor!! Kudos!

Share this post


Link to post
Share on other sites

Hi,

 

I am not sure if this is the correct place to post a problem but...

 

When I run auto installer, it comes to a place where it asks you to create new Configuration Group ID number. The link on top when clicked shows me that I have 15 ID's already in existence. So I type 16 in the box and the below is what comes on the next page and installation does not continue.

 

1146 - Table 'kamaluppal.configuration_group' doesn't exist

 

INSERT INTO `configuration_group` (`configuration_group_id`, `configuration_group_title`, `configuration_group_description`, `sort_order`, `visible`) VALUES ('16', 'Points/RewardsV2.00', 'Points/Rewards System Configuration', '16', '1')

 

[TEP STOP]

 

Please help.

 

Thank you very much.

Share this post


Link to post
Share on other sites

Hi all,

 

I have trouble to display language currency in admin parts.

Value of the point will display only in default currency ( in my case in EUR )

 

But the orders are in different currency. Please see admin/customers_points_pending.php

points.jpg

I would need to be available the values of point in in the same way currency as order.

don't you know somebody how to resolve this problem.

Share this post


Link to post
Share on other sites

hi everyone,

 

great contrib, i'm using it on my live shop.

 

i've noticed a problem and i apologize if it has already been addressed, i didn't have the time to sift through all the posts.

 

here it is: if a customer buys a "special" (my setup doesn't credit points for specials) AND a non-special, points are awarded for BOTH.

 

for instance, assuming the following products are in the customer's basket:

 

product 1 price $15 (non-special)

product 2 price $30 discounted by "specials" to $25

 

subtotal = $40 ($15 full price plus $25 discounted price)

points to customer = 40 (at 1 point per 1$ spent)

 

when in fact it should show:

points to customer = 15 (only for the non-discounted product, zero points for the "special")

 

any ideas?

Share this post


Link to post
Share on other sites

Hello,

 

I'm using Points reward 2.0 with succes.

My custumors can get them by creating, reviews, recommandation and ofcourse by buying products.

 

But now comes the problem, if you have enough points de option to pay with the points must be vissible.

And it isn't anymore, i have only add the contri "also consider" and integrated highslide and now i have a problem :'(

Maybe it was there before i did this, i don't know exacly.

 

Is there somebody who has any idea ..... i have no idea where to look anymore.

PHP and english are not my strongest languages :blush:

 

i hope that somebody can help me to the right direction.

 

regards,

Jan


Dreams can come true, if you help them a littlebit

Share this post


Link to post
Share on other sites
Hello,

 

I'm using Points reward 2.0 with succes.

My custumors can get them by creating, reviews, recommandation and ofcourse by buying products.

 

But now comes the problem, if you have enough points de option to pay with the points must be vissible.

And it isn't anymore, i have only add the contri "also consider" and integrated highslide and now i have a problem :'(

Maybe it was there before i did this, i don't know exacly.

 

Is there somebody who has any idea ..... i have no idea where to look anymore.

PHP and english are not my strongest languages :blush:

 

i hope that somebody can help me to the right direction.

 

regards,

Jan

 

I've had a brief look at your site. What else have you added as contributions... A FULL list please otherwise how is someone supposed to know what's going on with regards to helping you? Maybe you've done something to the checkout by adding another contribtuion?


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

I just installed this on my site today, however I cannot see the Points Redemption order under the Modules>Orders section in my admin page. I went over all the steps to make sure I did not miss any, but still having the same problem...

 

*** never mind, I figured it out!

Edited by thecandlespastore

Always grateful for any help received!!

Share this post


Link to post
Share on other sites

I am having the following problems. In my product_info.php under catalog it says to find the line

?>

<p><?php echo stripslashes($product_info['products_description']); ?></p>

 

and add some script over it. However when I look in my product_info.php I see this instead of the above:

 

<td><?php echo stripslashes($product_info['products_description']);

 

Which means that I have no idea where to add the script that I need to add since that line is not in my file. And on my site when I click on a product all I see is this:

 

 

1054 - Unknown column 'p.products_id' in 'on clause'

 

select count(p.products_id) as total from products_description pd, products p left join manufacturers m on p.manufacturers_id = m.manufacturers_id, products_to_categories p2c left join specials s on p.products_id = s.products_id where p.products_status = '1' and p.products_id = p2c.products_id and pd.products_id = p2c.products_id and pd.language_id = '1' and p2c.categories_id = '47'

 

I don't know what to do, really trying to get this going for the Black Friday sale in a few days and I can't seem to complete it. Any help would be greatly appreciated.


Always grateful for any help received!!

Share this post


Link to post
Share on other sites

I figured out that I had an outdated file so I upgraded that file. But after making the modifications needed I am still getting the same error on my website when I click on a category:

 

1054 - Unknown column 'p.products_id' in 'on clause'

 

select count(p.products_id) as total from products_description pd, products p left join manufacturers m on p.manufacturers_id = m.manufacturers_id, products_to_categories p2c left join specials s on p.products_id = s.products_id where p.products_status = '1' and p.products_id = p2c.products_id and pd.products_id = p2c.products_id and pd.language_id = '1' and p2c.categories_id = '47'

 

and I get this when I click on a product

 

Fatal error: Cannot redeclare tep_show_category() (previously declared in /home/zajanat/public_html/includes/header.php:172) in /home/zajanat/public_html/includes/boxes/categories.php on line 59


Always grateful for any help received!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×