Jump to content
deep-silver

### POINTS AND REWARDS MODULE V1.00 ###

Recommended Posts

Hi guys!

i have just installed the v20c version of this great contribution but experiment the following error message if i try to insert a new product in a categorie:

 

Warning: implode() [function.implode]: Bad arguments. in /web/htdocs/www.artemodels.com/home/catalog/admin/includes/application_top.php on line 175

 

but the admin/includes/application_top.php as not been modified! I have uploaded the same file from the back-up but this don't fix the problem...

 

Any help well be apreciated very much!!!

 

Thanks in advance.

 

Enzo

 

P.S. Sorry for duplicate this post in General Contribution Support.

Share this post


Link to post
Share on other sites

Dear Sir,

 

Please help, I want to cut off the decimal physically.

ex:

 

100 dollars = 1 point

 

if spent 150 dollars = 1 point (Not 1.5 point).

Consumers will get 1 point only.

 

Thank you for help.

Share this post


Link to post
Share on other sites

Version is 1.60.

 

Dear Sir,

 

Please help, I want to cut off the decimal physically.

ex:

 

100 dollars = 1 point

 

if spent 150 dollars = 1 point (Not 1.5 point).

Consumers will get 1 point only.

 

Thank you for help.

Share this post


Link to post
Share on other sites

I just installed 2.0d. The install went perfect and i show no errors, but in the product info page it always shows points credit: 0 points currently valued at $0.00 I have the default configuration set from the sql file so no idea.

Share this post


Link to post
Share on other sites

I just installed 2.0d. The install went perfect and i show no errors, but in the product info page it always shows points credit: 0 points currently valued at $0.00 I have the default configuration set from the sql file so no idea.

Share this post


Link to post
Share on other sites

php4/mysql4 & php5/mysql5 (have 2 server)

same problem

I have a problem with this fantastic module,

the total does not appear me points used in the directory orders.

 

new order ,

 

checkout_confirmation.php // all OK

 

Payment Sub-Total: $38.99 // sub total OK

Free Shipping: $0.00 // shipping

VAT 20.0%: $7.80 // VAT

Point redeem: -$13.00 // poit OK !

Discount Coupons:6bfdc2: -$6.50 // coupons gift

Total: $27.28 // total OK !

 

 

my account / my_points.php // all OK

23/04/2007 - #2 In sospeso - Punti riscossi - Riscossi ( -1,000 ) // point redeem OK

23/04/2007 - #2 In sospeso - Punti shopping - Pendenti ( 25 ) // news point OK

 

 

 

account_history_info.php // dont work !

 

Payment Sub-Total: $38.99 // payment sub total OK !

Free Shipping: $0.00 // shipping OK !

VAT 20.0%: $7.80 // VAT OK !

Discount Coupons:6bfdc2: -$6.50 // coupons gift OK !

Total: $40.28 // dont work - - - - - - - - - - - - - - - - missed point redeem !

 

Point redeem: -$13.00 ?????????????????

Total: $27.28 ????????????????????

 

 

in the DB table orders_total :

INSERT INTO orders_total (orders_total_id, orders_id, title, text, value, class, sort_order)

VALUES (6, 2, 'VAT 20.0%:', '$7.80', 5.9980, 'ot_tax', 3),

(5, 2, 'Free Shipping:', '$0.00', 0.0000, 'ot_shipping', 2),

(4, 2, 'Sub-Total:', '$38.99', 29.9900, 'ot_subtotal', 1),

(7, 2, 'Discount Coupons:6bfdc2:', '-$6.50', 5.0000, 'ot_coupon', 9),

(8, 2, 'Total:', '$40.28', 30.9880, 'ot_total', 10);

 

dont write the point

 

 

help my, sorry for my english

Share this post


Link to post
Share on other sites
account_history_info.php // dont work !

 

Payment Sub-Total: $38.99 // payment sub total OK !

Free Shipping: $0.00 // shipping OK !

VAT 20.0%: $7.80 // VAT OK !

Discount Coupons:6bfdc2: -$6.50 // coupons gift OK !

Total: $40.28 // dont work - - - - - - - - - - - - - - - - missed point redeem !

 

solved, the patch Register_Globals=off; fix to show points on checkout_confirmation.php - MaNoLiA - 21 Feb 2007

is bad, removed the poin system work

Share this post


Link to post
Share on other sites

can any one tell me if this would work with streamline/protx or would it involve to many problems?

Edited by salt

Share this post


Link to post
Share on other sites

Today I installed this great contribution (2.0d) and it's working fine (till now).

 

The only problem is:

 

I do not charge for sendcostes above 50 euro's.

When someone orders for 52 euro and has a pointsvalue of 5 euro and uses this

the totalorder is 47 euro and 0 euro sendcosts

but this is not what I want. I think it should be 45 euro for the goods and .... euro's for the sendcosts.

 

 

now:

 

total amount 52 euro

points 5 euro -

sendcosts 0 euro

total amount 47 euro

 

should be

 

total amount 52 euro

points 5 euro -

total 47 euro

sendcosts 2,50 euro

total amount 49,50

 

 

Values in admin/modules:

subtotal 1

points reedemption 5

sending costs 6

amount 7

 

 

How can I make this work?

 

Sorry for my bad english!

Share this post


Link to post
Share on other sites

Hi All,

 

I have installed this contribution.

My problem is, when I choose the options to use my points to pay for a product, and then get taken over to checkout_confirmation.php the normal price of the product still shows, as if the points are not being used.

 

Ive tried all things, and my register_globals is ON.

 

What can I do to fix this?

 

Thanks,

 

Matt Evans

New Zealand.

Share this post


Link to post
Share on other sites

Hi

 

No one who can help me with my sendcost problem? (see above)

 

 

And why is on the my_points.php no total amount of points?

The customer gets a overview with points but no total. Is there something wrong with it or not?

 

Regards,

 

Lieke

Share this post


Link to post
Share on other sites

Hello All,

 

I think his Mod if a very interesting and useful one for me.

 

I have tried reading some pages in the discussions and am not sure about certain things.

 

The main thing I would like to know is where should I start ? Which is the last FULL package available that is stable and from there then I can go ahead and make some changes as per the discussions ?

 

Anyone let me know which version I should start with ?

 

thanks in advance

 

dca

Share this post


Link to post
Share on other sites

Hello,

 

I read all this post, but my english is not good :( and I hav'nt the solution ...

 

My problem in checkout_confirmation.php :

 

Sous-Total: 60,50€

TNT Express : 8,18€

Points Redeemed: -68,68€

Total: -7,09€

 

The $order->info['total'] is good (0€) before

  if (MODULE_ORDER_TOTAL_INSTALLED) {
$order_total_modules->process();
//echo $order_total_modules->process();
echo $order_total_modules->output();
 }

 

After this, $order->info['total'] is not good (-7,09 €)

 

The $order->info['total'] used by my payment module Visa/MasterCard (ogone) is good.

 

For the same order, if I choose "no delivery at 0€" I have :

Sous-Total: 60,50€

Pick-Up : 0,00€

Points Redeemed: -60,50€

Total: 3,55€

 

I have make the test on an new install, I have the same problem ...

 

Do you have a solution ?

 

Best Regards and thank you very much for the information in this forum :-)

 

Gaëtan

Share this post


Link to post
Share on other sites

Hello,

 

Where in admin does the shop/site owner Confirm/Activate the points that the client has gained in a purchase ?

 

dca

Share this post


Link to post
Share on other sites

Hello dca :

 

In Order line :

-Customer Points Pending

-Orders detail (in bottom)

 

Or automatic validation in the configuration of Points&Rewards

Share this post


Link to post
Share on other sites
Hello dca :

 

In Order line :

-Customer Points Pending

-Orders detail (in bottom)

 

Or automatic validation in the configuration of Points&Rewards

 

 

Thanks.

 

That is where I was looking but strange thing is there is nothing. I have checked the orders.php and I have added the lines as in Step1 of Admin section and still, no sign of this.

 

dca

Share this post


Link to post
Share on other sites

is it possible to set system to give 1 point for 1 purchased product .. independent from amount ..?

 

thanx

Share this post


Link to post
Share on other sites
is it possible to set system to give 1 point for 1 purchased product .. independent from amount ..?

 

thanx

 

nativement, I don't think (I did not see the possibility in any case…), on the other hand, via a deep modification of the code, there must be average to calculate the handing-over of the points on the quantity in the place of the amount…

Share this post


Link to post
Share on other sites
Hello dca :

 

In Order line :

-Customer Points Pending

-Orders detail (in bottom)

 

Or automatic validation in the configuration of Points&Rewards

 

 

Hello.

 

Just found out why I was not getting the Admin section in Clients working and not actually showing up on the screen.

 

I thought the problem was with version 2.0, so I removed and did an install of 1.6.....but obviously the same problem.

 

The reason was that I also have the SPPC (Special Price per Customer) contribution in my site and there is a need in Step 4 of Admin section to repeat the text that is added in 2 sections......dont ask me why as I am not a programmer, but it made sense and it worked.

 

so now my customers.pho looks like this :

 

$contents[] = array('text' => '<a href="' . tep_href_link(FILENAME_CUSTOMERS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CUSTOMERS_CUSTOMERS . '</a><br>' .

'<a href="' . tep_href_link(FILENAME_CUSTOMERS_POINTS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CUSTOMERS_POINTS . '</a><br />' .// Points/Rewards Module V2.00

'<a href="' . tep_href_link(FILENAME_CUSTOMERS_POINTS_PENDING, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CUSTOMERS_POINTS_PENDING . '</a><br />' .// Points/Rewards Module V2.00

'<a href="' . tep_href_link(FILENAME_CUSTOMERS_POINTS_REFERRAL, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CUSTOMERS_POINTS_REFERRAL . '</a><br />' .// Points/Rewards Module V2.00

'<a href="' . tep_href_link(FILENAME_ORDERS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CUSTOMERS_ORDERS . '</a>');

} */

// BOF Separate Pricing Per Customer

if ($selected_box == 'customers') {

$contents[] = array('text' => '<a href="' . tep_href_link(FILENAME_CUSTOMERS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CUSTOMERS_CUSTOMERS . '</a><br>' .

'<a href="' . tep_href_link(FILENAME_CUSTOMERS_POINTS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CUSTOMERS_POINTS . '</a><br />' .// Points/Rewards Module V2.00

'<a href="' . tep_href_link(FILENAME_CUSTOMERS_POINTS_PENDING, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CUSTOMERS_POINTS_PENDING . '</a><br />' .// Points/Rewards Module V2.00

'<a href="' . tep_href_link(FILENAME_CUSTOMERS_POINTS_REFERRAL, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CUSTOMERS_POINTS_REFERRAL . '</a><br />' .// Points/Rewards Module V2.00

'<a href="' . tep_href_link(FILENAME_ORDERS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CUSTOMERS_ORDERS . '</a><br>' .

'<a href="' . tep_href_link('customers_groups.php', '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CUSTOMERS_GROUPS . '</a>');

}

 

 

as u can see I have added the 3 lines to the SPPC section too.

 

Now everything shows up and I can control the points through Admin

 

Hope this helps anyone who also has SPPC installed.

 

dca

Share this post


Link to post
Share on other sites

Hello All,

 

Seems that I have another problem. I have tried making trial orders in the site where I have the points mod installed, but everytime I am on checkout payment it shows me this :

 

pointsks8.jpg

 

Is it not supposed to also ask me how many points I want to deduct ? Say I only want to use 50 poins on this order ?

 

Anything I have not setup properly ?

 

If anyone has any idea, pls let me know. Seems I have finally managed to put this fabulous contribution without any major problems whatsoever, in fact following all the instructions was easy and no errors were made at all. Quite nice. So I would really appreciate help so that I can use this contribution LIVE on the site soon.

 

Thanks in advance.

 

dca

Share this post


Link to post
Share on other sites
Hello All,

 

Seems that I have another problem. I have tried making trial orders in the site where I have the points mod installed, but everytime I am on checkout payment it shows me this :

 

pointsks8.jpg

 

Is it not supposed to also ask me how many points I want to deduct ? Say I only want to use 50 poins on this order ?

 

Anything I have not setup properly ?

 

If anyone has any idea, pls let me know. Seems I have finally managed to put this fabulous contribution without any major problems whatsoever, in fact following all the instructions was easy and no errors were made at all. Quite nice. So I would really appreciate help so that I can use this contribution LIVE on the site soon.

 

Thanks in advance.

 

dca

 

Well,

 

It seems that my problem outlined earlier is not a problem as such. it seems that this version 2.0d I have installed only works this way.....Seems that the earlier version 1.6 , it was possible for the client to input manually how many points he wanted to redeem, if any. In version 2.0d it seems this is not the case.

 

I have spent time reading the posts, and it seems that this is the conclusion I reach.

 

Can anyone confirm if this is the case or not ?

 

 

Now I have another question for which I would be grateful if someone would respond with some input for this :

 

In the tests I did if a client buys € 25.00 of goods and has shipping of € 3.50 - version 2.0d calculates the number of max points he can use to redeem. If the client has sufficient points he gets the shipment for € 0.00.

It includes the shipping costs also in it+s calculation.

What I would like to see is that the client is only able to redeem points for the value of the goods ordered - shipping costs I dont want client to use the points for this.

 

Any ideas ?

 

So Ideally if client orders € 25.00 of goods, then he should only be able to use points for the value f the goods - not for the shipping costs.

 

If there is already a solution for this ir similar discussed in this thread, then I must have missed it and would be grateful if someone could point out the post to me.

 

Would be grateful for any help or hint anyone can give.

 

dca

Share this post


Link to post
Share on other sites

I have installed 2.0d. The install went perfect and i show no errors, but in the product info page it always shows points credit: 0 points currently valued at $0.00 I have the default configuration set from the sql file so no idea. :blink:

Share this post


Link to post
Share on other sites

I am trying to develop a site that only allows for the use of points rewarded to salesmen for making sales. I do not want to use any other payment forms. I have installed this contribution and it is GREAT, but I have one issue.

 

If I have 500 point and want to buy 2 products that cost 300 points each the system gives me a warning on the payment page that I do not have enough points, and if I hit continue the a warning appears at the top of the age telling me I do not have enough points, but if I hit continue anyway it allows me to complete the order.

 

my demo site is Promo site if you create an account it will award you 300 points and allow you to make purchases. The site is not live so any suggestions would be appreciated.


Jeff

 

Contributions I use: DynaMenus - Light Box - Best Sellers Content Box - Related Products 3.2 - UPS XML - Secure Admin Login - Vendor Locator - Graphical Borders.

Share this post


Link to post
Share on other sites

A follow-up to the above, perhaps there is a way to automatically apply the maximum points to any purchase and if the "cost" is higher than points, not allow the customer to continue.


Jeff

 

Contributions I use: DynaMenus - Light Box - Best Sellers Content Box - Related Products 3.2 - UPS XML - Secure Admin Login - Vendor Locator - Graphical Borders.

Share this post


Link to post
Share on other sites

ok if any one installs this contrib and gets an error 404 file not found for my_points.php or my_points_help.php uncomment them in filenames.php.

 

its just taken me 2 hrs to figure that out lol.

 

 

absolutly brillient contrib mind u

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×