Jump to content
deep-silver

### POINTS AND REWARDS MODULE V1.00 ###

Recommended Posts

i already try that but doesn´t work... you can try the cart at www.reikistore.com.ar/catalog

Why have you got the referal twice in your site? Once for create account and once for checkout??

 

I can see the redemptions problem but I dont know the answer.. Phocea said it was posted sometime back.. you'll have to find it.

Edited by chooch

Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

i am wondering if any of you know to make the add points box on customers_points.php work in reverse.

 

such as:

say my point value is 5%

 

 

instead of entering "100" to give the customer $5.00

 

i could enter "5.00" and give them 100 points

Share this post


Link to post
Share on other sites

this might sound a little noob. May i know where to change the layout of the text shown at checkout_payment.php. I tried to find it in catalog/checkout_payment.php but none of what i edited is what i wanted. is there another file or that is the only file to change?

Share this post


Link to post
Share on other sites
I can solve it, but not too elegant :)

 

Checkout_confirmation.php ~Line 77:

 

change

 

if ($customer_shopping_points_spending > (POINTS_MAX_VALUE) {

 

to

if ($customer_shopping_points_spending > (POINTS_MAX_VALUE * $order->info['subtotal'])) {

 

, and set up the Points_Max_Value = 0.5

 

but it is only solve only the SUBTOTAL

 

¿IS THERE ANY WAY TO DO THE SAME ON TE 2.D POINTS MODULES?

 

THANK YOU

Share this post


Link to post
Share on other sites
¿IS THERE ANY WAY TO DO THE SAME ON TE 2.D POINTS MODULES?

 

THANK YOU

have you tried testing it yourself? kindly try it and post your results for all of us to see as there may be people who use it because of your advice.


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
there was a fix posted in the thread some time back. it had parallels with another contribution and a fix was posted (i'm sure)

Hi Chooch,

 

I've been searching all over this forum but cannot locate the sollution.

I will keep on searching but was also hoping you could point me in the right direction?

 

I appreciate your help on this!

 

Best regards

 

Small Craft

Share this post


Link to post
Share on other sites
Hi Chooch,

 

I've been searching all over this forum but cannot locate the sollution.

I will keep on searching but was also hoping you could point me in the right direction?

 

I appreciate your help on this!

 

Best regards

 

Small Craft

 

Ok, I've been searching all afternoon and still cannot find a solution for my problem :(

 

I will describe it a bit more detailed below:

 

I have installed "Points and Rewards v20d"

I believe it is in conflict with the shipping module "MultiGeozone MultiShipping" and/or with may Paypal module.

 

The problem is as described here:

 

I put an item in the cart that costs € 4,99

Then I choose a shipping option in checkout_shipping that costs € 3,39

 

The total value of the order is estimated to € 7,79 while it should have been € 8.38 (ref below picture):

payment_information.jpg

 

This has as result that - if the customer has more than enough points available to cover the amount of his/her order, there will still be a small amount to pay left over (as per below image)

 

order_confirmation.jpg

 

Is their any-one here on this forum who can point me in the right direction? :'(

 

Many thanks

Share this post


Link to post
Share on other sites
have you tried testing it yourself? kindly try it and post your results for all of us to see as there may be people who use it because of your advice.

 

IN THE 2D VERSION, I DON´T HAVE THE "if ($customer_shopping_points_spending > (POINTS_MAX_VALUE) {" IN CHECKOUT_CONFIRMATION.PHP FILE.

 

IS THERE ANY WAY TO DO THE 50% IN THE NEW VERSION?

 

THANK YOU.

Share this post


Link to post
Share on other sites
IS THERE ANY WAY TO DO THE 50% IN THE NEW VERSION?
It isn't as easy as that, you will need to change more than just one file for the front end (and maybe some for the admin end) but I can't even remember what the older version of the points reward looked like - you will have to download the older version and compare files, sorry I can't tell you what to do because I don't have time to search the parts that you need editing, I am working on my own sites. Edited by chooch

Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
Ok, I've been searching all afternoon and still cannot find a solution for my problem :(

 

I will describe it a bit more detailed below:

 

I have installed "Points and Rewards v20d"

I believe it is in conflict with the shipping module "MultiGeozone MultiTable" and/or with may Paypal module.

 

The problem is as described here:

 

I put an item in the cart that costs € 4,99

Then I choose a shipping option in checkout_shipping that costs € 3,39

 

The total value of the order is estimated to € 7,79 while it should have been € 8.38 (ref below picture):

payment_information.jpg

 

This has as result that - if the customer has more than enough points available to cover the amount of his/her order, there will still be a small amount to pay left over (as per below image)

 

order_confirmation.jpg

 

Is their any-one here on this forum who can point me in the right direction? :'(

 

Many thanks

 

Is there any-one in this forum who has the same problem as me?

Can any-one advise me where the PAR mod collects its "estimated total value" from and on what .php page it is calculated?

In my modest opinion that's where it all goes wrong (in my case).

Is there a chance to use the code that is used in checkout_confirmation.php for the total value of the order to solve this problem?

 

Any help is greatly appreciated.

I have this contri up and running and need to fix this major flaw. :'(

 

Thanks!

Share this post


Link to post
Share on other sites

OK so I now officially have no hair left, I pulled it out.

 

Anyway. I have a pizza parlor I set up Rock & Roll Pizza I have set up points and it seems to work very well. I really like this contrib.

 

I am having one issue however - I have created a "tip" product that allows those the use CC to pay (comming soon) they can add a tip to the charge. I could not find a contribution that allows for a manual entry for the payment, so I made it a product. however I do not want customers to be able to earn points for giving a tip or use points to pay for a tip. If I put the product number (398) into the list for "Enable Product ID Description" I no longer see the option to pay with points. It does not matter if I select the product or not.

 

Can anyone help.


Jeff

 

Contributions I use: DynaMenus - Light Box - Best Sellers Content Box - Related Products 3.2 - UPS XML - Secure Admin Login - Vendor Locator - Graphical Borders.

Share this post


Link to post
Share on other sites
Is there any-one in this forum who has the same problem as me?

Can any-one advise me where the PAR mod collects its "estimated total value" from and on what .php page it is calculated?

In my modest opinion that's where it all goes wrong (in my case).

Is there a chance to use the code that is used in checkout_confirmation.php for the total value of the order to solve this problem?

 

Any help is greatly appreciated.

I have this contri up and running and need to fix this major flaw. :'(

 

Thanks!

 

I did not see your pict. you referenced in your post. Perhaps you can set a test account that we can use to debug. I am not an expert but have anaged to solve alot of my own problems with the contrib.


Jeff

 

Contributions I use: DynaMenus - Light Box - Best Sellers Content Box - Related Products 3.2 - UPS XML - Secure Admin Login - Vendor Locator - Graphical Borders.

Share this post


Link to post
Share on other sites
I did not see your pict. you referenced in your post. Perhaps you can set a test account that we can use to debug. I am not an expert but have anaged to solve alot of my own problems with the contrib.

payment_information.JPG

 

Hi,

 

For one reason or the other I cannot put an image on this forum (maybe some-one can tell me what I should do - maybe special format?? <_<

 

Anyway, if you would like to create a test account, feel free to do so.

 

what is realy strange: I have a local server running basicly the same site, and on there I do not seem to have the problem of miscalculating the estimate value of the order? :wacko:

 

I am out of options :(

Share this post


Link to post
Share on other sites

Hi all,

I have two problems:

 

1.

I have a problem with paypal IPN to function properly with this contrib.

 

During the checkout process when I tick the box to use the points but I don’t complete the order the points are redeemed anyway.

 

2.

Another problem is that the used up points for an order that is later deleted are not added back to my points. That means that I loose points even when I don’t purchase anything. Another words, used up points for an order that is deleted are lost, they are not added back to my points.

 

Anybody who could help me with this please?

 

Any help is greatly appreciated.

 

Thanks

Share this post


Link to post
Share on other sites
Solution on B,C,D is on this thread, read the posts...

For A, its not working like this at the moment, you will have to develop it yourself

 

PLEASE, HELP ME WITH THIS:

 

I HAVE THE "INSURANCE SHIPPING" MODULE (AT ORDER TOTAL), AND PAYMENT TYPE FEE (AT ORDER TOTAL TOO).

 

THE THING IS THAT WHEN YOU WANT TO USE YOUR POINTS, THE INSURANCE AND THE PAYMENT FEE, ARE OUT OF REDEMTIONS, LIKE THIS:

 

 

POINTS 1000 VALUE

Share this post


Link to post
Share on other sites
Solution on B,C,D is on this thread, read the posts...

For A, its not working like this at the moment, you will have to develop it yourself

 

PLEASE, HELP ME WITH THIS:

 

I HAVE THE "INSURANCE SHIPPING" MODULE (AT ORDER TOTAL), AND PAYMENT TYPE FEE (AT ORDER TOTAL TOO). IM USING POINTS AND REWARD 2.0D

 

THE THING IS THAT WHEN YOU WANT TO USE YOUR POINTS, THE INSURANCE AND THE PAYMENT FEE, ARE OUT OF REDEMTIONS, LIKE THIS:

 

 

(IF YOU HAVE 1000 POINTS, VALUE AT $100)

 

 

PRODUCTS $ 30

SHIPPING $ 12

PAYMENT FEE $ 5

INSURANCE $10

--------------------------

TOTAL $ 57

 

MAX REDEMTION $ 42

 

TO PAY $ 15

 

IS THER ANY WAY TO USE THE POINTS FOR INSURANCE AND PAYMENT TYPE FEE ALSO?

 

THANK YOU VERY MUCH.

Share this post


Link to post
Share on other sites

So there is really no one to help me with this problem please? Is there at least anyone who successfully integrated POINTS AND REWARDS MODULE V1.00 with Paypal IPN ?

 

Hi all,

I have two problems:

 

1.

I have a problem with paypal IPN to function properly with this contrib.

 

During the checkout process when I tick the box to use the points but I don’t complete the order the points are redeemed anyway.

 

2.

Another problem is that the used up points for an order that is later deleted are not added back to my points. That means that I loose points even when I don’t purchase anything. Another words, used up points for an order that is deleted are lost, they are not added back to my points.

 

Anybody who could help me with this please?

 

Any help is greatly appreciated.

 

Thanks

Share this post


Link to post
Share on other sites
So there is really no one to help me with this problem please?

there are people around to help you, but you don't bother getting back on the forum to tell us how it went.... it was me that told you where to find the points code when using ccgv and once you got that info there was no feedback from you stating whether it worked or not - furthermore, it cant be easy to answer your immediate question as no-one knows what contributions you have added.

Edited by chooch

Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
there are people around to help you, but you don't bother getting back on the forum to tell us how it went.... it was me that told you where to find the points code when using ccgv and once you got that info there was no feedback from you stating whether it worked or not - furthermore, it cant be easy to answer your immediate question as no-one knows what contributions you have added.

Hi Aleem,

Thanks for replay.

I didn’t know that this question

http://forums.oscommerce.com/index.php?sho...139&st=1404 was answered at all. I thought till now that nobody bothered to answer it. So I asked Rhea directly where it is but he didn’t know. So I gave up on it.

 

But now that you said you answer it, I went back to check again all the replays after my post to see if I missed it somehow.

So I just realized that you really answer it. http://forums.oscommerce.com/index.php?sho...139&st=1410 But the answer is included in a post to somebody else and probably the answer was added when that post was edited. So you must admit that it could be easy to miss. Anyway sorry for that and thank you for replay.I normally try to answer all replays.

 

I was searching for that code in txt file. I found a code under this text: “To users with Credit Class & Gift Voucher contribution try using this line” and also Paypal IPN Modifications So probably this is what you meant.

 

I will look at it at certainly will replay.

 

I have installed SPPC, CCGV(trad), POINTS AND REWARDS MODULE, Paypal IPN, Recover Cart Sales, Purchase Limitter, E-mail validation, Quantity Price Breaks for Separate Pricing Per Customer, Show Price list for SPPC 4.1 v1.0, Buy/Add button removal if quantity = 0(for SPPC w/ Column Product Listing), Hide products from customer groups for SPPC, Must Agree to Terms, and some small contribs.

 

Thanks

Share this post


Link to post
Share on other sites
I was searching for that code in txt file. I found a code under this text: “To users with Credit Class & Gift Voucher contribution try using this line” and also Paypal IPN Modifications So probably this is what you meant.

Yup, thats in the Points Reward install .txt file.. that is the code you need to make it work with CCGV(trad)

 

 

I have installed SPPC, CCGV(trad), POINTS AND REWARDS MODULE, Paypal IPN, Recover Cart Sales, Purchase Limitter, E-mail validation, Quantity Price Breaks for Separate Pricing Per Customer, Show Price list for SPPC 4.1 v1.0, Buy/Add button removal if quantity = 0(for SPPC w/ Column Product Listing), Hide products from customer groups for SPPC, Must Agree to Terms, and some small contribs.

First things first, i will test out my own site and see if i get the same problem... but with the exception of around 3, all of the above are related to checkout, prices and discounts... if it isn't an inherent points/reward problem it will be a mammoth task finding out exactly how to make it work on your site.


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

i see what you mean now. it is the same kind on debug problem that windfjf fixed for the orders page in v1.4 of IPN - that only happens because it needs to carry the points discount to paypal and must deduct it from your balance but for some reason doesn't re-credit it back to the account... very annoying!


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

Hi Aleem,

 

Tanks a lot for the replays. So far it is not working. I am really confused. As you said this looks like a mammoth task, something that I can’t handle unfortunately. I will have someone to look at it. I just want you to ask: do you have installed POINTS AND REWARDS MODULE, Paypal IPN and CCGV(trad) on your site? And is it all working properly for you?

 

Thank you very much for your time. I do appreciate it.

Share this post


Link to post
Share on other sites
I just want you to ask: do you have installed POINTS AND REWARDS MODULE, Paypal IPN and CCGV(trad) on your site? And is it all working properly for you?

It works perfectly well - both can be combined with a bit of patience.

 

I have no problems with the combining of the two what i have now noticed after playing around with the points contribution in the admin (and on more than one site to make sure) are more bugs with the 2.0d version that are really annoying. I also have product and category restrictions not working properly - when i restrict even one product or category, the redemptions box vanishes in checkout payment.

Edited by chooch

Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

Hi,

I install the POINTS AND REWARDS MODULE V2.0d to my

CRE Loaded Project 6.2

when I finish installed the POINTS AND REWARDS MODULE V2.0d ,all my products's price show 0

can not show the correct price any more,

 

Does any one can help me

 

thanks very much

Share this post


Link to post
Share on other sites

I too cannot make the restrictons works. I have 1 item to exclued and it does not work. Anyone have ideas?


Jeff

 

Contributions I use: DynaMenus - Light Box - Best Sellers Content Box - Related Products 3.2 - UPS XML - Secure Admin Login - Vendor Locator - Graphical Borders.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×