Jump to content
deep-silver

### POINTS AND REWARDS MODULE V1.00 ###

Recommended Posts

Hallo.

Does anybody set this contrib to Basic Template System? I tried to do it and almost everything worked but with some mysql mistakes. Maybe there is a "ready-to-install" contrib for BTS?


Best wishes,

Alex Z.

Share this post


Link to post
Share on other sites

Hi all,

 

First off all a big thank you to Deep Silver, he made a very nice contribution! Good work!

I had no trouble installing it on my (modified) shop.

However I have 1 problem:

 

In the checkout_payment screen, the customer cannot enter a specific amount of points to spend. They can only choose to spend it all or don't spend.

Obviously I missed something in the code but I cannot find it. I tried searching through this forum but could not find it here either :(

 

Also, I would like to know where and if I can duplicate in an other language (dutch) the e-mail that the customer receives.

 

Thanks to all. :thumbsup:

Best regards

Geeraard

Share this post


Link to post
Share on other sites

How can I know how many "Tell a friend" messages customers has posted? Is there a contribution for this?

Share this post


Link to post
Share on other sites

Me too, but i think is normal

 

Hi all,

 

First off all a big thank you to Deep Silver, he made a very nice contribution! Good work!

I had no trouble installing it on my (modified) shop.

However I have 1 problem:

 

In the checkout_payment screen, the customer cannot enter a specific amount of points to spend. They can only choose to spend it all or don't spend.

Obviously I missed something in the code but I cannot find it. I tried searching through this forum but could not find it here either :(

 

Also, I would like to know where and if I can duplicate in an other language (dutch) the e-mail that the customer receives.

 

Thanks to all. :thumbsup:

Best regards

Geeraard

Share this post


Link to post
Share on other sites
i don't want to use the cron option so i'm trying to get this to manually run... but it appears blank each time (for auto expire)

 

i opened the file and there was no closing ?>

so i added it.... still doesn't run.

 

i set my test account to expire on july 25 and then august 25... neither received an email notice about expired points.

 

i searched the install & support topic for more info about using the auto expire option / cron, but i didn't find anything

however, when i go through checkout or view my balance in my account - it tells me i have no points (if expiry date is today), so that portion is certainly working fine

wondering if anybody else has thins problem?

Share this post


Link to post
Share on other sites

is it possible to modify script so it give 1 point for one purchased product?

Share this post


Link to post
Share on other sites

hi, guys!!

first of all, thanx for this great Contributions, even i am not sucessfully installed yet!! :blush:

 

 

i have got the following error msg after the installation,

but seems like the whole install process have not even touch tho files tho!!!??

 

 

Fatal error: Cannot redeclare tep_show_category() (previously declared in c:\easyphp1-8\www\osc\includes\header.php:199) in c:\easyphp1-8\www\osc\includes\boxes\categories.php on line 13

 

 

i saw some other have also been post this same error msg here, but no answer yet,

so hope some one can help us out!!!!

have a good day guys!!

Share this post


Link to post
Share on other sites

hi guys

 

i appreciate your work a lot .. and your time ..

 

can someone take a few minutes for us non-programers and put together what changes we need to do to get rid of negative amount in total.

 

I read few pages now, some posted solutions, some said that this way is better, some say replace that code in your code .. i'm lost :)

 

thanx in advance

Share this post


Link to post
Share on other sites
Hi all,

 

First off all a big thank you to Deep Silver, he made a very nice contribution! Good work!

I had no trouble installing it on my (modified) shop.

However I have 1 problem:

 

In the checkout_payment screen, the customer cannot enter a specific amount of points to spend. They can only choose to spend it all or don't spend.

Obviously I missed something in the code but I cannot find it. I tried searching through this forum but could not find it here either :(

 

Also, I would like to know where and if I can duplicate in an other language (dutch) the e-mail that the customer receives.

 

Thanks to all. :thumbsup:

Best regards

Geeraard

 

Is there any-one out there that can help me woth the above problem?

 

Thanks in advance!

 

Best regards

Share this post


Link to post
Share on other sites

lately i've been having numerous reports from individuals redeeming credit and paying the rest of the amount via paypal; that they are receiving this error:

 

The link you have used to enter the PayPal system contains an incorrectly formatted item amount.

 

how can i fix this?

it's only occuring for occasional credit redemptions.

Share this post


Link to post
Share on other sites
lately i've been having numerous reports from individuals redeeming credit and paying the rest of the amount via paypal; that they are receiving this error:

 

The link you have used to enter the PayPal system contains an incorrectly formatted item amount.

 

how can i fix this?

it's only occuring for occasional credit redemptions.

shall i take it the error shows up only when points are redeemed?


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

Hi all,

 

I have been working with this contribution for quite some time now, and it is really great. However recently i tried to disable the point system for Specials. But this does not seem to work. In the admin, i set "award points for specials" to false, but when you buy a discounted product you still get the points. What is wrong? How can i make this work?

 

Thanks!

 

Matt


Matthias Thoen

my contribution: Photo Gallery for osCommerce

--check my homepage in my CARD--

Share this post


Link to post
Share on other sites
Hi all,

 

I have been working with this contribution for quite some time now, and it is really great. However recently i tried to disable the point system for Specials. But this does not seem to work. In the admin, i set "award points for specials" to false, but when you buy a discounted product you still get the points. What is wrong? How can i make this work?

 

Thanks!

 

Matt

 

anyone please?


Matthias Thoen

my contribution: Photo Gallery for osCommerce

--check my homepage in my CARD--

Share this post


Link to post
Share on other sites
hi guys

 

i appreciate your work a lot .. and your time ..

 

can someone take a few minutes for us non-programers and put together what changes we need to do to get rid of negative amount in total.

 

I read few pages now, some posted solutions, some said that this way is better, some say replace that code in your code .. i'm lost :)

 

thanx in advance

 

would anybody of developers mind to bear this secret with us :lol: :thumbsup:

Share this post


Link to post
Share on other sites

hello i have a problem with a Points/Rewards Module V2.00 Redeemption box

i cant install it (its not showing on the screen - checkout_payment.php)

a.JPG

if you can please help me

 

i know my eanglish is not so fluent

 

thx

Piotrek

Edited by PiterL

Share this post


Link to post
Share on other sites
hello i have a problem with a Points/Rewards Module V2.00 Redeemption box

i cant install it (its not showing on the screen - checkout_payment.php)

thx

Piotrek

 

I believe that you must set a points expiry date in the admin.

This problem has been discussed many times in this forum :)

 

Regards

Geeraard

Share this post


Link to post
Share on other sites
Hi all,

 

First off all a big thank you to Deep Silver, he made a very nice contribution! Good work!

I had no trouble installing it on my (modified) shop.

However I have 1 problem:

 

In the checkout_payment screen, the customer cannot enter a specific amount of points to spend. They can only choose to spend it all or don't spend.

Obviously I missed something in the code but I cannot find it. I tried searching through this forum but could not find it here either :(

 

Also, I would like to know where and if I can duplicate in an other language (dutch) the e-mail that the customer receives.

 

Thanks to all. :thumbsup:

Best regards

Geeraard

 

Is there somebody who can help me with this pls? :'(

Share this post


Link to post
Share on other sites
I believe that you must set a points expiry date in the admin.

This problem has been discussed many times in this forum :)

 

Regards

Geeraard

 

this is not this problem

in admin for this client (test accout) points have set expiration date and they are still valid

b.JPG

please help me - i dont know what to do - im desperated

Edited by PiterL

Share this post


Link to post
Share on other sites
this is not this problem

in admin for this client (test accout) points have set expiration date and they are still valid

b.JPG

please help me - i dont know what to do - im desperated

 

Hm,

 

What is the expiry date in admin/configuration/points and rewards module?

 

Grtz,

Geeraard

Share this post


Link to post
Share on other sites

I've been racking my brain to figure out what is wrong! Here's the problem:

 

The points to redeem don't display in checkout_payment.php. Here is what I know:

 

1) points_selection(); is being called but doesn't display anything at checkout.

2) referral_input(); is being called and is displaying the referral box correctly at checkout.

3) the customer I'm testing with has 1000 points so the points box should show up in the checkout...and the points have NOT expired.

4) in redemptions.php, it seems to pass the first 6 IF statements but when it gets to tep_draw_seperator it doesn't do anything. Consequently the points redemptions don't get displayed at checkout.

 

Any help would be greatly appreciated. I've spent several hours on it and can't figure it out.

 

TIA!!!!!!!!!

Share this post


Link to post
Share on other sites

Also, yes, my Auto Expire Points in Admin is set to 12 and Points Expire Auto Remainder is set to 30 days.

 

I'm so confused...then again what is new...

 

TIA

Share this post


Link to post
Share on other sites

Ok, I found the line that is causing the problem in redemptions.php:

 

if ((get_redemption_rules($order) == true) && (get_points_rules_discounted($order) == true)){

 

Anybody have any ideas why? It is the 2nd IF statement in the function points_selection()

 

TIA

Share this post


Link to post
Share on other sites
Ok, I found the line that is causing the problem in redemptions.php:

 

if ((get_redemption_rules($order) == true) && (get_points_rules_discounted($order) == true)){

 

Anybody have any ideas why? It is the 2nd IF statement in the function points_selection()

 

TIA

 

I figured it out... all of the "Enable * Restriction" entries in the Admin Configuration have to be false and blank. One of mine had an entry and that was causing it to blow up.

Share this post


Link to post
Share on other sites

Hello,

I have installed version 1.60 and running for a while. Just recently a strange thing is happening.

 

When payment is paid via Paypal:

 

Once the user clicks confirm payment with points used for some or all of the payment, The points are deducted form the account double..so Lets say they used 100 points, their account is deducted 200 points. I have the auto deduct set on False and points from the current order are not deducted. Points from the current order are deducted properly when I use the admin tool.

 

SO the problem is why is it dedcuting the points automatically, and in which file should I look?

 

www.2dogrc.com is the website.

 

Mark

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×