Jump to content
deep-silver

### POINTS AND REWARDS MODULE V1.00 ###

Recommended Posts

I've gone through installed this contrib successfully, and was just showing my finished store to my sister. I was horrified to see how many typos are in this contrib. I have gone through and found the majority of them, but I'm wondering when this text:

 

Points Credit : 7 points Corrently valued at $0.70

 

shows up in the product description, where can I change that? CORRENTLY should be CURRENTLY I can't release my site until I get the typos fixed.

 

HELP!??!?! :blush:

Share this post


Link to post
Share on other sites
I've gone through installed this contrib successfully, and was just showing my finished store to my sister. I was horrified to see how many typos are in this contrib. I have gone through and found the majority of them, but I'm wondering when this text:

 

Points Credit : 7 points Corrently valued at $0.70

 

shows up in the product description, where can I change that? CORRENTLY should be CURRENTLY I can't release my site until I get the typos fixed.

 

HELP!??!?! :blush:

sorry for my bad english spelling(thank god typo don't stop the script from working WELL :thumbsup: :thumbsup: :thumbsup: )

to fix it find it at your catalog/includes/languages/english/product_info.php

 

instead of complaining ,do something good for all of us and post here all corrected typo


Remember - - - "STRESSED" spelled backwards "DESSERTS"

Share this post


Link to post
Share on other sites
sorry for my bad english spelling(thank god typo don't stop the script from working WELL :thumbsup: :thumbsup: :thumbsup: )

to fix it find it at your catalog/includes/languages/english/product_info.php

 

instead of complaining ,do something good for all of us and post here all corrected typo

 

I'm sorry I wasn't complaining, I was shocked! There are many many typos and I'm surprised many others didn't post as well. I've spent a good part of the evening looking and did just find the error. Thank you for posting it as well.

Share this post


Link to post
Share on other sites

Typos? Haven?t seen any since I uploaded this Great contrib.! Mine actually shows it right (Points Credit: price points currently valued at $price) taken from my site, and I have gone over every thing twice and did not come through any typo... :blush: anyone wanna help with the problem i am haveing? "^above post"

Share this post


Link to post
Share on other sites
'Step-By-Step Manual Order Entry' - I couldn't get this to work with the Points and rewards module either - I just thought I'd made a mistake. I hope somebody can help.

 

Also, I still can't stop my customers redeeming their points against shipping - is this possible in v1.6?

 

Thanks again for the help

any joy???


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
'Step-By-Step Manual Order Entry' - I couldn't get this to work with the Points and rewards module either - I just thought I'd made a mistake. I hope somebody can help.

as the title of the above contribution.

you must enter order manually thats include points you would like to give.


Remember - - - "STRESSED" spelled backwards "DESSERTS"

Share this post


Link to post
Share on other sites
Great contrib., much appreciated and thanks for everything, the install doc was so easy to follow anyone can do it on there own (I did).

 

Anyhow I am posting here because I am having a problem viewing the product images in the admin area after installing the Contrib., at first I was having trouble with the emails that get sent to my customers when there points are redeemed, the link does not direct them to there account/points, this is how it showed (http://sitename.net//images/my_points.php) <wrong.

Then I was able to fix the link problem to show like this:

(http://sitename.net/my_points.php)

by changing this

(define('DIR_WS_CATALOG', '/images/'); // absolute path required)

into this

(define('DIR_WS_CATALOG', '/catalog/'); // absolute path required)

in the admin/includes/configure.php with the help of Deep-Silver, after doing so the product images only stopped working, all I see is the red X in the admin area, but on the site the images are viewed normally, is there something I am missing or I should add to solve this problem?

 

Thank you for your time in advance, really appreciate it.

 

anyone?

:(

Share this post


Link to post
Share on other sites
anyone?

:(

 

sorry for double posting, "cant edit a post", but i also noticed that the Reward point program faq Qestions 1 (What is the Reward Point Program?) at the very end where the date is suppose to show there is not date this is how it shows :

 

The Reward Point Program began on . All purchases made after that date will earn points.

i went to / public_html / includes / languages / english / my_points_help.php , and the code for the date is there, but dosent seem to work?

 

Taken from the my_points_help.php file: The Reward Point Program began on '. tep_get_last_date($key) . ' . All purchases made after that date will earn points.');

 

any help would be appreciated for both problems.

thanks

Share this post


Link to post
Share on other sites
as the title of the above contribution.

you must enter order manually thats include points you would like to give.

Hi Deep Silver...

 

Long time no speak :-)

 

Yes, do you have any tips on how to get the step by step manual order entry to allow Points to be redeemed if the admin places the order?

 

The contribution is very good and if it becomes common knowledge that CCGV, Points and QTpro can be used on it (as well as other contributions) then I guess it will go down well

 

I tried to get the points to work alongside the step by step manual order entry mod but couldn't.....

 

any advice please?

Edited by chooch

Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
sorry for double posting, "cant edit a post", but i also noticed that the Reward point program faq Qestions 1 (What is the Reward Point Program?) at the very end where the date is suppose to show there is not date this is how it shows :

 

The Reward Point Program began on . All purchases made after that date will earn points.

i went to / public_html / includes / languages / english / my_points_help.php , and the code for the date is there, but dosent seem to work?

 

Taken from the my_points_help.php file: The Reward Point Program began on '. tep_get_last_date($key) . ' . All purchases made after that date will earn points.');

 

any help would be appreciated for both problems.

thanks

As wrote in INSTALL.txt , when first installing this module you have to go to your admin and click on each option in points reward module in order to show the update date and began date


Remember - - - "STRESSED" spelled backwards "DESSERTS"

Share this post


Link to post
Share on other sites

This is a Great contribution.

 

I just get an idea after A test on your demo store.

 

The contribution seems just has one reward level for spending any amount of money in your store. And what I think is if any one can develop it on this. For example, you reward 2 points for each $1 if the customer spent over $50 amount each order, and reward 3 points for each $1 if the cousomer spent over $100 amount each order, and reward 5 points for each $1 if over $200...etc

 

That would be greater if the reward system can is abele to do this way, and that will attract you customers to spend more money each time they order...I am sorry I post thread because I am new with PHP, And I could not do that for my self. If any one can do it will be great( deep-silver, I think you will, right? Thank you any way).

Thank you so much for reading this post.

 

 

:rolleyes:

Share this post


Link to post
Share on other sites
As wrote in INSTALL.txt , when first installing this module you have to go to your admin and click on each option in points reward module in order to show the update date and began date

 

 

thanks, did so and it worked.

anyone able to help me with the product images not showing in the admin area of my site?

Edited by mike1985

Share this post


Link to post
Share on other sites
Typos? Haven?t seen any since I uploaded this Great contrib.! Mine actually shows it right (Points Credit: price points currently valued at $price) taken from my site, and I have gone over every thing twice and did not come through any typo... :blush: anyone wanna help with the problem i am haveing? "^above post"

 

Glad you didn't have problems with typos! I didn't notice them until I acted like a customer going through the FAQ etc. I counted probably 1/2 dozen typos. Could be I had an earlier copy then what you did? All is well, everything is fixed.

Share this post


Link to post
Share on other sites

Hi,

 

Great mod , I have one problem. We want to retrict to certain products. I set it up to do this based on product id, which works. But once they put an allowable item in the cart they can use points against all items in the cart, not just the allowable items.

 

Any ideas, is this me or is it a limitation in the mod.

 

Thanks in advance

 

Kevin

Share this post


Link to post
Share on other sites

This time I have a question.

The points program shows 15 points but in the table it says 58 points. See the screenshot. Total purchases are actually $58.00 but purchases with rewarded point shhould only be 15. How can I correct this?

 

points.jpg

Share this post


Link to post
Share on other sites

DISREGARD my post above. Everything is working correctly. I had deducted some points from the admin side and forgot about doing that. It works correctly.

Dennis

Share this post


Link to post
Share on other sites
Hi,

 

Great mod , I have one problem. We want to retrict to certain products. I set it up to do this based on product id, which works. But once they put an allowable item in the cart they can use points against all items in the cart, not just the allowable items.

 

Any ideas, is this me or is it a limitation in the mod.

 

Thanks in advance

 

Kevin

limitation in the mod. please read post before.

Brilliant contribution!

I would like to send you a donation. Let me know how to do it.

Dennis

Thanks but all my donations go to The people in need not me (not at the moment thank god).

So all donations for deep silver diverted to The RED CROSS. and god bless you if you do so.


Remember - - - "STRESSED" spelled backwards "DESSERTS"

Share this post


Link to post
Share on other sites
Hi Deep Silver...

 

Long time no speak :-)

 

Yes, do you have any tips on how to get the step by step manual order entry to allow Points to be redeemed if the admin places the order?

 

The contribution is very good and if it becomes common knowledge that CCGV, Points and QTpro can be used on it (as well as other contributions) then I guess it will go down well

 

I tried to get the points to work alongside the step by step manual order entry mod but couldn't.....

 

any advice please?

have you any advice for me Deep-Silver?


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

my english is not perfect :wacko:

if enable products restriction in admin area then view in product_info.php then still view points system.

Please help me....

 

os01.jpg

 

 

os02.jpg

 

Thx.

Jaroslav Knirsch

Edited by wheeloftime

Share this post


Link to post
Share on other sites

Excellent contribution. Well Thought. Well documented. The installation went quite smooth with CCGV.

 

-Installed Points and Rewards 1.60

-I have two stores sharing one admin and one database.

-Store1 = CAD dollars (default). Store2 = USA dollars. I am not using multi-stores.

-I award 1 point for each dollar spent with the default currency Canada (about 0.87 USD).

-Current point value = $ 0.03/point CAD funds (about .0262 USD).

 

My points are set using no decimal places with the ?,2? removed from the code. I wish to display points with no decimal places. I wish to display all currency with two decimal places except on the points_faq page.

 

 

URL catalog/my_points_help.php?faq_item=3 is displayed as follows:

Currently, for every $0.87USD spent at Company you'll earn 1 point. Each point is worth $0.03USD off a future purchase.

For example:

Product Cost: $87.33USD

Value of Points Earned: $2.62USD

 

 

I would like to display it as follows:

Currently, for every $0.8733USD spent at Company you'll earn 1 point. Each point is worth $0.0262USD off a future purchase.

For example:

Product Cost: $87.33USD

Value of Points Earned: $2.62USD

 

 

The existing code in catalog/includes/languages/english/my_points_help.php around line 108 reads as follows:

Currently, for every ' .  $currencies->format(1) . ' spent at ' . STORE_NAME . ' you\'ll earn ' . number_format(POINTS_PER_AMOUNT_PURCHASE)  . ' ' . $point_or_points . '.  Each point is worth ' .  $currencies->format(REDEEM_POINT_VALUE) . ' off a future purchase.

 

Please advise what the code should look like to display four decimal places for ?every $0.8733USD? and ?worth $0.0262USD?

 

Thank you.

Share this post


Link to post
Share on other sites

This message is relevant to osC MS1 so if you don't use this version you might skip this easiley (!)

(BTW: this Invision Board Sux Big Time :devil: )

 

Yes, i am still using that good old MS1 and i have to say that installation of this contribution (v1.6) was really smooth and without any errors whatsoever. DEEP-SILVER, you are a King, but you must already now that :)

 

Although i have to make some extra adjustements (since this cherry is made for MS2 only) like adopting missing function from MS2 in "/functions/general.php" (tep_count_modules) and also including new classes for splitpageresults from MS2 via renaming names like it was already posted somewhere in june 2005 on this same thread.

 

I really love the main scope of this contribution and i am pretty sure that my customers will love it as much as i do :)

 

Great RESPECT to author!

 

And now for a questions:

 

Since i have made changes to "orders_status" values completly (e.g. pending: 88889) i would like to know what (and where) changes do i have to make in "my_points.php" and in "customers_points_pending.php" to successfuly follow the main goal of this great contribution?

 

I would really be VERY happy if someone could give me any hint or suggestion according this issue ("orders_status" and "$orders" values).

 

Happy Valentine to all of ya :wub:

 

Dusan

Share this post


Link to post
Share on other sites

Still for MS1 users only using this cherry:

 

In SQL table "customers_points_pending" you also need to change field type to VARCHAR(15) as defined in MS1 against INT(11) as declared in MS2.

 

Next step left is to resolve 'if...statement' in "checkout_payment.php":

 

if ((get_redemption_rules($order) == true) && (get_points_rules_discounted($order) == true)){

 

At that point i would really need some suggestions as stated in my prior post considering those "$order" values and similar (orders_status)...

 

Any help will be very welcome!

 

If any of MS1 users need more help with things already been resolved in my postings - don't hesitate asking for more details. It will be pleasure for me.

 

Dusan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×