Jump to content
Sign in to follow this  
onetime

authorize.net + aim + no ssl

Recommended Posts

I am trying to install authorize.net however I am not able to find the correct latest contribution for what I am trying to do.

 

I have an oscommerse site running withouth an SSL certificate. I want to install the authorize.net contribution module that will allow my clients to go to the authorize.net page to input their CC credit card info and then send them back to my page. Is there such contribution?

 

Any help/tips would be greatly appreciated.

 

Thank you,

onetime

Share this post


Link to post
Share on other sites

you cannot do that with AIM, or at least I don't think you can. You want the Simple Integration Method. I believe that authorize.net module that comes with osCommerce uses the SIM method.

Edited by dreamscape

The only thing necessary for evil to flourish is for good men to do nothing

- Edmund Burke

Share this post


Link to post
Share on other sites

I called authorize.net. They told me they was a contribution but they didn't know the name of it.

 

After looking around I found it:

 

http://www.oscommerce.com/community/contri...h,authorize+sim

 

However I am having a problem. Once I go to the authorize.net page and then enter my credit card number... I hit submit... the redirect it's not working. It takes me back to http://www.patiofurnituresupplies.com/checkout_process.php however it loggs me off and I find no orders in my orders...

 

Any ideas?

Share this post


Link to post
Share on other sites

In a post buried about 2 or 3 months ago, there was someone that posted that he had to turn all of his sessions off to get it to redirect. I remembered that I had forced cookies activated so 2checkout would work, when i turned off forced cookies it worked.

Share this post


Link to post
Share on other sites

hmm, i did try that, it is transferring customer to authorize.net's secure (and rather ugly looking) page to enter credit card, cutomer id is being reported but i don't see order id. emails I am getting from authorize.net do not have order number either, but since customer id and amount is there so it's not that bad.

 

other thing is when the customer enters the credit card and payment is processed, a.net sends him back to my shop but the it gives the error that the cookie is disabled. I suspect that payment is processed but not the order.

 

and after installing this contrib, i can go to my admin section. i am getting this error:

 

Fatal error: Cannot redeclare tep_get_order_status_name() (previously declared in /hsphere/local/home/urdustan/urdustan.com/admin/includes/functions/general.php:1242) in /hsphere/local/home/urdustan/urdustan.com/admin/includes/functions/general.php on line 1311

 

 

any help will be appreciated.

 

Thanks,

 

Kashif

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×