Jump to content

Archived

This topic is now archived and is closed to further replies.

Simplyeasier

The SSL In OsCommerce Guide For The Innocent

Recommended Posts

define('HTTP_COOKIE_DOMAIN', 'www.mysite.com');
define('HTTPS_COOKIE_DOMAIN', 'www.mysite.com');


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites

Hi,

 

2 questions:

 

1) In the original post the cookie domains are defined as..

 

define('HTTP_COOKIE_DOMAIN', 'www.yourdomain.com');

define('HTTPS_COOKIE_DOMAIN', 'yourdomain.com');

 

I have a sharred SSL with the www. Does that mean I should add the www. to both defined cookie domains?, like so:

 

define('HTTP_COOKIE_DOMAIN', 'www.mydomain.com');

define('HTTPS_COOKIE_DOMAIN', 'www.mydomain.com');

 

2) when I type the url into the Firefox browser, it loads in SSL mode as HTTPS, however, it does not do that in IE, Chrome, or Opera. I don't want my site loading in SSL mode, and any help would be greatly appreciated.

 

Thanks.


osCommerce: made for programmers, ...because store owners do not want to be programmers.

https://trends.google.com/trends/explore?date=all&geo=US&q=oscommerce

Share this post


Link to post
Share on other sites

I am haveing some issues when configuring my ssl.

 

I use a geotrust dedicated cert the domain no www and when confiuring the configure.php Bellow is a snipit of my config file everythign seems to work ok and the ssl logs in properly however when atempting to go the the cart to make an edit I am booted out to the non ssl link and cannot edit the cart. I can maniually add the htts:// to see my cart but then when atempting to edit the I have the same results..

 

Also not I had to disable cookies as I was unable to login at all with it enable. Can anyone help?

 

 

admin configure.php

 

define('HTTP_SERVER', 'http://mydomain.com');

define('HTTP_CATALOG_SERVER', 'http://mydomain.com');

define('HTTPS_CATALOG_SERVER', 'https://mydomain.com');

define('ENABLE_SSL_CATALOG', 'true');

 

 

include/configure.php

 

define('HTTP_SERVER', 'http://mydomain.com');

define('HTTPS_SERVER', 'https://mydomain.com');

define('ENABLE_SSL', true);

define('HTTP_COOKIE_DOMAIN', 'mydomain.com');

define('HTTPS_COOKIE_DOMAIN', 'https://mydomain.com');

Share this post


Link to post
Share on other sites

×