Jump to content
Sign in to follow this  
toolguy191

Xsell

Recommended Posts

I still get the following message when click on the cross sell link in the admin panel.

NOT FOUND

The requested URL /catalog/admin/FILE_NAME_XSELL_PRODUCTS was not found on this server

 

What am i missing?

I have installed on both the catalog and admin sides and the database.

 

Thanks

 

I have the

define('FILENAME_XSELL_PRODUCTS', 'xsell.php');

in the catalog/admin/includes/filenames.php

 

Have checked to be sure that I have the xsell.php in the admin folder.

I have walked back through the install several times and do not see the issue.

 

Any other ideas?

Share this post


Link to post
Share on other sites

Go over these steps and try this. If you have already done these then jsut double check it against what i gave you

 

STEP 1:

Copy Admin/xsell_products.php to your site's admin folder (ie /catalog/admin/; /admin/; etc.)

 

STEP 2:

Add the following lines to admin/includes/application_top.php

 

define('FILENAME_XSELL_PRODUCTS', 'xsell_products.php');
define('TABLE_PRODUCTS_XSELL', 'products_xsell');

 

STEP 3:

Add the following line to admin/includes/languages/english.php

 

define('BOX_CATALOG_XSELL_PRODUCTS', 'Cross Sell Products');

 

STEP 4:

Add the following line into the array in admin/includes/boxes/catalog.php

 

'<a href="' . tep_href_link(FILENAME_XSELL_PRODUCTS) . '" class="menuBoxContentLink">' . BOX_CATALOG_XSELL_PRODUCTS . '</a><br>' .

Share this post


Link to post
Share on other sites
Go over these steps and try this. If you have already done these then jsut double check it against what i gave you

 

STEP 1:

Copy Admin/xsell_products.php to your site's admin folder (ie /catalog/admin/; /admin/; etc.)

 

STEP 2:

Add the following lines to admin/includes/application_top.php

 

define('FILENAME_XSELL_PRODUCTS', 'xsell_products.php');
define('TABLE_PRODUCTS_XSELL', 'products_xsell');

 

STEP 3:

Add the following line to admin/includes/languages/english.php

 

define('BOX_CATALOG_XSELL_PRODUCTS', 'Cross Sell Products');

 

STEP 4:

Add the following line into the array in admin/includes/boxes/catalog.php

 

'<a href="' . tep_href_link(FILENAME_XSELL_PRODUCTS) . '" class="menuBoxContentLink">' . BOX_CATALOG_XSELL_PRODUCTS . '</a><br>' .

Share this post


Link to post
Share on other sites
Go over these steps and try this. If you have already done these then jsut double check it against what i gave you

 

STEP 1:

Copy Admin/xsell_products.php to your site's admin folder (ie /catalog/admin/; /admin/; etc.)

 

STEP 2:

Add the following lines to admin/includes/application_top.php

 

define('FILENAME_XSELL_PRODUCTS', 'xsell_products.php');
define('TABLE_PRODUCTS_XSELL', 'products_xsell');

 

STEP 3:

Add the following line to admin/includes/languages/english.php

 

define('BOX_CATALOG_XSELL_PRODUCTS', 'Cross Sell Products');

 

STEP 4:

Add the following line into the array in admin/includes/boxes/catalog.php

 

'<a href="' . tep_href_link(FILENAME_XSELL_PRODUCTS) . '" class="menuBoxContentLink">' . BOX_CATALOG_XSELL_PRODUCTS . '</a><br>' .

 

I tried these steps twice, stillthe same message.

Share this post


Link to post
Share on other sites

Ok here is the issue im having. The installtion is perfect, but in the readme.txt says nothing about installing the appilcation_top.php that is in the installation. Without it i get no errors but i also get no but nothing shows up the way it is suppose to in the screen shot. Now when i install the application_top thats in the installation in the contribution i get this error.

 

Fatal error: Call to a member function on a non-object in /home/texascam/public_html/store/includes/header.php on line 7

 

 

It would be nice to get this fixed, anyone have any suggestions or ideas?

 

Thanks

Share this post


Link to post
Share on other sites

Yea i just tried installing this on a FRESH CLEAN store and i am getting the same error:

 

NOT FOUND

The requested URL /catalog/admin/FILE_NAME_XSELL_PRODUCTS was not found on this server

 

 

As anyone else come across this before and know how to fix it?

 

Thanks

Share this post


Link to post
Share on other sites
Yea i just tried installing this on a FRESH CLEAN store and i am getting the same error:

 

NOT FOUND

The requested URL /catalog/admin/FILE_NAME_XSELL_PRODUCTS was not found on this server

As anyone else come across this before and know how to fix it?

 

Thanks

 

Installed this and got the same error. T0ook a while to figure out, but i did it.

 

The file cat/admin/xsell_products was missing. In the contribution i downloaded it was not there, and no mention of adding it. After all the times this has been rewritten, someone must have noticed this before.

 

I went back to the earliest contribution and downloaded that copy, and lo and behold that file is there. Add it in its respective place, and off you go.


REMEMBER BACKUP, BACKUP AND BACKUP

Get the latest Responsive osCommerce CE (community edition) here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×