Jump to content
Sign in to follow this  
Don7Qf

Handling Fee for USPS

Recommended Posts

Hello all. My handling fee is not calculated at checkout for USPS shipping. It's enabled in Admin>Modules>Shipping>USPS but not added to the total. Any ideas?

Share this post


Link to post
Share on other sites

I know this is an OLD post, but I'm having the same issue...anyone got an idea, or know what may be causing the issue?

Edited by chimol

Steve

I appreciate all the help that everyone on this site has given me!

Share this post


Link to post
Share on other sites

I know this is an OLD post, but I'm having the same issue...anyone got an idea, or know what may be causing the issue?

 

Simple question. You did set the handling fee in admin?

If you did then this is where the handling fee is processed in usps.php

 

    if (($method == '' && in_array($type, $this->types)) || $method == $type) {
       if (strpos($type, "Flat Rate")) $type_flat = $type . ', subject to verification';
       else $type_flat = $type;
              $methods[] = array('id' => $type,
                              'title' => $type_flat,
                              'cost' => ($cost + MODULE_SHIPPING_USPS_HANDLING) * $shipping_num_boxes);
           }
         }

 

If your fee is set and the line with "MODULE_SHIPPING_USPS_HANDLING" has not been modified then it should work.

NOTE: Above is set to not adding a handling fee to a flat rate shipping fee. If you want to charge a handling fee for that service than some additional coding would need to be done.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×