Jump to content
bruyndoncx

[Contribution] Admin Specials by Category

Recommended Posts

This contribution rocks! :thumbsup:

 

So um, ya, do you have a time frame for when the "expiration date" will be added? That would make it rock "out loud" :)

 

Mike


"I'm gonna make you into poo."

Share this post


Link to post
Share on other sites
Hi! Even adding just one item via the old way causes my site to load in about 10 seconds. As soon as I remove it i'm down to just 1 second...

 

I undid the contribution and loaded my backup files and i still have the problem. Perhaps it's not related to this transaction but i'm pretty certain the problem started when i added a bunch of specials via this tool.

 

Any other thoughts would be great appreciated.

 

Thanks again!

Firstly i'd like to say thanks Carine for a fantastic contibution [exactly what i needed].Installed easily and worked perfectly....except... i have had the same problem as Josh Friedman.My site was running lighting fast until i installed this contibution.I hate to say it,but...the lack of speed is directly related to this contibution. I have removed it and installed my backed up files and my site still runs like a snail on quaaludes [reeeeaaallly slow]...any idea how to keep your contibuton and keep my site speed up?

 

Thanks

Danny

Share this post


Link to post
Share on other sites

Thanks for this great contribution!!!

Is there a way for not showing the specials by categories in the default specials infobox?

Thanks.

Share this post


Link to post
Share on other sites

Thanks for an excellent contribution! Been looking for something like this for a while :)

 

One question - how hard would it be to add a "Model Number" column, between the "Products" and "Products Price" columns?

 

I generally use model numbers on a rather large store, many products have very similar descriptions and it's easy to make mistakes when pricing them if I can't see the model numbers.

Share this post


Link to post
Share on other sites
Firstly i'd like to say thanks Carine for a fantastic contibution [exactly what i needed].Installed easily and worked perfectly....except... i have had the same problem as Josh Friedman.My site was running lighting fast until i installed this contibution.I hate to say it,but...the lack of speed is directly related to this contibution. I have removed it and installed my backed up files and my site still runs like a snail on quaaludes [reeeeaaallly slow]...any idea how to keep your contibuton and keep my site speed up?

 

Thanks

Danny

Having a lot of specials will slow down your site if you haven't optimized the oscommerce code in the database and in the code.

My contribution does not adress this issue. The performance impact is the same if you use my contribution or the standard oscommerce way of adding specials.


KEEP CALM AND CARRY ON

I do not use the responsive bootstrap version since i coded my responsive version earlier, but i have bought every 28d of code package to support burts effort and keep this forum alive (albeit more like on life support).

So if you are still here ? What are you waiting for ?!

 

Find the most frequent unique errors to fix:

grep "PHP" php_error_log.txt | sed "s/^.* PHP/PHP/g" |grep "line" |sort | uniq -c | sort -r > counterrors.txt

Share this post


Link to post
Share on other sites
Thanks for this great contribution!!!

Is there a way for not showing the specials by categories in the default specials infobox?

Thanks.

No there isn't as all the specials setup by category are stored in the same way as the ones defined one by one through the standard oscommerce admin specials page. There is currently no way to distinguish one from the other when you display specials.


KEEP CALM AND CARRY ON

I do not use the responsive bootstrap version since i coded my responsive version earlier, but i have bought every 28d of code package to support burts effort and keep this forum alive (albeit more like on life support).

So if you are still here ? What are you waiting for ?!

 

Find the most frequent unique errors to fix:

grep "PHP" php_error_log.txt | sed "s/^.* PHP/PHP/g" |grep "line" |sort | uniq -c | sort -r > counterrors.txt

Share this post


Link to post
Share on other sites
Thanks for an excellent contribution! Been looking for something like this for a while :)

 

One question - how hard would it be to add a "Model Number" column, between the "Products" and "Products Price" columns?

 

I generally use model numbers on a rather large store, many products have very similar descriptions and it's easy to make mistakes when pricing them if I can't see the model numbers.

Hello marc

 

it wouldn't be hard to do, just duplicate about line 179

			<td class=\"dataTableHeadingContent\"></td>

 

and add

	<td class=\"dataTableContent\">" . $row["products_model"] . "</td>

 

below for instance (around line 223)

	<td class=\"dataTableContent\">" . $row["products_name"] . "</td>

 

HTH


KEEP CALM AND CARRY ON

I do not use the responsive bootstrap version since i coded my responsive version earlier, but i have bought every 28d of code package to support burts effort and keep this forum alive (albeit more like on life support).

So if you are still here ? What are you waiting for ?!

 

Find the most frequent unique errors to fix:

grep "PHP" php_error_log.txt | sed "s/^.* PHP/PHP/g" |grep "line" |sort | uniq -c | sort -r > counterrors.txt

Share this post


Link to post
Share on other sites
Hello marc

 

it wouldn't be hard to do, just duplicate about line 179

			<td class=\"dataTableHeadingContent\"></td>

 

and add

	<td class=\"dataTableContent\">" . $row["products_model"] . "</td>

 

below for instance (around line 223)

	<td class=\"dataTableContent\">" . $row["products_name"] . "</td>

 

HTH

 

Excellent, Carine - Thanks! It's working perfectly :)

 

Currently, each special price has to be updated one at a time - how about one [uPDATE ALL] button to submit all changes to the page in one go? I've seen something similar before, I think it was in the Quick Price Updates contrib.

 

I've also noticed that, when listing products by category AND manufacturer, after submitting a change the display defaults back to listing only by category, and forgets the manufacturer - any way to fix this?

Share this post


Link to post
Share on other sites
Excellent, Carine - Thanks! It's working perfectly :)

 

Currently, each special price has to be updated one at a time - how about one [uPDATE ALL] button to submit all changes to the page in one go? I've seen something similar before, I think it was in the Quick Price Updates contrib.

 

I've also noticed that, when listing products by category AND manufacturer, after submitting a change the display defaults back to listing only by category, and forgets the manufacturer - any way to fix this?

I'll have to add the single update button to my feature list I'm afraid.

 

As for the manufacturer issue, looking at the code comments, I think this was fixed in v1.4. Can you check your version ?


KEEP CALM AND CARRY ON

I do not use the responsive bootstrap version since i coded my responsive version earlier, but i have bought every 28d of code package to support burts effort and keep this forum alive (albeit more like on life support).

So if you are still here ? What are you waiting for ?!

 

Find the most frequent unique errors to fix:

grep "PHP" php_error_log.txt | sed "s/^.* PHP/PHP/g" |grep "line" |sort | uniq -c | sort -r > counterrors.txt

Share this post


Link to post
Share on other sites
As for the manufacturer issue, looking at the code comments, I think this was fixed in v1.4. Can you check your version ?

 

I'm using :-

 

$Id: specialsbycategory.php,v 1.4 2005/06/29 23:03:00

 

 

I just checked again, and it definitely defaults to listing all manufacturers after updating.

Share this post


Link to post
Share on other sites
No there isn't as all the specials setup by category are stored in the same way as the ones defined one by one through the standard oscommerce admin specials page. There is currently no way to distinguish one from the other when you display specials.

 

Is there a contribution that does this?


Norman in 't Veldt

 

Moderator

osCommerce The Netherlands

Share this post


Link to post
Share on other sites
Firstly i'd like to say thanks Carine for a fantastic contibution [exactly what i needed].Installed easily and worked perfectly....except... i have had the same problem as Josh Friedman.My site was running lighting fast until i installed this contibution.I hate to say it,but...the lack of speed is directly related to this contibution. I have removed it and installed my backed up files and my site still runs like a snail on quaaludes [reeeeaaallly slow]...any idea how to keep your contibuton and keep my site speed up?

 

Thanks

Danny

 

 

Danny,

 

I added this mod yesterday, and the EXACT same thing happened to me...I have removed it and installed my backed up files and just like you, my site is REALLY slow...for sure, I'm losing orders because of this...were you able to find the solution? Please let me know either way...I'm panicing!!!

 

Randal

Share this post


Link to post
Share on other sites
Hi. I successfully installed this contribution and I think it's great (very easy to use)! One problem however (big problem), and I don't know if it's the contribution causing the problem or something else related to specials, but now when I have any number of specials, even just 1, my main index page slows down to a crawl. The category pages are just slightly better, though still very slow, and the product pages and shipping/contact/etc... are just fine). Any help would be greatly appreciated.

 

Thanks!

 

Hi Josh,

 

I added this mod yesterday, and the EXACT same thing happened to me...I have removed it and installed my backed up files and just like you, my site is REALLY slow...for sure, I'm losing orders because of this...were you able to find the solution? Please let me know either way...I'm panicing!!!

 

Randal

Share this post


Link to post
Share on other sites
Hi Josh,

 

I added this mod yesterday, and the EXACT same thing happened to me...I have removed it and installed my backed up files and just like you, my site is REALLY slow...for sure, I'm losing orders because of this...were you able to find the solution? Please let me know either way...I'm panicing!!!

 

Randal

 

 

UPDATE - To fix the slow condition: Add the "Optimize Database" Mod and run it. At least that fixed the problem for me...I haven't reinstalled the "Special by Category" Mod to see how fast my site runs together with the "Optimize Database" Mod together. Good luck everyone...

 

Randal

Share this post


Link to post
Share on other sites
UPDATE - To fix the slow condition: Add the "Optimize Database" Mod and run it. At least that fixed the problem for me...I haven't reinstalled the "Special by Category" Mod to see how fast my site runs together with the "Optimize Database" Mod together. Good luck everyone...

 

Randal

 

Hey Randall,

luckily my site wasn't live when this contribution slowed it to a crawl. I just loaded up my backed up site and have not had the kahunas to try installing it again. It appears this is only useful of small databases. I have over 12000 products on my music site www.tenseconds.com.au

 

Good luck if you give it another go

 

Danny

Share this post


Link to post
Share on other sites
luckily my site wasn't live when this contribution slowed it to a crawl. I just loaded up my backed up site and have not had the kahunas to try installing it again. It appears this is only useful of small databases.
You should not blame this contribution for the slowness of your site. It "only" makes it easy to administer the specials, but it uses the standard way of osC for handling specials. Whether or not you would have used this contribution, if you would have added a special (using the osC "native" way or in another manner) the same thing would have happened.

Share this post


Link to post
Share on other sites

Hi there... First off, fantastic contrib :) Didn't know I needed it, but man I did!!! Second question (it was asked earlier in the thread, about page 3) - has anyone managed to get it working with an expiry date? I'm just about to go off and start fiddling myself, but thought I'd better check, in case someone already has the answer for me :lol:

 

So any ideas?

 

Thanks,

~Barbara~

Share this post


Link to post
Share on other sites

Hi barbara,

 

I personally have not added expiration date.

 

Please clarify, do you want to add it

1) on top like % discount ? to set an expiry date for a bunch of items

2) on top like a filter e.g. like categories and manufacturer so you can review items about to expire

3) in the detail, to update individual dates ?

 

Just wondering what exactly are you looking for, I did not find any earlier post from you.


KEEP CALM AND CARRY ON

I do not use the responsive bootstrap version since i coded my responsive version earlier, but i have bought every 28d of code package to support burts effort and keep this forum alive (albeit more like on life support).

So if you are still here ? What are you waiting for ?!

 

Find the most frequent unique errors to fix:

grep "PHP" php_error_log.txt | sed "s/^.* PHP/PHP/g" |grep "line" |sort | uniq -c | sort -r > counterrors.txt

Share this post


Link to post
Share on other sites
Hi barbara,

 

I personally have not added expiration date.

 

Please clarify, do you want to add it

1) on top like % discount ? to set an expiry date for a bunch of items

2) on top like a filter e.g. like categories and manufacturer so you can review items about to expire

3) in the detail, to update individual dates ?

 

Just wondering what exactly are you looking for, I did not find any earlier post from you.

Hi there... Thanks for the reply :)

Yep, I'm looking to add an expiry date in the top, that applies to everything in the category (your number 1). I reguarily have week-long sales that apply to whole categories, and it would be great for them to automatically expire. I've started looking at the code, but have realised it's going to take a fair bit more time than I thought - I've got the display to add the date working, I just don't know how to get that to add the date to the database...

Thanks for any advice...

 

~Barbara~

p.s. the earlier post about expiry dates wasn't from me, I just noticed someone asking about them and thought I'd check up to see if anything had been done :thumbsup:

Share this post


Link to post
Share on other sites

Thanks for a great Mod!!!

 

I was wondering if there is any way to tweek this so that I could set the expiration dates for my specials. Thanks in advance for your help.

Share this post


Link to post
Share on other sites
Thanks for a great Mod!!!

 

I was wondering if there is any way to tweek this so that I could set the expiration dates for my specials. Thanks in advance for your help.

So has anyone thought about this? I've started playing around with it, but I think it's past my ability :(

Share this post


Link to post
Share on other sites

Hey,

 

I am thinking of using this contrib, but I have a few questions (Note: I have already installed it but haven't used it yet).

 

Firstly, I know this has been talked about before, but there hasn't been any solution. Basically, I have a category of "RAM" which has heaps of sub-categories. Is there any way to apply the specials to EVERYTHING under the category of RAM instead of having to go to every sub-category of it?

 

Has anyone sorted out the expiry fix yet?

 

I have also noticed that some people have had problems with their shop being slowed down after heaps of specials have been put on. I know it isnt directly related to this contrib, but their solution was to use an Optimise database contrib. What are the Optimize Database Contribs like? How do they actually work (I know this is out of scope of this thread, but thought I would ask it here with my other questions in the hope that I get a quick answer).

 

I think that is all the questions I have at this stage.

 

Cheers,

Chris

Share this post


Link to post
Share on other sites

I have to say, thank you. This, as well as most of the contributions I have tried, worked perfectly the first time. All of the hard work of osc's contributors is appreciated! Don't stop now!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×