Jump to content
bad_lemming

[Contribution] - USPS Methods

Recommended Posts

I think I answered my own problem. The key is to set in your admin configuration:Shipping/Packaging: Enter the Maximum Package Weight you will ship value to equal 70lbs which is the USPS max per box. Once you do this it appears the USPS methods will take the total weight and divide it amongst x number of packages and it will give you the shipping quote.

 

I am repeating a question that was asked back about 2 years ago on page 4 by Bruce due to the fact that I didn't see a response in the forum regarding this issue and I'm hoping someone has solved it b/c I routinely have orders that have total ship weights of greater than 70lbs even though they will be packaged in different boxes.

-----

 

1. Weight Issue: Ran into a bit of an issue / unexpected bug.

 

Here is the problem:

 

For those not aware, USPS Priority only allows up to 70 lbs.

 

When I added more items to my cart and the total weight came over 70 lbs, it comes back with an error and won't retrieve ANY of the USPS shipping methods.

 

As soon as I got the weight down below 70, it worked fine again.

 

Any suggestions?

 

2. Order: Is there any way to reorder the available shipping options during checkout to show cheapest to most expense?

 

The UPS XML system does a wonderful job of this.

 

----------

 

Any help you can provide on these items is greatly appreciated.

Share this post


Link to post
Share on other sites

For some reason, I can't select what method to ship with.

No where do I have the option to choose which methods are available to the customers. How do I get this?

Aren't there supposed to be option buttons to choose from in admin/shipping modules/usps ?

 

Help please.

Share this post


Link to post
Share on other sites
For some reason, I can't select what method to ship with.

No where do I have the option to choose which methods are available to the customers. How do I get this?

Aren't there supposed to be option buttons to choose from in admin/shipping modules/usps ?

 

Help please.

 

 

Are you using USPS shipping methods contrib?

 

If so, absolutely, you can choose which ways.

Follow the install directions! Step by step, and it will go in seamlessly.

Also, register with USPS, or the module will fail when doing transactions.

(learned by experience)

Share this post


Link to post
Share on other sites

I have. It shows up when I go to purchase, but there is no time estimate, and only three options, one of which I don't want there.

I need to choose which show up to the customer.

 

None of the these options appear in the admin section of the catalog.

I know that they should, but they aren't.

Any ideas why?

 

Also,

How do I use the USPS API?

Shouldn't there be somewhere for my to print the labels?

What about the Calculate Shipping API supplied by USPS? Is that SOMEWHERE in the Mod?

I'm not finding much of any detailed instructions on how to use this Mod.

Edited by Resident Geek

Share this post


Link to post
Share on other sites
I have. It shows up when I go to purchase, but there is no time estimate, and only three options, one of which I don't want there.

I need to choose which show up to the customer.

 

None of the these options appear in the admin section of the catalog.

I know that they should, but they aren't.

Any ideas why?

 

Also,

How do I use the USPS API?

Shouldn't there be somewhere for my to print the labels?

What about the Calculate Shipping API supplied by USPS? Is that SOMEWHERE in the Mod?

I'm not finding much of any detailed instructions on how to use this Mod.

 

if usps 2.9 is installed correctly, you should have about 15 selections to choose from, I only use priority and express national, and prioroty international, selected from the admin console.

 

Time estimates are simply the normally suggested times I think are hard-coded for each of the selections.

They only show up on the customers checkout process. You should be familiar with the time each method takes (or look it up on USPS.com) so you can choose appropriately which the customers can select from.

 

It sounds like you didnt follow the directions.

I recommend you uninstall the module via the admin console, turn off the USPS stock module, and re-install methods 2.9 following the directions step by step, and dont turn on the stock USPS at all.

 

I don't use the USPS API directly, methods does it all.

As long as you have the pieces in place and fill in the usps registration info when provided by them, it will work.

It will calculate the postage and apply it to the order.

 

Methods does not print labels for you, I believe there is another contrib for that.

 

There are relatively detailed instructions in the zip, just read & follow them.

Share this post


Link to post
Share on other sites

when i called up USPS and asked them to move me and i got moved to production but when I enter the information and when I checkout I dont see USPS here anymore what did I do wrong?

Share this post


Link to post
Share on other sites

You must not have selected "Enable USPS Shipping" as True. It still may be false.

 

Hey folks!

I'm having an issue as well.

For some reason, I am unable to get First Class to show up. Everything else is working fine now, (I figured it out), but First Class has disappeared.

Edited by Resident Geek

Share this post


Link to post
Share on other sites

Hello,

 

Need a little help with zones. If I only want to us USPS to PR, AK and Hi, do I need the contribution MultiGeoZone MultiTable Shipping, in order to create a multi zone destination? I do not see any other way to select multiple zones in the USPS Methods?

 

Thanks JR

Share this post


Link to post
Share on other sites

So what happened to domestic flat rate envelopes and boxes?

I'm using the latest version (2.9.2) and domestic priority mail flat rate envelope and box are missing from the admin menu and from the shipping options in check out.

Are they working for anyone else?

Does anyone know if they have been removed from the code or by usps or if I just have a bad install?

I know usps still offers the service.


I have moved on from oscommerce to magento and no longer monitoring this site.

Share this post


Link to post
Share on other sites

I have looked every where on this forum to try and find out why when I update the USPS module, I don't get any options in the admin for shipping methods to offer. It's blank, it's always been blank and no matter what I do, I don't get any options in the admin area. When you check out it works fine for domestic, gives you every option available, lists every option available for international but only lets them choose one option and that's Global Express guranteed and it's $41, it's been like that since it was installed and when ever we ask on here we never get an answer.

 

I just updated it to the newest version of USPS contribution and it's exactally the same as before. I was reading somewhere about updating the SQL, but I can't figure out how to get to whatever is supposed to be updated, some help would be greatly appreciated, I love OS commerce but this shipping module thing is killing our international sales. Help in Lamens terms, lol. Thanks

Share this post


Link to post
Share on other sites
I have looked every where on this forum to try and find out why when I update the USPS module, I don't get any options in the admin for shipping methods to offer. It's blank, it's always been blank and no matter what I do, I don't get any options in the admin area. When you check out it works fine for domestic, gives you every option available, lists every option available for international but only lets them choose one option and that's Global Express guranteed and it's $41, it's been like that since it was installed and when ever we ask on here we never get an answer.

 

I just updated it to the newest version of USPS contribution and it's exactally the same as before. I was reading somewhere about updating the SQL, but I can't figure out how to get to whatever is supposed to be updated, some help would be greatly appreciated, I love OS commerce but this shipping module thing is killing our international sales. Help in Lamens terms, lol. Thanks

 

Dpending on how your SQL is set up dictates how you apply the SQL script.

I have myphpadmin, which allows you to perform operations on your SQL.

There, you would simply pull up the SQL tab, insert the SQL statements to be applied and click execute.

This will then apply the SQL statements as provided for the module to your database, ending with something to the effect of SQL applied successfully.

 

Your USPS mothods contrib should work after that.

 

I have found and discussed with the latest editor of the contrib, that having the stock USPS module in place will mess with the contrib.

So, be sure that is turned off in the admin console before you apply this contrib.

 

AS ALWAYS BACK UP BACK UP BACK UP!

Share this post


Link to post
Share on other sites

Thank You, I finally found out how to get into Myphpadmin last night but wasn't sure where to go from there. No the original USPS module is turned off.

Share this post


Link to post
Share on other sites
Dpending on how your SQL is set up dictates how you apply the SQL script.

I have myphpadmin, which allows you to perform operations on your SQL.

There, you would simply pull up the SQL tab, insert the SQL statements to be applied and click execute.

This will then apply the SQL statements as provided for the module to your database, ending with something to the effect of SQL applied successfully.

 

Your USPS mothods contrib should work after that.

 

I have found and discussed with the latest editor of the contrib, that having the stock USPS module in place will mess with the contrib.

So, be sure that is turned off in the admin console before you apply this contrib.

 

AS ALWAYS BACK UP BACK UP BACK UP!

 

 

Ok so I updated the SQL and it went through fine, but now when I go to test out the Shippign for international shipping it gives me this error:

An error occured with the USPS shipping calculations.

If you prefer to use USPS as your shipping method, please contact the store owner.

 

Also no matter what Id o I don't have any options in the OSC admin to select for USPS shipping options.

Share this post


Link to post
Share on other sites
Ok so I updated the SQL and it went through fine, but now when I go to test out the Shippign for international shipping it gives me this error:

An error occured with the USPS shipping calculations.

If you prefer to use USPS as your shipping method, please contact the store owner.

 

Also no matter what Id o I don't have any options in the OSC admin to select for USPS shipping options.

 

 

I would suggest a complete uninstall and re-install following the directions verbatim.

Share this post


Link to post
Share on other sites
I would suggest a complete uninstall and re-install following the directions verbatim.

 

 

Ok I just reinstalled it step by step and figured out the problem about the shipping not showing up, I forgot to put in my User ID for USPS, but even after reinstalling it and updating the SQL I STILL don't have any options in the USPS admin on OSC. It shows every available option when checking out for international, but will only let you choose Global Express guarantee no matter what other options you choose.

Share this post


Link to post
Share on other sites
Ok I just reinstalled it step by step and figured out the problem about the shipping not showing up, I forgot to put in my User ID for USPS, but even after reinstalling it and updating the SQL I STILL don't have any options in the USPS admin on OSC. It shows every available option when checking out for international, but will only let you choose Global Express guarantee no matter what other options you choose.

 

At this point I suggest you PM the latest of the contrib authors to get their input on what is happening.

Share this post


Link to post
Share on other sites
I made this thread in an effort to consolidate issues with this Contribution.

 

http://www.oscommerce.com/community/contri...ch,USPS+Methods

 

Hi, i just installed the above , and im getting this:

 

An error occured with the USPS shipping calculations.

If you prefer to use USPS as your shipping method, please contact the store owner.

 

 

i entered the username and pw usps emailed me "Thank you for registering for the U. S. Postal Service's Web Tools Application Program Interfaces (APIs). We are providing you with a User ID that serves multiple purposes, as explained below."

 

 

can someone help? i enabled the usps via admin shipping modules, and entered the username and pw provided by usps, selected production for server

 

and still this error, can someone please help?

 

thanks

Share this post


Link to post
Share on other sites
Hi, i just installed the above , and im getting this:

 

An error occured with the USPS shipping calculations.

If you prefer to use USPS as your shipping method, please contact the store owner.

i entered the username and pw usps emailed me "Thank you for registering for the U. S. Postal Service's Web Tools Application Program Interfaces (APIs). We are providing you with a User ID that serves multiple purposes, as explained below."

can someone help? i enabled the usps via admin shipping modules, and entered the username and pw provided by usps, selected production for server

 

and still this error, can someone please help?

 

thanks

 

Stupid questions first:

Did you uninstall the stock usps module first?

Is password the same one you used for the sandbox (testing server)?

Did you enable the contrib?

Did you do all the edits in the files as described in the contrib install file?

Did you apply the SQL?

Did you set the file(s) permissions correctly? (755, except configs)

 

Thats enough to start with.

Share this post


Link to post
Share on other sites

Anyone know how to have the usps rate quotes be sorted on the checkout_shipping.php page from lowest price to highest price? thanks!

 

Scott

Share this post


Link to post
Share on other sites

Is anyone interested in getting dimensional support working with USPS. http://forums.oscommerce.com/index.php?sho...=269079&hl=

In that thread i list the things we should send the the xml server to get the correct quote. I am going to work on using the same dimensional settings that UPS xml uses. So that i can use UPS and USPS together with the same dimension so quotes will be correct.

 

When we ship a 8lbs package that is 25x25x22 the size is a big factor.

 

If anyone would also like this i can post the code i am working on.

Share this post


Link to post
Share on other sites
Is anyone interested in getting dimensional support working with USPS. http://forums.oscommerce.com/index.php?sho...=269079&hl=

In that thread i list the things we should send the the xml server to get the correct quote. I am going to work on using the same dimensional settings that UPS xml uses. So that i can use UPS and USPS together with the same dimension so quotes will be correct.

 

When we ship a 8lbs package that is 25x25x22 the size is a big factor.

 

If anyone would also like this i can post the code i am working on.

 

if you get this working and have an fairly easy install for it, i'd love to know.

 

also, i'm having an issue with a store i built... i've used this USPS methods module probably 15 other times, but for some reason this particular store works fine for domestic, yet gives the error message ("An error occured with the USPS shipping calculations. If you prefer to use USPS as your shipping method, please contact the store owner.") when the customer is international.

 

any suggestions what that might be? i've already checked all the settings and the store ZIP/country of origin are set correctly and shipping methods for international have been selected.

 

thanks!

Share this post


Link to post
Share on other sites

Is anyone else experiencing problems with USPS domestic shipping right now? The names changed on the shipping page and no matter what you select it defaults to FIRST CLASS on the next page. I'm thinking USPS changed something on their end cause I went to a backup from a week ago that i know was fine. Someone help!?!?!

 

Jason

Share this post


Link to post
Share on other sites

Jason,

 

Yes, I too am having a similar problem, although my shipping type defaults to PARCEL since I am not offering First Class.

 

I've noticed that my USPS International options do not seem to be affected, only USPS Domestic options.

 

I hope that a solution is forthcoming.

 

Dick

 

Is anyone else experiencing problems with USPS domestic shipping right now? The names changed on the shipping page and no matter what you select it defaults to FIRST CLASS on the next page. I'm thinking USPS changed something on their end cause I went to a backup from a week ago that i know was fine. Someone help!?!?!

 

Jason

Share this post


Link to post
Share on other sites

yup that's it! whatever is on the top of your list for shipping methods is all it will go to. USPS must have changed something last night. I checked a couple other OS sites and looked like they had the same thing going on.

 

Jason

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×