Jump to content
bad_lemming

[Contribution] - USPS Methods

Recommended Posts

Is this post relevant to that?

 

 

THis certinly appears to be relevant, but I am not finding the "First-Class Mail International" in either USPS.php module. I'm still a newby at OSC, so I apologize if I'm not understanding. I'm also not clear on the database change. Your help is appereciated. Thansk again for your help yesterday.

Share this post


Link to post
Share on other sites
I am not finding the "First-Class Mail International" in either USPS.php module.

I downloaded version 3.0.2 from here (I'm not 100% certain we are talking about the same contribution) and in the catalog/includes/modules/shipping/usps.php I found that piece of text on line 58 (line 50-58 shown):

 

	  $this->intl_types = array('GLOBAL EXPRESS' => 'Global Express Guaranteed',
							'GLOBAL EXPRESS NON-DOC RECT' => 'Global Express Guaranteed Non-Document Rectangular',
							'GLOBAL EXPRESS NON-DOC NON-RECT' => 'Global Express Guaranteed Non-Document Non-Rectangular',
							'EXPRESS MAIL INT' => 'Express Mail International (EMS)',
							'EXPRESS MAIL INT FLAT RATE ENV' => 'Express Mail International (EMS) Flat Rate Envelope',
							'PRIORITY MAIL INT' => 'Priority Mail International',
							'PRIORITY MAIL INT FLAT RATE ENV' => 'Priority Mail International Flat Rate Envelope',
							'PRIORITY MAIL INT FLAT RATE BOX' => 'Priority Mail International Flat Rate Box',
							'FIRST-CLASS MAIL INT' => 'First-Class Mail International');

I'm also not clear on the database change.

A column of VARCHAR is of limited size (around 255 characters from the top of my head). To store all the possible methods in the table a bigger column size is needed. Therefore the change from VARCHAR to TEXT. This is something you need to do in phpMyAdmin.

Share this post


Link to post
Share on other sites
I downloaded version 3.0.2 from here (I'm not 100% certain we are talking about the same contribution) and in the catalog/includes/modules/shipping/usps.php I found that piece of text on line 58 (line 50-58 shown):

 

	  $this->intl_types = array('GLOBAL EXPRESS' => 'Global Express Guaranteed',
							'GLOBAL EXPRESS NON-DOC RECT' => 'Global Express Guaranteed Non-Document Rectangular',
							'GLOBAL EXPRESS NON-DOC NON-RECT' => 'Global Express Guaranteed Non-Document Non-Rectangular',
							'EXPRESS MAIL INT' => 'Express Mail International (EMS)',
							'EXPRESS MAIL INT FLAT RATE ENV' => 'Express Mail International (EMS) Flat Rate Envelope',
							'PRIORITY MAIL INT' => 'Priority Mail International',
							'PRIORITY MAIL INT FLAT RATE ENV' => 'Priority Mail International Flat Rate Envelope',
							'PRIORITY MAIL INT FLAT RATE BOX' => 'Priority Mail International Flat Rate Box',
							'FIRST-CLASS MAIL INT' => 'First-Class Mail International');

 

A column of VARCHAR is of limited size (around 255 characters from the top of my head). To store all the possible methods in the table a bigger column size is needed. Therefore the change from VARCHAR to TEXT. This is something you need to do in phpMyAdmin.

 

 

I have USPS Methods 4.3.0 ALPHA which does not have that same text. Is version 3.0.2 better to use?

Share this post


Link to post
Share on other sites
I have USPS Methods 4.3.0 ALPHA which does not have that same text. Is version 3.0.2 better to use?

The download mentioned 4.3.0 alpha hasn't been tested so that doesn't instill a lot of trust. But perhaps it works fine. I don't use either so I can't tell you if there are issues with those versions.

Share this post


Link to post
Share on other sites

Jan, I have changed to version 3.0.2, but I am receiving a Parse error and the International options are not showing up in Admin. According to the trouble shooting, I need to use phpMyAdmin to update the database -> configuration TABLE

and CHANGE "set_function" to TEXT from VARCHAR.

 

I have never done this in phpMyAdmin. Can you coach me on this? Appreciate your help.

Share this post


Link to post
Share on other sites
Jan, I have changed to version 3.0.2, but I am receiving a Parse error and the International options are not showing up in Admin. According to the trouble shooting, I need to use phpMyAdmin to update the database -> configuration TABLE

and CHANGE "set_function" to TEXT from VARCHAR.

 

I have never done this in phpMyAdmin. Can you coach me on this? Appreciate your help.

Not really, I seldom use phpMyAdmin. But if you use this command in the sql text input, or copy and paste it to a text file and use that for an sql file then it should work.

ALTER TABLE `configuration` CHANGE COLUMN `set_function` `set_function` text default NULL;

Share this post


Link to post
Share on other sites
Not really, I seldom use phpMyAdmin. But if you use this command in the sql text input, or copy and paste it to a text file and use that for an sql file then it should work.

ALTER TABLE `configuration` CHANGE COLUMN `set_function` `set_function` text default NULL;

 

 

Got it! It's working perfectly now. Thank you SO much.

Share this post


Link to post
Share on other sites
USPS put me in production and now it work great!

Thanks for the contribution!

 

Wayne

 

 

Even after I have been put in production mode at ICCI for USPS I am still getting the same error anyone please help

 

United States Postal Service United States Postal Service

An error occured with the USPS shipping calculations.

If you prefer to use USPS as your shipping method, please contact the store owner.

Share this post


Link to post
Share on other sites

I hate to mention this, but exactly how to fix the parse error mentioned above is mentioned in the "troubleshooting" section of 3.0.2 - it says exactly what Jan mentioned above. I usually try to include this info in an addon installation doc if I know of a particular issue. Thank you to Jan for answering it anyways and providing the SQL statement.

 

Scott

Edited by olsonsp4c

Share this post


Link to post
Share on other sites

Hi, I am trying to install the USPS Methods 4_3_0 and I am getting a syntax error in an unrelated area. The error I am getting is:

Parse error: parse error, unexpected T_CONSTANT_ENCAPSED_STRING, expecting ',' or ';' in modules.php on line 173

 

The actual line of code from catalog/admin/modules.php is:

 

echo ' <tr id="defaultSelected" class="dataTableRowSelected" onmouseover="rowOverEffect(this)" onmouseout="rowOutEffect(this)" onclick="document.location.href='' . tep_href_link(FILENAME_MODULES, 'set=' . $set . '&module=' . $class . '&action=edit') . ''">' . "n";

 

Can anyone spot the error in this line of code?

Share this post


Link to post
Share on other sites

I havn't been checking up on you guys lately. Has everyone gotten v4.3.0 to work properly? I've read all the posts and it seems it is okay except for the lengthy install document which confuses some people to miss steps. I'm going to look at Olson's v3 with separate ounces and pounds and try to steal his work. lol, just kidding. I'll give you credit.

 

I'll look into the above error.

Edited by naps1saps

Share this post


Link to post
Share on other sites
I havn't been checking up on you guys lately. Has everyone gotten v4.3.0 to work properly? I've read all the posts and it seems it is okay except for the lengthy install document which confuses some people to miss steps. I'm going to look at Olson's v3 with separate ounces and pounds and try to steal his work. lol, just kidding. I'll give you credit.

 

I'll look into the above error.

 

Hey Greg,

 

feel free to steal away and I don't need credit :) I appreciate all your efforts...

 

Scott

Share this post


Link to post
Share on other sites
I havn't been checking up on you guys lately. Has everyone gotten v4.3.0 to work properly? I've read all the posts and it seems it is okay except for the lengthy install document which confuses some people to miss steps. I'm going to look at Olson's v3 with separate ounces and pounds and try to steal his work. lol, just kidding. I'll give you credit.

 

I'll look into the above error.

 

Greg,

Welcome back!

I managed to snag a php programmer locally and he solved the syntax error for me. I am not sure why the error only showed up when I tried to modify the file, but I have found several other files with errors that behave similarly. The php files seem to run fine until they are edited and then old syntax errors rear their ugly heads.

Share this post


Link to post
Share on other sites
I havn't been checking up on you guys lately. Has everyone gotten v4.3.0 to work properly? I've read all the posts and it seems it is okay except for the lengthy install document which confuses some people to miss steps. I'm going to look at Olson's v3 with separate ounces and pounds and try to steal his work. lol, just kidding. I'll give you credit.

 

I'll look into the above error.

 

 

I should have added that v4.3.0 is running fine for me now. The only issue I have is that it is not including first class international. I read somewhere in the forum that USPS change the case of the entries, and I suspect that is the problem with first class int'l. Is a change required in the text for that?

Share this post


Link to post
Share on other sites
Greg,

Welcome back!

I managed to snag a php programmer locally and he solved the syntax error for me. I am not sure why the error only showed up when I tried to modify the file, but I have found several other files with errors that behave similarly. The php files seem to run fine until they are edited and then old syntax errors rear their ugly heads.

 

You should always edit your files with notepad. if it looks like garbage without returns, open it in wordpad, save, then open in notepad. That will decode the returns into something notepad recognizes. Notepad is a character editor, wordpad encodes the file for character attributes (bold, underline, ...). If you paste something into wordpad, the formatting is pasted as well like size, font, ... Notepad just pastes the characters, that's all. This should keep your files readable no matter what code you are pasting into it.

 

I took a quick look and I think this is what it is called:

It is called "First Class Mail International"

domestic is called "First Class Mail"

Edited by naps1saps

Share this post


Link to post
Share on other sites
Hey Greg,

 

feel free to steal away and I don't need credit :) I appreciate all your efforts...

 

Scott

What weight is separated? When I was thinking of separating weight, I wanted to use an ounce and pound value for products. This doesn't seem to be the case.

Share this post


Link to post
Share on other sites
What weight is separated? When I was thinking of separating weight, I wanted to use an ounce and pound value for products. This doesn't seem to be the case.

 

It is separated in 3.0.2 so that it only displays pounds and ounces to the customer, but it still submits to usps as a unit.

 

Also, I'll through in my thoughts on an editor - I prefer "Notepad++" - it is amazing...

 

Scott

Share this post


Link to post
Share on other sites
I just installed 4.3.0 ALPHA following all instructions as described in the text document and it works perfectly. So far I have not run into any issues. Rates are displayed as expected.

 

I have installed v. 3.0.2 and updated my database but I can't seem to get this addon to work for me. So I decided to give v. 4.3.0 ALPHA a shot, and I still have the same error:

 

United States Postal Service United States Postal Service

An error occured with the USPS shipping calculations.

If you prefer to use USPS as your shipping method, please contact the store owner

 

I've been searching for an answer and so far found that one other person has the same error I have. Can someone point me towards the direction I need to go so I can get this contribution to work? Thanks.

Share this post


Link to post
Share on other sites
I have installed v. 3.0.2 and updated my database but I can't seem to get this addon to work for me. So I decided to give v. 4.3.0 ALPHA a shot, and I still have the same error:

 

United States Postal Service United States Postal Service

An error occured with the USPS shipping calculations.

If you prefer to use USPS as your shipping method, please contact the store owner

 

I've been searching for an answer and so far found that one other person has the same error I have. Can someone point me towards the direction I need to go so I can get this contribution to work? Thanks.

 

Alright, I reverted back the USPS module that came standard with fresh install and it still won't work. I contacted USPS and they told me I'm on production server and I need to contact someone in osCommerce. Just to be sure, I tested my username and password on another site that runs on Virtuemart to see if works and it does with no problems. So that proves they did move me to production.

 

I have entered my zip code and selected the country in the configuration, so I'm sure it's not the configuration.

 

I reinstalled the addon and it's still not working. Any ideas why?

Edited by asianknight7664

Share this post


Link to post
Share on other sites
Alright, I reverted back the USPS module that came standard with fresh install and it still won't work. I contacted USPS and they told me I'm on production server and I need to contact someone in osCommerce. Just to be sure, I tested my username and password on another site that runs on Virtuemart to see if works and it does with no problems. So that proves they did move me to production.

 

I have entered my zip code and selected the country in the configuration, so I'm sure it's not the configuration.

 

I reinstalled the addon and it's still not working. Any ideas why?

 

It could be several things:

 

1. Your USPS account is not set to "Production"

2. I think 4.0.3 requires the password, 3.0.2 you just put the login 2x (as the password)

3. The USPS servers are overloaded and can't handle your request (in this case, there is no solution except installing the USPS addon that works if the USPS servers are down)

 

Scott

Share this post


Link to post
Share on other sites
It could be several things:

 

1. Your USPS account is not set to "Production"

2. I think 4.0.3 requires the password, 3.0.2 you just put the login 2x (as the password)

3. The USPS servers are overloaded and can't handle your request (in this case, there is no solution except installing the USPS addon that works if the USPS servers are down)

 

Scott

 

Thanks for the reply Scott.

 

I've entered my username and password, and made sure that USPS placed my profile on production as well as have rate calculator enabled. Unfortunately, I still get the same error. I installed the addon you recommended, and still have the error message. I don't know where else to look for answers. :huh:

Share this post


Link to post
Share on other sites
Thanks for the reply Scott.

 

I've entered my username and password, and made sure that USPS placed my profile on production as well as have rate calculator enabled. Unfortunately, I still get the same error. I installed the addon you recommended, and still have the error message. I don't know where else to look for answers. :huh:

 

is this on domestic or international shipping? If it is international shipping, it is because the USPS changed their definitions for the database last week, so all USPS international shipping modules are broken except my USPS Priority Mail Flat Rate Shipping addon because it does not connect to USPS at all. I hope to have time to work on a fix for this sometime soon as all USPS modules are now broken due to the change including the stock osC module for international shipping.

 

Scott

Share this post


Link to post
Share on other sites
is this on domestic or international shipping? If it is international shipping, it is because the USPS changed their definitions for the database last week, so all USPS international shipping modules are broken except my USPS Priority Mail Flat Rate Shipping addon because it does not connect to USPS at all. I hope to have time to work on a fix for this sometime soon as all USPS modules are now broken due to the change including the stock osC module for international shipping.

 

Scott

 

It's both. For some reason I'm not able to get any of the rates to show up at all, just an error message stating an occurred with the shipping calculations. I'm trying to access my logs to see if I can find out exactly what's causing the error. I'll be happy if I can just get the domestic rate working.

Share this post


Link to post
Share on other sites

Okay, I searched through the log and couldn't find anything that indicates that the USPS sent anything to server. So I uncommented line 526 in the usps.php file located in includes/modules/shipping directory and had it email me the rates. When I checked my inbox, I got the e-mail however the message is blank. I understand that I'm suppose to see email text in XML format, but I don't.

 

Would this indicate that it's possible something is preventing the USPS from showing the rates on my site? I have added a few addons, however, I have reasons to believe that none of them could really interfere with them. Any ideas?

Edited by asianknight7664

Share this post


Link to post
Share on other sites

Have instaled both the 4.2.1 and 4.3.

 

Deinstalled and reinstalled and edited the admin options.

 

In 4.3 entered user name and pw and they were replaced with the word array after update.

 

In 4.2.1 ticked various option and after update this is displayed.

 

 

USPS Options

Array

 

Domestic Insurance Options

None

 

International Insurance Options

None

 

Domestic Shipping Methods

Array

 

Int'l Shipping Methods

Array

 

Can't find anything yet in the forum but will keep looking.

 

Any thoughts?


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×