Jump to content
bad_lemming

[Contribution] - USPS Methods

Recommended Posts

Okay, calm down Christian. There is a reason there is a community, and that is to help.

Individuals write the contributions, not huge companies. People sometimes make mistakes. You just have to live with that.

 

This is one of the reasons we all do it ourselves = To save money. We expect that we will have to put the time and effort into it. That is a given. You just have to be patient and learn, or pay the mega-bucks for a shopping cart.

 

The file that you are looking for is in the USPSMethods2.7 package, not the 2.7a, b, c, or d.

 

Hope that helps.

Blessings,

Dave

Edited by Highway of Life

I am a little pencil in the hand of a writing God who is sending a love letter to the world.

--Mother Teresa

Share this post


Link to post
Share on other sites

Very Meekly,

Wow that works great. Only one question though. I have looked everywhere about setting the default weight unit. On the documentation pages it says that you can set it on the localization page in admin. But my admin doesn't look any thing like theirs. Also made the changes listed in this post http://forums.oscommerce.com/index.php?sho...45entry328845 but that didn't help either. All my wieghts are entered in ounces so I set the line to be

 define('MODULE_SHIPPING_ZONES_TEXT_UNITS', 'oz(s)');

But when I do a test sale webtools API is calculating pounds. Any help on this would be most appreciated.

Thanks


On your last day only you will have to approve or disaprove of how your life has been.

Share this post


Link to post
Share on other sites

My default is pounds, and in the checkout_shipping.php all the shipping modules display pounds in tenths.

 

When you test buy an item that is .5lbs (8 oz), what does your shipping modules display? And remember, there is pre-defined packaging weight that it will add to your order.

 

Are you trying to get it to display pounds or ounces?


I am a little pencil in the hand of a writing God who is sending a love letter to the world.

--Mother Teresa

Share this post


Link to post
Share on other sites

Thanks for your reply Dave

Currently what is displayed at the Dilivery information page is

This is currently the only shipping method available to use on this order. 

United States Postal Service (1 x 6.5lbs) 

EXPRESS $33.45 

Priority $6.80

So that is one item at 6.5 lbs but it should be one item at 6.5 ounces.

You can check it out yourself at http://www.kolympia.com/Shop/

currently there are no payment methods defined so you can use the 4111 credit card method to make a test sale.

The problem for me is that I have 580 products entered and having to edit them all to reflect the math of oz to lbs is something that I would rather avoid.

Christian


On your last day only you will have to approve or disaprove of how your life has been.

Share this post


Link to post
Share on other sites

Thanks, the extra info helps.

 

I don't know where to change the default weight for calculation, but in shipping/usps.php on around line 82...

if (in_array('Display weight', explode(', ', MODULE_SHIPPING_USPS_OPTIONS))) {
       $shiptitle = ' (' . $shipping_num_boxes . ' x ' . $shipping_weight . 'lbs)';
     } else {
       $shiptitle = '';
     }

You can change the display there.

Sorry I can't be of more help, I have not crossed that bridge myself.

You might try calling USPS help.

 

Good luck,

Dave

Edited by Highway of Life

I am a little pencil in the hand of a writing God who is sending a love letter to the world.

--Mother Teresa

Share this post


Link to post
Share on other sites

Thanks again Dave,

After a lot of searching it seems that there is no work around editing every item. Groan.

Christian


On your last day only you will have to approve or disaprove of how your life has been.

Share this post


Link to post
Share on other sites

What do people do if they want KGs?

There must be a simpler way.

Since you have so many items, you might check into easy populate.

 

Blessings,

Dave


I am a little pencil in the hand of a writing God who is sending a love letter to the world.

--Mother Teresa

Share this post


Link to post
Share on other sites

Easypopulate just trashed my database


On your last day only you will have to approve or disaprove of how your life has been.

Share this post


Link to post
Share on other sites

I've tried testing out the international side of this and recieved this error message during the delivery information

 

United States Postal Service

-2147219080 - Missing value for Country.

Share this post


Link to post
Share on other sites

After going through and finding the errors caused by Easypopulate and correcting them. I entered the weights Decimalized ie 8oz = .5lb so 20oz = 1.25lb. When I do a test order I still get weird results. For an item that has a weight entered as 1.62 roughly 1lb 11oz I get this result from the usps shipping.

United States Postal Service (1 x 3.12lbs) 

EXPRESS $24.20

Priority $5.30

So what is the usps standard for entering units. I know that it is all pounds, but is is pounds decimalized. Or 1.1 for one pound one once or what. I looked everywhere on the USPS site they don't seem to have a clue.

Any help on this would be appreciated.


On your last day only you will have to approve or disaprove of how your life has been.

Share this post


Link to post
Share on other sites

Pounds decimalized.

 

What are your defaults in the Configuration > Shipping / Packaging administration?

 

And what is the product weight of your E DVD product?


I am a little pencil in the hand of a writing God who is sending a love letter to the world.

--Mother Teresa

Share this post


Link to post
Share on other sites

Mike: The USPS error looks like you don't have your store location and zone set up completely in your Admin area


I am a little pencil in the hand of a writing God who is sending a love letter to the world.

--Mother Teresa

Share this post


Link to post
Share on other sites

Dave thanks again for your help. Turns out that I still had a tare weight entered in ounces instead of pounds decimalized.


On your last day only you will have to approve or disaprove of how your life has been.

Share this post


Link to post
Share on other sites

I am experiencing a similar error to Mike above: :blush:

 

2147219080 - Missing value for Country.

 

This occurs during checkout_shipping when shipping is being quoted, on an installation that has been working for the last two years. It works perfectly on all addresses that I know of EXCEPT to the Virgin Islands (US).

 

The mailing address is (sort of) Tilly Tester, PO Box 123456, St. Thomas 00803, Virgin Islands (US)

 

My customer has tried entering VI and Virgin Islands (US) as the State and selecting it from States dropdown. She tried using United States as country and Virgin Islands (US) as country. All combinations get the same rejection from the USPS quote request.

 

Interestingly, UPS quotes a price and shipped ok, even though the address is a PO Box.... She did get her order processed finally using a street address and paying the $12 extra for UPS, but she is asking for a refund on it. :'(

 

Anyway, I notice in usps.php there is no country code for US Virgin Islands. The Zip Code gets a "national" quote on the usps.com website.

 

Any Ideas?????

Share this post


Link to post
Share on other sites

Sorry if this is too obvious, but did you check admin -> shipping/packaging -> country of origin ? Also for the virgin Island thing admin -> locations/ taxes -> countries -> page 12.


On your last day only you will have to approve or disaprove of how your life has been.

Share this post


Link to post
Share on other sites

I have installed the moded modules.php and general.php form 2.7 and the last posted usps.php in both locations. Here is my error:

 

Fatal error: Cannot redeclare class usps in /catalog/includes/modules/shipping/usps.php on line 14

 

When I go back and put in the original usps.php from 2.7 it works without error at least on the configuration side, Store side is a totally different issue as it now loads with:

 

Fatal error: Cannot redeclare tep_set_banner_status() (previously declared in catalog/includes/functions/general.php:694) in catalog/includes/functions/banner.php on line 15

 

Any help is appreciated.

Share this post


Link to post
Share on other sites

I removed the usps module from the configuraiton, resotred all of the original files. Everything is fine on the configuration side of things but the store is gone...

 

 

Fatal error: Cannot redeclare tep_set_banner_status() (previously declared in /catalog/includes/functions/general.php:694) in /catalog/includes/functions/banner.php on line 15

 

I then resorted everything from a full backup. Same freaking error. What is going on?

Share this post


Link to post
Share on other sites

I just added USPS Methods 2.7d to my store and now when I go to "install" the module nothing happens. I cannot edit the module.

 

I've tried deleting and reinstalling the files which was suggested in some other posts, but this too is not working.

 

Does anyone have a suggestion?

Share this post


Link to post
Share on other sites
I just added USPS Methods 2.7d to my store and now when I go to "install" the module nothing happens.  I cannot edit the module. 

 

I've tried deleting and reinstalling the files which was suggested in some other posts, but this too is not working.

 

Does anyone have a suggestion?

What files did you install/modify?

I am a little pencil in the hand of a writing God who is sending a love letter to the world.

--Mother Teresa

Share this post


Link to post
Share on other sites
I'm a little confused.  I am about to install this contribution.  Yet, there is a 25 Apr 2005 update.  Only thing in this update is another usps.php file.  Does this replace the one in:

catalog/includes/modules/shipping/usps.php

or

catalog/includes/languages/english/modules/shipping/usps.php

 

Much appreciate any help,

David

 

OK, where does it go????? Thanks :blink:

Share this post


Link to post
Share on other sites
OK, where does it go????? Thanks :blink:

Should be catalog/includes/modules/shipping/usps.php

But confirm by comparing the files.

 

Highway


I am a little pencil in the hand of a writing God who is sending a love letter to the world.

--Mother Teresa

Share this post


Link to post
Share on other sites

The version of usps.php of USPS methods, with Bill Sanguinette's modified version to support insurance, isn't working. It doesn't give any errors, it simply seems like it's the name is the regular usps methods version, it gives the same prices. My site has qtpro installed in addition. Has anyone seen this? Do I need to do more than drop in the new usps.php file? Where are the docs, Bill?

Share this post


Link to post
Share on other sites

I am using the updated usps.php by "Bill Sanguinetti 25 Apr 2005" which includes the USPS Insurance addon. It seems to work fine. My question is this: can someone alter this to make the insurance optional for the customer? I want to enable it but I dont want it to be on by default - I want the customer to decide if they would like insurace (and display the price as well).

Share this post


Link to post
Share on other sites
The version of usps.php of USPS methods, with Bill Sanguinette's modified version to support insurance, isn't working. It doesn't give any errors, it simply seems like it's the name is the regular usps methods version, it gives the same prices. My site has qtpro installed in addition. Has anyone seen this? Do I need to do more than drop in the new usps.php file? Where are the docs, Bill?

 

All right, I should have guessed this earlier, but well if there was documentation to remind me, I wouldn't have to post a message in this forum ;)

 

I merely forgot that I would have to remove and re-install the usps module. Oops. Stuff works now. But I am still worried. I'd like there to be an option of insurance, in some countries, with insurance forced to other countries where there is unreliable shipping. Hrm.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×