Jump to content
Sign in to follow this  
PandA.nl

HTML template for the BTS

Recommended Posts

The HTML template for the BTS is targetted at users that have the BTS pre-installed but, for whatever reason, would rather edit an HTML template (in stead of a PHP enabled template).

 

requires at least the BTSv1.5x (=> any BTSv.1.5 version will do) to be installed

affected files: none (drop in template)

estimated time needed for installation: < 1 minute

 

It's an STS alike addon, it even uses the same tag names as much as possible, so (hopefully) switching and converting templates between the two will be easy.

 

download: http://www.oscommerce.com/community/contributions,3126


Please do not PM me for support, I will not respond anyway.

Share this post


Link to post
Share on other sites

Hi this is me again =)

 

I'd tried to install it on CRE

but

i get this:

Warning: main(templates/HTML/boxes.tpl.php): failed to open stream: No such file or directory in c:\program files\easyphp1-8\www\cre_loaded_osc_6.0_sp1.2_rc2\catalog\includes\template_application_top.php on line 107

Fatal error: main(): Failed opening required 'templates/HTML/boxes.tpl.php' (include_path='.;C:\PROGRA~1\EASYPH~1\\php\pear\') in c:\program files\easyphp1-8\www\cre_loaded_osc_6.0_sp1.2_rc2\catalog\includes\template_application_top.php on line 107

 

I look closely and every template in CRE gat an boxes.tpl.php

 

I tried to add an random boxes.tpl.php from another template (i know this is bad) and i get:

Warning: file_get_contents(templates/main_page.html): failed to open stream: No such file or directory in c:\program files\easyphp1-8\www\cre_loaded_osc_6.0_sp1.2_rc2\catalog\templates\HTML\main_page.tpl.php on line 11

 

And nothing else i really don't know what to do with this :-/

 

I put the main_page.html in /templates

Just get a blank page :-/

Edited by tenshu

Share this post


Link to post
Share on other sites

*cannot edit sorry*

 

Blank page but the <head></head> is good :-/

 

Damn it make the same thing with sts for the bts

 

If nobody could help i will go back under MS2

Share this post


Link to post
Share on other sites

Hi tenshu,

 

If nobody could help i will go back under MS2

I took a quick look at the cre code yesterday, but it didn't make me feel optimistic I'm afraid :( . It looks quite messy to be honest (but a closer look could possibly change my opinion). Maybe one of the programmers over there could give it a shot, the "HTML for the BTS" script itself is quite clean. And, not sure if you know it, but we can't support cre at this board, so discussing details is not possible here anyway.

 

I've got a new version in my mind by the way, the current version makes changing the template php code a bit more confusing probably, if I find some spare time I hope to make that part a lot easyer. The idea is to create an extra template, alike the HTML template, which contains all php code (marked by the same tags as are being used in the HTML template).

Edited by PandA.nl

Please do not PM me for support, I will not respond anyway.

Share this post


Link to post
Share on other sites

I have the same problem :'(

 

Warning: main(templates/HTML/boxes.tpl.php): failed to open stream: No such file or directory in /home/xxxcom/shop/includes/template_application_top.php on line 92

Warning: main(templates/HTML/boxes.tpl.php): failed to open stream: No such file or directory in /home/xxxcomcom/shop/includes/template_application_top.php on line 92

Fatal error: main(): Failed opening required 'templates/HTML/boxes.tpl.php' (include_path='.:/usr/local/lib/php') in /home/xxxcom/shop/includes/template_application_top.php on line 92

 

What can i do?..

Share this post


Link to post
Share on other sites
I have the same problem  :'(

 

Warning: main(templates/HTML/boxes.tpl.php): failed to open stream: No such file or directory in /home/xxxcom/shop/includes/template_application_top.php on line 92

Warning: main(templates/HTML/boxes.tpl.php): failed to open stream: No such file or directory in /home/xxxcomcom/shop/includes/template_application_top.php on line 92

Fatal error: main(): Failed opening required 'templates/HTML/boxes.tpl.php' (include_path='.:/usr/local/lib/php') in /home/xxxcom/shop/includes/template_application_top.php on line 92

 

What can i do?..

won't be very easy I'm afraid. The cre bts code differs too much, so their coders should create something alike to make it work. Or someone else who feels like to dig into the cre code of course. It's a bit to messy for me.

Please do not PM me for support, I will not respond anyway.

Share this post


Link to post
Share on other sites

Great contribution,

 

I was wondering, how do I change the design for specific content pages like "product_info.php"

 

In the regular templates, there is a folder called "content", but there isn't in the template of this contribution.

 

I just would like to know how to chagne the product info design, thanks

 

Steve

Share this post


Link to post
Share on other sites
In the regular templates, there is a folder called "content", but there isn't in the template of this contribution.

 

I just would like to know how to chagne the product info design, thanks

I am not sure if it will help you to achieve wat you want but, if you want to edit the content files you can just create a "content" folder iside the HTML template dir and copy needed content file(s) from the fallback/content dir to it and edit it as you like (it will automaticly replace the file with the same name inside the fallback/content folder).

But please note that these content files are not HTML templates! Also these only control the center middle part, not the main layout (but you probably already knew that?).

 

hth (a bit :) )

Paul

Edited by PandA.nl

Please do not PM me for support, I will not respond anyway.

Share this post


Link to post
Share on other sites

Thanks, did exactly what I needed. One more thing. How do I get the login box to appear? I noticed it wasn't in main_page.code.php but when I do the following:

 

//begin{loginbox}                      
   include(DIR_WS_BOXES . 'loginbox.php');
//end{loginbox}  

 

It doesn't show the box, just shows the header_account.gif

 

Helps appreciated, thanks

Share this post


Link to post
Share on other sites

Hi Steve,

 

Thanks, did exactly what I needed. One more thing. How do I get the login box to appear?
the login box ?

 

Assuming your login box code should work, it could be possible that you have a login_box.tpl.php file (in the fallback/boxes dir or HTML/boxes dir) that messes things up.

 

But which login box do you exactly have?


Please do not PM me for support, I will not respond anyway.

Share this post


Link to post
Share on other sites
Here's an example of the login box I want:

 

http://inagiftbasket.com/ <- right column

 

but what I'm getting is just an image "header_account.gif"

The BTS boxes are a bit different from standard osC boxes, so you need a login box that is made for the BTS. I converted a login box contri to the BTS once, I will take a look, and probably adapt it so it is fully compatible with the BTSv1.5 (which should be easy)


Please do not PM me for support, I will not respond anyway.

Share this post


Link to post
Share on other sites

Ok,

 

the new login box code is ready. Makinging it ready for the BTSv1.5 was very easy, but I decided to clean it up a little and add a forgotten password and create account link to the box as well (multi-langual).

 

(it will probably released next monday, after Steve has tested it)

 

Now back to an important issue:

Thanks, did exactly what I needed. One more thing. How do I get the login box to appear? I noticed it wasn't in main_page.code.php but when I do the following:

 

//begin{loginbox}                      
   include(DIR_WS_BOXES . 'loginbox.php');
//end{loginbox}  

 

It doesn't show the box, just shows the header_account.gif

Once you've got the BTS ready loginbox, you may indeed add it like that to the php code template (main_page.code.php). Where you put it does not have any influence on how it works, but I would put it somewhere between the other boxes.

 

But if you don't want the loginbox to appear when someone's allready logged in for example, and maybe you want the (included) to appear it's nicer to add it like this:

 

//begin{loginbox}    
 if ( (!strstr($_SERVER['PHP_SELF'],'login.php') and !strstr($_SERVER['PHP_SELF'],'create_account.php')) | tep_session_is_registered('customer_id') )
 {
   if (!tep_session_is_registered('customer_id'))
   {
   require(DIR_WS_BOXES . 'login.php');
   }
    else
   {
   require(DIR_WS_BOXES . 'account.php');
   }
 }
//end{loginbox}

(just an example, change it depending on when you want the boxes to appear)

 

Remind that the begin tag is very important "//begin{loginbox}" (it is used by the script).

 

 

And now that the code is ready, you only need to add the same tag (but without the "//" so add": "{loginbox}") to your HTML template (main_page.html), where ever you the boxe(s) to appear.


Please do not PM me for support, I will not respond anyway.

Share this post


Link to post
Share on other sites
So far have had no problems with it.

steve

Thanks for letting us know steve :)

 

Especially since I haven't had much feedback yet (which is not suprising, since the number of template structure users will be very limited, until ms3 has been released)


Please do not PM me for support, I will not respond anyway.

Share this post


Link to post
Share on other sites

hmm.. this is very odd but every time i install either of your contribs (html or sts for bts) i get an htaccess login panel appear when using the relevant template. I've searched through the directorys and deleted any htacccess that appear, but howcome it doesnt do it on the other BTS templates?

Edited by adiwillow

Share this post


Link to post
Share on other sites

Don't know the answer to your question, but I have uploaded two new contributions this week, two new templates for BTS. One is called Cobalt and the other Flame. The links are in my signature. They're pretty basic, but I have annotated all of the important styles in the css file so that people know at a glance what changes what.

 

Vger

Share this post


Link to post
Share on other sites
hmm.. this is very odd but every time i install either of your contribs (html or sts for bts) i get an htaccess login panel appear when using the relevant template

very odd indeed, I never experienced it myself or even heard about it before. The only .htaccess that is included in the BTS has a "deny from all" line. And that should show you something like:
Forbidden

You don't have permission to access to this document on this server.

when you try to access the templates dir itself. Removing this .htaccess file might result in security problems btw!

 

That it does not happen with the other templates does not suprise me, there is no logical reason that I can think of that a login screen would appear. I think it has something to do with your server settings or something.

 

@Rhea: nice initiative to make these templates available :) . I haven't tried them yet, but I surely will do so soon.


Please do not PM me for support, I will not respond anyway.

Share this post


Link to post
Share on other sites

Hi.. justinstalled this.. great contrib.. but having trouble with 'infoBoxLT' class .. what is it? Where is it? Why does it crash dreamweaver whenever i try and find it ?

Share this post


Link to post
Share on other sites

in fact, following from my above post, most of the css appears to be missing.. where is it?

 

classes such as 'screenshotsHeaderText' and screenshotsBlock' are nowhere to be seen !

 

have i missed something here?

Share this post


Link to post
Share on other sites

Hi

 

I have a new install of OS and installed the BTS - which works great.

 

I installed the HTML for BTS but all that is rendered is a coloured bar and the actual tags themselves - not the contents of the tags.

 

What have I missed please? :blink:

Share this post


Link to post
Share on other sites

Did anyone find the answer for the above post? I am getting the same thing since I was moved to a PHP5 server. It appears the code that determines php or html is failing so it all defaults to html.

 

Line 23 is where the logs show the error, line 14 is the array 23 points to that gives the error and the function for the array is about line 30ish.

 

The code is doing a read php . I don't know if the tags need changed or just what it is trying to look at to make the determination.

 

Any help would be appreciated.

Share this post


Link to post
Share on other sites
Did anyone find the answer for the above post? I am getting the same thing since I was moved to a PHP5 server. It appears the code that determines php or html is failing so it all defaults to html.

 

Line 23 is where the logs show the error, line 14 is the array 23 points to that gives the error and the function for the array is about line 30ish.

 

The code is doing a read php . I don't know if the tags need changed or just what it is trying to look at to make the determination.

 

Any help would be appreciated.

 

I don't understand this contribution. If you are wanting HTML templates that work like STS, why not simply install STS and use it instead?

 

STSv4.5.8 has a ton of features such as infobox HTML templates, category HTML templates, product HTML templates, etc. etc.

 

It works with PHP3, PHP4 and PHP5.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×