Jump to content
Sign in to follow this  
theinternetfoundry

OSC XML Feed - Help & Discussion

Recommended Posts

Hi I get the following error when i try to view the xml.php file on IE7

 

The XML page cannot be displayed

Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later.

 

 

--------------------------------------------------------------------------------

 

A string literal was expected, but no opening quote character was found. Error processing resource 'http://www.gamefuse.com...

 

<?xml version="1.0" ?><STOREITEMS><CREATED value="Mon Apr 2 17:44:37 EST 2007"><PRODUCT ITEM='40'>&l...

 

 

 

how can i view the feed in IE7?

 

How do i connect my windows excel to view the feed?

Share this post


Link to post
Share on other sites
Hi I get the following error when i try to view the xml.php file on IE7

 

The XML page cannot be displayed

Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later.

--------------------------------------------------------------------------------

 

A string literal was expected, but no opening quote character was found. Error processing resource 'http://www.gamefuse.com...

 

<?xml version="1.0" ?><STOREITEMS><CREATED value="Mon Apr 2 17:44:37 EST 2007"><PRODUCT ITEM='40'>&l...

how can i view the feed in IE7?

 

How do i connect my windows excel to view the feed?

 

I get the same error with IE7 can anyone help with this

Share this post


Link to post
Share on other sites

I am using this contribution and it is really great.

 

But I have one problem. I have turned "pricing_show_specials" on ... it displays special price

But if I have special price inserted into special price table and i have than turned it off, the xml feed still displays the special price (not the normal - even if the special price is disabled)

 

Any idea how to fix this?

Share this post


Link to post
Share on other sites

Hy,

 

I've installed this contribution, it's great....

I need to add product description to the XML output... I've tryed sevral thing but nothing worked...

Did anyone done this succesfuly ? or does anyone know how to do that?

 

tnx in advance

Share this post


Link to post
Share on other sites

Hi,

 

Yes, the contrib it's great. Like wi-fi I need to add the product description to xml file. How can I do this?

 

Tnank you.

Edited by auro

Share this post


Link to post
Share on other sites

Hello,

 

Just thought I would share this for those who have added product descriptions and are struggling with illegal characters.

 

Add this code which encode special characters.

 

<php>

if ($product_description == 1) {

$row['products_description'] = htmlspecialchars($row['products_description'], ENT_QUOTES);

}

</php>

 

if that doesn't work then you might try this; all characters which have HTML character entity equivalents are translated into these entities.

 

<php>

if ($product_description == 1) {

$row['products_description'] = htmlentities($row['products_description']);

}

</php>

 

Hope this helps,

Simon


Gynogapod - Great Products, Tiny Prices!

Share this post


Link to post
Share on other sites

Thank you Simon for the hint about the product descrption... But this is appears in the xml with the html tags

like :

 

<p>><span style="font-size: 10pt; color: #363636;>my description</span></p>

as it is saved in the database like this way.

 

 

But I want to just display the text (pure text) with no tags....

 

How can I do that?

Share this post


Link to post
Share on other sites

I am using this contribution and it is really great. But now I need to add JavaScript to some product description fields.

 

I am adding this java script:

<script language="JavaScript" src="http://www.minotaur.cz/sfaf/catalog/audio/audio-player.js"></script>
<object type="application/x-shockwave-flash" data="http://www.minotaur.cz/sfaf/catalog/audio/player.swf" id="audioplayer1" height="24" width="290">
<param name="movie" value="http://www.minotaur.cz/sfaf/catalog/audio/player.swf">
<param name="FlashVars" value="playerID=1&soundFile=http://www.minotaur.cz/sfaf/catalog/audio/004383.mp3">
<param name="quality" value="high">
<param name="menu" value="false">
<param name="wmode" value="transparent">
</object>

 

Is there any way how to force the feed generator to skip the script?

Share this post


Link to post
Share on other sites

Hi everyone,

 

This contributions comes very close to what i'm looking for.

But as i'm not very familiar with programming i really would like to have some help.

 

I would like to create a product feed for an advert website to put in my products automatically.

The attribute categorie and subcategorie are parameters given by the advertwebsite to place the product ad, in a specified category.

 

Is this possible or do i need another contribution?

 

The parameters they need are the following;

 

<item>

<categorie> 1 </categorie> *

<subcategorie>Glas/kristal</subcategorie> *

<prijs>250,00</prijs>

<titel>waterkan</titel>

<omschrijving>Donkerpaarse waterkan, macaroni uit 1933. van Rozendaal uitgevoerd bij maastricht. Ruim 14,5 cm hoog. Mooi exemplaar!</omschrijving> <afbeeldingURL>http://www.uwwebsite.nl/fotos/foto-01.jpg</afbeeldingURL>

<deeplinkURL>http://www.uwwebsite.nl/link-naar-advertentie</deeplinkURL>

</item>

<item>

<categorie> 5 </categorie> *

<subcategorie>BMW</subcategorie> *

<prijs>1500,00</prijs>

<titel>Donkerblauwe BMW 5 serie </titel>

<omschrijving>Mooi donkerblauwe BMW 5 serie. Bouwjaar 1995. Is nog in goede staan. APK tot eind 2009. De auto is geheel gaaf.</omschrijving> <afbeeldingURL>http://www.uwwebsite.nl/fotos/foto-01.jpg</afbeeldingURL>

<deeplinkURL>http://www.uwwebsite.nl/link-naar-advertentie</deeplinkURL>

</item>

 

 

Thanks in advance.

 

Desi

Share this post


Link to post
Share on other sites

Hello everyone.

 

I had found this addon and I find it really interesting. But I have one bigger problem with it: view-source:http://magazin-protectia-muncii.ro/xml2.php

 

~1200 products are in my database, but this XML Feed only shows 2 of them (and they are repeating). How can I resolve this little bug?

 

Thanks a lot.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×