Jump to content
Gamer

Product Description 1.3

Recommended Posts

Hi!

 

I installed this contribution but the problem is the font size of the productDesc got bigger than prodHeadDesc. I could'nt customize the prodDesc in stylesheet.css. It is not doing anything or reacting to changes. And I found out that "TD.productListing-data" reacts with the change of font size of the product head description instead.

Where else can I go and check the problem?

Any suggestions to this problem?

 

Fidela :huh:

Edited by star8

Share this post


Link to post
Share on other sites

After i installed Prod_descr_v_1.5 i am getting tis error:

 

Warning: fread() [function.fread]: Length parameter must be greater than 0 in /////catalog/includes/functions/cache.php on line 60

 

Can anybody tel me please why is this happening?

 

Thank you very much

Share this post


Link to post
Share on other sites
I have installed this mod. Thank you! It worked perfect.

But then I tried to duplicate a product, and got some errors.

 

To solve this, you have to go to admin/categories.php.

 

Search for

tep_db_query("insert into " . TABLE_PRODUCTS . " (products_quantity, products_model, products_image, products_price, products_date_added, products_date_available, products_weight, products_status, products_tax_class_id, manufacturers_id)

(293)

 

Replace with:

tep_db_query("insert into " . TABLE_PRODUCTS . " (products_quantity, products_model, products_image, short_desc, products_price, products_date_added, products_date_available, products_weight, products_status, products_tax_class_id, manufacturers_id)

 

 

Did anyone ever figure this out? the short_desc column as posted in this query is not part of the products table, but belongs to the products_description table. I've looked over this for while now and still can not find a solution to this. Has anyone had any luck with this?

Share this post


Link to post
Share on other sites
Did anyone ever figure this out? the short_desc column as posted in this query is not part of the products table, but belongs to the products_description table. I've looked over this for while now and still can not find a solution to this. Has anyone had any luck with this?

 

bah, I'm an idiot. Never mind my last post. After baking in the desert somewhere in the Mid east, you tend to get a little flaky :)

Share this post


Link to post
Share on other sites

I am totally and completely in love with this contribution!!! I do have one question though. I would like to be able to keep the line breaks in my product descriptions. Is it possible to strip out all the tags except for the <br>'s? Any ideas on accomplishing this? Thanks so much!


Laurel

Share this post


Link to post
Share on other sites

Duh! That will teach me to read the whole thread! :) I've found the solution back on page 10 of this thread. Thanks! :)

 

I am totally and completely in love with this contribution!!! I do have one question though. I would like to be able to keep the line breaks in my product descriptions. Is it possible to strip out all the tags except for the <br>'s? Any ideas on accomplishing this? Thanks so much!

Laurel

Share this post


Link to post
Share on other sites

Hi!

 

I installed this great contribution: Products Short Description, downloaded the oldest version of this, the original v.1

 

The installation seemed to be ok, I am having no problem with the products_new.php but i am haveing some problems with the product_listing.php I have dubble checked my files and tried the files that came with the contribution witout any short product description in the product_listing.php.

 

My shop is quite modified so i guess there is something wrong elsewhere, but since the provided file did not work eighter i am out of solutions.

 

Does anyone have some advice or had similar problems with this?

 

Alex.

Share this post


Link to post
Share on other sites
Hi!

 

I installed this great contribution: Products Short Description, downloaded the oldest version of this, the original v.1

 

The installation seemed to be ok, I am having no problem with the products_new.php but i am haveing some problems with the product_listing.php I have dubble checked my files and tried the files that came with the contribution witout any short product description in the product_listing.php.

 

My shop is quite modified so i guess there is something wrong elsewhere, but since the provided file did not work eighter i am out of solutions.

 

Does anyone have some advice or had similar problems with this?

 

Alex.

 

I am refering to this contribution. Seems to be support for more than one in this tread.

http://www.oscommerce.com/community/contri...uct+description

Share this post


Link to post
Share on other sites

I removed the first contribution and changed it with this one Products_Short_Descriptions_V1_04

I have got it working as it should, but i am not interested in haveing the short decription in a extra column.

 

I have modified the code so the description is shown under the name in my products_listing.php now. But it is only shown when i have activated "Display Product Info" in oscommerce admin/productlisting. But then also the column is visable..

 

test.gif

 

Anyone got a tip for me here?

Share this post


Link to post
Share on other sites

hi alex,

like shown in the image, is it showing 2 times the prod description...

iam not sure if we are using the same product description contribution...

 

this is my file says about adding prod description in the product listing file

 

####[ OPEN ]##################################################################

 

catalog /includes/modules/product_listing.php

 

####[ FIND, 85 ]###########################################################

 

$cur_row = sizeof($list_box_contents) - 1;

 

####[ ADD AFTER ]#############################################################

 

$has_description = false;

 

####[ FIND, 100 ]#########################################################

 

$lc_text = ' <a href="' . tep_href_link(FILENAME_PRODUCT_INFO, ($cPath ? 'cPath=' . $cPath . '&' : '') . 'products_id=' . $listing['products_id']) . '">' . $listing['products_name'] . '</a> ';

}

 

####[ ADD AFTER ]#############################################################

 

if (PRODUCT_LIST_DESCRIPTION && $listing['products_description'] && PRODUCT_LIST_DESCRIPTION_MAX_LENGTH)

$lc_text .= '<br><table border="0" cellpadding="0" cellspacing="0" width="100%"><tr><td class="productDesc">' . tep_flatten_product_description($listing['products_description'], ' <a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $listing['products_id']) . '">' . TEXT_MORE . '</a>') . '</td></tr></table>';


l8ter

Share this post


Link to post
Share on other sites

Jes, it is showing the production description two places. This is because i have changes the code to show product description under the name. This part is fine. Problem is that if i go in admin panel under product listing and turn the short description column off (the description on the right) both the discriptions disapear. :( I have asked if anyone maby knows another command to pull the product info from the database, but no one seems to know this.

Share this post


Link to post
Share on other sites

Hi, i've installed this contrib (Many thanks to those involved) but I am having 1 small problem.

 

The description is showing fine but the more>>> link at the end is not showing.

 

Any ideas where I should look and what for.

 

Thanks again

Share this post


Link to post
Share on other sites

Hello,

 

I installed this Mod and all went ok But I dont see any short description on my products :( i oduble checked and everything was edited fine. What I am doing wrong why no short descriptiokn showing :( In Admin it work well and all is well saved.

 

Please Help, i need this contrib please :'(

 

P.S : I am using latest RC1

Edited by pardesi

Share this post


Link to post
Share on other sites

Sorry I found it, i had missed one line.

 

How can I make the Short description leave one empty line and ad List tag and not to be bold ?

 

Thanks :)

Share this post


Link to post
Share on other sites

Also for featured product Add on there is a mistake , it says to find : featured_products.php but this file deosent exist, which file to edit ?

 

Thanks

Share this post


Link to post
Share on other sites

Rather than relying on code to chop out reasonable description, I use <ShortDescription> and </ShortDescription> to delineate what part of the product description I want to show up in the listing. Gives me more control, and short description will look better. Easy modification - just replace tep_flatten_product_description code in general.php with:

  $short = '';
 if (preg_match('/<ShortDescription>(.*)<\/ShortDescription>/i', $description, $res))
 {
$short = $res[1];
 }
 $short .= $link;
 return $short;

Share this post


Link to post
Share on other sites

I had tried Products Short Description v1.02, contribution 1793.

It had worked fine as far as I could tell but it wasn't what I was looking for.

So I continued on my quest and I am having troubles finding what I need. Maybe the answer just isn't clear enough for me to see?

 

All I what is to be able to add a short description to my own liking (not taken from the product description) and have it show UNDER the product description on the product listing page. (See example pic below) So far it seems all of the contributions add another column to the table making a mess of the layout. Can anyone possibly point me in the correct direction? I have seen examples of what I am looking for, but no specific contribution or directions as to how.

 

psdescriptionow1.jpg


- :: Jim :: -

- My Toolbox ~ Adobe Web Bundle, XAMPP & WinMerge | Install ~ osC v2.3.3.4 -

Share this post


Link to post
Share on other sites

hello i installed this contrib and am trying to add enable/disable cats. however am having problems at catalog/products_new.php with the query

 

 

original short prod desc query:

 

$products_new_query_raw = "select p.products_id, pd.products_name, pd.products_description, p.products_image, p.products_price, p.products_tax_class_id, p.products_date_added, m.manufacturers_name from " . TABLE_PRODUCTS . " p left join " . TABLE_MANUFACTURERS . " m on (p.manufacturers_id = m.manufacturers_id), " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_status = '1' and p.products_id = pd.products_id and pd.language_id = '" . (int)$languages_id . "' order by p.products_date_added DESC, pd.products_name";

 

 

 

 

enable/disable cat query:

 

$products_new_query_raw = "select p.products_id, pd.products_name, p.products_image, p.products_price, p.products_tax_class_id, p.products_date_added, m.manufacturers_name from " . TABLE_PRODUCTS . " p, " . TABLE_CATEGORIES . " c, " . TABLE_PRODUCTS_TO_CATEGORIES . " p2c left join " . TABLE_MANUFACTURERS . " m on (p.manufacturers_id = m.manufacturers_id), " . TABLE_PRODUCTS_DESCRIPTION . " pd where c.categories_status=1 and p.products_id = p2c.products_id and c.categories_id = p2c.categories_id and p.products_status = '1' and p.products_id = pd.products_id and pd.language_id = '" . (int)$languages_id . "' order by p.products_date_added DESC, pd.products_name";

 

 

 

can someone please help on merging this?

Share this post


Link to post
Share on other sites

I have just followed the long list of changes and now get following error:

 

Fatal error: Cannot redeclare tep_set_banner_status() (previously declared in /mnt/w1006/d36/s07/b02be82e/www/products/catalog/includes/functions/general.php:701) in /mnt/w1006/d36/s07/b02be82e/www/products/catalog/includes/functions/banner.php on line 15

 

I have not been doing anything with the banner.php file - what should i do???

Share this post


Link to post
Share on other sites

I just added product description ver 2.2 at http://addons.oscommerce.com/info/3123

 

It took a little longer to install, because I had a few typo's like instead of short_desc - I entered short_desp. But all is working fine. The only thing I am a little disappointed with mod. There is no ( [/bmore info.. link.

 

Did notice there are a few of them out there, To get that extra feature, do I need to remove this ver completely or is there one out there that i could merge with?

 

Thanks.

 

blr044

Share this post


Link to post
Share on other sites
I just added product description ver 2.2 at http://addons.oscommerce.com/info/3123

 

It took a little longer to install, because I had a few typo's like instead of short_desc - I entered short_desp. But all is working fine. The only thing I am a little disappointed with mod. There is no ( more info.. )link.

 

Did notice there are a few of them out there, To get that extra feature, do I need to remove this ver completely or is there one out there that i could merge with?

 

Thanks.

 

blr044

 

 

After some editing, it would not work. So removed it and installed another version.

 

blr044

Share this post


Link to post
Share on other sites

Hi. I must be a Idiot because I can't find the on/off switch that some people are taling about in this topic. Well.. I installed the contribution and the more link does not show. Thats not a problem because I don't want it anyway. But in admin panel I have the short description field but it is empty all the time. I put something in it and it gets the text into the database. When I click to edit the product it shows an empty field again for the products short description and if I click update then it deletes the current short description because the field is empty. I have Header Tags Controller with STS 4.5.8 installed and they work. But the same thing happenes with the htc fields in the products. What should I do? I fear I have done this when I installed this contrib.

 

Please let me know if I need to post anything here. I will gladly pay for this support.

 

Thank you!

Edited by mironutz

Share this post


Link to post
Share on other sites

Hi guys,

 

 

I have to say this is great contribution and easy to install !! thanks for it. I have installed it with no problem.

 

Howerver the thing is i still have other minor problem. i have gone through installation manual 3 times and still can't solve the problem

 

I have the descriptions displayed fine if i list the product by categories. But the product descriptions won't display if product listed from:

 

1. Advanced Search . i have looked through my catalog/advanced_search_result.php

2. By manufacturer (infobox)

3. Shop by price.

4. New product by X month.

 

I have looked through the demo site and i want it exactly the same. Please help. Here is the Site

 

Please help. Let me know which code should i post.

Share this post


Link to post
Share on other sites

Hi everyone,

I've recently installed the short descriptions mod here: http://www.oscommerce.com/community/contributions,3123

I apologise if this is the wrong thread (it doesn't appear to be, but this page was linked to on the contributions page).

 

I've installed it as per the instructions with relative ease. It allows me to enter a short description, stores it in the database, but it doesn't actually display it.

The shop in question resides at http://www.motosweeney.com/temp/shop/

 

As you can see, it doesn't display it.

 

I've followed the directions pretty much to the line, so any help is appreciated.

 

Thanks,

Dave.

Edited by superfireydave

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×