Jump to content
jcisar

Featured Product Support v1.5.4

Recommended Posts

Follow the links in my posts here: Click Me


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites

I just installed this add on, everything appeared great, only thing is I can't get the featured products to appear on the home page?

 

There is no error codes in catalog or in admin, and the column box works perfectly as does the feature page,

 

Any idea what I have done wrong?

Share this post


Link to post
Share on other sites

I just installed this add on, everything appeared great, only thing is I can't get the featured products to appear on the home page?

 

There is no error codes in catalog or in admin, and the column box works perfectly as does the feature page,

 

Any idea what I have done wrong?

Hi,

 

I'm having same problem i don't think we done anything wrong,

 

Steve

Share this post


Link to post
Share on other sites

Hi

 

I'm just about to start to install the featured products contrib. How do I know if I am using the Simple Template System? Thanks

Share this post


Link to post
Share on other sites

I have installed the Featured Products contrib but I am getting this error message:

 

1146 - Table 'taxisupplies.featured' doesn't exist

 

select featured_id from featured where status = '1' and now() >= expires_date and expires_date > 0

 

[TEP STOP]

 

Any suggestions? Thanks

Share this post


Link to post
Share on other sites

I have installed the Featured Products contrib but I am getting this error message:

 

 

 

Any suggestions? Thanks

 

It looks like there has been no discussion activity on this thread for a while. Should I post my question elsewhere? At the same time I dont want to offend anyone by double posting. I am very aware that people volunteer their time here....please help :blush:

Share this post


Link to post
Share on other sites

Hello,

 

Thanks for this great contribution.

 

Just yesterday my hosting provider upgraded our server to PHP 5.2.9. This was sneaky on their part because our server originally had 5.0.5 installed. I won't go into anymore details, but it has caused some problems.

 

In particular to this contribution: When I searched for a product code in Admin to add it to the featured products list and then clicked the product code to add the product and choose an end date, the product id wasn't being picked up by featured.php and so I would get the product dropdown and would have to choose the product all over again.

 

I discovered that if if replaced

	  if ( ($action == 'new') && isset($HTTP_GET_VARS['prodID']) ) {
	  $product_query = tep_db_query("select p.products_id, pd.products_name from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_id = pd.products_id and pd.language_id = '" . (int)$languages_id . "' and p.products_id = '". (int) $HTTP_GET_VARS['prodID']. "'");
	  $product = tep_db_fetch_array($product_query);
	  $sInfo = new objectInfo($product);
  }

 

with

 

	  if ( ($HTTP_GET_VARS['action'] == 'new') && isset($HTTP_GET_VARS['prodID']) ) {
	  $product_query = tep_db_query("select p.products_id, pd.products_name from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_id = pd.products_id and pd.language_id = '" . (int)$languages_id . "' and p.products_id = '". (int) $HTTP_GET_VARS['prodID']. "'");
	  $product = tep_db_fetch_array($product_query);
	  $sInfo = new objectInfo($product);
  }

 

in lines 115 - 119 that everything worked.. I also needed to replace the

$action == 'new'

on line 140 with

$HTTP_GET_VARS['action'] == 'new'

.

 

I discovered the same issue with the Product Extra Fields contribe. I needed to use the

$HTTP_GET_VARS

version in the code as well.

 

Does anyone now why this is? Will this be an issue for this contrib? I have a feeling I am going to be dealing with this issue in a number of places, but I haven't spotted very many just yet.

 

aabe51

 

Just to let you know that this fix worked for me. Global Register is also "off" on my server.

Thanks.

Edited by achieve

Share this post


Link to post
Share on other sites

Hi everyone,

 

new here and am putting some contributions on my site. I have added the STS 4.5.8 and running OSC 2.2.

 

Now I am trying to solve an issue here that was discussed around page 15 or so about an issue of the center portion of the Featured Products not displaying correctly. I am trying to install the 1.63 vers of the Fetaured Products.

 

I have checked and re-checked the install instructs about 5 times now and everything is in place. As you can see when going to my site there is in the center top of my site a section called "Feature" and one item, but to the bottom right of that there is a section called "Featured Products" with 2 items which is what I have selected in the admin side and I am sure this is supposed to be at the bottom of my regular content area.

 

I do NOT have the $featuredboxtag in my template system as I have tried both to have it and not have it and it is not changing anything.

 

Your help would be greatly appreciated.

 

My Site

Share this post


Link to post
Share on other sites

Follow the links in my posts here: Click Me

 

Germ here is one for you, the smartest guy I know to help dummies like me. Seems I installed Featured products 1.64 and the two updates and have broken something. Works and looks great, but customers can't checkout. Checked the edits 3 time to make sure didn't miss something. When hitting checkout it stalls for 10 minutes. It has broken usps mod.Installed on rca 2 and newest php and sql

error is

Warning: fsockopen() [function.fsockopen]: unable to connect to production.shippingapis.com:80 (Connection timed out) in /home/sansabal/public_html/includes/classes/http_client.php on line 330

 

Thanks in advance

Bo

Share this post


Link to post
Share on other sites

Hello,

 

I wonder if it is possible to add "valid from" function to this contribution. I tried to make it similar to the contribution "Specials valid from" but the php code in catalog/admin/featured.php is different to the catalog/admin/specials.php.

 

I'am using the contribution "Specials valid from" and the function "Specials Only When Displaying Featured Products" is not working correct, because when a product is listed in the specials section (although the sale starts for example in 2 days and now the status is 0) the product is being shown in the featured products section on the homepage.

 

Any clues?? (sorry for bad English:(

Share this post


Link to post
Share on other sites

After installing this addon i get this message when i try to go to admin -> featured products to set it up;

 

1146 - Table 'kremsykkel_no.TABLE_FEATURED' doesn't exist

 

select count(*) as total from products p, TABLE_FEATURED s, products_description pd where p.products_id = pd.products_id and pd.language_id = '4' and p.products_id = s.products_id

 

[TEP STOP]

 

I suspect its something to do with SQL, which i dont know squat about..

 

Any way to fix this?

Share this post


Link to post
Share on other sites

After installing this addon i get this message when i try to go to admin -> featured products to set it up;

 

1146 - Table 'kremsykkel_no.TABLE_FEATURED' doesn't exist

 

select count(*) as total from products p, TABLE_FEATURED s, products_description pd where p.products_id = pd.products_id and pd.language_id = '4' and p.products_id = s.products_id

 

[TEP STOP]

 

I suspect its something to do with SQL, which i dont know squat about..

 

Any way to fix this?

Did you run the sql on the database?

Share this post


Link to post
Share on other sites

Now I am trying to solve an issue here that was discussed around page 15 or so about an issue of the center portion of the Featured Products not displaying correctly. I am trying to install the 1.63 vers of the Fetaured Products.

 

I have checked and re-checked the install instructs about 5 times now and everything is in place. As you can see when going to my site there is in the center top of my site a section called "Feature" and one item, but to the bottom right of that there is a section called "Featured Products" with 2 items which is what I have selected in the admin side and I am sure this is supposed to be at the bottom of my regular content area.

 

I do NOT have the $featuredboxtag in my template system as I have tried both to have it and not have it and it is not changing anything.

 

Your help would be greatly appreciated.

 

My Site

 

I'm also having this same problem... Is there anyone with a solution? airsofting, u don't seem to be running featured products on your live site - no solution as yet?

Share this post


Link to post
Share on other sites

Before I start doing this on my own does anyone have the code handy to add the products_quantity to the end of the drop down box? Price is great to see but worthless information. I would rather not add something to my featured products that is not in stock...

 

Or perhaps, which sql select to alter so that only products with quantity > 0 are added to the list?


Community Bootstrap Edition, Edge

 

Avoid the most asked question. See How to Secure My Site and How do I...?

Share this post


Link to post
Share on other sites

Before I start doing this on my own does anyone have the code handy to add the products_quantity to the end of the drop down box? Price is great to see but worthless information. I would rather not add something to my featured products that is not in stock...

 

Or perhaps, which sql select to alter so that only products with quantity > 0 are added to the list?

Too late, I think this does it...

 

// create an array of featured products, which will be excluded from the pull down menu of products
// (when creating a new featured product)
     $featured_array = array();
     $featured_query = tep_db_query("select p.products_id from " . TABLE_PRODUCTS . " p, " . TABLE_FEATURED . " s where s.products_id = p.products_id or p.products_quantity = '0'");
     while ($featured = tep_db_fetch_array($featured_query)) {
       $featured_array[] = $featured['products_id'];
     }

 

It was adding or p.products_quantity = '0' to the code to eliminate products already in the featured list.

 

Of course the syntax may not be the best. If there are some () needed somewhere to speed this up please let me know... it takes a couple of seconds longer doing this because it now queries the entire products list. 5-6 seconds longer in my case of 30k products


Community Bootstrap Edition, Edge

 

Avoid the most asked question. See How to Secure My Site and How do I...?

Share this post


Link to post
Share on other sites

 

It was adding or p.products_quantity = '0' to the code to eliminate products already in the featured list.

 

Actually it didn't work. Any mySQL gurus out there? I want to combine two select lists. First is the list of products in the featured table. That is the existing sql statement. Then combine that list with the list of products with quantity on hand = 0. Anyone?


Community Bootstrap Edition, Edge

 

Avoid the most asked question. See How to Secure My Site and How do I...?

Share this post


Link to post
Share on other sites

Ok, I'm going to have to appeal to everyone else. Trying to figure this out, it works in phpMyAdmin as this...

 

[snipped it all out because it really doesn't work]

 

Where am I going wrong?

 

(I'll probably see it right after I press the post button, lol.

 

I need an sql statement that returns all products with quantity of 0 AND those in the featured table.

Edited by mdtaylorlrim

Community Bootstrap Edition, Edge

 

Avoid the most asked question. See How to Secure My Site and How do I...?

Share this post


Link to post
Share on other sites

I think it's cludgy but this is what I am now using. Any comments?

 

     $featured_query = tep_db_query("select p.products_id from " . TABLE_PRODUCTS . " p, " . TABLE_FEATURED . " s where s.products_id = p.products_id union all select products_id from " . TABLE_PRODUCTS . " where products_quantity = '0'");

 

It effectively prevents any product with a quantity in stock of 0 and items already in the featured table from appearing in the list to add to the featured list.


Community Bootstrap Edition, Edge

 

Avoid the most asked question. See How to Secure My Site and How do I...?

Share this post


Link to post
Share on other sites

Help!

 

In installation it says:

 

"Step 17:

Now you need to create the database table that will be holding the featured products. To do so, you will need to run the featured_products_english.sql file's contents in your favorite sql interface (like phpmyadmin) to your existing database."

 

I don't understand at all, what does this mean? I can see the files in the installation folder database_sql, what do I do with them? I have PHPMyAdmin but there's no such database there yet obviously...

 

Right now I am getting "Fatal error: Call to a member function add_current_page() on a non-object in /home/doubleha/public_html/catalog/includes/application_top.php on line 312", my shop is down completely :(

Share this post


Link to post
Share on other sites

It means that you have to past the content of the featured_products_english.sql file into the sql command window within phpmyadmin and under the database you run your oscommerce shop if have multiple.

 

Basicly you should do as follow in phpadmin:

 

Select and click correct database in left side menu.

Select SQL tab in main window

Past sql code into window.

Select run...

 

It should no be added to database..

Share this post


Link to post
Share on other sites

got a bit of a problem

 

I did all the modifications and imported the .sql and created the table.

 

However when I go to the catalog -> featured product I get the following error:

 

1146 - Table 'dev_districtgames.TABLE_FEATURED' doesn't exist

 

select count(*) as total from products p, TABLE_FEATURED s, products_description pd where p.products_id = pd.products_id and pd.language_id = '1' and p.products_id = s.products_id

 

[TEP STOP]

 

the table is there however:

 

featured.png

 

so what did I do wrong?

Share this post


Link to post
Share on other sites

Check that you have put the databasename in the database.php file in the include folder. Remember there may be 2 places, both under catalog and admin.

 

1146 - Table 'dev_districtgames.TABLE_FEATURED' doesn't exist

 

TABLE_FEATURED looks like it is not declared and it is likly because you have missed one step or put in wrong place.

Share this post


Link to post
Share on other sites

Check that you have put the databasename in the database.php file in the include folder. Remember there may be 2 places, both under catalog and admin.

 

1146 - Table 'dev_districtgames.TABLE_FEATURED' doesn't exist

 

TABLE_FEATURED looks like it is not declared and it is likly because you have missed one step or put in wrong place.

 

 

Thanks. For some reason I forgot to add a define to the admin database_table file.

 

Now I have another problem.

 

I want to add a short description to each product, and I found this http://forums.oscommerce.com/topic/144208-featured-product-support-v1-5-4/page__view__findpost__p__960422 however I can't seem to find the code referenced (im using version 1.6.3) in featured.php

 

any help would be much appreciated.

Share this post


Link to post
Share on other sites

Hi,

 

I'm trying to install v. 1.64. Importing SQL gives following error:

 

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'CREATE TABLE `featured` (
 `featured_id` int(11) NOT NULL auto_i' at line 9 

 

Any idea?

Edited by WorkingHard

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×