Jump to content
jcisar

Featured Product Support v1.5.4

Recommended Posts

has anyone successfully been able to show category specific featured products? ie, only the featured products in the salt category appear when the user is browsing in the salt category, etc.?

 

i have read this entire post and cant seem to find anyone with the answer or the same problem, so im thinking I may have some small peice of code messed up somehow.

 

It does work this way on my store. When you are on the index page, you will get some featured products at random. When you are browsing a category, it will show you some featured products at random ONLY from that category and subcategories beneath it, it won't show featureds products outisde it.


MindTwist of Twisted Reality and Twisted Tienda

Share this post


Link to post
Share on other sites
Just spotted the comments above about specials - this works for me.

 

Problem is I don't want the items in the featured products module to be specials...

 

Has anyone found what is going on with the items only appearing in the featured products box if they are specials issue yet?

 

How about reading the thread, and not expecting someone to do it for you and post the answer? This is already posted with clear instructions on how to solve it.


MindTwist of Twisted Reality and Twisted Tienda

Share this post


Link to post
Share on other sites
How about reading the thread, and not expecting someone to do it for you and post the answer? This is already posted with clear instructions on how to solve it.

Sorry MindTwist - Before I did my post I did a search using the search function and didn't find anything.

 

I hold my hands up to not reading the whole thread though, so sorry.

 

Either way - thanks for letting me know the solution is in here I'll take a look.

 

Cheers

Edited by pauladkins

Paul

Total Wargamer

Share this post


Link to post
Share on other sites
It does work this way on my store. When you are on the index page, you will get some featured products at random. When you are browsing a category, it will show you some featured products at random ONLY from that category and subcategories beneath it, it won't show featureds products outisde it.

 

Hey Mindtwist,

 

I understand that this is how the contribution is designed to work, however I am getting different results, and really dont know where to start looking for the reason.

 

I am using STS templates per the documentation, and have the following templates structure for all of my categories:

 

index.php.html

index.php_213.html

index.php_210.html

index.php_215.html

etc.

etc.

etc.

 

 

Im putting items in the featured products admin, and they all still appear randomly no matter what category the user is in.

 

I was hoping someone else had run into this and could advise me where to start debugging. Im not much more than a cutter and paster when it comes to PHP, but I could certainly use any advice anyone has.

 

Thanks

Share this post


Link to post
Share on other sites
It does work this way on my store. When you are on the index page, you will get some featured products at random. When you are browsing a category, it will show you some featured products at random ONLY from that category and subcategories beneath it, it won't show featureds products outisde it.

 

 

i have done a little more digging and debugging with the sts system turned off, and have discovered the following in regards to why the products displayed are random no matter what category the user is in:

 

the sts instructions tell you to use the $featuredbox tag where you want the featured item to appear. However, this tag is the info box that appears in the left column on a non-templated store's main index page. And this box is always random.

 

So, I need to figure out how to call the featured product that appears on the main category page into the template.

 

Ive looked thoroughly and for the life of me, cannot figure out how to make this work.

 

Anyone have any ideas?

Share this post


Link to post
Share on other sites
i have done a little more digging and debugging with the sts system turned off, and have discovered the following in regards to why the products displayed are random no matter what category the user is in:

 

the sts instructions tell you to use the $featuredbox tag where you want the featured item to appear. However, this tag is the info box that appears in the left column on a non-templated store's main index page. And this box is always random.

 

So, I need to figure out how to call the featured product that appears on the main category page into the template.

 

Ive looked thoroughly and for the life of me, cannot figure out how to make this work.

 

Anyone have any ideas?

I can only answer for my version of Featured Products which if installed correctly, will automatically add the Featured Products in the main content area replacing the New Products for Month box.

If using STS, you need the $content tag in your template as well as correctly following all of my instructions listed for my version of Featured Products. I will not troubleshoot the others as I do not have the time to do so. I know the others have SQL issues amoung other things that need to be worked out or have been in this thread but has not been updated on the contribution page.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Hi Mindtwist. Thats exactly what I had to do verbatim to resolve my issue. Seems like somewhere along the line after the revised bkellum version, the DB query stopped showing all of the products and or prices.

 

It would be nice to have these versions better governed. maybe every install has to be changed docs only. Or every package has to include all documents , including revised docs.

 

 

Hi all, i've tried this out quite carefully and get nothing on my index page. It is very odd. If i copy the SQL from the feature.php box then I can make results appear but for the life of my i can't see why one works and the other doesn't...

 

Any other things I should check before finding a quiet corner to have a breakdown in?

Share this post


Link to post
Share on other sites
I can only answer for my version of Featured Products which if installed correctly, will automatically add the Featured Products in the main content area replacing the New Products for Month box.

If using STS, you need the $content tag in your template as well as correctly following all of my instructions listed for my version of Featured Products. I will not troubleshoot the others as I do not have the time to do so. I know the others have SQL issues amoung other things that need to be worked out or have been in this thread but has not been updated on the contribution page.

 

 

Bill,

 

I appreciate your response. Please know I am not trying to waste anyones time here. I have followed your instructions to the letter and am still only producing the infobox for the featured products which is random, not the categorized ones.

 

I am using the $content tag as well as a new tag created per your instructions.

 

No worries though. I wont take up any more of your time.

 

Ill either figure it out or use another contribution.

 

Thanks again

Share this post


Link to post
Share on other sites
Bill,

 

I appreciate your response. Please know I am not trying to waste anyones time here. I have followed your instructions to the letter and am still only producing the infobox for the featured products which is random, not the categorized ones.

 

I am using the $content tag as well as a new tag created per your instructions.

 

No worries though. I wont take up any more of your time.

 

Ill either figure it out or use another contribution.

 

Thanks again

What I meant was that if you are using any of the versions past the July 15, 2007 version that I posted, I cannot help as I have not installed any of those versions. The reason being is that I have not had any issues with my version (if it's not broke, don't fix it).

 

If you are using the July 15, 2007 version, by all means, let me know what problems you are having and I will try to help.

 

My version has instructions on what needs to be added/removed from the index.php page that controls/replaces the "New Products for Month" box with a "Featured Products" box. The products displayed in this box are set in the admin.

 

If you installed it correctly, then when using STS, the $content tag would pull in this Featured Products box automatically. The other Featured infobox in optional.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

I have a slightly different problem. I have 2 featured boxes! One on the bottom of the main page showing multiple products as it should be (instead of new products) and another featured box on top of the middle of the content area showing only 1 random featured product on every page and it's takes full width with one picture in the middle.

 

I use osC 2.2 RC2, latest STS and latest update to Featured products. First I installed previous one with that big .DOC file that I followed very carefully. Then I updated PHP from the last download and added couple of things to DB as instructed. I can turn it on and off in admin, add/remove/switch on and off products, etc. Bottom Featured area works as it should be, but I have no clue how to get rid of the top box. And I have no $featuredbox tag anywhere in my code.

 

Any help?

Share this post


Link to post
Share on other sites
I have a slightly different problem. I have 2 featured boxes! One on the bottom of the main page showing multiple products as it should be (instead of new products) and another featured box on top of the middle of the content area showing only 1 random featured product on every page and it's takes full width with one picture in the middle.

 

I use osC 2.2 RC2, latest STS and latest update to Featured products. First I installed previous one with that big .DOC file that I followed very carefully. Then I updated PHP from the last download and added couple of things to DB as instructed. I can turn it on and off in admin, add/remove/switch on and off products, etc. Bottom Featured area works as it should be, but I have no clue how to get rid of the top box. And I have no $featuredbox tag anywhere in my code.

 

Any help?

Steve,

This is an easy one. Simply remove the featured products STS tag from your template. The $content tag will display the Featured Products in the main content area with the products you have selected in the admin.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Steve,

This is an easy one. Simply remove the featured products STS tag from your template. The $content tag will display the Featured Products in the main content area with the products you have selected in the admin.

Bill,

It's not as easy as it looks. I have no $featuredbox tag. And I have only 2 templates at this time - index.php.html and sts_template.html. And they are default as came with STS. I only removed some boxes that I don't use now. If I remove these files, Featured Products woks as expected (but I have error on top of the page that sts_template.html is missing). So it's a problem related to STS. For some reason it includes both Featured Product boxes in $content tag. One for a single random item at the beginning and one with the list at the end. If I remove $content, then nothing shows at all as it should be. So it's they way STS and Featured products interact. It's happening when $content is processed. Perhaps I made a mistake when modifying files, but I checked every line several times and didn't find any errors. It acts like $featuredbox is always there at the beginning of $content. And I can't figure out what portion of code is responsible for this. May be there's some missing "if" or something.

Share this post


Link to post
Share on other sites
Bill,

It's not as easy as it looks. I have no $featuredbox tag. And I have only 2 templates at this time - index.php.html and sts_template.html. And they are default as came with STS. I only removed some boxes that I don't use now. If I remove these files, Featured Products woks as expected (but I have error on top of the page that sts_template.html is missing). So it's a problem related to STS. For some reason it includes both Featured Product boxes in $content tag. One for a single random item at the beginning and one with the list at the end. If I remove $content, then nothing shows at all as it should be. So it's they way STS and Featured products interact. It's happening when $content is processed. Perhaps I made a mistake when modifying files, but I checked every line several times and didn't find any errors. It acts like $featuredbox is always there at the beginning of $content. And I can't figure out what portion of code is responsible for this. May be there's some missing "if" or something.

Steve,

You have not installed Featured Products correctly then. Most likely, your error is in your index.php page. This is NOT a STS problem. This is user error. Re-check your installation of Featured Products.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Steve,

You have not installed Featured Products correctly then. Most likely, your error is in your index.php page. This is NOT a STS problem. This is user error. Re-check your installation of Featured Products.

Bill,

I did recheck once again line by line every modification to files. Everything was OK. Then I started putting trace comments into suspected files like <!-- this calls that in this file --> and eventually I traced it down to ../includes/boxes/featured.php. Then I replaced this file with the dummy empty file like "<$php $>" and the problem went away. Apparently this file is included when it shouldn't. I still have to figure out what piece of code includes it and why. File itself puts out Featured box unconditionally - there are no ifs there. But debugging PHP is a real pain in the neck. Only way I know is adding trace comments and looking at resulting HTML. But again, it works correctly with STS disabled without any changes. And making dummy file for boxes/featured.php solves my problem.

Share this post


Link to post
Share on other sites
Bill,

I did recheck once again line by line every modification to files. Everything was OK. Then I started putting trace comments into suspected files like and eventually I traced it down to ../includes/boxes/featured.php. Then I replaced this file with the dummy empty file like "<$php $>" and the problem went away. Apparently this file is included when it shouldn't. I still have to figure out what piece of code includes it and why. File itself puts out Featured box unconditionally - there are no ifs there. But debugging PHP is a real pain in the neck. Only way I know is adding trace comments and looking at resulting HTML. But again, it works correctly with STS disabled without any changes. And making dummy file for boxes/featured.php solves my problem.

 

I hope you didn't add this file in the "Files to Include" in the STS Module. If you did, that was a mistake.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
I hope you didn't add this file in the "Files to Include" in the STS Module. If you did, that was a mistake.
This file - ../boxes/featured.php is included in 3 places as per instructions that came with Featured Products. In ../sts_inc/sts_user_code.php, ../sts_inc/sts_column_left_php and ../includes/filenames.php. Perhaps I can remove the call from one of the places, but making dummy file was easier. Now I just have to figure out why it's called. And may as well learn something about program logic and structure. Edited by Syeager

Share this post


Link to post
Share on other sites
This file - ../boxes/featured.php is included in 3 places as per instructions that came with Featured Products. In ../sts_inc/sts_user_code.php, ../sts_inc/sts_column_left_php and ../includes/filenames.php. Perhaps I can remove the call from one of the places, but making dummy file was easier. Now I just have to figure out why it's called. And may as well learn something about program logic and structure.

Steve, are you using my July 15, 2007 Featured Products version?


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
What I meant was that if you are using any of the versions past the July 15, 2007 version that I posted, I cannot help as I have not installed any of those versions. The reason being is that I have not had any issues with my version (if it's not broke, don't fix it).

 

If you are using the July 15, 2007 version, by all means, let me know what problems you are having and I will try to help.

 

My version has instructions on what needs to be added/removed from the index.php page that controls/replaces the "New Products for Month" box with a "Featured Products" box. The products displayed in this box are set in the admin.

 

If you installed it correctly, then when using STS, the $content tag would pull in this Featured Products box automatically. The other Featured infobox in optional.

 

Bill,

 

I have figured out my issue for the most part. I have never used a stock OSC site without some sort of template system, so I was not distinguishing properly between the infobox for the featured product and the featured product box that appears on the bottom of the page in the middle of the content. The infobox always shows a random product. I have created an STS tag per your instructions for this on the homepage of my site before anyone goes into any category. There will always be a rotating random product there. That works fine.

 

For the interior pages, I needed to take the code that creates the main featured product box and create an sts tag for that. My reasoning is that I want a featured product for each category to appear within the area of the product listings on the index.php pages. I want each category to only show products from that category while the user is browsing the categories. So, I added an STS tag for that using the code in /includes/modules/featured.php

 

After upload, to my surprise, it worked. However, All of my categories are at least two levels deep, i.e. index.php?cpath=3_232_384 The featured product module only appears when the user is browsing the index.php?cpath=3 category, and not the subcategories within it like index.php?cpath=3_232 , etc.. My question after all of that, is ... is there a way to make the module work for the subcategories also.

 

I took a look at the SQL queries at the top of the module itself, and Im not knowledgeable enough to be able to figure this one out.

 

Does this make sense to you?

 

Thank you again for your time.

Edited by aejeffor

Share this post


Link to post
Share on other sites

Before anyone berates me for not reading the forum, I have already tried the nested subcategories featured.php page. It works, but pulls random products instead of products in that category.

 

It seems to me that it is almost there, just one small edit and it would work, but unfortunately, I dont know where to make that edit.

 

Any ideas or thoughts would be appreciated.

Share this post


Link to post
Share on other sites
What I meant was that if you are using any of the versions past the July 15, 2007 version that I posted, I cannot help as I have not installed any of those versions. The reason being is that I have not had any issues with my version (if it's not broke, don't fix it).

 

If you are using the July 15, 2007 version, by all means, let me know what problems you are having and I will try to help.

 

My version has instructions on what needs to be added/removed from the index.php page that controls/replaces the "New Products for Month" box with a "Featured Products" box. The products displayed in this box are set in the admin.

 

If you installed it correctly, then when using STS, the $content tag would pull in this Featured Products box automatically. The other Featured infobox in optional.

 

Bill/Anyone,

 

I have been 'trial and erroring' with this contribution now for a month, and I cannot get it work as designed. I have installed and reinstalled it several times now just in case I was missing something but it still gives me the same problem. The featured product appears on every page, that I add the $featuredbox tag to. However, it will not show the proper category. It keeps showing a random one.

 

I have debugged it to the point where, I can get it to show the proper featured product, ONLY if I am in a category that has just categories below it. As soon as I add an item to the top level category, the featured box begins to output random products again.

 

Here is an example:

Main category - Oils

Sub Category - Nut Oils

Sub Category - Olive Oils

Sub Category - Other Oils

 

If I have the above structure, the contribution will work correctly for the Top Level Oils Page. However, the moment I add a regular item to the Oils category (not the subcategories) then the contribution reverts back to random products. And the subcategories, which also have subcategories,and items within them, always have a random product.

 

Im pulling my hair out on this one. If anyone has ideas, please let me know.

 

Thank you in advance

Edited by aejeffor

Share this post


Link to post
Share on other sites

Can somebody tell me if Featured Products 1.5.9 will work with mySQL 5 or do I need a newer version.

 

I just got done uninstalling 1.5.4 since I was unable to get it to work with mySQL 5 update that was applied to my server.

 

Thanks,

Pete

 

P.S. If there is anything else I should know, please let me know. Thanks again.


I find the fun in everything.

Share this post


Link to post
Share on other sites
:thumbsup: I have updated the instructions for Featured Products & STSv4.5.3 and added all of the files (new and modified) together to allow for a quick merge into a new store.

 

This was created for the current osCommerce version "Online Merchant RC1" that was released on July 3, 2007.

 

I post the link as soon as it is uploaded into the Featured Products section.

 

Enjoy,

 

Hi

 

I have been follow your install text from Featured Products 161 with STS 453 instructions inside Featured Products 1_62.zip Reading carefully and proceding step by step from oscomerce 2.2rc2a

I've just not relayed for the number of version of oscommerce, but now I have a problem, can you help me, please?

 

this is the bug, when i try to go to index.php appear an error like this:

 

Fatal error: Call to a member function add_current_page() on a non-object in /var/www/mejoralasalud/tienda/includes/application_top.php on line 312

 

really thanks in advance,

 

Regards, and excuse me for my bad english

Share this post


Link to post
Share on other sites

Hello,

 

Can someone help me with this.........I have followed all instructions in Featured Products 1.5.9 (and double checked everything). In the Admin Panel I have the option for Featured in Configuration but it is not showing up in Catalog.

 

Any ideas??

 

kirkout

Share this post


Link to post
Share on other sites
Hello,

 

Can someone help me with this.........I have followed all instructions in Featured Products 1.5.9 (and double checked everything). In the Admin Panel I have the option for Featured in Configuration but it is not showing up in Catalog.

 

Any ideas??

 

kirkout

Use a file comparison tool such as Beyond Compare to compare the files on your server with the files from the contribution to see what you are missing. It is most likely due to missing code in your index.php file.

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×