Jump to content
Sign in to follow this  
wheeloftime

Estimated Shipping Costs

Recommended Posts

If someone can help i will appreciate it. I have been trying to install this module without success. I have installed version v1.7 & v1.7b and i am running into the same problem. The contribution seems to work perfect when I am logged into an account. When a guess that does not have an account visit they get the following error:

 

No Rates Returned, F05A : Recipient country requires a postal code served by FedEx.

 

When I try to use the form to submit a Zip code, I get the same error again. I am basically stuck and I don’t know where to start looking for a solution. If anyone can help, I will greatly appreciate it as I would love to have this contribution on my site.

 

Thanks/ 5past9

Share this post


Link to post
Share on other sites

I have had estimate shipping installed for several months now. I believe it was working just fine. However, I just noticed that when someone tries to use it for international estimates, they must put something (anything) in the zip code blank, otherwise there is no result. If they do put a number, even just a single digit, then they will get an estimate that looks accurate.

 

Is there some change I can make to remove this requirement to enter something in the box for the international estimates? I am selling from the US.

 

I would very much appreciate any help.

thank you,

Leslie

 

the site is:

http://www.kaligear.com

Edited by kaligear

Share this post


Link to post
Share on other sites

The estimated shipped submite for a rate quote request with a blank zip code. The zip cose is empty, and still, I get:

 

111210: The requested service is unavailable between the selected locations.

If you prefer to use ups as your shipping method, please contact Quik Ship Toner via Email.

 

When I enter the zipcode, the quote is correct, but it looks very funky with an error message before the zipcode is entered.

 

It looks as if this problem was addressed around ver 1.5, I am using 1.7. I have re-installed it also. Thanks

 

Jack

Share this post


Link to post
Share on other sites
The estimated shipped submite for a rate quote request with a blank zip code. The zip cose is empty, and still, I get:

 

111210: The requested service is unavailable between the selected locations.

If you prefer to use ups as your shipping method, please contact Quik Ship Toner via Email.

 

When I enter the zipcode, the quote is correct, but it looks very funky with an error message before the zipcode is entered.

 

It looks as if this problem was addressed around ver 1.5, I am using 1.7. I have re-installed it also. Thanks

 

Jack

 

i'm getting the same error when trying to install this contribution. does it no longer work? i can't even get the quote .. i just get this error

Share this post


Link to post
Share on other sites
Also, the Express Saver rate shown in the estimated shipping box is different than the Express Saver rate shown during checkout.

 

My USPS Priority Mail rate is exactly the same though.

Did you ever find a solution to this problem? I'm running Fedex 2.04 and have the same problem.

 

Thanks,

Akoss

Share this post


Link to post
Share on other sites

I like this contrib and installed it on my site but:

 

I only have the option to show the estimated shipping costs from the shopping cart view. I was under the impression that this contrib would add a new infobox to all the pages so the customer could get the shipping info anywhere along the shopping experience.

 

I believe this site www.frencybee.com has the same contrib but it is available in the shopping cart infobox on the right column at any time after you put something in the cart.

 

Can anyone help me with this? I would like to have my site set up the exact same way.

 

Cheers,

 

David

Share this post


Link to post
Share on other sites

If you use that code and paste in as a file in box folder plus include that in left or right colum it should be available on all pages.

 

Satish


Ask/Skype for Free osCommerce value addon/SEO suggestion tips for your site.

 

Check My About US For who am I and what My company does.

Share this post


Link to post
Share on other sites

I figured I would have to put it in the boxes/shopping_cart.php but I am unclear as to HOW to do it. Which code are you referring to?

 

Could you be so kind as to walk me through it? I have never added more stuff to an infobox and put it on the left or right column before.

 

Cheers,

 

David

Share this post


Link to post
Share on other sites

I remember reading this somewhere but cannot find it now - and it's connected to the contrib, which I have installed:

How can you remove some of the countries listed in the drop down?


SolarFrenzy

Solar powered gadgets at down to earth prices.

 

CheekyNaughty

Promoting British Design

Share this post


Link to post
Share on other sites
Did you ever find a solution to this problem? I'm running Fedex 2.04 and have the same problem.

 

Thanks,

Akoss

I have not found a solution yet. Anyone else having the same problem?

 

I did just notice though that my shipping estimator gives the two FedEx options as Express Saver and Ground Delivery even though it should be for a residential entry. I wonder if that is why the Express Saver is cheaper as well...business rate and not residential. Does anyone know where I might fix this? Thanks so much!

Share this post


Link to post
Share on other sites

I've decided to try this, looks like what I'd like to have on one of my sites. I've installed it (Popup Estimated Shipping v1.7b with UPS/USPS support), looks fine, no errors reported. However, the box is just refreshing when I try to get an estimate. I tried the Register Globals Fix but it is refreshing regardless of the fix and not returning any results.

 

Is anyone using or supporting this who knows why this would be happening? I am using USPS (without issue) only.

 

Thank you in advance.

Share this post


Link to post
Share on other sites
I've decided to try this, looks like what I'd like to have on one of my sites. I've installed it (Popup Estimated Shipping v1.7b with UPS/USPS support), looks fine, no errors reported. However, the box is just refreshing when I try to get an estimate. I tried the Register Globals Fix but it is refreshing regardless of the fix and not returning any results.

 

Is anyone using or supporting this who knows why this would be happening? I am using USPS (without issue) only.

 

Thank you in advance.

 

I have a new install on RC2.2a with the Estimated Shipping Module 1.7 installed (along with USPS Methods 2.9.6). I have it in a box on the right column. When a guest has items in their cart, the box shows up however, no shipping methods show up. If you log in, then the estimated shipping box works as it should.

 

I have installs on RC1.1 that work perfectly fine, so my suspicion is that something with RC2.2a is affecting the proper operation of the module. Can anyone help?

 

Thanks.

Share this post


Link to post
Share on other sites
I have a new install on RC2.2a with the Estimated Shipping Module 1.7 installed (along with USPS Methods 2.9.6). I have it in a box on the right column. When a guest has items in their cart, the box shows up however, no shipping methods show up. If you log in, then the estimated shipping box works as it should.

 

I have installs on RC1.1 that work perfectly fine, so my suspicion is that something with RC2.2a is affecting the proper operation of the module. Can anyone help?

 

Thanks.

 

 

Sorry, that should say that I have previous installs on RC2.1, not 1.1

Share this post


Link to post
Share on other sites

Hi all,

 

Just wondering if someone would like to view in other currencies other that the base currency, is it possible to change the default currencies for the estimated shipping costs popup window, For example, the base currency is USD, when someone in UK would like to view the estimated shipping costs in GBP, is there a way to show the shipping cost in GBP as well? <_<

 

many thanks

Share this post


Link to post
Share on other sites

Hi,

 

I'm trying to get this contibution to work with Free shipping per product 1.0 The only code ree shipping per product 1.0 adds to checkout_shipping.php is:

 

if ($free_shipping == false) {
 $check_free_shipping_basket_query = tep_db_query("select products_id from " . TABLE_CUSTOMERS_BASKET . " where customers_id = '" . (int)$customer_id . "'");
 while ($check_free_shipping_basket = tep_db_fetch_array($check_free_shipping_basket_query)) {
$check_free_shipping_query = tep_db_query("select products_free_shipping from " . TABLE_PRODUCTS . " where products_id = '" . (int)$check_free_shipping_basket['products_id'] . "'");
$check_free_shipping = tep_db_fetch_array($check_free_shipping_query);
$check_free_shipping_array[] = $check_free_shipping['products_free_shipping'];
 }
 if (in_array("1", $check_free_shipping_array) && !in_array("0", $check_free_shipping_array)) {
$free_shipping = true;
include_once(DIR_WS_LANGUAGES . $language . '/checkout_shipping.php');
 }
}

 

I have added this to estimated_shipping_functions.php between

 

/* Free shipping disabled */
} else {
	$free_shipping = false;
}

 

and

 

// process the selected shipping method

if (!tep_session_is_registered('shipping')) tep_session_register('shipping');

 

but it doesn't give the desired result. What have I missed?

 

Help appreciated.

Share this post


Link to post
Share on other sites

Hello everyone, :)

until it, I did not realize was, but after having activate VAT for shipping, I realize that in estimated_shipping, fees for colissimo international ports, for example, is against a good, in colissimo access, it always displays the price HT and even being logged.

By cons, there is no problem in the page checkout_shipping.php, the cost of its ports of TTC.

 

Did you notice this problem?

I compare different modules history to see if he misses a line or if there is code that is not the same between these 2 modules, but I can not see a source of the problem

 

I know this is a detail, since we said that this is an estimate but what is unfortunate for the client once logged, it is a price to realize that final page It is stronger

 

thank you very much for your returns, :)

Steph

 

 

ps : sorry for my english :blush:

Share this post


Link to post
Share on other sites
I have a new install on RC2.2a with the Estimated Shipping Module 1.7 installed (along with USPS Methods 2.9.6). I have it in a box on the right column. When a guest has items in their cart, the box shows up however, no shipping methods show up. If you log in, then the estimated shipping box works as it should.

 

I have installs on RC1.1 that work perfectly fine, so my suspicion is that something with RC2.2a is affecting the proper operation of the module. Can anyone help?

 

Thanks.

 

This will be a late reply for marvs5, but may help someone else who is experiencing the same issue. For the Register Globals Fix from this contrib to work, you have to be using the Register Globals Contribution by Richard Bentley found at http://www.oscommerce.com/community/contributions,2097. (Or at least a portion of his contrib.)

 

The link_post_variable referenced in the fix from this contribution is part of his Register Globals fix, not a stock OSC function (or RC2.2a function). I don't actually use Richards Register Globals fix, I'm using a 2.2a adaptation, but I copied his useful function to my includes/functions/general.php file to troubleshoot other contributions. You can find the exact code and instructions by downloading his contrib. and then searching for the link_post_variable and link_get_variable insert for general.php.

 

I'm not a programmer, so naturally I assume no liability...blah blah. But I also assume no credit which should all go to the authors of the respective contribs themselves, especially Richard for taking the trouble to give the rest of us some hints on keeping our old code going. Way to go! http://forums.oscommerce.com/style_images/...icons/icon6.gif

Share this post


Link to post
Share on other sites

Hi everyone

have installed this excellent cont but I have two issues both which have been raised before but never answered.

 

1) in my shopping_cart.php the continue shopping button disappears from the page after a while. (Originnally noted by Kina post 255) Why does it do it and how can I stop it going AWOL.

 

2) I have free shipping over £100, but the shipping estimator shows both what the cost would be and that it is also free. So two entries for the order. Is there anyway I can just show the free shipping? (Originally raised by Leveera post 332)

 

Any help would be really appreciated

 

Andrea

Share this post


Link to post
Share on other sites

Hi Everyone,

 

This looks like a great contribution and I think it will suit my needs perfectly.

 

I just wondered if anyone could tell me if they have used this contribution using settings similar to mine:

 

Australian based store, Aus Post Shipping Module installed, which calculates postage within Australia by Zipcode, and internationally by country name. Free shipping over a certain amount within Australia.

 

Any comments would be greatly appreciated.

 

I would like to use this on the shopping cart page below the cart. No popup.

 

Thanks!

Share this post


Link to post
Share on other sites
I have a new install on RC2.2a with the Estimated Shipping Module 1.7 installed (along with USPS Methods 2.9.6). I have it in a box on the right column. When a guest has items in their cart, the box shows up however, no shipping methods show up. If you log in, then the estimated shipping box works as it should.

 

I have this same issue. Module works fine once logged in, but won't work for guests. Anyone have a solution?

Share this post


Link to post
Share on other sites

Hi

I have a big problem with the Estimated Shipping Cost addon.

 

I followed the guide step by step. But, when i push "get quote" i get this error:

 

error.jpg

(http://pcdeler.net/ship_estimator.php?action=ship_error)

 

I just have this problem when accessing Estimated Shipping Cost from the shopping cart.(It works when the user is logged in though)

Trough products, everything works like a charm!

 

Whats wrong?

One thing more thing: How do i get rid of the state field?

Any help would be appreciated!

 

Webpage: pcdeler.net

 

Regards Morten Jansrud

Edited by Mortenjan

Share this post


Link to post
Share on other sites
Hi

I have a big problem with the Estimated Shipping Cost addon.

 

I followed the guide step by step. But, when i push "get quote" i get this error:

 

error.jpg

(http://pcdeler.net/ship_estimator.php?action=ship_error)

 

I just have this problem when accessing Estimated Shipping Cost from the shopping cart.(It works when the user is logged in though)

Trough products, everything works like a charm!

 

Whats wrong?

One thing more thing: How do i get rid of the state field?

Any help would be appreciated!

 

Webpage: pcdeler.net

 

Regards Morten Jansrud

 

wrong add on, sorry:)

Share this post


Link to post
Share on other sites

I have now tried this estimated shipping addon. (Im quite sure im in the right place now :blush: )

 

But great.. This either doesnt work.

I get this error:

 

Fatal error: Call to undefined method shoppingCart::get_content_type() in /home/pcdelern/public_html/includes/classes/estimated_shipping_class.php on line 30

 

familiar?

 

Regards Morten

Share this post


Link to post
Share on other sites

Stupid question but how do you change the style in the css file for this contribution?

I was able to change the header colour by trial and error but that's about it.

My borders are not visible (I guess they are set to white) and I could not find a parameter in the css file that made the border show up.

 

Am I doing something wrong, can somebody provide an expanation on what the entries in the css for this mode are?

 

Thanks

 

D.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×