Jump to content
Sign in to follow this  
wheeloftime

Estimated Shipping Costs

Recommended Posts

Thanks for all the help wheeloftime and potikyan.

I installed the contribution that you linked. I enabled all the shipping rates I need. However, I have one concern, and that is how does it know where to base the rates off of? I don't specify my address anywhere in the module, so how does it know where I will be shipping from?

 

Thanks!

Andrew

The base is there what you fill in for the admin->configuration->shipping/packaging and the options 'Country of origin' and 'Postal Code'.

Share this post


Link to post
Share on other sites

Ah, how silly of me. Thanks!

So, I finally got it working, except that when the popup is first loaded, it says this:

 

111210: The requested service is unavailable between the selected locations.

If you prefer to use ups as your shipping method, please contact <name>

 

If you enter the zip, then everything turns out fine. How can I get rid of this initial message?

 

The base is there what you fill in for the admin->configuration->shipping/packaging and the options 'Country of origin' and 'Postal Code'.

Share this post


Link to post
Share on other sites
Hi,

I was wondering if anyone else had issues getting USPS rates with USPS Methods contrib** installed?

 

All other shipping modules work fine, but nothing shows up for USPS =\

 

What a great contrib--

 

Jerry

(** http://www.oscommerce.com/community/contri...h,USPS+Methods)

Which version of this USPS contrib do you have installed ? Est. Shipping with UPS/USPS support works for the default osC shipping modules but maybe this contrib has a little different behaviour and I would have to look into it to be able to say something more precise.

Share this post


Link to post
Share on other sites
Which version of this USPS contrib do you have installed ? Est. Shipping with UPS/USPS support works for the default osC shipping modules but maybe this contrib has a little different behaviour and I would have to look into it to be able to say something more precise.

 

Hi, I currently have Version 2.7d of USPS Methods installed,

thanks, Jerry

Share this post


Link to post
Share on other sites

Can anyone please help?

 

Ah, how silly of me. Thanks!

So, I finally got it working, except that when the popup is first loaded, it says this:

If you enter the zip, then everything turns out fine. How can I get rid of this initial message?

Share this post


Link to post
Share on other sites
Hi, I currently have Version 2.7d of USPS Methods installed,

thanks, Jerry

Jerry,

 

I just installed your USPS version in my test shop but it does show up like the rest. I get no quotes because, I guess, I have no account with USPS but if I understood you correctly it didn't show up at all with you ?

You can always compare the output of the est. shipping box with the first checkout screen as those should match. If USPS shows up when going through checkout normally and not within the est. shipping infobox something else must be wrong. Whether you get correct quotes I can not tell as I can not test such thing.

 

regards,

Howard

Share this post


Link to post
Share on other sites

Hi Howard,

much thanks for looking in-

in my install, the Est. Ship module works great with all default shipping modules except the modified USPS- all ship methods appear with prices. with the USPS Methods mod, no methods or prices appear underneath the zip code form. (hence, i cannot even compare with checkout shipping cost)

 

anyway i will try to install again..

 

perhaps Estimated Shippping Costs module can one day allow admin to select which methods are allowed.. :rolleyes: :P

 

 

thanks again!

 

jerry

 

 

 

Jerry,

 

I just installed your USPS version in my test shop but it does show up like the rest. I get no quotes because, I guess, I have no account with USPS but if I understood you correctly it didn't show up at all with you ?

You can always compare the output of the est. shipping box with the first checkout screen as those should match. If USPS shows up when going through checkout normally and not within the est. shipping infobox something else must be wrong. Whether you get correct quotes I can not tell as I can not test such thing.

 

regards,

Howard

Share this post


Link to post
Share on other sites
Hi Howard,

much thanks for looking in-

in my install, the Est. Ship module works great with all default shipping modules except the modified USPS- all ship methods appear with prices. with the USPS Methods mod, no methods or prices appear underneath the zip code form. (hence, i cannot even compare with checkout shipping cost)

 

anyway i will try to install again..

 

perhaps Estimated Shippping Costs module can one day allow admin to select which methods are allowed.. :rolleyes: :P

thanks again!

 

jerry

Jerry,

 

You should check if the USPS module shows up in your normal checkout procedure. If it does there and not within the est. shipping box then for some reason it is not picked up, but as said, it does show up with me although without any quotes.

The est. shipping is meant for showing the normal checkout shipping costs on beforehand, not for filtering shipping methods for one of the many available shipping modules :rolleyes: Don't hold your breath :D

Share this post


Link to post
Share on other sites

Suddenly, it works-- :blink:

 

went thru the order process again and after logging in and going back to the cart to test the estimate popup, the methods and quotes appear--

maybe it took a few logins to propagate in the db? :huh:

 

anyhow big thanks once again howard!

 

 

 

 

 

Jerry,

 

You should check if the USPS module shows up in your normal checkout procedure. If it does there and not within the est. shipping box then for some reason it is not picked up, but as said, it does show up with me although without any quotes.

The est. shipping is meant for showing the normal checkout shipping costs on beforehand, not for filtering shipping methods for one of the many available shipping modules :rolleyes: Don't hold your breath :D

Share this post


Link to post
Share on other sites
Suddenly, it works-- :blink:

 

went thru the order process again and after logging in and going back to the cart to test the estimate popup, the methods and quotes appear--

maybe it took a few logins to propagate in the db? :huh:

 

anyhow big thanks once again howard!

There is not a relation with the db so that's certainly not it. I see now that you talk about the popup version which might behave differently but I do not know that version.

Share this post


Link to post
Share on other sites

hi,

 

i really like the popup shipping estimate. i had ship in cart working but thought it looked really cluttered. this is much better.

 

problem is, i'm using canada post for shipping and i'm getting an "XML parsing error" where the shipping options and costs should be.

 

the details of the XML feed from canada post are beyond me, so i don't even know where to start to fix this.

 

any ideas?

 

thanks.

-p.

 

(www.plastiquemonkey.com/shop)

Share this post


Link to post
Share on other sites

one more thing:

 

the popup window isn't picking up the stylesheet cues. the background color is a dark brown, so the black text is barely readable.

 

any ideas how to fix this?

-p.

Share this post


Link to post
Share on other sites

Hi,

 

I've revamped my site, and having a little problem now. I combined all my infoboxes to the left of the page, and when I add something to the cart, the ESC mod makes my box pop out further than I want it to be. I've looked and set the BOX_WIDTH in it to 1, and it still justs out. Can anyone help me with this issue? Minor bug but it's driving me crazy :P

 

Thank you.

 

http://www.angelic-giftstore.com

 

just add something to the cart to see what I mean for the infoxbox on the left.

Share this post


Link to post
Share on other sites
Hi,

 

I've revamped my site, and having a little problem now. I combined all my infoboxes to the left of the page, and when I add something to the cart, the ESC mod makes my box pop out further than I want it to be. I've looked and set the BOX_WIDTH in it to 1, and it still justs out. Can anyone help me with this issue? Minor bug but it's driving me crazy :P

 

Thank you.

 

http://www.angelic-giftstore.com

 

just add something to the cart to see what I mean for the infoxbox on the left.

 

It looks like your country drop down menu is what's setting the width of the box, so I'd try to decrease the width of the drop down box.

Share this post


Link to post
Share on other sites
It looks like your country drop down menu is what's setting the width of the box, so I'd try to decrease the width of the drop down box.

 

 

Ok thank you. I can't seem to find that in the files I looked at. I'll redownload the package and see what I might be missing. Thank you again.

Share this post


Link to post
Share on other sites
Ok thank you. I can't seem to find that in the files I looked at. I'll redownload the package and see what I might be missing. Thank you again.

 

 

Ok, I downloaded and found out where I can make the table right below the Country drop down menu smaller lol. :blink:

 

But that was it. I looked and looked through all the files but am just not seeing it. If anyone can steer me in the right direction, would be most appreciated

Share this post


Link to post
Share on other sites
Ok, I downloaded and found out where I can make the table right below the Country drop down menu smaller lol. :blink:

 

But that was it. I looked and looked through all the files but am just not seeing it. If anyone can steer me in the right direction, would be most appreciated

You can change the BOX_WIDTH+50 to something like BOX_WIDTH+10 inside the (catalog)/includes/modules/estimated_shipping.php to make the country list alone smaller

Share this post


Link to post
Share on other sites
You can change the BOX_WIDTH+50 to something like BOX_WIDTH+10 inside the (catalog)/includes/modules/estimated_shipping.php to make the country list alone smaller

 

 

Ok thanks wheeloftime, I had it as low as possible but still wouldn't work. So extended my infobox width, fixed that problem but created another in the making lol. Not to do with that issue though, not sure what I did now! Thank you again.

Share this post


Link to post
Share on other sites

Okay, this may be a stupid question...but here it goes...

 

How do I make the popup window for the "estimated shipping cost" longer? When all of my shipping methods are listed, the popup window size cannot be changed...thus, you can't read all of the shipping costs.

 

any ideas?

 

thanks.

Edited by MarylandEd

Share this post


Link to post
Share on other sites
Okay, this may be a stupid question...but here it goes...

 

How do I make the popup window for the "estimated shipping cost" longer? When all of my shipping methods are listed, the popup window size cannot be changed...thus, you can't read all of the shipping costs.

 

any ideas?

 

thanks.

 

The code that controls the size of the popup window is in catalog/shopping_cart.php just above the </head>. You can change the width and height of the popup window, as well as make it resizable. Currently it is set not to have scrollbars or ability to resize the window, but these can easily be changed. The code you need to change is below.

 

<script language="javascript"><!--

function popupWindow(url) {

window.open(url,'popupWindow','toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=no,resizable=no,copyhistory=no,width=500,height=310,screenX=150,screenY=250')

}

//--></script>

Share this post


Link to post
Share on other sites
The code that controls the size of the popup window is in catalog/shopping_cart.php just above the </head>. You can change the width and height of the popup window, as well as make it resizable. Currently it is set not to have scrollbars or ability to resize the window, but these can easily be changed. The code you need to change is below.

 

<script language="javascript"><!--

function popupWindow(url) {

window.open(url,'popupWindow','toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=no,resizable=no,copyhistory=no,width=500,height=310,screenX=150,screenY=250')

}

//--></script>

 

 

Thanks! That solved my problem...

Share this post


Link to post
Share on other sites

I'm still getting this problem:

 

111210: The requested service is unavailable between the selected locations.

If you prefer to use ups as your shipping method, please contact <name>

 

If you enter the zip, then everything turns out fine. How can I get rid of this initial message?

 

Thanks!

 

 

Can anyone please help?

Share this post


Link to post
Share on other sites

Hi, I am getting this error when the shipping box opens:

testshop/FILENAME_POPUP_SHIPPING 404

 

Any thoughts?

Edited by pbpools

Share this post


Link to post
Share on other sites
Hi, I am getting this error when the shipping box opens:

testshop/FILENAME_POPUP_SHIPPING 404

 

Any thoughts?

Define the page in ../includes/filenames.php

define('FILENAME_POPUP_SHIPPING', 'popup_shipping.php');

Edited by fl70

It ain't your grandma's box!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×