Jump to content
Sign in to follow this  
wheeloftime

Estimated Shipping Costs

Recommended Posts

Fredrik, I'm not sure that using my way will resolve the problem you mentioned (I personally haven't had that problem) because it still calls the same code as those placed in non-popup versions.

 

Thanks,

Gary

 

I read in this thread that the sesson broke and therefore the lost of items in cart. The change to fix this in the last version was to add something in the line that refresh the page in the country selection drop list.

So if you have the shipping estimator in a popup, the lost of cart should not apear, since the refreshing is happen in a popup. I might got this all wrong, but I think it would work this way.

 

If someone have the problem with lost items in cart, please let us know. This is of great importance, because if you as a store owner dont have this problem, it doesent mean that someone of your visitors and potential customer dont have this problem depending on his settings in the browser etc.

 

// Fredrik

Share this post


Link to post
Share on other sites
I just checked your site. It looks great. Would you please post here (or pm me) how you modified the contribution to work on a pop up window?

I'd love to have this modification as well. I'm having a difficult time getting the mod to work within STS template and this would be a perfect resolution.

 

Thanks,

Cindy


cdickson

Share this post


Link to post
Share on other sites
I'd love to have this modification as well. I'm having a difficult time getting the mod to work within STS template and this would be a perfect resolution.

 

Thanks,

Cindy

 

Cindy, I'll be uploading this modification/instructions to the contribution page shortly and will post a link here.

 

Regards,

Gary

Share this post


Link to post
Share on other sites

Hello,

 

Thanks for your contrib!!

 

I am having a little trouble in the popup window. It looks like some of the html coding is off but I don't know how/where to fix it.

 

<p class="smallText" align="right"><img src="includes/languages/english/images/buttons/button_closewindow.gif" alt="close"> <?php echo '<a href="java script:window.close()">' . TEXT_CLOSE_WINDOW . '</a>'; ?></p>

 

It shows as TEXT_CLOSE_WINDOW in the popup. I'm assuming there is a missing .gif file for a button, button_closewindow.gif, in the package as well. That's no biggy, I can create one.

 

Need some help.

 

TIA

Share this post


Link to post
Share on other sites
Hello,

 

Thanks for your contrib!!

 

I am having a little trouble in the popup window. It looks like some of the html coding is off but I don't know how/where to fix it.

 

<p class="smallText" align="right"><img src="includes/languages/english/images/buttons/button_closewindow.gif" alt="close">?<?php echo '<a href="java script:window.close()">' . TEXT_CLOSE_WINDOW . '</a>'; ?></p>

 

It shows as TEXT_CLOSE_WINDOW in the popup. I'm assuming there is a missing .gif file for a button, button_closewindow.gif, in the package as well. That's no biggy, I can create one.

 

Need some help.

 

TIA

 

Just uploaded version 1.7b with the above bug fixes. It is the full package. Here's all that was changed.

 

1. Place button_closewindow.gif found in the package into catalog/includes/languages/english/images/buttons/ folder

2. Add the below code to catalog/includes/languages/english/estimated_shipping.php just above the ?>

 

define('TEXT_CLOSE_WINDOW', 'Close window');

 

Good luck,

Gary

Share this post


Link to post
Share on other sites
Just uploaded version 1.7b with the above bug fixes. It is the full package. Here's all that was changed.

 

1. Place button_closewindow.gif found in the package into catalog/includes/languages/english/images/buttons/ folder

2. Add the below code to catalog/includes/languages/english/estimated_shipping.php just above the ?>

 

define('TEXT_CLOSE_WINDOW', 'Close window');

 

Good luck,

Gary

 

Hello Gary,

 

Thanks for the really fast response!!

 

Adding define('TEXT_CLOSE_WINDOW', 'Close window'); in catalog/includes/languages/english/estimated_shipping.php fixed the 'TEXT_CLOSE_WINDOW' issue but now I have a button with the text link to close the window next to the button. (The button doesn't work, just the text link) :)

 

Any ideas?

 

TIA

Share this post


Link to post
Share on other sites
Hello Gary,

 

Thanks for the really fast response!!

 

Adding define('TEXT_CLOSE_WINDOW', 'Close window'); in catalog/includes/languages/english/estimated_shipping.php fixed the 'TEXT_CLOSE_WINDOW' issue but now I have a button with the text link to close the window next to the button. (The button doesn't work, just the text link) :)

 

Any ideas?

 

TIA

 

That's strange. Could you please post your popup_shipping.php code or let me know what your website is so I can check it out?

 

Gary

Share this post


Link to post
Share on other sites
That's strange. Could you please post your popup_shipping.php code or let me know what your website is so I can check it out?

 

Gary

 

Hi Gary,

 

Its located at palmettoshopper.com/outlet/

 

The popup_shipping.php is:

 

<?php

/*

$Id: popup_tracker.php,v 1.0 200/05/18 12:18:40 $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2002 osCommerce

 

Released under the GNU General Public License

*/

 

require('includes/application_top.php');

require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_ESTIMATED_SHIPPING);

$navigation->remove_current_page();

?>

<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN">

<html <?php echo HTML_PARAMS; ?>>

<head>

<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">

<base href="<?php echo (($request_type == 'SSL') ? HTTPS_SERVER : HTTP_SERVER) . DIR_WS_CATALOG; ?>">

<title><?php echo TITLE; ?> : <?php echo HEADING_TITLE; ?></title>

<link rel="stylesheet" type="text/css" href="stylesheet.css">

<?php

// osCoders.biz - Analystics - start

if ($request_type == 'SSL') {

?>

<script src="https://ssl.google-analytics.com/urchin.js" type="text/javascript">

</script>

<script type="text/javascript">

_uacct="UA-188558-1";

urchinTracker();

</script>

<?php

} else {

?>

<script src="http://www.google-analytics.com/urchin.js" type="text/javascript">

</script>

<script type="text/javascript">

_uacct="UA-188558-1";

urchinTracker();

</script>

<?

}

// osCoders.biz - Analistics - end

?>

</head>

 

<table width="100%" height="275"><tr><td align="center" valign="top">

<table width="93%" border="0" align="center" cellpadding="0" cellspacing="0">

<!-- BEGIN estimated shipping -->

<tr>

<td><br><?php include(DIR_WS_MODULES . FILENAME_ESTIMATED_SHIPPING); ?></td>

</tr>

<!-- END estimated shipping -->

<tr><td>

<p class="smallText" align="right"><img src="includes/languages/english/images/buttons/button_close_window.gif" alt="close"> <?php echo '<a href="java script:window.close()">' . TEXT_CLOSE_WINDOW . '</a>'; ?></p>

</td></tr>

 

</table>

<br>

 

</body>

</html>

Share this post


Link to post
Share on other sites
<!-- END estimated shipping -->

<tr><td>

<p class="smallText" align="right"><img src="includes/languages/english/images/buttons/button_close_window.gif" alt="close"> <?php echo '<a href="java script:window.close()">' . TEXT_CLOSE_WINDOW . '</a>'; ?></p>

 

Ok, I see. I didn't realize that you put a large close button for the window. The missing button was just a small x icon that I'm using (see my site www.westwoodprinters.com), but your way will work too. You basically want to get rid of the 'close window' text and be able to click on the button you've created. Here's what to do:

 

Open popup_shipping.php

 

FIND

<p class="smallText" align="right"><img src="includes/languages/english/images/buttons/button_close_window.gif" alt="close"> <?php echo '<a href="javascript:window.close()">' . TEXT_CLOSE_WINDOW . '</a>'; ?></p>

 

REPLACE WITH

<p class="smallText" align="right"><?php echo '<a href="javascript:window.close()">' . '<img src="includes/languages/english/images/buttons/button_close_window.gif" alt="close" border="0"></a>'; ?></p>

 

This should work just fine.

Gary

Edited by potikyan

Share this post


Link to post
Share on other sites
Ok, I see. I didn't realize that you put a large close button for the window. The missing button was just a small x icon that I'm using (see my site www.westwoodprinters.com), but your way will work too. You basically want to get rid of the 'close window' text and be able to click on the button you've created. Here's what to do:

 

Open popup_shipping.php

 

FIND

<p class="smallText" align="right"><img src="includes/languages/english/images/buttons/button_close_window.gif" alt="close"> <?php echo '<a href="javascript:window.close()">' . TEXT_CLOSE_WINDOW . '</a>'; ?></p>

 

REPLACE WITH

<p class="smallText" align="right"><?php echo '<a href="javascript:window.close()">' . '<img src="includes/languages/english/images/buttons/button_close_window.gif" alt="close" border="0"></a>'; ?></p>

 

This should work just fine.

Gary

 

Hi Gary,

 

That worked!! Thanks!!

 

I created a button when it appeared one wasn't included. I looked at the code and couldn't find one in the contrib.

 

Really appreciate your help!!

 

One other very minor thing. Any idea why my "Submit" button appears to be 'superscript'?

 

Again, many thanks!!

Share this post


Link to post
Share on other sites
Hi Gary,

 

That worked!! Thanks!!

 

I created a button when it appeared one wasn't included. I looked at the code and couldn't find one in the contrib.

 

Really appreciate your help!!

 

One other very minor thing. Any idea why my "Submit" button appears to be 'superscript'?

 

Again, many thanks!!

 

Not sure what to make of it. I had a similar problem when I was using an image button, so I ended up replacing it with the generic form button. I tried to change the vertical alignment of the button within the box, but nothing helped.

 

Glad it works now.

Gary

Share this post


Link to post
Share on other sites
Not sure what to make of it. I had a similar problem when I was using an image button, so I ended up replacing it with the generic form button. I tried to change the vertical alignment of the button within the box, but nothing helped.

 

Glad it works now.

Gary

 

I noticed that on your site but when I installed the contrib there were image buttons so I just created my own to match my site.

 

Did the new version you just uploaded use txt links or buttons?

 

Thanks!!

Share this post


Link to post
Share on other sites
I finally got around to writing the instructions for the popup support and posted it on the contribution page (link below).

 

Popup Estimated Shipping v1.7a with UPS/USPS support

 

Good luck.

Gary

Gary,

 

Thanks for writing and posting this popup version. It works beautifully with the STS Template without having to go through the process of putting it in one of the columns, which I preferred not to do. :thumbsup:

 

Cheers!


cdickson

Share this post


Link to post
Share on other sites
I finally got around to writing the instructions for the popup support and posted it on the contribution page (link below).

 

Popup Estimated Shipping v1.7a with UPS/USPS support

 

Good luck.

Gary

 

 

Great work on the modification! I just installed it and it works like a champ.

 

I took a look at your site (very nice) and implentation of the contribution and I was wondering if you could tell me how you elimated the display of the Estimated Date of Delivery (EDD) for UPS? Also, how did you eliminate the text "111210: The requested service is unavailable between the selected locations. If you prefer to use ups as your shipping method, please contact..." that appears before the visitor makes their selection. And finally, how can I change the graphic button to a 'regular' HTML form button?

 

Thanks a lot!

 

- eyestuffguy

Share this post


Link to post
Share on other sites
Great work on the modification! I just installed it and it works like a champ.

 

I took a look at your site (very nice) and implentation of the contribution and I was wondering if you could tell me how you elimated the display of the Estimated Date of Delivery (EDD) for UPS? Also, how did you eliminate the text "111210: The requested service is unavailable between the selected locations. If you prefer to use ups as your shipping method, please contact..." that appears before the visitor makes their selection. And finally, how can I change the graphic button to a 'regular' HTML form button?

 

Thanks a lot!

 

- eyestuffguy

 

Hi. To change the image button to the html form submit button do the following in catalog/includes/modules/estimated_shipping.php:

 

FIND:

 <tr><td align="center" class="smallText">' . TEXT_ZIPCODE . '?' . tep_draw_input_field('estzipcode', $estzipcode,'MAXLENGTH="20" SIZE="10"') . '?' . tep_image_submit('button_est_ship_submit.gif', IMAGE_BUTTON_SUBMIT) . '</td></tr></TABLE>' . tep_get_estimated_shipping_quotes($country,  $HTTP_GET_VARS['action'],$customer_country_id));

 

REPLACE WITH:

 <class="smallText">' . TEXT_ZIPCODE . '?' . tep_draw_input_field('estzipcode', $estzipcode,'MAXLENGTH="20" SIZE="8"') . '?' . '<input type="submit" value="Submit">' . '</TABLE>' . tep_get_estimated_shipping_quotes($country,  $HTTP_GET_VARS['action'],$customer_country_id));

 

As for the other problem, I'm not sure what that is. Let me know where I can see your site and I'll take a look at it. It sounds like an error message generated from your UPS shipping module.

 

Gary

Share this post


Link to post
Share on other sites
Hi. To change the image button to the html form submit button do the following in catalog/includes/modules/estimated_shipping.php:

 

FIND:

 <tr><td align="center" class="smallText">' . TEXT_ZIPCODE . '?' . tep_draw_input_field('estzipcode', $estzipcode,'MAXLENGTH="20" SIZE="10"') . '?' . tep_image_submit('button_est_ship_submit.gif', IMAGE_BUTTON_SUBMIT) . '</td></tr></TABLE>' . tep_get_estimated_shipping_quotes($country,  $HTTP_GET_VARS['action'],$customer_country_id));

 

REPLACE WITH:

 <class="smallText">' . TEXT_ZIPCODE . '?' . tep_draw_input_field('estzipcode', $estzipcode,'MAXLENGTH="20" SIZE="8"') . '?' . '<input type="submit" value="Submit">' . '</TABLE>' . tep_get_estimated_shipping_quotes($country,  $HTTP_GET_VARS['action'],$customer_country_id));

 

As for the other problem, I'm not sure what that is. Let me know where I can see your site and I'll take a look at it. It sounds like an error message generated from your UPS shipping module.

 

Gary

 

Thanks Gary.

I'm fiddling with this now.

 

How about my other question regarding "how you elimated the display of the Estimated Date of Delivery (EDD) for UPS?"

 

Also, I'll send a link to my site at another time since it's quite a mess now.

 

Thanks!!!

Share this post


Link to post
Share on other sites
Thanks Gary.

I'm fiddling with this now.

 

How about my other question regarding "how you elimated the display of the Estimated Date of Delivery (EDD) for UPS?"

 

Also, I'll send a link to my site at another time since it's quite a mess now.

 

Thanks!!!

 

EDD might be a feature of your UPS shipping module, as I never had that displaying on my site. If it is a shipping module feature, you might be able to disable it through your admin panel (modules-->shipping-->ups). I could be wrong though, so if anyone knows, please comment.

Share this post


Link to post
Share on other sites

I've installed this contribution (and put it in the shopping_cart.php) and it works well. I've also installed the "switch between incl. and excl. Tax" contribution, which works well also.

 

Now I would like to combine the two. If a non-registered customer fills in the shipping-country I would like the total price in the shopping cart to be either incl. or excl. Tax, depending on the country.

 

The whole thing should be integrated in the shopping cart I think, so it would be like:

 

Shopping cart:

Items in shopping cart

Total price (incl. or excl. Tax, depending on country)

Shipping costs (also depending on country)

 

and below that comes the 'form' to change the country (like it is in this contribution right now).

 

Can you still follow me?

 

Anyway, I have a problem with creating what I want ...... I suppose I have to add something to the shopping_cart.php, and it probably has to come from /classes/order.php, but I'm not sure and I don't know how and what to do.

 

Can anyone help me with this?

Share this post


Link to post
Share on other sites

nice contribution!

 

who's tracking code is this and why is it on here:

from catalog/popup_shipping.php

<?php
			// osCoders.biz - Analystics - start
			if ($request_type == 'SSL') {
			?>
			 <script src="https://ssl.google-analytics.com/urchin.js" type="text/javascript">
			 </script>
			 <script type="text/javascript">
			   _uacct="UA-188558-1";
			   urchinTracker();
			 </script>
			<?php
			} else {
			?>
			 <script src="http://www.google-analytics.com/urchin.js" type="text/javascript">
			 </script>
			   <script type="text/javascript">
				_uacct="UA-188558-1";
				urchinTracker();
			 </script>
			<?
			}
			// osCoders.biz - Analistics - end
			?>

 

there's also an image:

"images/m01.1.gif" width="93" height="35" called in the same file, but it doesn't exist in the install file... i reckon this wasn't supposed to be added to the download package?

Share this post


Link to post
Share on other sites
nice contribution!

 

who's tracking code is this and why is it on here:

from catalog/popup_shipping.php

<?php
			// osCoders.biz - Analystics - start
			if ($request_type == 'SSL') {
			?>
			 <script src="https://ssl.google-analytics.com/urchin.js" type="text/javascript">
			 </script>
			 <script type="text/javascript">
			   _uacct="UA-188558-1";
			   urchinTracker();
			 </script>
			<?php
			} else {
			?>
			 <script src="http://www.google-analytics.com/urchin.js" type="text/javascript">
			 </script>
			   <script type="text/javascript">
				_uacct="UA-188558-1";
				urchinTracker();
			 </script>
			<?
			}
			// osCoders.biz - Analistics - end
			?>

 

there's also an image:

"images/m01.1.gif" width="93" height="35" called in the same file, but it doesn't exist in the install file... i reckon this wasn't supposed to be added to the download package?

 

Oops. Thanks for noticing. This is a google analytics code that shouldn't be included. Just delete the above between the //osCoders.biz snippets. As for the m01.1.gif, that's also site specific and should be removed.

Share this post


Link to post
Share on other sites

Subject: How to make work with contrib Free Shipping per product ?

Hi,

I just installed version 1.5 (since in Europe and don't want pop up nor ups--I think that's the one to have?) Fast and easy install.

So far looks good.

 

But I have the contribution Free Shipping Per Product 1.1 (http://www.oscommerce.com/community/contributions,2517 ) which lets me designate free shipping for individually designated products within my country. Is there a way I can take that into account?

 

Thanks a zillion.

India


*** Je suis plus souvent sur le forum français ***

ms2fr, Header Tags 2.5.5b, Order logging before payment, Better PayPal Description perso, Free shipping per product, Must agree to terms, Country State Selector, World Zones, Visible countries, Store Pick Up, several shipping modules, Personal Invoice Number, 'On the Fly' Auto Thumbnailer using GD Library, More_Pics_6 for 2.2 ms2, Ultimate SEO URLs 2-2.1d/e,Virement Bancaire, Estimated Shipping 1.5, xml_guide, SP+,Step By Step 1.8, Order Editor 2.6.3, Google Analytics, Dynamic Sitemap 2.0, OSC-Expeditor, Recover Cart Sales, Links Manager 1.15

local : linux 2.6 Fedora Core 3, server : APACHE 2.0.54, MySQL 4.1.18, php : 4.4.0 (on strike refuse to update)

remote : IcoOpenBSD 4.x, server : IcodiaSecureHttpd, MySQL 4.1.24, php : 4.4.9

 

You never get a second chance to make a first impression.

Share this post


Link to post
Share on other sites
Subject: How to make work with contrib Free Shipping per product ?

Hi,

I just installed version 1.5 (since in Europe and don't want pop up nor ups--I think that's the one to have?) Fast and easy install.

So far looks good.

 

But I have the contribution Free Shipping Per Product 1.1 (http://www.oscommerce.com/community/contributions,2517 ) which lets me designate free shipping for individually designated products within my country. Is there a way I can take that into account?

 

Thanks a zillion.

India

:( I will be happy to struggle with the code if only I had a clue where to start.

-clueless


*** Je suis plus souvent sur le forum français ***

ms2fr, Header Tags 2.5.5b, Order logging before payment, Better PayPal Description perso, Free shipping per product, Must agree to terms, Country State Selector, World Zones, Visible countries, Store Pick Up, several shipping modules, Personal Invoice Number, 'On the Fly' Auto Thumbnailer using GD Library, More_Pics_6 for 2.2 ms2, Ultimate SEO URLs 2-2.1d/e,Virement Bancaire, Estimated Shipping 1.5, xml_guide, SP+,Step By Step 1.8, Order Editor 2.6.3, Google Analytics, Dynamic Sitemap 2.0, OSC-Expeditor, Recover Cart Sales, Links Manager 1.15

local : linux 2.6 Fedora Core 3, server : APACHE 2.0.54, MySQL 4.1.18, php : 4.4.0 (on strike refuse to update)

remote : IcoOpenBSD 4.x, server : IcodiaSecureHttpd, MySQL 4.1.24, php : 4.4.9

 

You never get a second chance to make a first impression.

Share this post


Link to post
Share on other sites

Hello,

Thanks for your work on the pop-up variant of the estimated shipping costs contribution.

I just installed it and I noticed something that (I think) should be 'repared''.

 

In the shopping cart, the link and button 'continue shopping' have disappeared, and I think it has to do with the following code from shopping_cart.php.

 

Hope you can fix it (I can't).

 

 

 

<?php
$back = sizeof($navigation->path)-2;
if (isset($navigation->path[$back])) {
?>
			<td class="main"><?php echo '<a href="' . tep_href_link($navigation->path[$back]['page'], tep_array_to_string($navigation->path[$back]['get'], array('action')), $navigation->path[$back]['mode']) . '">' . tep_image_button('button_continue_shopping.gif', IMAGE_BUTTON_CONTINUE_SHOPPING) . '</a>'; ?></td>
<?php
}
?>

Share this post


Link to post
Share on other sites
Hello,

Thanks for your work on the pop-up variant of the estimated shipping costs contribution.

I just installed it and I noticed something that (I think) should be 'repared''.

 

In the shopping cart, the link and button 'continue shopping' have disappeared, and I think it has to do with the following code from shopping_cart.php.

 

Hope you can fix it (I can't).

<?php
$back = sizeof($navigation->path)-2;
if (isset($navigation->path[$back])) {
?>
			<td class="main"><?php echo '<a href="' . tep_href_link($navigation->path[$back]['page'], tep_array_to_string($navigation->path[$back]['get'], array('action')), $navigation->path[$back]['mode']) . '">' . tep_image_button('button_continue_shopping.gif', IMAGE_BUTTON_CONTINUE_SHOPPING) . '</a>'; ?></td>
<?php
}
?>

 

Hi. The popup shouldn't have any effects on the continue shopping button. The code above looks just like mine, except for the <td class="main"> and the closing </td>. Here is the exact code I have in my shopping_cart.php. Change the above with this and see if the button comes back.

 

<?php
$back = sizeof($navigation->path)-2;
if (isset($navigation->path[$back])) {
?>
			<?php echo '<a href="' . tep_href_link($navigation->path[$back]['page'], tep_array_to_string($navigation->path[$back]['get'], array('action')), $navigation->path[$back]['mode']) . '">' . tep_image_button('button_continue_shopping.gif', IMAGE_BUTTON_CONTINUE_SHOPPING) . '</a>'; ?>
<?php
}
?>

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×