Jump to content
Sign in to follow this  
arm1tage

2Checkout V2 WORKING with OSC 2.2MS2!

Recommended Posts

A reply from 2CO tech support.

 

How to remove the TCOID from osc to 2CO

 

I was still successfully able to reach the 2checkout secure order page from

your website, however I did notice that your shopping cart was passing the

parameter and value (TCOID=081fffa44c4399a40e6389d9204aa7ef).  TCOID is not

a

parameter that you should be passing to our system.  This is a parameter

that

2CO uses exclusively inside our system, and no where else.

 

The information needed to configure a 3rd Party or Custom Shopping Cart can

be

found in correspondence box #7.


--

 

John Cannon

Share this post


Link to post
Share on other sites

So...oscommerce will not work with 2checkout without a ssl certificate..

Is this correct?

Share this post


Link to post
Share on other sites

No matter what I change when I try to log in and make a test order I get the cookie_usage.php file. I have my cookie directory set to "/" which is the directory of the catalog. I have cookies turned on, I have tried it in several different browsers on different computers and run into the same problem. Is there something else to do besides setting cookie domain to your domain name and the cookie directory to "/"?? If i turn off force cookies then everything works but I can not get the 2checkout page to return to my website and still be logged in, it wants me to log in again and then the order status is not updated. If I turn force cookies on then I cant get passed the that warning page about cookies. Any help???

Share this post


Link to post
Share on other sites

I have added the latest installation, followed the instructions dilegently and am getting this error message from 2co:

 

Parameter Error

 

Incorrect parameters were supplied, therefore this purchase cannot begin.

 

If you are attempting to purchase from a web site please contact the web site so that they can correct the error.

 

I look at the navigate bar of my firefox and I am not passing anything to 2checkout.

 

I did not upload items to the 2co database, I did comment out the lines in pm2checkout.php as the instructions indicated. Any ideas?

 

I would like to go live with the site on Monday. Somebody speak spanish. i'm in Colombia (y aqui se habla espa?ol) and i don't speak english very well.

 

thanks in advance.

Share this post


Link to post
Share on other sites
I installed the Mod 904, (2checkout v2.1a) and all seems to be working except the passbacks. I can make a purchase and go all the way to 2checkout confirmation - the transaction works because i get their email, etc. However, the page on 2co stays there. I have updated the return pages in "Look and feel" just nothing is happening. Needless to say no information is being updated in osc.

 

any ideas?

 

Did you ever figure out a fix for this problem. I'm in the same boat right now. My look and feel doesn't change. What did you do to fix this?? Thanks


Web Development, 365... 366 in a leap year.

Share this post


Link to post
Share on other sites

Hey,

 

I have serious problem with using pm2checkout under MS 2.2. I was going step-by-step as recommended in the installation instructions. Everything seemed to be in order, until I have made some test buy. In the payment checkout form I just can see credit card's logos, but no CC #, CVV, CC exp. date fields. Pls can somebody help me ? I am really upset. I have already repeated the installation three times and nothing has changed :(

 

PLS HELP !

 

Thanks in advance

Share this post


Link to post
Share on other sites
Hey,

 

I have serious problem with using pm2checkout under MS 2.2. I was going step-by-step as recommended in the installation instructions. Everything seemed to be in order, until I have made some test buy. In the payment checkout form I just can see credit card's logos, but no CC #, CVV, CC exp. date fields. Pls can somebody help me ? I am really upset. I have already repeated the installation three times and nothing has changed  :(

 

PLS HELP !

 

Thanks in advance

 

When you check out, are you checking out on your site or is the buyer being redirected to 2CO?


Web Development, 365... 366 in a leap year.

Share this post


Link to post
Share on other sites
When you check out, are you checking out on your site or is the buyer being redirected to 2CO?

Its by checking out on my webiste, after the shipping confirmation.

Share this post


Link to post
Share on other sites

I'm slightly confused . . . :blink:

 

Does the latest version of this contribution allow us to sell downloadable goods? I've seen posts that say no, but also others that hint otherwise.

 

If I can sell downloadable goods using this contribution, how do I set it up? On all my demo purchases I'm returned to my site's OSC successful checkout page, but no download link is shown. Also my shopping cart isn't cleared . . .

 

Any help would be appreciated.

 

 

 

-J.L.

Share this post


Link to post
Share on other sites
No matter what I change when I try to log in and make a test order I get the cookie_usage.php file. I have my cookie directory set to "/" which is the directory of the catalog. I have cookies turned on, I have tried it in several different browsers on different computers and run into the same problem. Is there something else to do besides setting cookie domain to your domain name and the cookie directory to "/"?? If i turn off force cookies then everything works but I can not get the 2checkout page to return to my website and still be logged in, it wants me to log in again and then the order status is not updated. If I turn force cookies on then I cant get passed the that warning page about cookies. Any help???

 

 

 

I am not sure if I have replied to you before, so excuse me if I have. I am having this same issue with 2checkout. Have you found a solution?

 

This is painful.

;)

Share this post


Link to post
Share on other sites
No matter what I change when I try to log in and make a test order I get the cookie_usage.php file. I have my cookie directory set to "/" which is the directory of the catalog. I have cookies turned on, I have tried it in several different browsers on different computers and run into the same problem. Is there something else to do besides setting cookie domain to your domain name and the cookie directory to "/"?? If i turn off force cookies then everything works but I can not get the 2checkout page to return to my website and still be logged in, it wants me to log in again and then the order status is not updated. If I turn force cookies on then I cant get passed the that warning page about cookies. Any help???

 

The thing is, OSC needs "Force Cookies" to be set to True in order to function with 2CO.

Forced cookies on the other hand ONLY work with a true SSL cert. They do NOT work with a shared SSL cert!

If you set "Force Cookie Use" to True while using a shared SSL, you will get the cookie_usage.php error, regardless whether cookies are on or off in your browser settings.

 

So...oscommerce will not work with 2checkout without a ssl certificate..

Is this correct?

 

Yes, correct.

Share this post


Link to post
Share on other sites
Only products already in 2CO's database will show up in the itemized list

on 2CO's "Order Detail" page. By default, products are auto-created in 2CO's dc

when purchased in a LIVE transaction. You want either ALL or NONE of your

products to be in the db. Otherwise if the customer buys 2 items only 1 may

be displayed.

 

To DISABLE itemized cart:

in /catalog/includes/modules/payment/pm2checkout.php:

comment out lines with c_name, c_price, and c_description parameters.

 

 

Can someone provide what the actual code looks like when it is commented out? I'm not exactly sure which lines I am commenting out, and at what part of the line.

 

Thanks

Share this post


Link to post
Share on other sites

I have installed 2checkout_v2.1 to OSCommerce, I had a couple problems as the one that was fixed by removing the ending spaces(problem with headers). Now I am told that There are a cokiies problem?? When I remove Force Cookies, I dont see that problem but I get parameters errors. Anybody know hwo to fix it? Btw my site is www.vanilandia.com

Edited by voltio

Share this post


Link to post
Share on other sites

Hi everyone,

 

I have this module working with the pass back and things seem ok.

 

One thing though. I dont want the module to auto create the product as I have the same product (id) that uses attributes that gives the product different values.

 

I would be grateful if someone could tell / show me exactly what I need to comment out in order to stop this auto creation of the product.

 

Many Thanks

 

Pete :)

Share this post


Link to post
Share on other sites

Please...anyone.. I really need some help with the above post. Its really messing things up for me on my live store :(

Share this post


Link to post
Share on other sites

Open the file: includes/modules/payment/pm2checkout.php

 

Comment out or delete the following lines:

 

$process_button_string .= tep_draw_hidden_field('c_name_' . $i, $order->products[$i]['name']);
$process_button_string .= tep_draw_hidden_field('c_description_' . $i, $text);
$process_button_string .= tep_draw_hidden_field('c_price_' . $i, $order->products[$i]['final_price']);
$process_button_string .= tep_draw_hidden_field('c_tangible_' . $i, 'Y'); // uncomment and change to N if you sell only non-tangible (ie downloadable) goods

Share this post


Link to post
Share on other sites
Hi everyone,

 

I have this module working with the pass back and things seem ok.

 

One thing though. I dont want the module to auto create the product as I have the same product (id) that uses attributes that gives the product different values.

 

I would be grateful if someone could tell / show me exactly what I need to comment out in order to stop this auto creation of the product.

 

Many Thanks

 

Pete :)

 

how did you get it to work? i still have the passback problem.. everything goes through 2checkout but when i click finalize order it goes to the login page and doesnt empty the cart or show in pending orders

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×