Jump to content
jcall

All Customers Report

Recommended Posts

I installed this contribution and it is great! Client is lovin' it!

 

I have two questions which I hope I'm not asking too much.

 

1. is there a way to sort the customers by when they signed up?

 

2. Is there a way to break the list up into pages? Maybe 50-100 customers per page for display in the browser?

 

Any help would be greatly appreciated.

 

Thank you in advance.

 

Jim

1 - The instructions explain how to add another column. You can add one based on that date and it would then be sortable.

 

2 - Not currently. Although you can sort of control that by using the start-stop dates.

 

Jack

Share this post


Link to post
Share on other sites

Jack,

 

I have just installed your latest version of this contribution and have run into a problem. I enter a start date and click the submit button and the list gets populated. However, when I click on a row heading to sort the list it reverts everything back to the way it was before I hit the submit button.

 

Do you have any ideas as to what may be causing this?

 

Thanks.

Share this post


Link to post
Share on other sites

Yes, it's an oversight in the coding. I didn't add the code to remember the settings on a sort. I will add that when I get the chance.

 

Jack

Share this post


Link to post
Share on other sites
Yes, it's an oversight in the coding. I didn't add the code to remember the settings on a sort. I will add that when I get the chance.

 

Jack

 

 

Sounds good. Thanks for your help and thanks for all of your time and efforts in helping making osCommerce what it is.

Share this post


Link to post
Share on other sites

I have installed and double checked the the changes i have made, and it all seems fime, but when i clike on the report, i get the following error.

 

Call to undefined function: tep_hide_session_id() in /homepages/21/d227036576/htdocs/admin/all_customers.php on line 122

 

Any help would be appreciated, this contribution looks just like what i need.


zappautomation

Share this post


Link to post
Share on other sites

Thanks Jack.

I have had a look at the links, but I'm not a programmer, what is this telling me?

 

Thanks

 

Gary

 

This should help.

 

Jack


zappautomation

Share this post


Link to post
Share on other sites

That error is saying there is a missing segment of code, which is common since that is how the package was released. Those posts, or some of them, explain how to add that missing code.

 

Jack

Share this post


Link to post
Share on other sites

Hi Jack,

 

Thank you very much for this contribution.

Very useful, easy to install and easy to customize.

 

All work good on 2.2 RC2a

 

God bless you.

Share this post


Link to post
Share on other sites

You're welcom but the thanks goes to Jared. I just made an addition to his work.

 

Jack

Share this post


Link to post
Share on other sites

Sorry... I shouldn't forget about this at the first place.

 

Many thanks as well to everyone who involved to build this contribution, especially to Jared.

 

Well done.......... :)

Share this post


Link to post
Share on other sites
Yes, it's an oversight in the coding. I didn't add the code to remember the settings on a sort. I will add that when I get the chance.

 

Jack

 

Jack,

 

Any luck on finding the time to correct this? I'm curious to see it in action with the changes made...

 

Thanks

Share this post


Link to post
Share on other sites

Hi everuone,

 

Used this contrib and is very nice.

I'dd like change the "state" to the company info customers fill in during registration.

Can anyone guid me through it?

Thanks in advance.

 

MLK

Share this post


Link to post
Share on other sites

I like this contribution, however i need to be able to amend it a little, What I would like to add is date of last log on, date account created and what the customer has ordered in the past.

 

Can someone please guide me as to the SQL command I would use and where I would need to modify it.


I dont help with templates (thats what the seller is for)

 

th search function will often help, when it dont try this in google.

 

site:http://forums.oscommerce.com then your search word

Share this post


Link to post
Share on other sites
Hi everuone,

 

Used this contrib and is very nice.

I'dd like change the "state" to the company info customers fill in during registration.

Can anyone guid me through it?

Thanks in advance.

 

MLK

Instructions for adding fields are in the contribution.

 

Jack

Share this post


Link to post
Share on other sites
I like this contribution, however i need to be able to amend it a little, What I would like to add is date of last log on, date account created and what the customer has ordered in the past.

 

Can someone please guide me as to the SQL command I would use and where I would need to modify it.

For fields that are part of the customers tables, the instructions are in the contribution.

 

Jack

Share this post


Link to post
Share on other sites
For fields that are part of the customers tables, the instructions are in the contribution.

 

Jack

 

Hi Jack,

 

Thanks for the response, however the instructions only indicate that if the information is in the customers table the last log in etc is in Customer_info table, how would i code in the change of table in the SQL query?


I dont help with templates (thats what the seller is for)

 

th search function will often help, when it dont try this in google.

 

site:http://forums.oscommerce.com then your search word

Share this post


Link to post
Share on other sites

The instructions are the same except what instead of adding a field using c. (like in c.customers_fax), you would use ci. (like in ci.customers_info_date_of_last_logon).

 

Jack

Share this post


Link to post
Share on other sites
The instructions are the same except what instead of adding a field using c. (like in c.customers_fax), you would use ci. (like in ci.customers_info_date_of_last_logon).

 

Jack

 

Jack your a genius, i got that bit working. Now I have another issue, Im trying to also include what people have ordered, Now if im thinking correct it would be with a left join statement but I have no idea how to do this because of matching up the CID and the OID then the products. Can you give me a example of how I would implent this into the code.


I dont help with templates (thats what the seller is for)

 

th search function will often help, when it dont try this in google.

 

site:http://forums.oscommerce.com then your search word

Share this post


Link to post
Share on other sites
Jack your a genius, i got that bit working. Now I have another issue, Im trying to also include what people have ordered, Now if im thinking correct it would be with a left join statement but I have no idea how to do this because of matching up the CID and the OID then the products. Can you give me a example of how I would implent this into the code.

No, that's more than a simple change. You can check the orders.php file to see how they call in all of the data though.

 

Jack

Share this post


Link to post
Share on other sites

I seem to have broken something... I made all the changes to the letter (so I thought), but now some of the links are missing from the admin panel, including the reports link. I can't see any info in any of the links, such as customers, products, admin options... nothing shows up.

 

It appears that the store is still active, but I am unable to see any information in the admin section.

 

Any ideas what I've managed to accomplish and how I can fix it?

 

Thanks very much. This is my first tech request...

 

I've put the reports.php file back to the way it was, but I still have a blank white page when I select any admin options.

 

<?php
/*
 $Id: reports.php,v 1.5 2003/07/09 01:18:53 hpdl Exp $

 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2002 osCommerce

 Released under the GNU General Public License
*/
?>
<!-- reports //-->
	  <tr>
		<td>
<?php
 $heading = array();
 $contents = array();

 $heading[] = array('text'  => BOX_HEADING_REPORTS,
				 'link'  => tep_href_link(FILENAME_STATS_PRODUCTS_VIEWED, 'selected_box=reports'));

 if ($selected_box == 'reports') {
$contents[] = array('text'  => 
//Admin begin
//								   '<a href="' . tep_href_link(FILENAME_STATS_PRODUCTS_VIEWED, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_REPORTS_PRODUCTS_VIEWED . '</a><br>' .
//								   '<a href="' . tep_href_link(FILENAME_STATS_PRODUCTS_PURCHASED, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_REPORTS_PRODUCTS_PURCHASED . '</a><br>' .
//								   '<a href="' . tep_href_link(FILENAME_STATS_CUSTOMERS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_REPORTS_ORDERS_TOTAL . '</a><br>');
							   tep_admin_files_boxes(FILENAME_STATS_PRODUCTS_VIEWED, BOX_REPORTS_PRODUCTS_VIEWED) .
							   tep_admin_files_boxes(FILENAME_STATS_PRODUCTS_PURCHASED, BOX_REPORTS_PRODUCTS_PURCHASED) .
							   tep_admin_files_boxes(FILENAME_STATS_CUSTOMERS, BOX_REPORTS_ORDERS_TOTAL);

//Admin end
 }

 $box = new box;
 echo $box->menuBox($heading, $contents);
?>
		</td>
	  </tr>
<!-- reports_eof //-->

Share this post


Link to post
Share on other sites

It is most likely one of the other admin files that was edited. You should restore them all and try again.

 

Jack

Share this post


Link to post
Share on other sites

Thanks for the reply, Jack. I'm not sure how to restore those files... I did a backup right before this all happened, but it looks like the backup is just customers, products, and some more info like that.

 

I can log on as a different user and see what they are permitted to see, but my admin account isn't able to see anything.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×