Jump to content
Hugo RSF

Contribution Issue

Recommended Posts

Hi.

I'm using the contrib "Extra pages with admin" and Tinymce.

I have changed the code to tep_draw_textarea_field instead tep_draw_fckeditor and all is looking "fine".

But when I try to add an extra page I receive the error:

 

"Error: Page title required."

 

I have register_globals = on

 

I have tried:

if (empty($$title_field_name)) {
	  $messageStack->add(ERROR_PAGE_TITLE_REQUIRED, 'error');

 

if (empty($_POST['title_field_name'])) {
	  $messageStack->add(ERROR_PAGE_TITLE_REQUIRED, 'error');

 

and

if (empty($_POST['$title_field_name'])) {
	  $messageStack->add(ERROR_PAGE_TITLE_REQUIRED, 'error');

 

But none has solve this problem.

 

I appreciate your help here.

 

Thank you

Share this post


Link to post
Share on other sites
Hi.

I'm using the contrib "Extra pages with admin" and Tinymce.

I have changed the code to tep_draw_textarea_field instead tep_draw_fckeditor and all is looking "fine".

But when I try to add an extra page I receive the error:

 

"Error: Page title required."

 

I have register_globals = on

 

But none has solve this problem.

 

I appreciate your help here.

 

Thank you

 

I uploaded a new file, check the contribution page: http://www.oscommerce.com/community/contributions,2021

Edited by djmonkey1

Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

Hello djmonkey1.

Great job there. I appreciate your help here, really.

Your contribution has solved the problem with admin area. Now it is stored without any problems, but in the frontpage there's still nothing.

 

Maybe it is about the file catalog/includes/boxes/extra_info_pages.php?

If you can help me here I (and others too) would apreciate your kindness.

Share this post


Link to post
Share on other sites
Hello djmonkey1.

Great job there. I appreciate your help here, really.

Your contribution has solved the problem with admin area. Now it is stored without any problems, but in the frontpage there's still nothing.

 

Maybe it is about the file catalog/includes/boxes/extra_info_pages.php?

If you can help me here I (and others too) would apreciate your kindness.

 

Where is the frontpage and what are you supposed to be seeing there?


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

Hi.

I was expecting to see the extra pages in the infobox "Information" in the catalog but it is empty. In admin it is ok.

Share this post


Link to post
Share on other sites
Hi.

I was expecting to see the extra pages in the infobox "Information" in the catalog but it is empty. In admin it is ok.

 

All the information is in the database; you can see this via admin. Are you sure you've made all the necessary changes to the catalog side?


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

Hi again.

It works if I choose 2 - Contact Us as Page Type. I was choosing 1 - Index... not working at all.

I have checked again the catalog files... everything done except this in catalog/index.php:

REPLACE
<?php echo TEXT_MAIN; ?>
WITH
<?php echo $pagetext; ?>

This is because the original tag doesn't exist.

 

What I still don't understand is:

 

1) Why is there Index, Shipping, Privacy, Others, and Old Page as Page Types?

2) If I choose Shipping, wasn't suppose to have the "shipping.php" pointing to the page I have changed?

3) How do I include the contact_us.php always fixed in the bottom of extra_info_pages infobox?

 

Thank you in advance for your help here djmonkey1.

Share this post


Link to post
Share on other sites
Hi again.

It works if I choose 2 - Contact Us as Page Type. I was choosing 1 - Index... not working at all.

I have checked again the catalog files... everything done except this in catalog/index.php:

REPLACE
<?php echo TEXT_MAIN; ?>
WITH
<?php echo $pagetext; ?>

This is because the original tag doesn't exist.

 

What I still don't understand is:

 

1) Why is there Index, Shipping, Privacy, Others, and Old Page as Page Types?

2) If I choose Shipping, wasn't suppose to have the "shipping.php" pointing to the page I have changed?

3) How do I include the contact_us.php always fixed in the bottom of extra_info_pages infobox?

 

Thank you in advance for your help here djmonkey1.

 

To get any page to show the information you've saved in the database, you have to follow these instructions for each page:

 

catalog/contact_us.php

AFTER

require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_CONTACT_US);

ADD

#################
$page_query = tep_db_query("select 
						   p.pages_id, 
						   p.sort_order, 
						   p.status, 
						   s.pages_title, 
						   s.pages_html_text
						from 
						   " . TABLE_PAGES . " p LEFT JOIN " .TABLE_PAGES_DESCRIPTION . " s on p.pages_id = s.pages_id 
						where 
						   p.status = 1
						and
						   s.language_id = '" . (int)$languages_id . "'
						and 
						   p.page_type = 2");


$page_check = tep_db_fetch_array($page_query);

$pagetext=stripslashes($page_check[pages_html_text]);

#################

same file

REPLACE

  <tr>
	<td><table border="0" width="100%" cellspacing="1" cellpadding="2" class="infoBox">
	  <tr class="infoBoxContents">
		<td><table border="0" width="100%" cellspacing="0" cellpadding="2">
		  <tr>
			<td class="main"><?php echo ENTRY_NAME; ?></td>


WITH


	  <tr>
		<td class="main"><?php echo $pagetext; ?><br><br></td>
	  </tr>
  <tr>
	<td><table border="0" width="100%" cellspacing="1" cellpadding="2" class="infoBox">
	  <tr class="infoBoxContents">
		<td><table border="0" width="100%" cellspacing="0" cellpadding="2">
		  <tr>
			<td class="main"><?php echo ENTRY_NAME; ?></td>

 

If you wanted to switch over your shipping.php file, you would need to do these changes to that file and set the page type to 3 (see near the top of the changed code where it says "and p.page_type = 2"), since 3 corresponds to shipping. Not exactly the most user friendly structure, but that's how it works.

 

The reason there are the number of page types that there are is because of this menu defined in admin/extra_info_pages.php:

<select name="page_type" size=1>
							 <option value="1" <? if($page_type == 1) { echo 'selected="selected"'; } ?>>1 - Index</option>
							 <option value="2" <? if($page_type == 2) { echo 'selected="selected"'; } ?>>2 - Contact Us</option>
							  <option value="3" <? if($page_type == 3) { echo 'selected="selected"'; } ?>>3 - Shipping</option>
							 <option value="4" <? if($page_type == 4) { echo 'selected="selected"'; } ?>>4 - Privacy</option>
							 <option value="5" <? if($page_type == 5) { echo 'selected="selected"'; } ?>>5 - Links</option>
							 <option value="6" <? if($page_type == 6) { echo 'selected="selected"'; } ?>>6 - Other </option>
							 <option value="7" <? if($page_type == 7) { echo 'selected="selected"'; } ?>>7 - Other</option>
							 <option value="8" <? if($page_type == 8) { echo 'selected="selected"'; } ?>>8 - Other</option>
							 <option value="9" <? if($page_type == 9) { echo 'selected="selected"'; } ?>>9 - Old Page</option>
							 </select>

By modifying this menu you can have as few or as many page types as you want.

 

Anyway, I probably shouldn't have waded into this as I'm not familiar with this contribution but I hope this helps.


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

Ok. You're doing too much allready, which I appreciate your kindness.

 

The problem is I can't find some code in other pages like shipping.php. I only find this:

<tr>
	<td><table border="0" width="100%" cellspacing="1" cellpadding="2" class="infoBox">
	  <tr class="infoBoxContents">
		<td><table border="0" width="100%" cellspacing="0" cellpadding="2">
		  <tr>

And the instructions says to modify this (which I don't find):

<tr>
	<td><table border="0" width="100%" cellspacing="1" cellpadding="2" class="infoBox">
	  <tr class="infoBoxContents">
		<td><table border="0" width="100%" cellspacing="0" cellpadding="2">
		  <tr>
			<td class="main"><?php echo ENTRY_NAME; ?></td>

 

If someone can help me out here... I would be appreciated.

Thank you

Share this post


Link to post
Share on other sites
Ok. You're doing too much allready, which I appreciate your kindness.

 

The problem is I can't find some code in other pages like shipping.php. I only find this:

 

If someone can help me out here... I would be appreciated.

Thank you

 

Whatever code you have in your pages, you will need to have

<?php echo $pagetext; ?>

instead of whatever is the main body of information on the respective pages you want to control using this mod.


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

Hello All.

 

I just installed this mod and got it to show up in the catalog and admin without a probelm. When I click the link in the new box i get:

 

No input file specified

 

Did I miss something in the install? I checked the database and the info is there as well. For some reason, it just doesn't seem to be making the connection.

 

Can someone help me with this?

 

TIA


Thanks!

Clesha

Share this post


Link to post
Share on other sites

First off, thanks to all of the community, and the great contributions. The Extra Pages mod is great.

 

I am having some problems after Installing Extra Info Pages. I have OS Comm 2.2 with WPP payments 0.73, and extra pages 4.5.

 

After installing the Extra pages, I have that working pretty well. But in doing so, my WPP payment module is not working correctly. I keeping getting paypal dump errors emailed to me (since I have debug mode on for emails to me on errors.)

 

This has only occured since I installed the extra pages program. Also, I used to be able to leave a cart with items in it, then go back to my site as a visitor and still have those items in the cart. Now, the cart is empty each time. I am wondering if the two are related?

 

I have learned alot about PHP & SQL, more than I ever wanted to, but it has been fun. Now this has become a real problem because I cannot get my orders. I can't just revert to a backup of a few days ago, because I have other mods installed since then.

 

Any thoughts, or ideas would be helpful. I have gone through the process of installing extra pages, seeing where my problem might be, but I just can't seem to put my finger on it.

 

I am also aware of some changes Paypal has made, but I think this was happening as of the 29th of Sept, before the paypal changes.

 

Thanks!

Paul

 

PS, the site is Pauls Unique Woodworks

Share this post


Link to post
Share on other sites

I?m getting an error-message when i try to add a new page...

1264 - Out of range value adjusted for column 'sort_order' at row 1

insert into pages (sort_order, status, page_type) values ('', '1', '4')

[TEP STOP]

How can i fix this, please!?


I am who I am, unfortunately.

Share this post


Link to post
Share on other sites

I have the STS contribution installed. I tried to install the Extra Pages 4.3, but I keep getting this error on both the site and the admin area:

 

1146 - Table 'corpsol0_osc2.pages' doesn't exist

 

select count(*) as total from pages p LEFT JOIN pages_description s on p.pages_id = s.pages_id where s.language_id='1'

 

[TEP STOP]

 

I don't understand this error message at all. Can anyone shed some light on this?

Share this post


Link to post
Share on other sites

Hi all

 

I did install this contribution and everything seems to be working fine. Great contribution Thank you.

 

I wanted to know if I can add images there. I'm doing a lingerie shop and would like to have some products listed in a different page. Something to look like what's new or specials. I'm fairly new and don't know how to do this or if its possible with this contribution.

 

I'll appreciate your help

 

Thank you

Share this post


Link to post
Share on other sites

Hi All

 

I've just installed this contribution, but I'm getting an error when clicking 'Extra info Pages Manager' in the Admin section. I get a missing page error:

 

'Not Found

 

The requested URL /international/admin/FILENAME_PAGE_MANAGER was not found on this server.

Apache/2.0.55 (Red Hat) Server at jecltd.com Port 80'

 

I followed the instructions etc, and I've checked that I've uploaded all the correct files. There is no FILENAME_PAGE_MANAGER file in the version of the contrib that I d/led however. Is this what could be wrong? I downloaded the latest version available ( v4.6 Works with register_globals OFF) uploaded by djmonkey1 on the 3rd Oct. is this missing a file somewhere, or is it more likely that I've missed a bit of editing of code somewhere?

 

I hope someone can help.

 

Many thanks in advance

Scott

Share this post


Link to post
Share on other sites

Hi Again

 

I have just been looking through all the different versions available. I've noticed that ver 4.3 has a large amount of files in it compared to 4.6. Are the files found in 4.6 just files to be added to 4.5? Apologies if this is a simple question, but I understood that if it was a new version number, it was usually an entire package.

Also, as I won't be needing the FCKeditor fix, should I go back to 4.3, and update it with files from 4.6?

Again, I hope somebody is able to help.

 

Many thanks in advance

Scott

Share this post


Link to post
Share on other sites

Hey Everyone,

 

Ok... finally got this contribution installed and working. Well almost.

 

Pages added from the admin work fine and links are built and go where they should. Expect for the Contact Us page. Added the contact us page as type 2 and followed the instructions, but with the current code it doesn't work. The link is there but it links to id=7 as oposed to the contact_us.php.

 

However.... if I change the following code:

if($page['intorext'] == 1)  {
$page_list .= '<tr><td class="infoBoxContents"><a target="'.$target.'" href="' . $page['externallink'] . '">' . $page['pages_title'] . '</a></td></tr>';
}
else {
  // commented for fix of cart empty 4.40 by azer   $page_list .= '<tr><td class="infoBoxContents"><a target="'.$target.'" href="' . tep_href_link($link) . '">' . $page['pages_title'] . '</a></td></tr>';
$page_list .= '<tr><td class="infoBoxContents"><a target="'.$target.'" href="' . tep_href_link(FILENAME_PAGES, 'pages_id=' .$page['pages_id'], 'NONSSL') . '">' . $page['pages_title'] . '</a></td></tr>';
}
}

 

and remove the comments from azer and remove the other $page_list .= xxxx , the contact_us.php pages displays properly. I'm no php programer, but if I read the following code...

 

if($page['pages_title'] != 'Contact Us'){

$link = FILENAME_PAGES . '?pages_id=' . $page['pages_id'];



}else{

$link = FILENAME_CONTACT_US;
}

 

is $link not required when trying to output the contact_us.php links?

 

Not sure... hope someone here can help out.

 

Thanks!

Shayne

Share this post


Link to post
Share on other sites
I have a concern about this contribution. I installed it on a site last week, then noticed that it places an information box below the one that I already have in place. IS there anyway to script this contribution so that the "extra pages" get placed into the already existing information box. Any help would be greatly appreciated, or give me a place to "get started"

Thanks

 

Hi, I have the exact same issue. using the latest version 4.6 on my development site (XP based under Xampp) I have a new "informations" box below the "information" box in the left column. (the notes asked for

 

? catalog/includes/languages/english.php

?

? ADD

?

? define('BOX_HEADING_PAGES', 'Informations');

 

so i know where that comes from!

 

However i expected the new pages to be part of the original "information" box.

 

Also I note that the link in this new box does not work; however the original link, in the original box does and links to the new page complete with new text... :blink:

 

If anyone could guide me through this i would appreciate it

Share this post


Link to post
Share on other sites

Hi All

 

Sorry to ask this again, but I've not had any luck in trying to sort this myself. I realised that I hadn't edited the english.php in the admin section, but even after editing, it hasn't fixed the issue. I'm still getting:

 

'Not Found

 

The requested URL /international/admin/FILENAME_PAGE_MANAGER was not found on this server.

Apache/2.0.55 (Red Hat) Server at jecltd.com Port 80'

 

when I click on 'Extra Info Pages Manager' in the admin section. Has anybody else encountered this issue in the past at all?

 

I'd appreciate any assistance.

 

Many thanks

Scott

Share this post


Link to post
Share on other sites
Hey Everyone,

 

Ok... finally got this contribution installed and working. Well almost.

 

Pages added from the admin work fine and links are built and go where they should. Expect for the Contact Us page. Added the contact us page as type 2 and followed the instructions, but with the current code it doesn't work. The link is there but it links to id=7 as oposed to the contact_us.php.

 

However.... if I change the following code:

if($page['intorext'] == 1)  {
$page_list .= '<tr><td class="infoBoxContents"><a target="'.$target.'" href="' . $page['externallink'] . '">' . $page['pages_title'] . '</a></td></tr>';
}
else {
  // commented for fix of cart empty 4.40 by azer   $page_list .= '<tr><td class="infoBoxContents"><a target="'.$target.'" href="' . tep_href_link($link) . '">' . $page['pages_title'] . '</a></td></tr>';
$page_list .= '<tr><td class="infoBoxContents"><a target="'.$target.'" href="' . tep_href_link(FILENAME_PAGES, 'pages_id=' .$page['pages_id'], 'NONSSL') . '">' . $page['pages_title'] . '</a></td></tr>';
}
}

 

and remove the comments from azer and remove the other $page_list .= xxxx , the contact_us.php pages displays properly. I'm no php programer, but if I read the following code...

 

if($page['pages_title'] != 'Contact Us'){

$link = FILENAME_PAGES . '?pages_id=' . $page['pages_id'];
}else{

$link = FILENAME_CONTACT_US;
}

 

is $link not required when trying to output the contact_us.php links?

 

Not sure... hope someone here can help out.

 

Thanks!

Shayne

 

Yes whoever programed this didn't finish, it filters the posts wrong and is a mess i replaced that code u showed with my own modified if statement, this one checks if contact us is the name and if it

s internal if u change to external it will link the other way. I don't know if the php grammer is right but it works.

if($page['intorext'] == 1) {
 $page_list .= '<tr><td class="infoBoxContents"><a target="'.$target.'" href="' . $page['externallink'] . '">' . $page['pages_title'] . '</a></td></tr>';
}elseif($page['pages_title'] == 'Contact Us'){
 $page_list .= '<tr><td class="infoBoxContents"><a target="'.$target.'" href="' . FILENAME_CONTACT_US . '">' . $page['pages_title'] . '</a></td></tr>';
}else{
$page_list .= '<tr><td class="infoBoxContents"><a target="'.$target.'" href="' . tep_href_link(FILENAME_PAGES, 'pages_id=' .$page['pages_id'], 'NONSSL') . '">' . $page['pages_title'] . '</a></td></tr>';
}

 

P.S. I also made it work with BTS, and use the theme for the new pages.

Share this post


Link to post
Share on other sites
Yes whoever programed this didn't finish, it filters the posts wrong and is a mess i replaced that code u showed with my own modified if statement, this one checks if contact us is the name and if it

s internal if u change to external it will link the other way. I don't know if the php grammer is right but it works.

if($page['intorext'] == 1) {
 $page_list .= '<tr><td class="infoBoxContents"><a target="'.$target.'" href="' . $page['externallink'] . '">' . $page['pages_title'] . '</a></td></tr>';
}elseif($page['pages_title'] == 'Contact Us'){
 $page_list .= '<tr><td class="infoBoxContents"><a target="'.$target.'" href="' . FILENAME_CONTACT_US . '">' . $page['pages_title'] . '</a></td></tr>';
}else{
$page_list .= '<tr><td class="infoBoxContents"><a target="'.$target.'" href="' . tep_href_link(FILENAME_PAGES, 'pages_id=' .$page['pages_id'], 'NONSSL') . '">' . $page['pages_title'] . '</a></td></tr>';
}

 

P.S. I also made it work with BTS, and use the theme for the new pages.

 

Hi all,

 

Having just installed this conrtribution on my local Development site, it works fine (except the links in the new Info box dont work ) ...

 

However having attempted an install online i find my site generates the following error..

 

1146 error - Table "databasename.pages" doesn't exist

 

BUT IT DOES! - ran and re ran the sql and confirmed that the tables are present and appear to be OK

 

so why the error message????

 

anyone help please - it doing my head in

Share this post


Link to post
Share on other sites

Hi Everybody,

 

after installing everything I observed the following:

 

while the old 'information' box shows the new text added with Extra pages-info, plus the contact form, the Extra pages-info box link only shows the text, but NOT the contact form. Can anybody explain this behaviour and is it possible to include the contact form?

 

For more information see http://www.b2bcosmetics.ch/b2bshop/

 

Thanks to anybody who can help!

 

Steve

Share this post


Link to post
Share on other sites
Hi Everybody,

 

after installing everything I observed the following:

 

while the old 'information' box shows the new text added with Extra pages-info, plus the contact form, the Extra pages-info box link only shows the text, but NOT the contact form. Can anybody explain this behaviour and is it possible to include the contact form?

 

For more information see http://www.b2bcosmetics.ch/b2bshop/

 

Thanks to anybody who can help!

 

Steve

 

Make sure Contact Us is selected in the page type selection menu, if u used my fix for the contact us page make sure the title is exactly spelled " Contact Us " like that. Also make sure there is no body in the text because it might default and think it's what it's spos to show, worst comes the worst u can select "External" and put in contact_us.php and make sure same page is clicked. If none of this works then just post again.

Share this post


Link to post
Share on other sites
Hi all,

 

Having just installed this conrtribution on my local Development site, it works fine (except the links in the new Info box dont work ) ...

 

However having attempted an install online i find my site generates the following error..

 

1146 error - Table "databasename.pages" doesn't exist

 

BUT IT DOES! - ran and re ran the sql and confirmed that the tables are present and appear to be OK

 

so why the error message????

 

anyone help please - it doing my head in

 

I am just getting to know osc, but most the times that has to do with not connecting to the right db, misspelling, or not declared. Since it's not in all caps and a define then i am guessing it is defined, so next it makes me think ur looking at the wrong db, or there is a typo ether where it looks for it, or in the database itself. Also if u set any kind of weird permissons maybe it doesn't have permission to read it, so it connects but doesn't fetch the table. I am new at osc php so i am just guessing, i hope it helps, if that doesn't work, i would double check all connection strings, or values. The last thing i would also check, is current versions of php, mysql, and if this is on a server or a test server, sometimes local test servers, arn't setup right, or don't process mysql commands right. Hope this helps some.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×