Jump to content
Sign in to follow this  
clarocque

cDynamic Meta Tags

Recommended Posts

The structure is pretty easy - there are only 3 files on the catalog side. They are in there respective folders in the zip....

 

includes/meta_tags.php

includes/languages/english/meta_tags.php

includes/functions/meta_tags.php


osC Contributions I have published.

 

Note: Some I only provided minor changes, updates or additions!

Share this post


Link to post
Share on other sites

I am using Dynamic Meta Tags v1.3a and all works fine but I am also using Extra pages-info box w/ admin . I followed the install and in Step 3 , I did the same in info_pages.php but it does not behave the same as index.php and product_info.php . Here is the code from my info_pages.php , maybe someone can help or point me in the right direction. Has anyone else come across this?

 

<?php
/*
 $Id: info_pages.php,v 1.22 2003/06/05 23:26:22 hpdl Exp $

 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2003 osCommerce

 Released under the GNU General Public License
*/

require('includes/application_top.php');

$id = (int)$HTTP_GET_VARS['pages_id'];
$page_query = tep_db_query("select pages_id, pages_title, pages_html_text, status from " . TABLE_PAGES . " where pages_id = $id");

$page_check = tep_db_fetch_array($page_query);

?>
<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN">
<html <?php echo HTML_PARAMS; ?>>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">
<?php 
# cDynamic Meta Tags
/*<title><?php echo TITLE; ?>*/
require(DIR_WS_INCLUDES . 'meta_tags.php');
#
?>
<base href="<?php echo (($request_type == 'SSL') ? HTTPS_SERVER : HTTP_SERVER) . DIR_WS_CATALOG; ?>">
<link rel="stylesheet" type="text/css" href="stylesheet.css">
</head>
<body marginwidth="0" marginheight="0" topmargin="0" bottommargin="0" leftmargin="0" rightmargin="0">
<!-- header //-->
<?php require(DIR_WS_INCLUDES . 'header.php'); ?>
<!-- header_eof //-->

<!-- body //-->
<table border="0" width="100%" cellspacing="3" cellpadding="3">
 <tr>
   <td width="<?php echo BOX_WIDTH; ?>" valign="top"><table border="0" width="<?php echo BOX_WIDTH; ?>" cellspacing="0" cellpadding="2">
<!-- left_navigation //-->
<?php require(DIR_WS_INCLUDES . 'column_left.php'); ?>
<!-- left_navigation_eof //-->
   </table></td>
<!-- body_text //-->
   <td width="100%" valign="top"><table border="0" width="100%" cellspacing="0" cellpadding="0">
     <tr>
       <td><table border="0" width="100%" cellspacing="0" cellpadding="0">
         <tr>
           <td class="pageHeading"><?php echo $page_check[pages_title]; ?></td>
         </tr>
       </table></td>
     </tr>
     <tr>
       <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
     </tr>
     <tr>
       <td class="main"><?php echo $page_check[pages_html_text]; ?></td>
     </tr>
     <tr>
       <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
     </tr>
     <tr>
       <td><table border="0" width="100%" cellspacing="1" cellpadding="2" class="infoBox">
         <tr class="infoBoxContents">
           <td><table border="0" width="100%" cellspacing="0" cellpadding="2">
             <tr>
               <td width="10"><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td>
               <td align="right"><?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT) . '">' . tep_image_button('button_continue.gif', IMAGE_BUTTON_CONTINUE) . '</a>'; ?></td>
               <td width="10"><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td>
             </tr>
           </table></td>
         </tr>
       </table></td>
     </tr>
   </table></td>
<!-- body_text_eof //-->
   <td width="<?php echo BOX_WIDTH; ?>" valign="top"><table border="0" width="<?php echo BOX_WIDTH; ?>" cellspacing="0" cellpadding="2">
<!-- right_navigation //-->
<?php require(DIR_WS_INCLUDES . 'column_right.php'); ?>
<!-- right_navigation_eof //-->
   </table></td>
 </tr>
</table>
<!-- body_eof //-->

<!-- footer //-->
<?php require(DIR_WS_INCLUDES . 'footer.php'); ?>
<!-- footer_eof //-->
<br>
</body>
</html>
<?php require(DIR_WS_INCLUDES . 'application_bottom.php'); ?>

Share this post


Link to post
Share on other sites
I am using Dynamic Meta Tags v1.3a and all works fine but I am also using Extra pages-info box w/ admin .  I followed the install and in Step 3 ,  I did the same in info_pages.php but it does not behave the same as index.php and product_info.php .  Here is the code from my info_pages.php , maybe someone can help or point me in the right direction.  Has anyone else come across this?

 

<?php
/*
 $Id: info_pages.php,v 1.22 2003/06/05 23:26:22 hpdl Exp $

 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2003 osCommerce

 Released under the GNU General Public License
*/

require('includes/application_top.php');

$id = (int)$HTTP_GET_VARS['pages_id'];
$page_query = tep_db_query("select pages_id, pages_title, pages_html_text, status from " . TABLE_PAGES . " where pages_id = $id");

$page_check = tep_db_fetch_array($page_query);

?>
<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN">
<html <?php echo HTML_PARAMS; ?>>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">
<?php 
# cDynamic Meta Tags
/*<title><?php echo TITLE; ?>*/
require(DIR_WS_INCLUDES . 'meta_tags.php');
#
?>
<base href="<?php echo (($request_type == 'SSL') ? HTTPS_SERVER : HTTP_SERVER) . DIR_WS_CATALOG; ?>">
<link rel="stylesheet" type="text/css" href="stylesheet.css">
</head>
<body marginwidth="0" marginheight="0" topmargin="0" bottommargin="0" leftmargin="0" rightmargin="0">
<!-- header //-->
<?php require(DIR_WS_INCLUDES . 'header.php'); ?>
<!-- header_eof //-->

<!-- body //-->
<table border="0" width="100%" cellspacing="3" cellpadding="3">
 <tr>
   <td width="<?php echo BOX_WIDTH; ?>" valign="top"><table border="0" width="<?php echo BOX_WIDTH; ?>" cellspacing="0" cellpadding="2">
<!-- left_navigation //-->
<?php require(DIR_WS_INCLUDES . 'column_left.php'); ?>
<!-- left_navigation_eof //-->
   </table></td>
<!-- body_text //-->
   <td width="100%" valign="top"><table border="0" width="100%" cellspacing="0" cellpadding="0">
     <tr>
       <td><table border="0" width="100%" cellspacing="0" cellpadding="0">
         <tr>
           <td class="pageHeading"><?php echo $page_check[pages_title]; ?></td>
         </tr>
       </table></td>
     </tr>
     <tr>
       <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
     </tr>
     <tr>
       <td class="main"><?php echo $page_check[pages_html_text]; ?></td>
     </tr>
     <tr>
       <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
     </tr>
     <tr>
       <td><table border="0" width="100%" cellspacing="1" cellpadding="2" class="infoBox">
         <tr class="infoBoxContents">
           <td><table border="0" width="100%" cellspacing="0" cellpadding="2">
             <tr>
               <td width="10"><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td>
               <td align="right"><?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT) . '">' . tep_image_button('button_continue.gif', IMAGE_BUTTON_CONTINUE) . '</a>'; ?></td>
               <td width="10"><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td>
             </tr>
           </table></td>
         </tr>
       </table></td>
     </tr>
   </table></td>
<!-- body_text_eof //-->
   <td width="<?php echo BOX_WIDTH; ?>" valign="top"><table border="0" width="<?php echo BOX_WIDTH; ?>" cellspacing="0" cellpadding="2">
<!-- right_navigation //-->
<?php require(DIR_WS_INCLUDES . 'column_right.php'); ?>
<!-- right_navigation_eof //-->
   </table></td>
 </tr>
</table>
<!-- body_eof //-->

<!-- footer //-->
<?php require(DIR_WS_INCLUDES . 'footer.php'); ?>
<!-- footer_eof //-->
<br>
</body>
</html>
<?php require(DIR_WS_INCLUDES . 'application_bottom.php'); ?>

 

It will not do the same as it does for pruducts pages as the code to support it is not there. If you wan to use the same as a generic (feault) index page add ths info to the language file and add te page to $heading_pages list.

 

If you want more than that you will have to code in a what you want.


osC Contributions I have published.

 

Note: Some I only provided minor changes, updates or additions!

Share this post


Link to post
Share on other sites

Hello, this is a great contributions, Thanks. I noticed that I don't get any keywords and Description in my index.php, when i try to view the page source I only get the Site Title like this

  <title>MyStore.com</title>
 <META NAME="Description" Content="MyStore.com...">
 <META NAME="Keywords" Content="">

it works great on other pages except the index. What could be the problem. Anything that I missed? Thank you.

Share this post


Link to post
Share on other sites
Hello, this is a great contributions, Thanks. I noticed that I don't get any keywords and Description in my index.php, when i try to view the page source I only get the Site Title like this
  <title>MyStore.com</title>
 <META NAME="Description" Content="MyStore.com...">
 <META NAME="Keywords" Content="">

it works great on other pages except the index. What could be the problem. Anything that I missed? Thank you.

 

For the main index page (home page) you have to specify the information in the inlcudes/languages/english/meta_tags.php page. In there you scan specify tags for index page and all pages.


osC Contributions I have published.

 

Note: Some I only provided minor changes, updates or additions!

Share this post


Link to post
Share on other sites

I'm installing this piece of php code to my shop and I'm modifying it to make it multi-language.

 

I'm just customising it a bit more but I will publish a new version 1.4 once finished.

 

But very nice development Chris ! If only all OSC contributions were written that way.

 

Did you think of moving the settings in english/meta_tags.php to the database configuration group or do you want to keep some setting unique for each language ? Would also be nice to configure the separator, the order of the title display, etc. A lot of possibilities in fact !

 

Thanks, :thumbsup:

 

Didier.

Edited by Spaceboy

Share this post


Link to post
Share on other sites
I'm installing this piece of php code to my shop and I'm modifying it to make it multi-language.

 

I'm just customising it a bit more but I will publish a new version 1.4 once finished.

 

But very nice development Chris ! If only all OSC contributions were written that way.

 

Did you think of moving the settings in english/meta_tags.php to the database configuration group or do you want to keep some setting unique for each language ? Would also be nice to configure the separator, the order of the title display, etc.  A lot of possibilities in fact !

 

Thanks,  :thumbsup:

 

Didier.

 

Didier,

 

Thanks for the compliments...

 

Yes, I have thought of moving the configuration to the database, but exactly like you said I was then thinking of multi-language settings beeing different so I just never got around to it.

 

There are many options that could be built in - so many I just chose to not get in to them for a public release.

 

I have made some changes to optomize the queries but I have not repackaged for upload on osC yet.

 

If you are planning to do a new release and want to see them you can see the most recent changes on my site as I those releases are the latest code changes even if I have not had a chance to put up on osC yet.

 

Good luck ;)

 

Chris


osC Contributions I have published.

 

Note: Some I only provided minor changes, updates or additions!

Share this post


Link to post
Share on other sites

To get STS to work with this great contribution i did this:

 

open: /catalog/includes/sts_display_output.php

 

find echo "<title>" . TITLE . "</title>";

** should be around line 159 or so.

 

replace it with this:

require(DIR_WS_INCLUDES . 'meta_tags.php');

 

 

Then on your index.php and product_info.php pages just complete remove your standard osc <title><?php echo TITLE; ?></title> or the one that was added in this contribution. What you are doing is removing all instances of <title> and </title> from index.php and product_info.php

 

 

The only issue i have is that my product_info.php page is showing a - - at the end of the title.

 

My other pages like the contact page ect are just displaying the normal site title.

 

Eric

Share this post


Link to post
Share on other sites

As promised, here is a small update of this contribution. V1.4 has been published.

 

This is the changelog for version 1.4 :

 

- meta description : "..." is only displayed if displayed string is shorter than input string

- added language_id to all database queries where missing.

 

You can find it here : http://www.oscommerce.com/community/contributions,2895

 

Didier.

Share this post


Link to post
Share on other sites

I have installed this contribution. Before my home page used to have a tag line in the title that was pulled from the languages file. Now with the contribution my homepage is displaying jut my websites name.

 

Any one know where this is pulling from?

Share this post


Link to post
Share on other sites
I have installed this contribution. Before my home page used to have a tag line in the title that was pulled from the languages file. Now with the contribution my homepage is displaying jut my websites name.

 

Any one know where this is pulling from?

 

It's the STORE_NAME that you can configure in the Admin/configuration.

 

Didier.

Share this post


Link to post
Share on other sites

Hello,

 

In installing the this dynamic contribution I've taken myself offline, I know it's me, but I could do with a little help. Please!

 

Error

Warning: main(includes/functions/meta.php): failed to open stream: No such file or directory in /home/ggraph/public_html/includes/meta_tags.php on line 36

Warning: main(includes/functions/meta.php): failed to open stream: No such file or directory in /home/ggraph/public_html/includes/meta_tags.php on line 36

Fatal error: main(): Failed opening required 'includes/functions/meta.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/ggraph/public_html/includes/meta_tags.php on line 36

 

Regards

 

Mark B

Share this post


Link to post
Share on other sites

Hello Again, I looked at includes/meta_tags.php on line 36, and found that it was looking for a FUNCTIONS directory that I don't have?.

 

I changed it to just INCLUDES and now I'm back up

 

Whether the mod os now working is beyond me at the moment.

 

Regards

 

Mark B

Share this post


Link to post
Share on other sites
Hello Again, I looked at includes/meta_tags.php on line 36, and found that it was looking for a FUNCTIONS directory that I don't have?.

 

I changed it to just INCLUDES and now I'm back up

 

Whether the mod os now working is beyond me at the moment.

 

Regards

 

Mark B

 

 

Well I would say it is not working as you need those functions. I am not sure how your osc store does not have a functions folder but you need to upload the files in the functions folder youi may have to change the path...


osC Contributions I have published.

 

Note: Some I only provided minor changes, updates or additions!

Share this post


Link to post
Share on other sites

Hi all,

I installed this contribution..i think. How do I know it is working? Do the meta tags get placed in the .php files that I have added the code to?

2dogrc

Share this post


Link to post
Share on other sites
Hi all,

I installed this contribution..i think.  How do I know it is working?  Do the meta tags get placed in the .php files that I have added the code to?

2dogrc

 

This is elementary for me but maybe not everyone knows this : you have to look at the HTML source in your browser. You will see the contents of all your meta tags.

 

If you have Firefox, there is a good extension called "Meta Tags Panel". It shows you all meta tags in a panel of Firefox. Cool to see what happens.

 

Link : http://ex-code.com/metatags/mozilla.html

 

Didier.

Share this post


Link to post
Share on other sites

Hello,

 

I had a few teething problems when installing this contribution (all down to me) now when I search for my site I get this info up, can anyone help me to change this info for something more condusive to my site.

 

Categories. Manufacturers. Please SelectCanonFoxGT InteractiveHewlett PackardLogitechMatroxMicrosoftSierraWarner. What's New? Quick Find. Use keywords to find the product you are looking for. Advanced Search. Information. Gasoline Graphics. New Products For May

 

Many Thanks

 

Mark B

Share this post


Link to post
Share on other sites

I just installed this and have a question.

 

How do I reset the cache folder? Do I simply remove the contents or was there a more graceful way in the admin control panel?

 

thanks

Share this post


Link to post
Share on other sites
I just installed this and have a question.

 

How do I reset the cache folder?  Do I simply remove the contents or was there a more graceful way in the admin control panel?

 

thanks

The cache file is flushed each time you do a change in the catalogue section (see categories.php).

 

# cDynamic Meta Tags 
 // If the action will affect the cache entries
 if ( eregi("(insert|update|setflag)", $action) ) include_once('includes/reset_meta_cache.php');

 

You can add other actions like "delete", etc.. if you want to monitor these changes also.

 

Another way would be to put a link in the "Cache" folder (beside the other cache tools) to call the "reset_meta_cache.php" file. Should work no ?

 

Didier.

Share this post


Link to post
Share on other sites
Hello,

 

I had a few teething problems when installing this contribution (all down to me) now when I search for my site I get this info up, can anyone help me to change this info for something more condusive to my site.

 

Categories. Manufacturers. Please SelectCanonFoxGT InteractiveHewlett PackardLogitechMatroxMicrosoftSierraWarner. What's New? Quick Find. Use keywords to find the product you are looking for. Advanced Search. Information. Gasoline Graphics. New Products For May

 

Many Thanks

 

Mark B

Mark,

 

We cannot supply here specific e-commerce support. This thread only deals with the support for the cDynamic Meta Tags contribution.

 

What did you show us ? Your keywords or the description ? Did you customize the metatag.php file for each language ?

 

You really have a weird :huh: OSC installation as you are missing also the "functions" folder. Are you working with the standard OCS MS2.2 ?

 

Didier.

Share this post


Link to post
Share on other sites

Hi Didier,

 

I found my functions folder within the includes directory, when I moved it to the root folder I broke my site even when I directed the files I thought I should to the new location.

 

The info I pasted is the site description, I followed the excellent instructions to the letter and was a lttle stumped when it broke first time because the functions folder was misplaced, I've been getting areound 70 hits per day since installing this contribution but I have submitted the site to all the main search sites also so I'm not sure whether I'm getting the most out of this yet but I will persevere, I would appreciate a little guidance as the description has nothing to do with what I sell.

 

Kind Regards

 

Mark B

Share this post


Link to post
Share on other sites

You seem to have the categories of the basic database installation with stuff from Logitech, etc. The metatag "description" uses the breadcrumb values. It's all dynamic so I do not understand why you have those default descriptions.

 

BTW, I have checked out your site and your metatags seems to be correct. The wrong description is coming from your development site ?

 

Didier.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×