Jump to content
Sign in to follow this  
clarocque

cDynamic Meta Tags

Recommended Posts

its a clean OSC install - i switch to product listing (DVD category)

 

got this as desc:

 

<META NAME="Description" Content="- DVD Filme from osCommerce">

 

there is the trailing "-"

 

even if i enter some stuff for the HEAD_DESC_TAG_INDEX i got "- test" as desc.

(thanks that those variables are working now!)

 

the double thing is fixed aswell - thanks!

 

 

ah and nevermind about the STS... i dont use it anymore - but i didnt replace the title on first installation. so maybe its working aswell - but maybe there are probelms with head tas controller code inside the STS (its merged in latest version)

Edited by spleen

Share this post


Link to post
Share on other sites
its a clean OSC install - i switch to product listing (DVD category)

 

got this as desc:

 

<META NAME="Description" Content="- DVD Filme from osCommerce">

 

there is the trailing "-"

 

even if i enter some stuff for the HEAD_DESC_TAG_INDEX i got "- test" as desc.

(thanks that those variables are working now!)

 

the double thing is fixed aswell - thanks!

ah and nevermind about the STS...  i dont use it anymore - but i didnt replace the title on first installation. so maybe its working aswell - but maybe there are probelms with head tas controller code inside the STS (its merged in latest version)

 

 

OK I see where you mean now...

Open /includes/meta_tags.php got to line 205

find:

// Description
$metadescription=$desc;
if (tep_not_null($index_desc) && $default==false )
$metadescription.=' - '. $index_desc;
$metadescription=meta_create_meta_description($metadescription);

and replace with:

// Description
$metadescription=$desc;
if (tep_not_null($metadescription)&& $default==false )
$metadescription.=' - ';
if (tep_not_null($index_desc) && $default==false )
$metadescription.=$index_desc;
$metadescription=meta_create_meta_description($metadescription);

 

Try that I dont have time to test right now so let me know...

 

Chris


osC Contributions I have published.

 

Note: Some I only provided minor changes, updates or additions!

Share this post


Link to post
Share on other sites

hi there!

 

well index.php is fine now!

 

but DVD category:

 

<META NAME="Description" Content="- DVD Filme from osCommerce -">

 

there is still the trailign slash and now another ending one...

Share this post


Link to post
Share on other sites
hi there!

 

well index.php is fine now!

 

but DVD category:

 

<META NAME="Description" Content="- DVD Filme from osCommerce -">

 

there is still the trailign slash and now another ending one...

 

 

Sorry, I can't duplicate that... but just to let you know, by defaulyt I added dashes in a few places. If you want to csutomize yours go through the code and commend the lines.

 

Like line 208 , change that to //$metadescription.=' - ';

 

These are not bugs just a tatst difference java script:emoticon(':blink:')

smilie

 

Hope that helps...

 

Chris


osC Contributions I have published.

 

Note: Some I only provided minor changes, updates or additions!

Share this post


Link to post
Share on other sites

hehe yeah i understand ;)

 

seemed for me like beeing a small bug that the seperator will be added even if there is no second attribute.

 

well ill give it a try when im back from holidays ;)

Share this post


Link to post
Share on other sites
hehe yeah i understand ;)

 

seemed for me like beeing a small bug that the seperator will be added even if there is no second attribute.

 

well ill give it a try when im back from holidays ;)

 

Yes, I would agree - however I am not able to duplicate that when there is no second one - sorry...

 

I see this....

<META NAME="Description" Content="DVD Movies - Action from osCommerce - Desc to add to all - Desc for index...">

 

and

 

<META NAME="Description" Content="DVD Movies from osCommerce - Desc to add to all - Desc for index...">

 

and

 

<META NAME="Description" Content="Courage Under Fire (DVD-CUFI) by Fox - Regional Code 2 (Japan, Europe, Middle East, South Africa). Languages English, Deutsch. Subtitles English, Deutsch, Spanish. Audio Dolby Surround 5.1. Picture Format 169 Wide-Screen....">

 

sorry...

 

Chris


osC Contributions I have published.

 

Note: Some I only provided minor changes, updates or additions!

Share this post


Link to post
Share on other sites
why do you say this?

 

 

If you use a . you will avaid issues when the url changes...

 

 define('HTTP_COOKIE_DOMAIN', '.domain.com');
 define('HTTPS_COOKIE_DOMAIN', '.domain.com');

 

this will also keep the cookie valid switching from NONSSL<->SSL


osC Contributions I have published.

 

Note: Some I only provided minor changes, updates or additions!

Share this post


Link to post
Share on other sites
why do you say this?

...because Chris is correct in advising that the cookie SCOPE should be defined as such.

 

That is the #1 most common mistakes I have seen with store owner configuration. As Chris as stated it should be .domain.com and NOT www.domain.com or http://www.domain.com as is so common.

 

.domain.com - corrent

www.domain.com - will work but may present problems

http://www.domain.com - don't even try it...will fail every time

 

Bobby

Share this post


Link to post
Share on other sites

wow thanks. Mistake I had made myself, although in my situation I had not encountered any problems, although I am not live yet, and am not forcing cookies...

 

when I was getting my ssl cert, I had the choice of getting domain.com or www.domain.com ... I got it issued to www.domain.com, but would it have been better to get it issued to .domain.com?

 

thanks guys, I appreciate this help

Share this post


Link to post
Share on other sites
wow thanks.  Mistake I had made myself, although in my situation I had not encountered any problems, although I am not live yet, and am not forcing cookies...

 

when I was getting my ssl cert, I had the choice of getting domain.com or www.domain.com ... I got it issued to www.domain.com, but would it have been better to get it issued to .domain.com?

 

thanks guys, I appreciate this help

 

 

No, you were correct to get it as www.domain.com. If you got your SSL at domain.com, when it is called you would get a SSL error.

(Assuming you are using a domain with the www. like www.domain.com).


osC Contributions I have published.

 

Note: Some I only provided minor changes, updates or additions!

Share this post


Link to post
Share on other sites

Does anyone know if cDynamic Meta Tags compatible with the Simple Template System (STS)? I cant seem to get them to work together.

 

Tried putting $headcontent into the header of my template file AND in the php source.. :'(

Share this post


Link to post
Share on other sites
Does anyone know if cDynamic Meta Tags compatible with the Simple Template System (STS)?  I cant seem to get them to work together. 

 

Tried putting $headcontent into the header of my template file AND in the php source.. :'(

 

 

I am not sure as I have never looked at STS, it does work with BTS - if I get a chane I will take a look at STS and see what is different.

 

With out looking at it I believe the only difference for BTS is step 3, instead of having to do all pages you only have to do one tpl page.

 

I will try to look at STS soon.

 

Chris


osC Contributions I have published.

 

Note: Some I only provided minor changes, updates or additions!

Share this post


Link to post
Share on other sites
No, you were correct to get it as www.domain.com.  If you got your SSL at domain.com, when it is called you would get a SSL error.

(Assuming you are using a domain with the www. like www.domain.com).

Hi , sorry to sidetrack the topic but

 

i got mine as https://domain.com and seem to be having issues with oscommerce as i get redirected to https://www.domain.com , how could i fix this so it'll point me to https://domain.com ?

Share this post


Link to post
Share on other sites
Hi , sorry to sidetrack the topic but

 

i got mine as https://domain.com and seem to be having issues with oscommerce as i get redirected to https://www.domain.com , how could i fix this so it'll point me to https://domain.com ?

 

 

includes/configure.php (and admin to if using SSL)

 

 define('HTTPS_SERVER', 'https://domain.com')


osC Contributions I have published.

 

Note: Some I only provided minor changes, updates or additions!

Share this post


Link to post
Share on other sites
I see this....

QUOTE

<META NAME="Description" Content="DVD Movies - Action from osCommerce - Desc to add to all - Desc for index...">

 

 

and

 

QUOTE

<META NAME="Description" Content="DVD Movies from osCommerce - Desc to add to all - Desc for index...">

 

 

and

 

QUOTE

<META NAME="Description" Content="Courage Under Fire (DVD-CUFI) by Fox - Regional Code 2 (Japan, Europe, Middle East, South Africa). Languages English, Deutsch. Subtitles English, Deutsch, Spanish. Audio Dolby Surround 5.1. Picture Format 169 Wide-Screen....">

 

well just gave the additional infos a try - well i can duplicate all of your infos. but if there is no "Desc to add to all" there will be the last slash (only if you add teh fix you posted some posts before) .

 

the trailing one will always be there if you are not on product_info or index (main).

 

well im using Ultimate SEO aswell and some other modifications but cant see the reason in there.

i will try it on a clean store aswell soonish.

 

@kslager - i didnt get it working aswell :( you might better use Header Tags Controller contrib...

Share this post


Link to post
Share on other sites
well just gave the additional infos a try - well i can duplicate all of your infos. but if there is no "Desc to add to all" there will be the last slash (only if you add teh fix you posted some posts before) .

 

the trailing one will always be there if you are not on product_info or index (main).

 

well im using Ultimate SEO aswell and some other modifications but cant see the reason in there.

i will try it on a clean store aswell soonish.

 

@kslager - i didnt get it working aswell :( you might better use Header Tags Controller contrib...

 

Marcel, I have re uploaded the changes just in case.. make sure you update to the latest includes.meta_tags.php = made some small changes, but not that are affecting your issue.

 

I am not duplicating you issue. Are you cahcing the results? If so delete the cache files or turn it off and check. You might be viewing an old cahced file?


osC Contributions I have published.

 

Note: Some I only provided minor changes, updates or additions!

Share this post


Link to post
Share on other sites

Hello

 

thank a lot for the contrib...

 

i would like to modify the number of characters that can be display in meta title ?

 

is it possible ?


Best regards,

 

?run? Mign?t

Share this post


Link to post
Share on other sites

Hi,

 

I installed this contribution:

http://www.oscommerce.com/community/contributions,2895

 

cDynamic Meta Tags v1.0 to my OSC store, but I can't figure out how to get products to show up in the TITLE tag. I can drill down to categories and they show up, but when I click on a product, it still just puts the category in the TITLE. Is there any way to change this to the PRODUCT?

 

Thanks for you help.

 

My Store: http://www.cybergeekhosting.com/catalog/

Share this post


Link to post
Share on other sites
Hello

 

thank a lot for the contrib...

 

i would like to modify the number of characters that can be display in meta title ?

 

is it possible ?

 

 

The default length settings are in includes/functions/meta.php

 

The length is specified for the functions on that page.


osC Contributions I have published.

 

Note: Some I only provided minor changes, updates or additions!

Share this post


Link to post
Share on other sites
Hi,

 

I installed this contribution:

http://www.oscommerce.com/community/contributions,2895

 

cDynamic Meta Tags v1.0 to my OSC store, but I can't figure out how to get products to show up in the TITLE tag. I can drill down to categories and they show up, but when I click on a product, it still just puts the category in the TITLE. Is there any way to change this to the PRODUCT?

 

Thanks for you help.

 

My Store: http://www.cybergeekhosting.com/catalog/

 

Have you don any other modifications? The contribution is designed to add the product name to the title.and I have not heard of anyone else having this problem???


osC Contributions I have published.

 

Note: Some I only provided minor changes, updates or additions!

Share this post


Link to post
Share on other sites

Yea, I installed a "Search Engine Friendly URLs" contrib as well. Maybe that is the problem.

 

Is there a better way to make the URLs search engine friendly?

 

Thanks again for the information.

Share this post


Link to post
Share on other sites
Yea, I installed a "Search Engine Friendly URLs" contrib as well. Maybe that is the problem.

 

Is there a better way to make the URLs search engine friendly?

 

Thanks again for the information.

 

 

Try this: http://www.oscommerce.com/community/contributions,2823


osC Contributions I have published.

 

Note: Some I only provided minor changes, updates or additions!

Share this post


Link to post
Share on other sites

I noticed that inactive items are showing up in the meta keywords tag on when displaying all items in a category.

 

Any idea how can I change the query to only get active items?

 

For an example:

 

http://www.ukgoods.com/biscuits-mcvities-c-33_52.html

 

The meta keywords are showing up as:

 

<meta NAME="Keywords" Content="mcvities, mcvities favourites biscuit tin, mcvities fruit shortcake, mcvities plain chocolate hobnobs, mcvities victoria biscuit tin, mcvities hobnobs, mcvities rich tea biscuits, mcvities milk">

 

The McVities Favourites Biscuit Tin and McVities Victoria Biscuit Tin are specialty Christmas items and are inactive.

 

Thanks,

 

Donna Gordon

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×