Jump to content
Sign in to follow this  
clarocque

cDynamic Meta Tags

Recommended Posts

Sorry, this might give a better idea of what my meta_tags.php page is saying:

 

# pages to use HEADING_TITLE loop

foreach ($heading_pages as $index => $page){

if (strpos($_SERVER['PHP_SELF'], $page) ){

$metatitle=HEADING_TITLE.' - ';}}

Share this post


Link to post
Share on other sites

I need some help, if in admin I set the cache options to 2-Cache to directory I get the following errors:

 

Warning: fopen(/home/fr50cool/public_html//home/*****public_html/cache/_product_info.php_products_id=18.meta-cache) [function.fopen]: failed to open stream: No such file or directory in /home/*****/public_html/includes/meta_tags.php on line 392

 

Warning: fwrite(): supplied argument is not a valid stream resource in /home/*****/public_html/includes/meta_tags.php on line 393

 

Warning: fclose(): supplied argument is not a valid stream resource in /home/*****/public_html/includes/meta_tags.php on line 394

 

The first error seems to be doubling the address it's looking for and has added a double slash /home/fr50cool/public_html//home/*****public_html/cache/_product_info.php_products_id=18.meta-cache

 

I don't really understand what is happening. I have a cache folder in the root of my store /home/*****/public_html/cache/

 

If anyone can help I would appreciate it.

 

Thanks

Share this post


Link to post
Share on other sites

Hi, I really need help. I've been dealing with this for days, and can't seem to find an answer.

 

When i click the next page link at the bottom of my index page, I get this error at the top of the page:

 

Warning: strpos() [function.strpos]: Empty delimiter. in /home/subcitiz/public_html/includes/meta_tags.php on line 347

 

at the bottom of the same page I get this error:

 

Error! Unable to determine the page link!

 

When I go to the meta_tags.php page, on line 347, (the page and line in question) this is what I have:

 

# pages to use HEADING_TITLE loop

foreach ($heading_pages as $index => $page){

if (strpos($_SERVER['PHP_SELF'], $page)){

$metatitle=HEADING_TITLE.' - ';}}

#-------------------------------#

 

I'm not sure how to fix this. I think that $page has no value. I've tried to get help for the last week with no luck.

 

Any and all help will be extremely appreciated.

 

Thanks,

Jason

Share this post


Link to post
Share on other sites

There is something weird going on with the meta tags contrib.

It is inserting text in serveral places. For example:

bytmc

 

<title>The Molding of a Champion by: Children-Youth - A Place of Hope Store -</title>

 

<META NAME="Description" Content="The Molding of a Champion (bytmc) by Children-Youth - The Molding of a Champion Helping Your Child Shape a Winning Destiny Winning Strategies for nurturing future life champions Practical parenting advice from a leading...">

 

<META NAME="Keywords" Content="the molding of a champion, bytmc books, children-youth, books, videos, dvd, supplements for eating disorders, depression, abuse, store">

 

I also find the term in a few places on the page:

 

href="http://www.aplaceofhopestore.com/molding-champion-p-69.html" class="headerNavigation">bytmc</a></td>

<td class="pageHeading" valign="top">The Molding of a Champion<br><span class="smallText">[bytmc]</span></td>

 

This is happening to every product page, but with different phrases. Anotehr page is doing the same thing with the phrase bahsea.

 

Where in the world are these terms coming from? They are not in my original product pages.

 

Is this something from the SEO contrib?

Share this post


Link to post
Share on other sites

I'm having some trouble getting cDynamic Meta Tags working on product_reviews_info.php

 

I have tried copying the data in /catalog/includes/meta_tags.php for product_info.php and applying it to product_reviews_info.php, but that caused no META tags to display just leaving me with the URL in the title bar.

 

Any help on this matter would be greatly appreciated.

 

thank you.

Share this post


Link to post
Share on other sites

Thanks for this great contribution! I have an easy question (I think!) Is there a way to get rid of my company name that displays in the title tag on my index page. I don't believe I need it there and would like to make room for other keywords.

 

Thanks In Advance,

Jason

Share this post


Link to post
Share on other sites

How do I reset the cache manuelly?\

I tried going to mysite.com/catalog/admin/includes/reset_meta_cache.php but then I get an error on line 40 saying it cant connect to the db. which makes sense cause the file isn't being called by another file that already connected to the db if i got straight to it. I'm getting the wrong titles/meta tags for my products. for example

http://primestatues.com/catalog/face-legs-one-eye-p-308.html

Share this post


Link to post
Share on other sites

Hi,

 

After installing this contrib every time I edit something in admin I get this message

[left]Warning: Cannot modify header information - headers already sent by 
(output started at /xxxx/local/home/xxxxxx/xxxxxxxxx.co.uk/
cart/admin/includes/application_top.php:212)
in /xxxx/local/home/xxxxxx/xxxxxx.co.uk/cart/admin/includes/functions/general.php on line 22 

[/left]

Can anyone help Please?


Better to be looked over than overlooked!

Share this post


Link to post
Share on other sites

I have this contrib installed and it is working, sort of...

 

On the index.php it is showing the keywords and description that I specified. :thumbsup:

 

On the product_info.php pages it is showing the description pulled from the title, description, etc. :thumbsup:

 

HOWEVER, it is only listing 3 keywords or phrases - no matter what product it is or how much information is on the page. It doesn't pull ANY information from the description.

 

How can I get it to list actual keywords for these products without typing them manually and without them being long winded phrases?

 

Here are two product examples and the index -

 

META NAME="Description" Content="Quantum 9910 Workbook Downloadable (PDF) 17MB (9910DWB) by Singer - English This is a 17MB downloadable workbook for the Quantum 9910. You must have Adobe or another PDF viewer to open this file. Buy Singer sewing embroidery machines at..."

META NAME="Keywords" Content="quantum 9910 workbook downloadable (pdf) 17mb, 9910dwb singer manuals workbooks, workbooks,"

 

META NAME="Description" Content="Singer 7470 Confidence Sewing Machine (7470) by Singer - The Singer 7470 Confidence makes sewing a dream. Check out all these fantastic features Electronic Sewing Machine with Push-Button Stitch Selection With just a simple push of a button you have..."

META NAME="Keywords" Content="singer 7470 confidence sewing machine, 7470 singer machines, sewing machines,"

 

Index - META NAME="Description" Content="Best Sewing Deals @ Attic Treasures Buy Singer sewing embroidery machines at BestSewingDeals.com. We offer the lowest prices, oustanding customer service, free shipping*, and we teach you to use your machine. We won't be undersold!"

META NAME="Keywords" Content="singer, sewing, embroidery, embroidery machines, sewing machines, sewing lessons, futura, quantum futura, singer quantum futura, xl6000, singer xl6000, singer futura, singer dealer"

 

I tried adding:

 tep_not_null($product_meta_info['products_description'])
 ? $key.=$product_meta_info['products_description'].','
: NULL;

to the catalog/includes/meta_tags.php #get data for keywords section - and it worked, sort of...

 

It included text, as in sentences and MULTIPLE word phrases, to the "keywords" but it didn't add *just* keywords; it also included all the small words that should have been excluded by the "exclude" list, such as "the" "and" etc.

 

I also tried increasing the length for the keywords in the functions/meta.php to 500 but that had no effect.

 

Am I asking too much here? Is this not something this contribution can actually do? I have seen others in this topic list the keywords they are getting and they seem to be *just* keywords and quite a few of them - or are these just the ones they listed for the index page?

 

I have ZERO knowledge of .php, code writing, etc. I am totally self-taught but a very quick study. If you point me in the right direction, I can usually figure it out but I can't seem to get this one. Any help would be greatly appreciated! :)

 

Blessings,

K

Share this post


Link to post
Share on other sites

All of my pages seem to be working fine except my index page. Here is what it has:

<title>Victory Life Center</title>

<META NAME="Description" Content="Victory Life Center -">

<META NAME="Keywords" Content="">

 

I do have the following on my index page:

<?php

# cDynamic Meta Tags

/*<title><?php echo TITLE; ?>*/

require(DIR_WS_INCLUDES . 'meta_tags.php');

#

?>

 

Any idea why it would only be this page?

Am I am using mainpagedefine contrib. Anybody else using this contrib that is having the same problem?

If mainpage contrib is the problem, anybody know what would the hardcode I could enter on the index.php for metatags?

 

If mainp

Share this post


Link to post
Share on other sites

hows is this done during the installation ?

 

STEP 4 - Set Permissions on Cache folder

Using your favorite FTP program FTP in and set your permissions to 777

 

if i am using wsftp or core ftp where and how do i set these permissions ?

Share this post


Link to post
Share on other sites
for cdynamic meta tags do i have to run the sql query. i am looking at the latest version from azer here

 

version 1.6. is that the best version to install ? please do let me know.

 

http://www.oscommerce.com/community/contributions,2895

 

thanks

 

 

Use version 1.4 , it has no db queries to be run

Edited by toyicebear

Share this post


Link to post
Share on other sites
Use version 1.4 , it has no db queries to be run

includes/functions/meta_tags.php should be uploaded to your *catalog*/includes/ directory

 

 

the name of the file mentioned above is "meta_tags.php" but the one included in the contribution under functions is called "meta.php"

 

does any one know whats up with that ? please do let me know.

 

thanks

 

amit

Share this post


Link to post
Share on other sites
includes/functions/meta_tags.php should be uploaded to your *catalog*/includes/ directory

the name of the file mentioned above is "meta_tags.php" but the one included in the contribution under functions is called "meta.php"

 

does any one know whats up with that ? please do let me know.

 

thanks

 

amit

 

 

If i dont rember wrongly it has 3 files....

 

includes/meta_tags.php

includes/functions/meta.php

includes/languages/english/meta_tags.php

 

They should be uploaded to the same folders in your web shop...

Share this post


Link to post
Share on other sites
If i dont rember wrongly it has 3 files....

 

includes/meta_tags.php

includes/functions/meta.php

includes/languages/english/meta_tags.php

 

They should be uploaded to the same folders in your web shop...

yes i agree there are all these 3 files but in the instructions they call the functions file meta_tags.php and actually it is meta.php. that was the only confusion.

Share this post


Link to post
Share on other sites
yes i agree there are all these 3 files but in the instructions they call the functions file meta_tags.php and actually it is meta.php. that was the only confusion.

i guess what i have just realized is that these contributions dont work with STS . is there a way around it ? i did all the changes got no errors but it did not work. no meta tags generated.

 

can someone confirm this ? that this contribution is not compatible with the STS and if not anything else recommended ?

 

please do let me know.

 

thanks

 

amit

Share this post


Link to post
Share on other sites
i guess what i have just realized is that these contributions dont work with STS . is there a way around it ? i did all the changes got no errors but it did not work. no meta tags generated.

 

can someone confirm this ? that this contribution is not compatible with the STS and if not anything else recommended ?

 

please do let me know.

 

thanks

 

amit

 

STS changes the install of many of the contribs...

 

Then you can easily use this one together with STS: Meta Tags Controller Support

Share this post


Link to post
Share on other sites

I am not even sure how to describe this. I uploaded the contribution. And when I go to my domain name...it ask for username and password....and I am thinking....WHAT? my store no longer shows up.

 

I have bts template already installed...but that is the only other contribution I have made prior to the cDynamic_Meta_Tags contribution.

 

Is this a permissions problems? How do I fix this?

Share this post


Link to post
Share on other sites
I am not even sure how to describe this. I uploaded the contribution. And when I go to my domain name...it ask for username and password....and I am thinking....WHAT? my store no longer shows up.

 

I have bts template already installed...but that is the only other contribution I have made prior to the cDynamic_Meta_Tags contribution.

 

Is this a permissions problems? How do I fix this?

Okay...I feel silly. I misunderstood the directions. The directions of the contribution said...

 

cache/ should be uploaded to your *catalog*/ directory

 

So...I did not have a cache file. I needed to create a cache file and then put the htaccess file in the cache file... NOT REPLACE the catalog htaccess file with the cache one.

 

Gosh that was so confusing me. I haven't got the contribution to work yet. But my site is showing and once I figure out how to use...I hopefully can get it all to work.

 

Lah Lah Diggy Me :rolleyes:

Share this post


Link to post
Share on other sites

Hi.

 

Thanks for a great contribution.

 

I have installed cDynamic Meta Tags v1.4

 

It is working fine except that it is changing all my decimal points to commas

 

So 4.5 is changing to 4,5

 

Is there some reason for this?

 

I would be most grateful if you could point me to the code to correct this

 

Thanks.

 

Ken.

Edited by Ken44

Share this post


Link to post
Share on other sites

I thought I had found the answer

 

In /includes/functions/meta.php about line 98

 

I changed

 

$splitstr = @explode("~`~`~`~`", truncate_string(meta_simple_strip_tags(str_replace(array(",","."),",", $str)), $length));

 

to this

 

$splitstr = @explode("~`~`~`~`", truncate_string(meta_simple_strip_tags(str_replace(array(","),",", $str)), $length));

 

This seems to work but the results no longer cache

 

My php skills are not that good. Is there any way to keep my decimal points and still cache the results?

 

Thanks

 

Ken.

Share this post


Link to post
Share on other sites

I have just downloaded cDynamic_Meta+Tags_v1.6. In the readme file it says to run the sql file. I have done this. Now when I log onto my admin there is a section called Dynamic Meta Tag in the Mystore section. These are the values for the option.

 

 

Cache options 0

Show Manufacturer in Title ? true

Show Model in Title ? true

Chemo Cache Class set lifetime of cache 30/days

Pages to use HEADING_TITLE for title 'product_reviews.php', 'contact_us.php', 'product_reviews.php'

 

 

 

Do I need to do anything else to get this working, how do I know it is working ie adding files to a driectory or soemthing. I am new to this and confused. I want my site ot show up in search engine, what more do o have to do to make this possible.

 

Great help is always appreciated.

Share this post


Link to post
Share on other sites

Hi....My name is Janet.

 

I have uploaded the latest version of cDynamic Meta Tag. I would have left a reply on the forum for this contribution...but it is 17pages long...and I doubt you or anyone would find me at the very end. So...I hope I have not interupted you too terribly. I don't normally write people.

 

I uploaded the latest version and I have a BTS template. On step 3..where it says STEP 3 - Edit pages you want to use meta tags on (like index.php, product_info.php etc)

 

I went to my index.php page but could not find the code

<title><?php echo TITLE; ?></title>

 

to even replace it.

 

However, I did find it under templates/Css-fluid-1/main_page.tpl.php

 

So I replaced the code above with the code

<?php 
# cDynamic Meta Tags
/*<title><?php echo TITLE; ?>*/
require(DIR_WS_INCLUDES . 'meta_tags.php');
#
?>

 

After doing this...I get this error

 

Fatal error: Cannot redeclare meta_create_title() (previously declared in /home/electron/public_html/catalog/includes/meta_tags.php:30) in /home/electron/public_html/catalog/includes/meta_tags.php on line 36

 

I have spent several days looking at this...I even looked over the other instructions CRE installation to see if I should have used those instructions...but again...I don't find the code in the main_page.tpl.php to change it. So I must not use those instructions either.

 

If you can be of help...I would appreciate any you can offer. I plan of leaving a fee for this contribution once I can figure it out.

 

Thanks and Have A Blessed Holiday.

 

Janet

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×