Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Sign in to follow this  
Guest

[Contribution] Ultimate SEO URLs v2.0

Recommended Posts

Guest

I have released Ultimate SEO URLs v2.0 and is available from the contribution area.

 

This release is bundled with the new osC Advanced Cache Class which moves the cache from the filesystem to the database. The mature code base has changed very little from v1.4 other than the modifications needed to port the new cache class.

 

From the release note:

This release is bundled with the new osC Advanced Cache Class. This moves the cache off the filesystem and into the database.

 

Why store cache in the database? Well, there were some store owners that had trouble with setting up a cache directory and also getting the permissions correct. This is an elegant solution to those problems since there is no need to enter any path or setup any directory with the right permissions. Also, the cache class will serve as the backbone of my future releases (osC Advanced Templating Engine, osC Search Engine / Spider, more performance enhancements, etc).

 

===========

= BUG FIXES =

===========

 

1) Fixed logic problem on admin side with resetting cache. Change is located in admin/categories.php

 

========

= NOTES =

========

 

This is a full package release and is bundled (files and directions) with the osC Advanced Cache Class. As such, I wanted to move the support to a new thread to keep the versions separate. If you have a support request please post it in the Ultimate SEO URLs v2.0 thread.

 

Download Ultimate SEO URLs v2.0

 

Bobby

Share this post


Link to post
Share on other sites

Sounds cool. Is there any benefit to using this new version in terms of speed, security, effeciency, etc., or is it mostly just to standardize your contribs to using your cache class?

 

Other question: I noticed that I can view the cache file by calling up: www.mysite.com/cache/seo_english.cache in my browser. Is this a problem? Is there any sensitive info that could be decrypted from this? I don't think it can modified right? I have rights on ...\cache directory set to 777.

Share this post


Link to post
Share on other sites
Guest

They will both perform about the same so no real difference there. However, it ensures that people will not be able to view your files in a browser (for those that did not create the cache directory OUTSIDE their web root) and thus has better security.

 

Bobby

Share this post


Link to post
Share on other sites

Has there been any mention of using redirect 301 [moved permanently] with this contribution? Anyone started coding anything I can use/build-on that would save me re-inventing the wheel.

Share this post


Link to post
Share on other sites

Hi Chemo

 

Just thought i'd say Hi and thanks for a excelent contrib definatly one of the top 3 I have used.. :thumbsup: :thumbsup: :thumbsup: :thumbsup: :thumbsup: :thumbsup:

 

 

 

Thanks

 

 

 

Marc

 

 

Aromacraft

 

P.s Your versions 1.x couldent get it to work but this went on without a problem. :thumbsup:

Share this post


Link to post
Share on other sites

I having trouble with this one, I have installed:

7 Feb 2005 - Ultimate SEO URLs v2.0b

 

I'm sure I have followed all steps to the letter but my index page is blank, php_error log says:

 

[17-Feb-2005 15:26:25] PHP Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 11796480 bytes) in /usr/local/home/httpd/vhtdocs/domain.com/includes/classes/cache.class.php(157) : eval()'d code on line 21846

 

My store has approx 11000 items in there.

 

ideas?

 

Oh, and is this the correct place for support on this, or is the other thread Ultimate SEOstill the active one?

 

john

Edited by johnniefp

Share this post


Link to post
Share on other sites
Guest
Has there been any mention of using redirect 301 [moved permanently] with this contribution? Anyone started coding anything I can use/build-on that would save me re-inventing the wheel.

Yes. Check the download area for this contribution. As a side note, I believe this is the only contribution that addresses the issue.

 

Hi Chemo

 

Just thought i'd say Hi and thanks for a excelent contrib definatly one of the top 3 I have used..  :thumbsup:  :thumbsup:  :thumbsup:  :thumbsup:  :thumbsup:  :thumbsup: 

Thanks

Marc

Aromacraft

 

P.s Your versions 1.x couldent get it to work but this went on without a problem.  :thumbsup:

Thank you for your kind words. :)

 

I having trouble with this one, I have installed:

7 Feb 2005 - Ultimate SEO URLs v2.0b

 

I'm sure I have followed all steps to the letter but my index page is blank, php_error log says:

 

[17-Feb-2005 15:26:25] PHP Fatal error:  Allowed memory size of 16777216 bytes exhausted (tried to allocate 11796480 bytes) in /usr/local/home/httpd/vhtdocs/domain.com/includes/classes/cache.class.php(157) : eval()'d code on line 21846

 

My store has approx 11000 items in there.

 

ideas?

 

Oh, and is this the correct place for support on this, or is the other thread Ultimate SEOstill the active one?

 

john

Given 11K items it will consume about 1.2 Mb of memory for just over a few milliseconds. However, it appears as though the script has consumed 15 Mb of memory before it even reaches the SEO portion. I would look into optimizing your site...

 

Bobby

Share this post


Link to post
Share on other sites

Thanks for your input Chemo, increasing the memory alloc in php.ini did indeed help, though as you imply, I think I may need to look a bit deeper at the structure of the store...hmmmm.

 

A most excellent contrib by the way, as for the install scripts & installation procedure/instructions, well.. lets just say "I like your style".

 

I'll be playing with minor hack on this tomorrow to preg_replace <br> to - as my descriptions often have breaks in them, I'll post when done, it may help others.

 

Cheers

john

Share this post


Link to post
Share on other sites

Ive installed the mod - everything works great.

 

But how can i get robots to spider this page

 

http://tools4flooring.com/removal-machines-c-68_70.html

 

but not again as

 

http://tools4flooring.com/removal-machines...?sort=3a&page=1

 

(sorted by price)

 

im getting a few duplicate entries for the same page in google. How can i make sure only the original is indexed?

 

thanks in advance!

Share this post


Link to post
Share on other sites

Hi Bobby,

 

I installed the contribution (after first removing all cname, page cache, and ultimate v1.4) and am getting a weird problem.

 

1. Both mods are functioning as expected (correctly rewriting urls), however when I click on an individual product, instead of taking me to that product's page, it sends me to a blank page. No errors, just glorious snowy white blankness. Here are the urls that show in the address bar of two random product pages. One using cName, the other using rewrite:

 

http://www.alaskajewelry.com/product_info....ice%99-earrings

 

http://www.alaskajewelry.com/glacier-ice%9...ings-p-191.html

 

Any ideas?

 

PS-thanks for your tireless work on this Bobby.


Quidquid latine dictum sit, profundum viditur.

Share this post


Link to post
Share on other sites

what on earth...

 

Now it's working. Can't tell you why. All I did was toggle back and forth between rewrite an cname again in the admin. Love the new site Bobby.


Quidquid latine dictum sit, profundum viditur.

Share this post


Link to post
Share on other sites
Guest
what on earth...

 

Now it's working.  Can't tell you why.  All I did was toggle back and forth between rewrite an cname again in the admin.  Love the new site Bobby.

..oh yeah...forgot to tell everyone that the contribution only works on Tuesdays :)

 

I don't know what caused the hiccup but assume it was a cache issue somewhere.

 

Bobby

 

P.S. - ssshhhh...nobody is suppose to look at my profile and check out my new site :D

Share this post


Link to post
Share on other sites
Guest

Hey Bobby I was posting in the wrong forum. I just found this one and I am now going to post to it.

 

Anyways

 

my first post said I would drop you 10 bucks on that donation box on the bottom of the html install page. And if I got it done in a half hour I would give you more.

 

It has been about two hours now. I was reading in the wrong forum.

 

I am still willing to give more. I am trying to run the www.mysite.com/install-cashe.php

 

but when I go to it it just directs to my main page and not your custom page.

 

the install-seo.php worked great. But I just cannot get past this step.

Share this post


Link to post
Share on other sites
Guest

oh my god I was spelling it wrong for the last two hours.

 

believe me I feel as dumb as you think I am

Share this post


Link to post
Share on other sites
Guest

Cache in the config section of admin was turned off . I turned it on.

 

Still shows the SID at the end. Am I trying to do something that is not possible?

Share this post


Link to post
Share on other sites

Hi, I don't understand the purpose for

STEP 5 - Edit *catalog*/includes/modules/product_listing.php

 

It says find this code:

case 'PRODUCT_LIST_BUY_NOW':
$lc_align = 'center';
$lc_text = '<a href="' . tep_href_link(basename($PHP_SELF), tep_get_all_get_params(array('action')) . 'action=buy_now&products_id=' . $listing['products_id']) . '">' . tep_image_button('button_buy_now.gif', IMAGE_BUTTON_BUY_NOW) . '</a> ';
break;

but the code actually looks like this:

case 'PRODUCT_LIST_BUY_NOW':
$lc_text = TABLE_HEADING_BUY_NOW;
$lc_align = 'center';
break;

When I replace the code with the code you provided in your instructions, it just changed the the product listing heading from "Add to Cart" to the image of the "Buy Now!" button.

 

When I click on the "Buy Now" button it just goes to the cart. Doesn't seem to add any products or do anything else.

 

Is it suppose to do something? I might be missing something about it.

 

Everything else works great. Thanks! :)

Share this post


Link to post
Share on other sites
Guest
oh my god I was spelling it wrong for the last two hours.

 

believe me I feel as dumb as you think I am

Spelling is important :)

 

OK it is installed.  But only partially working.

 

this is what the links look like

 

http://www.preciousmetalbars.com/four-1-oz...0f47f61ca8f1b1b

The SID is still on the end of it now. How do I make that disappear?

That is an issue with your configure.php file...not the contribution.

 

Make sure your cookie domain is like ".preciousmetalbars.com" => NOTICE THE DOT IN FRONT OF THE DOMAIN. The dot sets the cookies scope site wide. You current setting is most likely http://www.preciousmetalbars.com and this is INCORRECT.

 

Once again, it is an issue with your configuration and not the contribution.

 

Hi, I don't understand the purpose for

STEP 5 - Edit *catalog*/includes/modules/product_listing.php

 

It says find this code:

case 'PRODUCT_LIST_BUY_NOW':
$lc_align = 'center';
$lc_text = '<a href="' . tep_href_link(basename($PHP_SELF), tep_get_all_get_params(array('action')) . 'action=buy_now&products_id=' . $listing['products_id']) . '">' . tep_image_button('button_buy_now.gif', IMAGE_BUTTON_BUY_NOW) . '</a> ';
break;

but the code actually looks like this:

case 'PRODUCT_LIST_BUY_NOW':
$lc_text = TABLE_HEADING_BUY_NOW;
$lc_align = 'center';
break;

When I replace the code with the code you provided in your instructions, it just changed the the product listing heading from "Add to Cart" to the image of the "Buy Now!" button.

 

When I click on the "Buy Now" button it just goes to the cart. Doesn't seem to add any products or do anything else.

 

Is it suppose to do something? I might be missing something about it.

 

Everything else works great. Thanks! :)

Look farther down the script. That is indeed in there but not the part of code that I was referring to.

 

In the stock osC-MS2 file it is on lines 131-134.

 

The code that you are citing is on lines 58-60.

 

Bobby

Share this post


Link to post
Share on other sites
Guest

I changed the cookie domain from "www.preciousmetalbars.com" to ".preciousmetalbars.com" But still the SID is attached to the end of the site name. any other possbilities?

 

I have not yet reset the cache or anything I am not sure if I need to do that. If I do how do I do that?

Share this post


Link to post
Share on other sites
Guest

I am still having troubles with this. I am not sure what else could be wrong with my site. Is there any specific contributions this does not work with?

 

I have the cookie domain setup to be ".preciousmetalbars.com" but nothing has changed. is there something specific that I can do to work this out. I will pay if needed.

Share this post


Link to post
Share on other sites
Guest

Hi i have install this contribution and it's working great. Though i have 1 question, which is better - rewrite or cName for search engines. I am also confused about session. This is my conf.-

 

Force Cookie Use =False

Check SSL Session ID =False

Check User Agent =False

Check IP Address =False

Prevent Spider Sessions =True

Recreate Session =False

 

thanks in advance.

Kevin

Share this post


Link to post
Share on other sites
I am still having troubles with this. I am not sure what else could be wrong with my site. Is there any specific contributions this does not work with?

 

I have the cookie domain setup to be ".preciousmetalbars.com" but nothing has changed. is there something specific that I can do to work this out. I will pay if needed.

 

Heady, go check the other thread for this contribution, page 36, about halfway down the page, here's the url:

 

http://forums.oscommerce.com/index.php?sho...c=130999&st=700

 

You'll see where i posted a solution that will most likely work for your problem... the SID being patched into the url isn't anything to do with this contribution, it's just the way that most web servers run by default... a quick little ini_set should correct the problem, and i've left the code to look for and what to replace it with in the other thread, enjoy :D

 

Richard Lindsey.


Richard Lindsey

Share this post


Link to post
Share on other sites
Guest
I am still having troubles with this. I am not sure what else could be wrong with my site. Is there any specific contributions this does not work with?

 

I have the cookie domain setup to be ".preciousmetalbars.com" but nothing has changed. is there something specific that I can do to work this out. I will pay if needed.

Clear your cookie cache on your browser. I came across a similar situation where the osCsid was persistent EVEN after I changed to a correct cookie domain setting. Turns out that it was still pulling the old cookie and once I removed it from the cookie cache on the browser it worked perfectly :)

 

Hi i have install this contribution and it's working great. Though i have 1 question, which is better - rewrite or cName for search engines. I am also confused about session. This is my conf.-

thanks in advance.

Kevin

Rewrite..hands down.

 

Bobby

Share this post


Link to post
Share on other sites
Guest

I just turned on force cookies and it works fine now.

Share this post


Link to post
Share on other sites

FYI, I've installed the Redirect .php file (beta 3) and it seems to work great. Here's what I did to test (let me know if I should test it another way):

 

Before installing I looked for the old style links in Yahoo and Google and clicked them to confirm that I would go to the "Product not found page." on my site. Then I installed your file, and re-clicked the same links, as well as a bunch of others, and I was redirected to the correct product page with the new SEO URLs displayed! Seems to work! Worked great for products and for category listings.

 

So I guess I could take this include out of application_top.php after a few months, right? What do you recommend? Does it slow things down to leave it in? If not, maybe just leave it there?

 

-Chris.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×