Jump to content
empo

Customer Add Product

Recommended Posts

Hello!

 

Thanks for the great contribution.

I just added this contribution to my site - it’s great - however am getting php warnings when I select customers from the admin panel. I believe it might be due to php5 which is currently installed on my server; I’m using oscommerce-2.2rc1.

 

------------------------------warnings---------------------------------------------------------

 

Warning: array_merge() [function.array-merge]: Argument #1 is not an array in /var/www/web1/web/catalog/admin/customers.php on line 734

Warning: array_merge() [function.array-merge]: Argument #2 is not an array in /var/www/web1/web/catalog/admin/customers.php on line 735

 

Warning: reset() [function.reset]: Passed variable is not an array or object in /var/www/web1/web/catalog/admin/includes/classes/object_info.php on line 10

 

Warning: Variable passed to each() is not an array or object in /var/www/web1/web/catalog/admin/includes/classes/object_info.php on line 11

-----------------------------------------------------------------------------------

 

Any help on fixing the php warnings is highly appreciated.

 

Many thanks,

psg

Share this post


Link to post
Share on other sites

Hello,

thanks for this fantastic contribution!

 

I'm completely new in MySql, so…where can I change the standard, so new Users are automatically allowed to add products?

 

Thanks!

jorgusch

Share this post


Link to post
Share on other sites

i have a problem, i get an black screen, i don't see anything.

 

MY_ADD_PRODUCT

MY_EDIT_PRODUCT_TITLE

 

this is all blank. How can i fix this?

 

And i have the same questions as jorgusch, hope you can help me out

Share this post


Link to post
Share on other sites
Hello,

thanks for this fantastic contribution!

 

I'm completely new in MySql, so…where can I change the standard, so new Users are automatically allowed to add products?

 

Thanks!

jorgusch

 

is there already a solution?

Share this post


Link to post
Share on other sites

I am wanting to add additional fields to this contribution, I already have the tables in the database but am inputting the data manually at the moment.

 

I need both upload fields and text fields, any ideas?

Share this post


Link to post
Share on other sites

Hi All,

 

Just one question about this super contrib : its possible to add automatically, without the admin part, the price or product from the customer ?

 

Thanks

Share this post


Link to post
Share on other sites
Just one question about this super contrib : its possible to add automatically, without the admin part, the price or product from the customer ?

 

Hi!

Have the same question and one more.

 

When I'm in the main window "add new product" by the option "Date Available:" the calendar wont open when I click on the button.

Dos someone have a solution on both the questions?

 

Thanks!

Jure

Share this post


Link to post
Share on other sites

Thanks!

The calendar is OK with the new version from 23.03.2008.

 

But there is a new problem now.

If I add a product as a admin I can see it in the main page catalog. But when I go to the admin panel there are no products.

If I add a product as a CAP then I can see the products as a admin in the admin panel.

 

Any help to solve this problem?

 

Thanks

Share this post


Link to post
Share on other sites

Ok so I'm running os2.2rc2a. It's a fresh install and this is the first mod that i've done. I'm using the latest CAP 1.4.3. I've gone read through every single reply on this reply and done some of the tweaks recommended here. I've done the tweak that fixed placing the newly added product to the correct category instead of the "top". I haven't been able to fix where the product will show up in the catalog. Instead, I currently have to log in as admin and then edit the newly added product and click "in stock" so that it can show for the public to see. What am i missing? Oh, PHP 5.22 , MYSQL 5.02.2. Someone please help, I've been at this for about a week!

Share this post


Link to post
Share on other sites
Thanks!

The calendar is OK with the new version from 23.03.2008.

 

But there is a new problem now.

If I add a product as a admin I can see it in the main page catalog. But when I go to the admin panel there are no products.

If I add a product as a CAP then I can see the products as a admin in the admin panel.

 

Any help to solve this problem?

 

Thanks

 

So, I just tried to look it up for you but the answer is in this thread..... somewhere. you have to change the mysql database. Look at customer_id find administrator and change the value to 0. Using phpmyadmin made it real easy. Look for the reply........

Share this post


Link to post
Share on other sites
So, I just tried to look it up for you but the answer is in this thread..... somewhere. you have to change the mysql database. Look at customer_id find administrator and change the value to 0. Using phpmyadmin made it real easy. Look for the reply........

 

I have changed the value in the row "customers_id" to "0" and its working. :)

My fault that I did not read the post properly.

 

Thanks!

Edited by boyhazard

Share this post


Link to post
Share on other sites
I have changed the value in the row "customers_id" to "0" and its working. :)

My fault that I did not read the post properly.

 

Thanks!

Is your cap module working....if so please let me know what oscommerce, php, and mysql version you're using. I'm having problems with mine, as previously stated. thank you.

Share this post


Link to post
Share on other sites

i got a problem on categories.php in the admin, i can only see the product added by the customers , when i look at the query i can understand because of and c.customers_id = p.customer_id

 

$products_query = tep_db_query("select p.products_model, p.products_id, p.customer_id,c.customers_firstname,c.customers_lastname, pd.products_name, p.products_quantity, p.products_image, p.products_price, p.products_date_added, p.products_last_modified, p.products_date_available, p.products_status from " . TABLE_PRODUCTS . " p, ".TABLE_CUSTOMERS." as c , " . TABLE_PRODUCTS_DESCRIPTION . " pd, " . TABLE_PRODUCTS_TO_CATEGORIES . " p2c where p.products_id = pd.products_id [b]and c.customers_id = p.customer_id[/b] and pd.language_id = '" . (int)$languages_id . "' and p.products_id = p2c.products_id and p2c.categories_id = '" . (int)$current_category_id . "' order by pd.products_name");  
  }

 

by the way here are some ideas and request what you think guys about it :

 

- in the categories.php being able to select the products added by the customer

- limit the categories where customer can add products

- being able to switch off the need of customer approbation

- in the product added by customer to have the informations of the customers who added it

 

in the mail :

- a link to the admin preview page for the product added

- more info about the product and the customer


MS2

Share this post


Link to post
Share on other sites

for my problem i found the solution in the same page, meaning changing the 'adminstrator' customer to customers_id=0 :-"


MS2

Share this post


Link to post
Share on other sites

anyone got a clue how can we make that the customer doesnt choose an existing categories but, when he add a product it would create automacticully a categories wich name would be the customer_id ?


MS2

Share this post


Link to post
Share on other sites

I have some new troubles. Nothing big.

I can joust copy and paste PHP - don't understand more of it

 

Here they are:

 

1. some errors in the admin/customers:

When I work on my local PC server (apache2triad) then there are no errors and when I install it on my host than they are there (MySQL 5.0.45 and PHP 5.2.5).

---

Warning: array_merge() [function.array-merge]: Argument #1 is not an array in /web/d1/users/podpecan/izjava/admin/customers.php on line 743

Warning: array_merge() [function.array-merge]: Argument #2 is not an array in /web/d1/users/podpecan/izjava/admin/customers.php on line 743

Warning: array_merge() [function.array-merge]: Argument #2 is not an array in /web/d1/users/podpecan/izjava/admin/customers.php on line 745

Warning: reset() [function.reset]: Passed variable is not an array or object in /web/d1/users/podpecan/izjava/admin/includes/classes/object_info.php on line 17

Warning: Variable passed to each() is not an array or object in /web/d1/users/podpecan/izjava/admin/includes/classes/object_info.php on line 18

 

2. some translations from Spanish to English:

---

Un nouveau produit a XtX ajoutX

Cher administrateur

Un nouveau produit a été ajouté dans la catégorie :

Cet ajout a été fait par :

Pour approuver ce nouveau produit, veuillez vous rendre dans votre panneau d

---

Un nouveau produit a été ajouté ou modifié

Un nouveau produit a été ajouté dans la catégorie :

Cet ajout a été fait par :

Pour approuver ce nouveau produit, veuillez vous rendre dans votre panneau d

---

 

Thanks

Share this post


Link to post
Share on other sites

I am looking for the following, let me know if anyone has any ideas:

 

1) I want one entry fields to populate all languages rather than have fields for each language

2) I am looking to rename my uploaded files upon upload so that they have the product_id first and then the file name as I am concerned about overwriting duplicate file names.

 

I would really value your help on this, thanks for a great contribution

Share this post


Link to post
Share on other sites

Hi

 

many compliments for this great contribution :thumbsup:

 

Probably I look like a naive, but have read all the replies and I've not found the answer. I searched for a mounth and tried a lot of solutions without success

 

Please please please ... explain me: how can I allow the customer to edit the new product description by wysiwyg editor? i always meet an error like this (already written in Jul 16 2007 by NEMROD34):

if i write in description :

blabla

 

blabla bla

 

i show this in prewiew:

_p_blabla_/p_ _p align="center"_blabla bla_/p_

and so in the recorded one and in the admin or public view

please give me one way to search this solution

 

thanks

Share this post


Link to post
Share on other sites

Hi all,

 

I have read the problem before, but that was with version from 2005.

But everything looks nice, but when customer log in and clicks "add a product"

 

then i get a http 500 error :-"

Someone knows how to fix this :'( :'(

Edited by dpower717

Share this post


Link to post
Share on other sites

I've ran into 2 problems which are below, would be great if someone knew how to fix them!

 

As a customer I can add a product, when I click to Manage my products and then click on edit and edit the product and click Preview I am sent to my index.php file and the alterations are discarded.

 

As a customer when I click on Manage my products and click on one of the products I just get a blank page rather then it automatically goes to the edit page like the admin section.

 

Would really appreciate any help with this!

Share this post


Link to post
Share on other sites

I have some problems after I installed the latest version. When I login as an administrator I cannot find were i can set the permissions for the customers to add products and when I click as a customer edit my products I am getting the following error

"

Parse error: syntax error, unexpected $end in C:\wamp\www\Nano\catalog\account_manage.php on line 824"

 

P.s After I gave permission to one user by executing an SQL query from phpmyadmin I click to add a new product and the result was that I was transferred to a page full of php code and at the bottom there was the following error

"Fatal error: Class 'objectInfo' not found in C:\wamp\www\Nano\catalog\account_add.php on line 197"

Edited by cs42na

Share this post


Link to post
Share on other sites
Is your cap module working....if so please let me know what oscommerce, php, and mysql version you're using. I'm having problems with mine, as previously stated. thank you.

I'm using osCommerce 2.2-MS2 (the latest) and the latest Apache2Triad on my local machine.

On the net I have PHP 5.2.5 and MySql 5.0.45.

Share this post


Link to post
Share on other sites

i've got 1 question:

 

when the product uploaded by the client is sold...can i as a store owner input a sales percentage to be taken automatically? or does the customer see if the product was sold? and then i will pay him the money?how does this work?thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×