Jump to content
PopTheTop

Fancier Invoice & Packingslip v1.0

Recommended Posts

Hi there.

I have this contribution installed and it's great! I just can't get it to send the e-mail.

When it's set to send I get this error at checkout:

 

Warning: require(includes/modules/EMAIL_INVOICE_DIRFILENAME_EMAIL_INVOICE) [function.require]: failed to open stream: No such file or directory in /customers/comwares.be/comwares.be/httpd.www/checkout_process.php on line 251

 

Fatal error: require() [function.require]: Failed opening required 'includes/modules/EMAIL_INVOICE_DIRFILENAME_EMAIL_INVOICE' (include_path='.:/usr/share/php') in /customers/comwares.be/comwares.be/httpd.www/checkout_process.php on line 251

 

I think it has to do with the path in coniguration.php but I really can't figure it out.

My shop is going live so I would really appreceate any help.

 

And does anyone can tell me how to reset the invoice number?

Share this post


Link to post
Share on other sites
Hi there.

I have this contribution installed and it's great! I just can't get it to send the e-mail.

When it's set to send I get this error at checkout:

 

Warning: require(includes/modules/EMAIL_INVOICE_DIRFILENAME_EMAIL_INVOICE) [function.require]: failed to open stream: No such file or directory in /customers/comwares.be/comwares.be/httpd.www/checkout_process.php on line 251

 

Fatal error: require() [function.require]: Failed opening required 'includes/modules/EMAIL_INVOICE_DIRFILENAME_EMAIL_INVOICE' (include_path='.:/usr/share/php') in /customers/comwares.be/comwares.be/httpd.www/checkout_process.php on line 251

 

I think it has to do with the path in coniguration.php but I really can't figure it out.

My shop is going live so I would really appreceate any help.

 

And does anyone can tell me how to reset the invoice number?

OK, I fixed the send e-mail, for some reason configuration.php wasn't altered.

I set it to box_invoice.php because the other one is beeing sent with broken background.

But it seems that the box tmplate isn't fully translated.

The thank you still is in English and also invoice is in English.

 

Anyone knows how to reset the invoice number?

Share this post


Link to post
Share on other sites

The same invoice is displayed several times on different screens:

  • admin.invoice.php
  • catalog/print_my_invoice.php
  • mail sent to ordering customer after order is placed

This duplicate of code is not very maintenance-friendly: since all 3 should result in the same invoice, a change in one of them should also be done in the others.

 

Some considerations:

  • There must exist a html-command for calling another screen, but I cannot find it. What is this command?
  • Since 'admin' is a password-protected directory, the admin-screen should call the other one (and not vice-versa!).

Has anyone already followed this track? Experiences?

 

Thank you for your help!

Share this post


Link to post
Share on other sites

Hello to all.

Today I've installed Fancier Invoice 6.2 and i'm having a problem with it. The customer is receiving the invoice in HTML format, but the 'Send Extra Order' email is not. The problem appears only when 'Send HTML or Text Invoices to Customers' is true. I've checked and rechecked the steps...and i'm out of ideas.

 

So, to make me clear..the system is working just fine when 'Send HTML or Text Invoices to Customers' is disabled. How can I solve this problem?

 

Thank you.

Share this post


Link to post
Share on other sites

Hello all,

 

I installed Fancier Invoice & Packingslip v6.2 (version of August 7, 2009). In the included help-file (install.htm), it sais at the end of the introduction (first paragraph):

Please Note:

This contribution is not compatible with ANY PayPal IPN payment modules and I do not plan on making it so either. All the PayPal IPN payment modules are still way too buggy and conflict with MANY other contributions. With this contribution, you need to use the stock osC PayPal payment module.

Where can I find this 'stock osC PayPal payment module'?

I googled it, but it gave no results.

Can someone provide me an URL where I can download this module, or find more details on it?

 

Thank you for your help!

JJ

Share this post


Link to post
Share on other sites

I just uploaded a new version so now more info is displayed (incl shipment type/cost, (sub)total and tax)

 

Indeed the code is not very friendly nor did I create it this way (I just fix it for now), since this will be default in oscommerce 3.0 I do not plan on rewriting it as of yet.

Share this post


Link to post
Share on other sites

Hello all,

 

I get an error message on every invoice where the customer has chosen to pay by credit card:

Fatal error: Using $this when not in object context in /home/a2586580/public_html/catalog/account_history_info.php on line 199

This code line does contain '$this', and it is used outside a class. This part of the code is only executed in case of a credit card.

Has anyone encountered this problem? What is the most handy way to solve this problem (while still allowing payment by credit card)?

 

Thank you for your help!

JJ

Share this post


Link to post
Share on other sites

Hi,

 

Installed this contribution and The invoices look great!

 

However, I have 2 problems:-(

 

1) The email invoice sent to the customer does not add the tax on - although the invoice in the admin area shows the tax

 

2) when the customer tries to print the invoice from his account area he gets the following error in a popup window

 

Not Found

 

The requested URL /FILENAME_PRINT_MY_INVOICE was not found on this server.

 

What have I done wrong ??

 

Thanks for help in advance.....


Now running on a fully modded, Mobile Friendly 2.3.4 Store with the Excellent MTS installed - See my profile for the mods installed ..... So much thanks for all the help given along the way by forum members.

Share this post


Link to post
Share on other sites

Sorry - the Tax is on - its the shipping that is missed off.


Now running on a fully modded, Mobile Friendly 2.3.4 Store with the Excellent MTS installed - See my profile for the mods installed ..... So much thanks for all the help given along the way by forum members.

Share this post


Link to post
Share on other sites

OK - now sorted out the Print invoice error.

 

Had to add the following to the end of filenames.php

 

define('FILENAME_PRINT_MY_INVOICE', 'print_my_invoice.php');

 

That paet now seems to work ok.

 

Still got the problem with the emailed invoice though...

 

Help would be appreciated

 

Thanks


Now running on a fully modded, Mobile Friendly 2.3.4 Store with the Excellent MTS installed - See my profile for the mods installed ..... So much thanks for all the help given along the way by forum members.

Share this post


Link to post
Share on other sites

Hi,

 

This is quite URGENT if anyone can help - my customers are getting invoices emailed to them with the shipping amount not included - causing confusion and probably a legal loophole where they would not have to pay the shipment charge.

 

Can someone please help ??

 

Thanks


Now running on a fully modded, Mobile Friendly 2.3.4 Store with the Excellent MTS installed - See my profile for the mods installed ..... So much thanks for all the help given along the way by forum members.

Share this post


Link to post
Share on other sites

Hi, I'm new at this. Is there anywhere that I can ge step-by-step directions to install this?

Edited by Harald Ponce de Leon
Removed links

Share this post


Link to post
Share on other sites

Hi

 

I can't seem to run the SQL code and I was hoping someone might be able to help....

 

When I run the code in mysql front I get the following error:

 

SQL execution error # 1264. Response from the database:

Out of range value adjusted for column 'configuration_id at row 1

 

I am using mysql 5. I would really like to get this contrib working and I would be grateful for any help.

Share this post


Link to post
Share on other sites

Hi

 

I recently upgraded all of my oscommerce sites.

 

Using the basic cart I installed Chemo URL and the basic PayPal.php. I tested the site for payments through PayPal and it works perfectly.

 

I installed Fancier Invoice and then got a problem. When you make a payment through PayPal instead of being returned to check_out_success.php page you are returned to checkout_process.php and the order is not written.

 

The instructions say that this contrib works on the basic PayPal is there something that I should be changing to make sure that after payment you are returned to check_out_success.

 

Your help would be much appreciated.

Share this post


Link to post
Share on other sites

I have posted earlier but with no response I was hoping someone could answer this for me…..When I run the SQL code I get a 1264 error which I can’t seem to get round or fix. I have had this error before when installing other contributions and have ended up aborting the install because I can not get the SQL code to run. I really want to get this contribution working and I was hoping there is a way of installing without running the SQL code. Is there a way of defining the template you want to use in the php code? I am not bothered about having the facility to change the template used in admin.

 

I really want to get this working and I would be very greatful if someone could help me.

 

I am using osc 2.2 mysql 5

 

Thanks in advance

Share this post


Link to post
Share on other sites

I have posted earlier but with no response I was hoping someone could answer this for me…..When I run the SQL code I get a 1264 error which I can’t seem to get round or fix. I have had this error before when installing other contributions and have ended up aborting the install because I can not get the SQL code to run. I really want to get this contribution working and I was hoping there is a way of installing without running the SQL code. Is there a way of defining the template you want to use in the php code? I am not bothered about having the facility to change the template used in admin. I really want to get this working and I would be very greatful if someone could help me. I am using osc 2.2 mysql 5Thanks in advance

 

Hey Turbo:

 

I am new at this as well but here is how I got it to work.

 

1. go to your database and open it up

2. then look for the configuration table

3. use the browse function and look at every entry in the configuration table

4. at the end of the list take note of the number it ends on. -- for example: the last entry is #143. So the next one would be #144.

 

in the sql code, look for

 

 VALUES ('', 

 

You will find it twice. So in the first one, where the ' ' is at, insert the next number, as in the above example it would be '144'. then the next one you would add '145'

5. then run the script and all should be well.

 

Hope this helps

Edited by Zachary

Share this post


Link to post
Share on other sites

I just edited catalog/includes/modules/payment/paypal_standard.php

Replaced all standard stuff with the Fancier Invoice stuff in the file...

If I remember correctly, between the lines:

// initialized for the email confirmation

and

// load the after_process function from the payment modules

Replace everything with the code from catalog/includes/modules/email_invoice/email_invoice.php

 

Then, in the newly pasted text from email_invoice.php, BEFORE the line:

require(DIR_FS_ADMIN . DIR_WS_LANGUAGES . $language . "/" . FILENAME_ORDERS_INVOICE);

ADD (to get language name):

	$language_query = tep_db_query("select directory from " . TABLE_LANGUAGES . " where languages_id = '" . $languages_id . "'");
$language_array = tep_db_fetch_array($language_query);
$language = $language_array['directory'];

 

Done!

Seems to work perfectly, and keeps the store's email notifications 'in Sync' (did this also with the Dutch iDEAL payment plugin (iDealm)

 

I have the fancier invoice working for some time now, but with an older Paypal version. A couple of months ago the confirmations didn't come in anymore and the order was not registerd in the database when a customer was paying with paypal. So yesterday I tried the paypal_standard.php file that comes with the Oscommerce RC2 version. Ofcourse I only received the standard Oscommerce confirmation when placing an order.

So I tried the above solution in paypal_standard.php.

I receive the email confirmation with the fancier invoice layout, only without the subtotal, tax and total. Also the ordernumber is missing from the subject.

When a customer is placing an order woth payment in advanced, the confirmation is ok, with the subtotal, tax and total and the ordernummer in the subject

 

So I think the problem is in the paypal_standard.php. So my question is, do you use the above solution and is it working correct? If so can you post your file here?

Or is there another solution that someone is using.

 

I'm on the last version of this contrib and on Rc2

 

Claudia

Share this post


Link to post
Share on other sites

Fancier invoice is working partially for me...

when I log in and click on the view button, I do see the "improved" invoice, but when I click on the button to print it I get a 404 error of page not found...

I've read of someone else having the same issue and checked the installation again but no luck...

the link the button is pointing to is http://www.mydomainname.com/test_store/FILENAME_PRINT_MY_INVOICE?order_id=10

can someone please point to where I can fix this?

 

Also the graphic of the html invoice appears to be misalligned...attached a capture to show...any help on how to fix this too? I believe it is a problem of css?

invoice_not_aligned.jpg

Share this post


Link to post
Share on other sites

you will have to edit your Catalog\admin\invoice.php in all the places that look anything to do with the images like the bold marked areas;

 

<td width="11"><img src="../images/borders/maingrey_01.gif" width="11" height="16" alt=""></td>

<td background="../images/borders/maingrey_02.gif"><img src="../images/borders/maingrey_02.gif" width="24" height="16" alt="" ></td>

<td width="19"><img src="../images/borders/maingrey_03.gif" width="19" height="16" alt=""></td>

 

insted of having the 100% default that comes with the MOD

 

it sorted my problem out... which was the same...

Share this post


Link to post
Share on other sites

i have a different problem.... the HTML Emails that are sent out to the customers are not using the correct language file

 

and have things like;

 

INVOICE_ORDER_CONFIRMATION INVOICE_TEXT_NUMBER_SIGN 10INVOICE_TEXT_DASH2015

 

 

i have been through nearly every language file, and i can not find the problem, the e-mail seems to be picking up a default language file and not the language file that should be used.

 

could someone point me in the right direction to the correct language file...??

 

i have OSC 2.2RC2a installed with the latest Fancier_invoice_6.2_Fixed_2009-15-09 installed.

 

thanks for any help.

Share this post


Link to post
Share on other sites

problem found, just needed to read a little more of the instalation text and the problem is found..

 

If you have the Edit Orders MOD, add it in catalog\admin\includes\languages\english\edit_orders.php

 

Make sure it is also in: catalog\admin\includes\languages\english\orders.php

 

You should also find it in: catalog\includes\languages\english\checkout_process.php

 

or any other languages that are being used..

Share this post


Link to post
Share on other sites

I've been using this contrib for a while now with great success. However I installed 2 new payment modules (bank tranfer and Western Union Transfer) and have a little issue. These payment modules are not complex as the only thing they do is send some extra information (transfer and bank account details) in the order invoice email. This is working fine in text mode and html email disabled. With html enabled this 'email footer' text is not displayed...

 

Of course I want it to work in the HTML email as well. I think this is not included in the html email template or something? I tried to include the 'email footer' from the payment modules in the html template, but without success.

 

Anybody with the same issue and solution? Many thanks


Though no one can go back and make a brand new start, anyone can start from now and make a brand new ending.

Share this post


Link to post
Share on other sites

What do I need to add to get the Tax, Shipping etc to show up on the emailed invoice like the invoice available on the site?

 

Also on the Account History section it lists the date as "Friday 15 January, 2010" but I want it to be "Friday January 15, 2010"

Edited by Stealth1

Share this post


Link to post
Share on other sites

I use this contribution and I have this problem when I finnish an order, and I can`t find where to change this "speelmans.com/webshop/" to show proper way.I think this cause the problem but maybe is something else please if you can.

The error is:

Warning: require(C:/xampp/htdocs/speelmans.com/webshop/admin/includes/languages/bulgarian/invoice.php) [function.require]: failed to open stream: No such file or directory in D:\xampp\htdocs\riza_bg_develop\includes\modules\email_invoice\email_invoice.php on line 30

 

Fatal error: require() [function.require]: Failed opening required 'C:/xampp/htdocs/speelmans.com/webshop/admin/includes/languages/bulgarian/invoice.php' (include_path='.;D:\xampp\php\PEAR') in D:\xampp\htdocs\riza_bg_develop\includes\modules\email_invoice\email_invoice.php on line 30

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×