Jump to content
PopTheTop

Fancier Invoice & Packingslip v1.0

Recommended Posts

View the invoice in Admin; right click on a side image and view image. Make note of the path. On your local machine, open in image editor of your choice and save under same name. Upload via FTP.

 

Do a search in your files for every instance of each image's filename and make note of the height/width specs. Change to suit.

 

jon


It's all just ones and zeros....

Share this post


Link to post
Share on other sites
^ Is any one having this problem? it seems like a strange but probably fairly simple error. I cant believe everyone else has their invoices looking like this and hasnt said anything. Am I the only one who thinks this is a problem?

 

At the moment im forced to copy the entire thing into word and delete the lines because they look too amateur. Why does the box have a smooth outline when you view it online but not when you print it?

 

Also, Could someone post a screenshot of how the HTML email invoice option looks, I would rather send the HTML version to my customers although I dont know how it looks or if it all works ok. Is it possible to send a sample to myself?

 

Thanks,

 

Ben

I have raised this previously in this thread. There is a reason, but there was no solution.

 

I really do not know why people continue to install this contribution.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

is there no simple way to get the lines to look like they do on the screen when you print?

Edited by Benjjj6

Share this post


Link to post
Share on other sites
is there no simple way to get the lines to look like they do on the screen when you print?

If using outlook 2000, or IE6, it should be ok. I do not kow about IE7. Later versions of outlook do have the problem.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

hmmm ok thanks everyone for your replies.

 

Leslie you mentioned that you dont why people are still using this contribution. Is there an aleternative that you consider to be better?

Share this post


Link to post
Share on other sites
hmmm ok thanks everyone for your replies.

 

Leslie you mentioned that you dont why people are still using this contribution. Is there an aleternative that you consider to be better?

Not really. This one does not work with the majority of software that is in use (microsoft office above 2000). We do our invoice and packing slip manually.

It would be ok for admin functions if using IE6, but, and here is the rub, the customers may or may not be using outlook 2000 or below.

For the emails I use send_order_html_email_v1 and HTML MAILS by Jordi (Easy and working). These work on my web site.

 

I have this contrib installed on my old web site (add police. to my current web site).

 

I am currently trying print order receipt on my test server (local pc), but am having problems with graphical borders.

 

So that is the current situation, you have all these problems with installing this contrib, and it does not work for some customers (for reasons beyond your control).


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

There is a fix for the problem i was having! :D

 

The following is a fix from Sam at www.MilordsMerchants.com who kindly sent this fix to me and asked me to post it on the forums (he's very busy!) it solved the problem perfectly for both him and me... I hope it works for anyone else with the same problem.

 

I didnt have exactly the same line numbers but I replaced all instances that I found and it worked, here it is:

 

I too have the 'broken borders' on the Admin invoice.

I noticed however that the customers invoice and print was ok.

Also note that different browsers are known to produce different results.

I tested with Firefox 2.0 and IE 6.0 which for this are similar...

 

By examining the generated code, I found differences around the 'boxes' area are significant.

For example, the horizontal line for

Shop it is 'width="100%" Height="16"' whereas for

Admin it is 'width="24" Height="16"'.

 

By altering the appropriate code, the Admin invoice should have a better chance of rendering correctly on screen and paper.

 

So, alter your admin/invoice.php, 16 changes (leave the shop version alone!)

On each of these lines you are changing lines that have "...._img src="images/borders/main****_0*.gif" ...."

In my case:

line 70: width="24" becomes width="100%"

line 114: width="24" becomes width="100%"

line 169: width="24" becomes width="100%"

line 283: width="24" becomes width="100%"

line 104: width="24" becomes width="100%"

line 148: width="24" becomes width="100%"

line 201: width="24" becomes width="100%"

line 360: width="24" becomes width="100%"

line 74: height="21" becomes height="100%"

line 118: height="21" becomes height="100%"

line 173: height="21" becomes height="100%"

line 287: height="21" becomes height="100%"

line 100: height="21" becomes height="100%"

line 144: height="21" becomes height="100%"

line 197: height="21" becomes height="100%"

line 356: height="21" becomes height="100%"

 

thats it! enjoy...

---

regards Sam.

 

 

Thanks Sam! :)

Edited by Benjjj6

Share this post


Link to post
Share on other sites
Firstly, let me say that I am not willing to stay up for days and read all 1200 threads in this post to find my answer.

 

I downloaded this contrib not too long ago, only to be hit with a warning that:

 

This is not compatible with any PayPal IPN contribution.

 

So, there it went.

 

IS this now compatible with PayPal IPN?

No.

 

So, what if you have this installed and someone purchases via PayPal IPN? Does it cause any problems, or is it just that they do not have a fancy invoice?

Share this post


Link to post
Share on other sites
So, what if you have this installed and someone purchases via PayPal IPN? Does it cause any problems, or is it just that they do not have a fancy invoice?

They get the nowmal one.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
Screenshots...

Invoice:

Invoice.jpg

PackingSlip:

PackingSlip.jpg

 

 

Hi there i just installed version 3.3 as other seem a little complex but this version does what i need. I would like to change the packing slip title, on the last image it says "packing slip" but on mine it says "osCommerce Online Merchant Administration Tool" where can i locate this to change?

 

many thanks

Share this post


Link to post
Share on other sites
There is a fix for the problem i was having! :D

 

The following is a fix from Sam at www.MilordsMerchants.com who kindly sent this fix to me and asked me to post it on the forums (he's very busy!) it solved the problem perfectly for both him and me... I hope it works for anyone else with the same problem.

 

I didnt have exactly the same line numbers but I replaced all instances that I found and it worked, here it is:

Thanks Sam! :)

Yes, that solution fixes the problem. Thanks to Sam and Benjjj6.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
Hi there i just installed version 3.3 as other seem a little complex but this version does what i need. I would like to change the packing slip title, on the last image it says "packing slip" but on mine it says "osCommerce Online Merchant Administration Tool" where can i locate this to change?

 

many thanks

 

 

also does any one know how to increase font size for ship to address? cant seem to find font size

Share this post


Link to post
Share on other sites

when i print out either the invoice or packing slip the rounded boxes dont print properly, it does the 4 corners and a line on all sides but it doesnt meet the corner image, any ideas on how to fix this?

Share this post


Link to post
Share on other sites

I have installed the Fancier invoice 6.2_fixed_2007 from the oscommerce website...

 

It worked fine (i thought), But then i tried checking things to see if everything was still working succesfully.

 

So i have a few questions (and yes i even tried reading all 64 pages of comments)

 

1. How do you get the absolute path that is required in configure.php...

I tried several things, but i know i am doing something wrong there, because i get error database connection on my images if i have the configure.php in my

local drive. if i remove it i dont have a problem... so how do i solve it?

 

2. When i try placing an order, the checkout_process.php gives me a blank page.

But when i remove the HTML invoice codings from that php, i have nog problem... What is happening there?

 

3. When i want to view my account history, it also gives me a blank page.

 

So why is it not working..? I already de-installed the paypal IPN (dont want to use it anyway). So no data was in there of that installation before i did this.

I tried fixing the problem myself.. but i have been at it for 2 days and it is frustrating me out...

Can someone please help me??

 

Thanks. Mandy.

Share this post


Link to post
Share on other sites
I have installed the Fancier invoice 6.2_fixed_2007 from the oscommerce website...

 

It worked fine (i thought), But then i tried checking things to see if everything was still working succesfully.

 

So i have a few questions (and yes i even tried reading all 64 pages of comments)

 

1. How do you get the absolute path that is required in configure.php...

I tried several things, but i know i am doing something wrong there, because i get error database connection on my images if i have the configure.php in my

local drive. if i remove it i dont have a problem... so how do i solve it?

 

2. When i try placing an order, the checkout_process.php gives me a blank page.

But when i remove the HTML invoice codings from that php, i have nog problem... What is happening there?

 

3. When i want to view my account history, it also gives me a blank page.

 

So why is it not working..? I already de-installed the paypal IPN (dont want to use it anyway). So no data was in there of that installation before i did this.

I tried fixing the problem myself.. but i have been at it for 2 days and it is frustrating me out...

Can someone please help me??

 

Thanks. Mandy.

 

 

No help needed anymore.. appearantly it had somethign to do with the contribution Track and Trace 1.3 that i had installed.

It's working now.

Share this post


Link to post
Share on other sites

This is a great contribution. Wondering if the jazzed up invoice can be sent to the customer in place of the system generated order confirmation email? I can't get that email to format properly.

 

Thanks,

 

Bruce

Share this post


Link to post
Share on other sites
Hi there i just installed version 3.3 as other seem a little complex but this version does what i need. I would like to change the packing slip title, on the last image it says "packing slip" but on mine it says "osCommerce Online Merchant Administration Tool" where can i locate this to change?

 

many thanks

 

 

Hi guys i want fancy email invoice/order i understand the newer version of this contribution does this instead of the basic.

I installed 3.3 because it was basic. Will it conflict or is it easy upgrade?

Share this post


Link to post
Share on other sites

Hi Everyone

 

I seem to be getting a problem when i choose payment type to be "Credit Card". I enter the Credit Card details using the test credit card number of 411.....

 

On the next screen after this i get the following error in the middle box where order #: .... date .... payment type is:

 

Fatal error: Using $this when not in object context in ...\catalog\includes\modules\email_invoice\templates\html_invoice.php on line 184

 

Have i missed something? Only happens when i choose credit card payment. All other payments (C.O.D.) is fine.

Share this post


Link to post
Share on other sites
when i print out either the invoice or packing slip the rounded boxes dont print properly, it does the 4 corners and a line on all sides but it doesnt meet the corner image, any ideas on how to fix this?

 

I have the same problem but not with customer or admin side. They seem to look all fine. The problem i am having is with the html email being sent to the customer. What file and settings in it i need to change to have the email being sent look like customer / admin side.

 

Also another thing that is happening in the customer side when it comes online to view the order. In the middle box where the order #, Order date, payment type is displayed i am getting them side by side in every view (being when customer prints invoice, admin side, email side) but not when customer views their order. I get it like this:

 

Order #: 3

 

Order Date: 01/24/2008

Payment Method: Cash on Delivery

 

Underneath each other. How can i do it so it looks like all other view. Next to each other.

 

Thanks in advance

Share this post


Link to post
Share on other sites
Hi Everyone

 

I seem to be getting a problem when i choose payment type to be "Credit Card". I enter the Credit Card details using the test credit card number of 411.....

 

On the next screen after this i get the following error in the middle box where order #: .... date .... payment type is:

 

Fatal error: Using $this when not in object context in ...\catalog\includes\modules\email_invoice\templates\html_invoice.php on line 184

 

Have i missed something? Only happens when i choose credit card payment. All other payments (C.O.D.) is fine.

 

Ok after a bit of tinkering i got this fixed. For others that might have intalled mysql 5.0+ then what you need to do is remove all instances of $this and where ever the $this is pointing to put a "$" sign just before it.

 

I would still like some help with my other prob above as i can't figure that one out.

Share this post


Link to post
Share on other sites

Hello nice contrib

 

But have 2 probs.

 

When a costumer place an order, then in the osc default invoice, there are some comments to the payment method in the bottom.

I cant find out how the get fancier to show those payment commets??

 

And then when orderstatus is changed on the ordre, the confimation mail sent is in text??

 

What to do and/or what have I done wrong

 

Raas

Share this post


Link to post
Share on other sites

Nice Contribution.

 

Just wondering if anybody has thought about sending an order confirmation/advise from admin.

 

After changing an order (say adding or removing a product) we would like to be able to send a new copy of the order confirmation/advise to the customer. Can this be done from admin - say order.php somehow???? Can it call the email_invoice function somehow and has anybody already got something like this working???? :D

Share this post


Link to post
Share on other sites

Thank you for the mod.

 

I installed 6.1, I didnt see any difference with 6.2 but that could be where my issue is coming in.

 

Everything works great except when I click on the invoice button from the admin panel, and the order confirmation emailm its got code instead of what its supposed to in certain places.? It works fine from the catalog side for reviewing an invoice. So I assume that it is in one of the admin/ invoice type files.

 

here is what I am seeing, The blacked out areas appear ok. The one part that you cant see is the comments which looks odd too.

uhoh.jpg

 

As you can see there is something missing somewhere. Just dont know which file to look in. Any help will be appreciated

Share this post


Link to post
Share on other sites
Thank you for the mod.

 

I installed 6.1, I didnt see any difference with 6.2 but that could be where my issue is coming in.

 

Everything works great except when I click on the invoice button from the admin panel, and the order confirmation emailm its got code instead of what its supposed to in certain places.? It works fine from the catalog side for reviewing an invoice. So I assume that it is in one of the admin/ invoice type files.

 

here is what I am seeing, The blacked out areas appear ok. The one part that you cant see is the comments which looks odd too.

uhoh.jpg

 

As you can see there is something missing somewhere. Just dont know which file to look in. Any help will be appreciated

 

Scratch that post above

 

Apparantly after editing three yes three of the admin files i just plain forgot to upload them to my server... DUUUUUUH. Sorry to bother you guys. I feel like an .....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×