Jump to content
PopTheTop

Fancier Invoice & Packingslip v1.0

Recommended Posts

I got this contrib working with much editing, hassles, ......

 

But know I realize that the invoices do not show the state on them. My customer file has the state, but the invoice and packing slip do not show the state. What do I do to get the state to show up on invoice and packing slip?

Share this post


Link to post
Share on other sites
My invoices and packing slips do not show the state on them. My customer file has the state listed for the customer, but the invoice and packing slip do not show the state. What do I do to get the state to show up on invoice and packing slip?

From what I can tell it pulls the info from

 

tep_address_format

 

<td class="main"><?php echo tep_address_format($order->customer['format_id'], $order->customer, 1, '', '<br>'); ?></td>

 

<td class="main"><?php echo tep_address_format($order->delivery['format_id'], $order->delivery, 1, '', '<br>'); ?></td>

What defines the data in tep_address_format?

Share this post


Link to post
Share on other sites
From what I can tell it pulls the info from

 

tep_address_format

What defines the data in tep_address_format?

includes/function/general.php

 

Here is what I have. What is there in this code that stops the state from showing on invoice and packing slip?

 

function tep_address_format($address_format_id, $address, $html, $boln, $eoln) {

$address_format_query = tep_db_query("select address_format as format from " . TABLE_ADDRESS_FORMAT . " where address_format_id = '" . (int)$address_format_id . "'");

$address_format = tep_db_fetch_array($address_format_query);

Share this post


Link to post
Share on other sites
includes/function/general.php

 

Here is what I have. What is there in this code that stops the state from showing on invoice and packing slip?

Any answer on how to make the state appear on invoices and packing slips?

Share this post


Link to post
Share on other sites

Hi i have a problem with this addon... see screenshot

Anyone know something about this?

 

Fatal error: Using $this when not in object context in /home/3/e/elektrofun/www/catalog/admin/invoice.php on line 192

 

Feil_invoice.jpg

Share this post


Link to post
Share on other sites
Hi i have a problem with this addon... see screenshot

Anyone know something about this?

 

Fatal error: Using $this when not in object context in /home/3/e/elektrofun/www/catalog/admin/invoice.php on line 192

 

 

New info:

 

This happens only when my VISA card module is payed with... al other payment the invoice is ok.

What is with this line 192??

 

 

 

Morten

Share this post


Link to post
Share on other sites

LOL this mod is great but whoever wrote the lang files needs to stay off the weed!!!! its messing with your head. :D :D

Share this post


Link to post
Share on other sites

Hi

 

I'm very interested in this contribution but the install.txt file states that it doesn't work with ANY PayPal IPN contributions.

 

Is this still the case or will it work with PayPal IPN?

 

Thanks.

Share this post


Link to post
Share on other sites

Hi.

 

 

Sorry for some possibly stupid questions...

 

1.

I got the impression that you could send the invoice as e-mail to the customer.

Did I get that totaly wrong?

 

If I got it right, how do I do it?

 

2.

where do I edit the colors of the invoice/packingslip in admin panel? I´ve edited the stylesheet and that makes the customers view of the invoice look nice but the one in admin panel looks just as the one that came original in this contrib...

 

3.

An other question while I´m at it.

If it´s possible to e-mail the invoice,

Could it be done that the customer choose if they want the invoice send by e-mail or not when checking out, and if they choose to have it send by regular mail, add a cost to it, and let the cost be managed in modules or so....

 

 

 

Just brainstorming....

 

Otherwise great contrib!!!!!

 

Best regards.

//Talle

Share this post


Link to post
Share on other sites

Great contribution, all i need...

 

but i don't get email anymore, when somebody order(and also he)!

 

I changed Send Extra Order Emails to normal email, but still nothing.

 

thank you for help

Share this post


Link to post
Share on other sites

I installed this nice contri, but i have a question. Is it true that my order number and invoice number are always the same? In mine it is always the same. In database changed the invoice number to begin different, but the order number stays exactly the same as my invoice number. Is this normal?

Share this post


Link to post
Share on other sites

Installed this contribution, and must say it looks really nice.

 

One little problem though... (there's always one)

 

I'm a UK site, and my default currency is GBP (surprise).

The emailed HTML invoice has a strange symbol inserted in front of every £ symbol. This symbol looks like a capital A with a carat symbol on the top. Now, the rest of the site is fine, the fancy invoices display and print properly from admin mode, it is just the emailed invoices that are wrong.

 

It is the same for all three included invoice templates, and it is the same for a variety of mailers.

 

I wonder if anyone has any thoughts about what this could be and how to fix it.

Share this post


Link to post
Share on other sites
Hi.

Sorry for some possibly stupid questions...

 

1.

I got the impression that you could send the invoice as e-mail to the customer.

Did I get that totaly wrong?

 

If I got it right, how do I do it?

 

After the customer places his/her order, osCommerce automatically send the e-mail to the customer in HTML format, but only if Admin -> Configuration -> E-Mail Options -> Send HTML or Text Invoices to Customers = true & Use MIME HTML When Sending Emails = true. Unfortunately, subsequent status e-mail are sent as text only, and unless you install another contrib which allows you to manually control e-mails (see Install.htm -> Future Additions).

 

2.

where do I edit the colors of the invoice/packingslip in admin panel? I´ve edited the stylesheet and that makes the customers view of the invoice look nice but the one in admin panel looks just as the one that came original in this contrib...

You will need to revise catalog/admin/includes/stylesheet.css

 

3.

An other question while I´m at it.

If it´s possible to e-mail the invoice,

Could it be done that the customer choose if they want the invoice send by e-mail or not when checking out, and if they choose to have it send by regular mail, add a cost to it, and let the cost be managed in modules or so....

Just brainstorming....

Interesting....why not just activate Install.htm--> step 9 (optional)? This allows the customer to go to My Accounts and print any invoice directly from his printer. No mailing, no extra costs, simple!


Ragi Sekaly

Northern Penguin Technologies

Share this post


Link to post
Share on other sites
Installed this contribution, and must say it looks really nice.

 

One little problem though... (there's always one)

 

I'm a UK site, and my default currency is GBP (surprise).

The emailed HTML invoice has a strange symbol inserted in front of every £ symbol. This symbol looks like a capital A with a carat symbol on the top. Now, the rest of the site is fine, the fancy invoices display and print properly from admin mode, it is just the emailed invoices that are wrong.

 

It is the same for all three included invoice templates, and it is the same for a variety of mailers.

 

I wonder if anyone has any thoughts about what this could be and how to fix it.

 

So as usual, after posting the question I figure it out myself.

 

The problem was actually in my mailers. The character encoding was set wrong. Switching to UNICODE fixed the problem. Everything now displays nicely....

Share this post


Link to post
Share on other sites

hopefully someone will be able to answer this...

 

i get this error when i am trying to checkout.. and i believe it is trying to send out an html email notification..

 

 

Warning: main(includes/modules/EMAIL_INVOICE_DIRFILENAME_EMAIL_INVOICE) [function.main]: failed to open stream: No such file or directory in /home/moderate/public_html/sandbox/store/osc/checkout_process.php on line 226

Fatal error: main() [function.require]: Failed opening required 'includes/modules/EMAIL_INVOICE_DIRFILENAME_EMAIL_INVOICE' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/moderate/public_html/sandbox/store/osc/checkout_process.php on line 226

 

if i turn off sending in html then yes it goes through succesfully.

 

can someone explain why i cannot send the initial checkout email?????

 

pllllleaseeee.. with sugar on top!!!!

Share this post


Link to post
Share on other sites

Hi,

 

Just installed this contrib - looks great, however i might have missed something along the way as my invoices and packing slips have a missing image and some strange text:

 

image.gif

 

As you can see by the red circles there seems to be something not quite right.

 

I've definatley uploaded our logo to the correct directory and stated the correct path in the appropriate files.

 

Not sure where to go from here?

 

Any help, as always, would be greatly appreciated.

 

Many Thanks

D4

Share this post


Link to post
Share on other sites

I see others have tried to get customer name and order number in the email subject line that is sent to the admin (makes it easy to fill order and/or ask customer a question).

 

I have had success getting such information into the original plain text order confirmation emails (both the customer and admin), but not when emailing the HTML invoice.

 

So, that tells me that something is happening in email_invoice.php in building the email, and how it sends it to customers.

 

However, I can't figure out how to change it, as I'm not understanding the ie_ commands.

 

This is what I've changed in checkoutprocess.php, towards the bottom. This works in adding order number to subject for a text only email to the customer and admin after an order is placed:

// BOF order number in email subject
 $new_mail_subject = EMAIL_TEXT_SUBJECT . ' - ' . EMAIL_TEXT_ORDER_NUMBER . ' ' . $insert_id . "\n";
// EOF order number in email subject
// BOF order number in email subject
tep_mail($order->customer['firstname'] . ' ' . $order->customer['lastname'], $order->customer['email_address'], $new_mail_subject, $email_order, STORE_OWNER, STORE_OWNER_EMAIL_ADDRESS);

//BOF order number in email subject
if (SEND_EXTRA_ORDER_EMAILS_TO != '') {
tep_mail('', SEND_EXTRA_ORDER_EMAILS_TO, $new_mail_subject, $email_order, $order->customer['firstname'] . ' ' . $order->customer['lastname'], $order->customer['email_address']);
//EOF order number in email subject and the customers name and emailaddress

 

This is what is in includes/modules/email_invoice/email_invoice.php... not sure what to change here to add invoice number to subject. When I change it, the subject line of the email is simply blank. I think this is where some of the above coding needs to be placed, so the email invoice in HTML is sent has the order Id in the subject and the "from" email to the admin is from the customer's email account:

$ei_message->build_message();
$ei_message->send($order->customer['name'], $order->customer['email_address'], STORE_OWNER, STORE_OWNER_EMAIL_ADDRESS, EMAIL_TEXT_SUBJECT);

if (SEND_EXTRA_ORDER_EMAILS_TO != '') {

   $ei_message->send('', SEND_EXTRA_ORDER_EMAILS_TO, STORE_OWNER, STORE_OWNER_EMAIL_ADDRESS, EMAIL_TEXT_SUBJECT);

 

Any ideas how I would change the code in the email_invoice.php file so it works. If you notice, it doesn't use "tep_mail" but rather "$ei_message->send".

 

Together, we can figure this out?

Share this post


Link to post
Share on other sites

How come why i try to print im invoice from my website it pops up a window with my home page instead of the invoice?

can anyone tell me where i messed up

 

Thanks

Share this post


Link to post
Share on other sites

how come when i try and print my invoice from my website it pops up a window with my home page in it instead of the invoice?

anyone know where i messed up

 

thanks

Share this post


Link to post
Share on other sites

HI

When i go to print my invoice the order number isnt showing just says

order#

can anyone tell me what i forgot or have to fix

 

Thanks

Share this post


Link to post
Share on other sites

@varnco:

 

I managed to get the order/invoice number in the E-mail subject using HTML-mail:

edit "email_invoice.php" in catalog/includes/modules/email_invoice

 

1. find this code (around line 107):

$ei_message->send($order->customer['name'], $order->customer['email_address'], STORE_OWNER, STORE_OWNER_EMAIL_ADDRESS, EMAIL_TEXT_SUBJECT);

 

and replace this with:

$new_mail_subject = EMAIL_TEXT_SUBJECT . ' - ' . EMAIL_TEXT_ORDER_NUMBER . ' ' . $insert_id;
$ei_message->send($order->customer['name'], $order->customer['email_address'], STORE_OWNER, STORE_OWNER_EMAIL_ADDRESS, $new_mail_subject, $email_order);

 

2. then find this code (around line 110):

$ei_message->send(STORE_OWNER, SEND_EXTRA_ORDER_EMAILS_TO, $order->customer['name'], $order->customer['email_address'], EMAIL_TEXT_SUBJECT);

 

and replace this with:

$ei_message->send(STORE_OWNER, SEND_EXTRA_ORDER_EMAILS_TO, $order->customer['name'], $order->customer['email_address'], $new_mail_subject, $email_order);

 

Hope this will help you.

 

BTW: The original code for adding the order# in the E-mail subject is found in this contrib: http://www.oscommerce.com/community/contributions,2878

Share this post


Link to post
Share on other sites

Hello,

 

i have a problem with the database:

 

" #1264 - Out of range value adjusted for column 'configuration_id' at row 1 "

 

Thanks!

Share this post


Link to post
Share on other sites
hopefully someone will be able to answer this...

 

i get this error when i am trying to checkout.. and i believe it is trying to send out an html email notification..

Warning: main(includes/modules/EMAIL_INVOICE_DIRFILENAME_EMAIL_INVOICE) [function.main]: failed to open stream: No such file or directory in /home/moderate/public_html/sandbox/store/osc/checkout_process.php on line 226

Fatal error: main() [function.require]: Failed opening required 'includes/modules/EMAIL_INVOICE_DIRFILENAME_EMAIL_INVOICE' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/moderate/public_html/sandbox/store/osc/checkout_process.php on line 226

 

if i turn off sending in html then yes it goes through succesfully.

 

can someone explain why i cannot send the initial checkout email?????

 

pllllleaseeee.. with sugar on top!!!!

 

 

I have the exact same problem and have been battling with it for over a week. What is wierd (and perhaps a clue to someone with more knowledge) is that I had this site on another server before taking it live. Everything was working perfectly, moved the site to the new server and everything except the email /checkout_success now works.

 

This site is currently live and it is a very real issue. I would be extremely grateful if someone could give me some advice or assistance. :'(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×