Jump to content
PopTheTop

Fancier Invoice & Packingslip v1.0

Recommended Posts

I just installed this beautiful contribution. But i can't simply get the html e-mail to work. I have installed everything according to the Install.htm supplied, after several try, still no html e-mail sendt after completing a order on my shop.

 

In Admin/E-Mail Options, i have set the "Send HTML or Text Invoices to Customers" to "true", and i have installed everything according to the install.htm. I hope that some one can help me getting this funktion to work.

 

I also have a wary small "problem". In Denmark where i am from, we write the date like so: day/month/year. But i Admin invoice, the date is set to month/day/year. How can i "reverse" the month/day to day/month?

 

Not least, and this i possible a stupid question, but i cant figure out how to change the background color in Admin/invoice. The background i just a bit darker than white (#FFFFFF), that does not look good when printing...anyone who can help me with this?

Share this post


Link to post
Share on other sites

I'm having problems with my invoice and packing slip. Everything else seems to work alright. This looks so much nicer than the standard invoices. I'm new to this kind of stuff so any help is very much appreciated.

 

Screen01.jpg

Screen02.jpg

 

Thanks

 

Travis

Share this post


Link to post
Share on other sites

New version uploaded, danish added and some small adjustments

 

 

cka

Share this post


Link to post
Share on other sites
New version uploaded, danish added and some small adjustments

cka

 

 

Could you enlighten us to what changes have been made - the changelog in the install.htm file has not been updated nor any notes in the contribution area - i would like to know if it is worth the effort to update my site.

 

Thanks,

Tom

Share this post


Link to post
Share on other sites

I am sorry that I did't update the install file and change log.

 

I found a link to a file that I could not find, fixed that.

Added danish language.

some small languages errors fixed.

 

cka

Share this post


Link to post
Share on other sites

I am getting the below headings in my product order description.

 

HEADING_PRODUCTS HEADING_MODEL HEADING_UNIT HEADING_TOTAL

 

Instead of Product, Model, Unit, Total.

 

Can anyone help me out with this??? Also, instead of displaying with the title 'Invoice', I am getting ' NAVBAR_TITLE_4'.

 

Pls help me out.

Share this post


Link to post
Share on other sites
I'm having problems with my invoice and packing slip. Everything else seems to work alright. This looks so much nicer than the standard invoices. I'm new to this kind of stuff so any help is very much appreciated.

 

Thanks

 

Travis

Check admin/includes/languages/english/invoice.php and packingslip.php

Share this post


Link to post
Share on other sites

I am getting the below headings in my product order description.

 

HEADING_PRODUCTS HEADING_MODEL HEADING_UNIT HEADING_TOTAL

 

Instead of Product, Model, Unit, Total.

 

Can anyone help me out with this??? Also, instead of displaying with the title 'Invoice', I am getting ' NAVBAR_TITLE_4'.

 

Pls help me out.

[/quote

Check admin/includes/languages/english/invoice.php and packingslip.php

 

Also duble check includes/local/configure.php

Share this post


Link to post
Share on other sites

has anyone got this mod working with QTPRO4.2a?

 

So that the product attributes are visible in invoice and packingslip?

 

All my attribs are fine everywhere else - just get -:

 

in place of attribs in the above files though :o(

Share this post


Link to post
Share on other sites

Doh!

 

From step 2 in the instructions, somehow I managed to enter the INSERT INTO stuff into the SQL database twice!!

 

Can someone tell me how to remove the extra entries? I've never had to edit the database.

 

Currently, I have double entires in the configuaration:

 

Send HTML or Text Invoices to Customers true

Send HTML or Text Invoices to Customers true

Default E-Mailed HTML Invoice Template html_invoice.php

Default E-Mailed HTML Invoice Template html_invoice.php

E-Mail Transport Method sendmail

E-Mail Linefeeds LF

Use MIME HTML When Sending Emails false

Verify E-Mail Addresses Through DNS false

Send E-Mails true

 

 

Thank you in advance for any assistance.

 

Dave


-Dave

Share this post


Link to post
Share on other sites

Could someone tell me how can I remove this, Like I don't want any number there like right now 04-and then will be the invoice number that should be fine, but what is 04- ????

 

how1cs.jpg

Share this post


Link to post
Share on other sites

I was able to fix the double entry with some simple manual edit and restore.. fixed

 

There are some missing defines in admin/includes/languages/english/*.*.php files. I found them in the danish versions and copied them over to the english.

 

define('INVOICE_TEXT_INVOICE_NR', 'Invoice No.: ');

define('INVOICE_TEXT_INVOICE_DATE', 'Invoice date: ');

define('TITLE_PACKING', 'Packing Slip');

 

I have one final issue. I also have a Purchase Order contribution installed that previously modified admin/includes/invoice.php

 

Could someone please assist me in properly adding this code to the new fancier invoice.php

 

here is what exists in the new file, around line 178 to 189:

 

<?php
 if (tep_not_null($order->info['cc_number']))  {
$this->cc_card_number_less_middle_digits = substr($order->info['cc_number'], 0, 4) . str_repeat('x', (strlen($order->info['cc_number']) - 8)) . substr($order->info['cc_number'], -4);
?>
				 		   <td>?<b><?php echo ENTRY_PAYMENT_METHOD; ?></b>?<?php echo $order->info['payment_method']; ?>?(<?php echo $order->info['cc_type']; ?>)<br><?php echo tep_draw_separator('pixel_trans.gif', '100%', '6'); ?><br>?<b><?php echo ENTRY_PAYMENT_CC_NUMBER; ?></b>?<?php echo $this->cc_card_number_less_middle_digits; ?></td>
<?php
 } else {
?>
				 		   <td>?<b><?php echo ENTRY_PAYMENT_METHOD; ?></b>?<?php echo $order->info['payment_method']; ?></td>
<?php
 }
?>

 

Here is what I need to add (based on stock osc)

find

<tr>
	<td class="main"><b><?php echo ENTRY_PAYMENT_METHOD; ?></b></td>
	<td class="main"><?php echo $order->info['payment_method']; ?></td>
  </tr>

Below it add


<?php
// Company PO Account start
 if (tep_not_null($order->info['purchase_order_number']))
	{
?>
	  <tr>
		<td colspan="2"><?php echo tep_draw_separator('pixel_trans.gif', '1', '10'); ?></td>
	  </tr>
	  <tr>
		<td class="main"><?php echo ENTRY_PURCHASE_ORDER_NUMBER; ?></td>
		<td class="main"><?php echo $order->info['purchase_order_number']; ?></td>
	  </tr>
<?php
// Company PO Account end
}
?>

 

how would I add this correctly?

 

Thanks!

Dave


-Dave

Share this post


Link to post
Share on other sites

answering my own questions again, but this works for anyone else using Purchase Order 2.3.3

 

<?php
 } else {
?>
				 		   <td> <b><?php echo ENTRY_PAYMENT_METHOD; ?></b> <?php echo $order->info['payment_method']; ?></td>
<?php
 }
?>
			   		  </tr>
<?php
// Company PO Account start
 if (tep_not_null($order->info['purchase_order_number']))
	{
?>
	  <tr>
		<td colspan="2"><?php echo tep_draw_separator('pixel_trans.gif', '1', '10'); ?></td>
	  </tr>
	  <tr>
		<td class="main"> <b><?php echo ENTRY_PURCHASE_ORDER_NUMBER; ?></b> <?php echo $order->info['purchase_order_number']; ?></td>
	  </tr>
<?php
// Company PO Account end
}
?>
						<tr>
							<td><?php echo tep_draw_separator('pixel_trans.gif', '1', '7'); ?></td>
						</tr>
						</table>

 

One last question. I now have the purchase order number appearing in the invoice and packingslip nicely, BUT the PO # is not appearing in the emailed version to customer or storeowner.

 

Anyone know how/where to fix that?

 

 

Thanks again - great contribution


-Dave

Share this post


Link to post
Share on other sites

I have this contrib working and it is great!

 

I have one small problem, when I'm in the admin interface and pull up the packing slip to print and include in the shipping boxes, they boxes straight lines and rounded edges are not lined up on the Mac.

 

This is OS X 10.4.6 and I can duplicate it on Safari and Firefox.

 

Internet Explorer prints the invoices and packing slips find with all lines and edges lined up, but Firefox on Windows/Mac along with Safari mis-align.

 

The alignment isn't off by THAT much, but it does take away from it's professionalism. I know this really isn't this mods fault (at least I don't believe it is), I think it may be a browser issue.

 

I'm just hoping someone knows how to get around this.

 

Thanks!

Share this post


Link to post
Share on other sites
One last question. I now have the purchase order number appearing in the invoice and packingslip nicely, BUT the PO # is not appearing in the emailed version to customer or storeowner.

 

Anyone know how/where to fix that?

Thanks again - great contribution

 

 

Roaddoctor did you receive an answer to your question about the customers Purchase Order # ?

 

I too think this is a great contribution. :thumbsup:

 

I would like to have the customers Purchase Order Number appearing on all documents.

It could replace the Order #: ______ next to the Payment method

 

Thank you in advance

 

Ray

Share this post


Link to post
Share on other sites

I am having trouble with the PO# printing on the invoice and packing slip.

 

Here is my code:

 

<?php

if (tep_not_null($order->info['cc_type']) || tep_not_null($order->info['cc_owner']) || tep_not_null($order->info['cc_number'])) {

?>

<tr>

<td colspan="2"><?php echo tep_draw_separator('pixel_trans.gif', '1', '10'); ?></td>

</tr>

<tr>

<td class="main"><?php echo ENTRY_CREDIT_CARD_TYPE; ?></td>

<td class="main"><?php echo $order->info['cc_type']; ?></td>

</tr>

<tr>

<td class="main"><?php echo ENTRY_CREDIT_CARD_OWNER; ?></td>

<td class="main"><?php echo $order->info['cc_owner']; ?></td>

</tr>

<tr>

<td class="main"><?php echo ENTRY_CREDIT_CARD_NUMBER; ?></td>

<td class="main"><?php echo $order->info['cc_number']; ?></td>

</tr>

<tr>

<td class="main"><?php echo ENTRY_CREDIT_CARD_EXPIRES; ?></td>

<td class="main"><?php echo $order->info['cc_expires']; ?></td>

</tr>

<?php

} else

?>

</tr>

<?php

// Company PO Account start

if (tep_not_null($order->info['purchase_order_number']))

{

?>

<tr>

<td colspan="2"><?php echo tep_draw_separator('pixel_trans.gif', '1', '10'); ?></td>

</tr>

<tr>

<td class="main"> <b><?php echo ENTRY_PURCHASE_ORDER_NUMBER; ?></b> <?php echo $order->info['purchase_order_number']; ?></td>

</tr>

<?php

// Company PO Account end

}

?>

 

All help appreciated.

 

Thanks.

 

Jamie.

Share this post


Link to post
Share on other sites
MMMM!! - found it !! - damned permission on the invoice.php file in admin languages - I don't recall that being documented. :blush: :angry:

 

I have a similar problem. My catalog/config.psp permissions are set at -rwxrwxr-x which seems a little open. Shouldn't the perimissions be tighter? Permissions on my catalog/admin/includes/languages/english/invoice.php file are -rw-rw-r-- .

 

What did you need to change your's to fix?

Share this post


Link to post
Share on other sites
what was your solution to this problem?? I seem to be getting this as well.

 

Warning: main(/home/compactdivisions.com/public_html/catalog/admin/includes/languages/english/invoice.php): failed to open stream: No such file or directory in /home/compactd/public_html/shop/includes/modules/email_invoice/email_invoice.php on line 30

 

Fatal error: main(): Failed opening required '/home/compactdivisions.com/public_html/catalog/admin/includes/languages/english/invoice.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/compactd/public_html/shop/includes/modules/email_invoice/email_invoice.php on line 30

 

I have this problem and there have been several people say that the problem is in the path. My question is, where was this path defined (what file needs to be fixed)? I thought it might be in the configure.php file (from step 6 of the installation instructions) but I still don't see my error.

Share this post


Link to post
Share on other sites
MMMM!! - found it !! - damned permission on the invoice.php file in admin languages - I don't recall that being documented. :blush: :angry:

Sorry, I meant to say configure.php (not config.psp).... geez!

Share this post


Link to post
Share on other sites
I have this problem and there have been several people say that the problem is in the path. My question is, where was this path defined (what file needs to be fixed)? I thought it might be in the configure.php file (from step 6 of the installation instructions) but I still don't see my error.

OK, I've done my best to figure this one out and to follow advice given others here on the subject but I am really have a problem with Step 6 of the instructions for V6.1.

 

I believe the problem is in catalog/includes/local/configure.php on this line:

This is the way the file comes before I am suppose to edit it:

 

define('DIR_FS_ADMIN', '/home/YOUR-DOMAIn/public_html/catalog/admin/'; // absolute path required.

 

As I understand it, this is the only line that needs to be edited in this file.

 

I am having trouble determining the exact absolute path.

 

First of all, my son-in-law did the initial installation of oscommerce for me. I set up a sub-domain on our web server (hosted by ICDSoft) for him to put oscommerce while we develop a new presence. This allowed us to continue in the meantime with the current pages live and online without worrying about messing up the Frontpage extensions.

 

So the url for this development area is http://dev.aspenshopsonline.com/

Unfortunately, my son in law put in another directory level above the catalog folder and called it oscommerce.

 

So, the catalog url is actually http://dev.aspenshopsonline.com/oscommerce/catalog

 

In checking with ICDSoft, they say the structure on their servers is like this:

 

/www [this level contains the web files accessible via HTTP, FTP and scripts.

/www/www [this is where the regular website is located (www.aspenshopsonline.com)]

/www/dev [this is where the subdomain containing the development site is located (www.dev.aspenshopsonline.com)]

 

When I look at the file manager in my ICDSoft Control Panel I can also see this structure.

 

 

 

So, I tried to define DIR_FS_ADMIN as /home/dev.aspenshopsonline.com/oscommerce/catalog/admin but when Paypal returns after processing the payment transaction I got the following warning:

 

Warning: main(/home/dev.aspenshopsonline.com/oscommerce/catalog/admin/includes/languages/english/invoice.php) [function.main]: failed to open stream: No such file or directory in /home/aspenshop/www/dev/oscommerce/catalog/includes/modules/email_invoice/email_invoice.php on line 30

 

Warning: main(/home/dev.aspenshopsonline.com/oscommerce/catalog/admin/includes/languages/english/invoice.php) [function.main]: failed to open stream: No such file or directory in /home/aspenshop/www/dev/oscommerce/catalog/includes/modules/email_invoice/email_invoice.php on line 30

 

Fatal error: main() [function.require]: Failed opening required '/home/dev.aspenshopsonline.com/oscommerce/catalog/admin/includes/languages/english/invoice.php' (include_path='.:/usr/local/lib/php') in /home/aspenshop/www/dev/oscommerce/catalog/includes/modules/email_invoice/email_invoice.php on line 30

 

 

 

When I defined DIR_FS_ADMIN as home/www/dev/aspenshopsonline.com/oscommerce/catalog/admin I get the following warning:

 

Warning: main(/home/aspenshop/www/dev/aspenshopsonline.com/oscommerce/catalog/admin/includes/languages/english/invoice.php) [function.main]: failed to open stream: No such file or directory in /home/aspenshop/www/dev/oscommerce/catalog/includes/modules/email_invoice/email_invoice.php on line 30

 

Warning: main(/home/aspenshop/www/dev/aspenshopsonline.com/oscommerce/catalog/admin/includes/languages/english/invoice.php) [function.main]: failed to open stream: No such file or directory in /home/aspenshop/www/dev/oscommerce/catalog/includes/modules/email_invoice/email_invoice.php on line 30

 

Fatal error: main() [function.require]: Failed opening required '/home/aspenshop/www/dev/aspenshopsonline.com/oscommerce/catalog/admin/includes/languages/english/invoice.php' (include_path='.:/usr/local/lib/php') in /home/aspenshop/www/dev/oscommerce/catalog/includes/modules/email_invoice/email_invoice.php on line 30

 

 

You notice in the returned warning the refer to /home/aspenshop/www.dev/.........

 

I'm not sure why /home is part of the path definition, nor why /home/aspenshop/ shows up in the warning message except aspenshop is the login username for oscommerce. I've tried to enter a number of other paths with and without the /home prefix and got similar warnings.

 

Any help anyone? So far I have read "all" the messages in this forum thread (some 700+ messages) and learned a lot. I am very impressed with how Scooter (PopTheTop) has become so expert in such a short time! This guy is very savy and sharp. My thanks to him and all the others who have been so patient with us. I would recommend anybody who has a problem, thoroughly search the forums before asking the same questions over and over. It has got to be very trying for these folks to keep responding to so many people whose answers are right here on the forum if they would just take some time to read the prior messages. The only other constructive criticism I might offer is that when you resolve a problem that had not been answered before that you share what you did to fix it.

 

Again many thanks,

 

Ron Lee

Share this post


Link to post
Share on other sites
OK, I've done my best to figure this one out and to follow advice given others here on the subject but I am really have a problem with Step 6 of the instructions for V6.1.

 

I believe the problem is in catalog/includes/local/configure.php on this line:

This is the way the file comes before I am suppose to edit it:

 

define('DIR_FS_ADMIN', '/home/YOUR-DOMAIn/public_html/catalog/admin/'; // absolute path required.

 

As I understand it, this is the only line that needs to be edited in this file.

 

I am having trouble determining the exact absolute path..........

 

((remainder of original post removed from this response))

 

A WAY TO COME UP WITH THE ABSOLUTE PATH:

 

OPEN UP THE OSCOMMERCE ADMINISTRATION PANEL and select "Server Info" under the Tools menu. Scroll down to the section called ENVIRONMENT. You will see an entry called SCRIPT_FILENAME. There you will find a path listed. If you use that path up to and including /admin for your DIR_FS_ADMIN definition I'm pretty sure it will work for you too. Here is what mine turned out to be:

/home/aspenshop/www/dev/oscommerce/catalog/admin/

 

Now I don't have a clue why this definition requires aspenshop instead of my real domain name which is aspenshopsonline.com. Perhaps somebody can enlighten me?</

Share this post


Link to post
Share on other sites
After a succesfull install i get the following message after the checkout process.

This only happens when I set "send HTML or text invoices to customers"to true.

 

Warning: main(): open_basedir restriction in effect. File(/home/YOUR_DOMAIN/public_html/catalog/admin/includes/languages/dutch/invoice.php) is not within the allowed path(s): (/usr/local/psa/home/vhosts/nicedeal.nl/httpdocs:/tmp) in /usr/local/psa/home/vhosts/nicedeal.nl/httpdocs/includes/modules/email_invoice/email_invoice.php on line 30

 

Warning: main(/home/YOUR_DOMAIN/public_html/catalog/admin/includes/languages/dutch/invoice.php): failed to open stream: Operation not permitted in /usr/local/psa/home/vhosts/nicedeal.nl/httpdocs/includes/modules/email_invoice/email_invoice.php on line 30

 

Warning: main(): open_basedir restriction in effect. File(/home/YOUR_DOMAIN/public_html/catalog/admin/includes/languages/dutch/invoice.php) is not within the allowed path(s): (/usr/local/psa/home/vhosts/nicedeal.nl/httpdocs:/tmp) in /usr/local/psa/home/vhosts/nicedeal.nl/httpdocs/includes/modules/email_invoice/email_invoice.php on line 30

 

Warning: main(/home/YOUR_DOMAIN/public_html/catalog/admin/includes/languages/dutch/invoice.php): failed to open stream: Operation not permitted in /usr/local/psa/home/vhosts/nicedeal.nl/httpdocs/includes/modules/email_invoice/email_invoice.php on line 30

 

Fatal error: main(): Failed opening required '/home/YOUR_DOMAIN/public_html/catalog/admin/includes/languages/dutch/invoice.php' (include_path='.:/usr/local/psa/apache/share/pear') in /usr/local/psa/home/vhosts/nicedeal.nl/httpdocs/includes/modules/email_invoice/email_invoice.php on line 30

Who can help me??

This looks very much like a similar problem I had returning from the PayPal payment page. The error message you have shows /home/YOUR_DOMAIN/public_html/catalog/admin/.....etc. I think your problem is that YOUR-DOMAIN should be reflect your store domain. Depending on the type web server configuration you have the part that says /public_html/ might also be wrong.

 

In my case, the problem was in the /catalog/admin/includes/local/configure.php file. Check yours.

Find // Folder Definitions

If there is an entry that reads:

define('DIR_FS_ADMIN', '/home/YOUR_DOMAIN/public_html/catalog/admin/'); // absolute path required

then you need to edit the path. (this is covered rather loosely in Step 6 of the install.htm file which is part of the version 6.1 download.)

 

Now here's the trick. "YOUR_DOMAIN" here is not your website domain i.e. www.myshop.com. It's the Database username as listed here: /catalog/admin/includes/configuration.php (slightly different filename and in a different folder).

 

Also, /public_html in my case was actually /www.

 

To make it easier to determine the the true absolute path to type into the definition for DIR_FS_ADMIN open up the OSCommerce Admin Panel, select "Tools", then "Server Info" and scroll down to the "Environment" section.

Find the entry for SCRIPT_FILENAME and paste that into the definition (without server_info.php at the end - the path should end at /admin/). Be sure to include the final /. Also be sure you are editing the right file. You want to be editing /catalog/admin/includes/local/configure.php

 

If your DIR_FS_ADMIN was already correct, then I would look around to see if there are any other definitions in the files that say /home/YOUR_DOMAIN/public_html/ and try replacing as above. If you have the means to search text in your files automatically you should be able to spot the problem pretty fast.

Share this post


Link to post
Share on other sites
This looks very much like a similar problem I had returning from the PayPal payment page. The error message you have shows /home/YOUR_DOMAIN/public_html/catalog/admin/.....etc. I think your problem is that YOUR-DOMAIN should be reflect your store domain. Depending on the type web server configuration you have the part that says /public_html/ might also be wrong.

 

In my case, the problem was in the /catalog/admin/includes/local/configure.php file. Check yours.

Find // Folder Definitions

If there is an entry that reads:

define('DIR_FS_ADMIN', '/home/YOUR_DOMAIN/public_html/catalog/admin/'); // absolute path required

then you need to edit the path. (this is covered rather loosely in Step 6 of the install.htm file which is part of the version 6.1 download.)

 

Now here's the trick. "YOUR_DOMAIN" here is not your website domain i.e. www.myshop.com. It's the Database username as listed here: /catalog/admin/includes/configuration.php (slightly different filename and in a different folder).

 

Also, /public_html in my case was actually /www.

 

To make it easier to determine the the true absolute path to type into the definition for DIR_FS_ADMIN open up the OSCommerce Admin Panel, select "Tools", then "Server Info" and scroll down to the "Environment" section.

Find the entry for SCRIPT_FILENAME and paste that into the definition (without server_info.php at the end - the path should end at /admin/). Be sure to include the final /. Also be sure you are editing the right file. You want to be editing /catalog/admin/includes/local/configure.php

 

If your DIR_FS_ADMIN was already correct, then I would look around to see if there are any other definitions in the files that say /home/YOUR_DOMAIN/public_html/ and try replacing as above. If you have the means to search text in your files automatically you should be able to spot the problem pretty fast.

 

OOPS!!! THE FILE TO EDIT IS configure.php in the /catalog/includes/local folder, not in the /catalog/admin/includes/local/ folder. SORRY ABOUT THAT! (and I was the one who said be careful about that! shame shame on me!!)

Share this post


Link to post
Share on other sites

Instructions For Getting This Great Contribution to Work with Paypal IPN (osCommmerce_PayPal_IPN_v1.2)

 

These are the steps required in addition to those in the installation guide that comes with the contribution, in order to get it to work with the official osCommmerce_PayPal_IPN_v1.2 contribution. Backup your files before performing these steps!!! It worked for me, but nothing is guaranteed in the coding world!

 

Repeat Step 7 of the installation instructions for /catalog/includes/modules/payment/paypal_ipn.php, as follows

 

Step 7b:

Open: catalog/includes/modules/payment/paypal_ipn.php

 

Directly under:

// lets start with the email confirmation

 

Add this:

// START HTML Invoice
 if (EMAIL_INVOICE == 'true') {
require(DIR_WS_MODULES . EMAIL_INVOICE_DIR . FILENAME_EMAIL_INVOICE);
 } else {
// END HTML Invoice

 

Directly above:

// load the after_process function from the payment modules
 $payment_modules->after_process();

 

Add this:

// START HTML Invoice
 }
// END HTML Invoice

 

Further Steps Required

 

Open catalog/includes/modules/email_invoice/email_invoice.php

 

Find this code near the beginning of the file:

 

require(DIR_FS_ADMIN . DIR_WS_LANGUAGES . $language . "/" . FILENAME_ORDERS_INVOICE);

 

Replace this with

 

//   Edited to make Fancier Packing SLip and Invoice v 1.2 work with Paypal IPN
//   require(DIR_FS_ADMIN . DIR_WS_LANGUAGES . $language . "/" . FILENAME_ORDERS_INVOICE);

  $language_query = tep_db_query("select directory from " . TABLE_LANGUAGES . " where languages_id = '" . tep_db_input($languages_id) . "'");
  $language = tep_db_fetch_array($language_query);
  $language_dir= $language['directory'];

  require(DIR_FS_ADMIN . DIR_WS_LANGUAGES . $language_dir . "/" . FILENAME_ORDERS_INVOICE);

 

Open catalog\includes\modules\email_invoice\templates\html_invoice.php

 

Replace all instances of $oID with $order_id

 

I imagine you will need to repeat this for all files in the template dir that you intend to use, but I haven't verified this.

 

Hey presto... it should now work!

 

I hope this is of some help to people out there!

Edited by di11on

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×